Subject: [lp-wan] I-D Action: draft-ietf-lpwan-ipv6-static-context-hc-01.txt

From: [email-masked]
Date: Wed, 01 Mar 2017 23:11:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 over Low Power Wide-Area Networks of the IETF.

        Title           : LPWAN Static Context Header Compression (SCHC) and fragmentation for IPv6 and UDP
        Authors         : Ana Minaburo
                          Laurent Toutain
                          Carles Gomez
	Filename        : draft-ietf-lpwan-ipv6-static-context-hc-01.txt
	Pages           : 29
	Date            : 2017-03-01

Abstract:
   This document describes a header compression scheme and fragmentation
   functionality for IPv6/UDP protocols.  These techniques are
   especially tailored for LPWAN (Low Power Wide Area Network) networks
   and could be extended to other protocol stacks.

   The Static Context Header Compression (SCHC) offers a great level of
   flexibility when processing the header fields.  Static context means
   that information stored in the context which, describes field values,
   does not change during the packet transmission, avoiding complex
   resynchronization mechanisms, incompatible with LPWAN
   characteristics.  In most of the cases, IPv6/UDP headers are reduced
   to a small identifier.

   This document describes the generic compression/decompression process
   and applies it to IPv6/UDP headers.  Similar mechanisms for other
   protocols such as CoAP will be described in a separate document.
   Moreover, this document specifies fragmentation and reassembly
   mechanims for SCHC compressed packets exceeding the L2 pdu size and
   for the case where the SCHC compression is not possible then the
   IPv6/UDP packet is sent.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-context-hc/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-hc-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lpwan-ipv6-static-context-hc-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ana Minaburo <[email-masked]>
Date: Fri, 3 Mar 2017 10:53:34 +0100

Hello LPWANers,

I do not if you have seen this, but I’m sending you the link to the new version of SCHiC compression, please read it and send us comments,

Thanks
Ana

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [lp-wan] I-D Action: draft-ietf-lpwan-ipv6-static-context-hc-01.txt
> Date: 2 March 2017 at 08:11:26 GMT+1
> To: <[email-masked]>
> Cc: [email-masked]
> 
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan