Subject: [lp-wan] COAP - Message ID Field Length

From: Michael Coracin <[email-masked]>
Date: Mon, 5 Mar 2018 10:40:58 +0000

Hello,

In the "LPWAN Static Context Header Compression (SCHC) for CoAP" document, the description of the Message ID field indicates a Field Length of 8 bits, whereas the COAP specification indicates a size of 16 bits for this field.

   Message ID:  16-bit unsigned integer in network byte order.  Used for

      the detection of message duplication, and to match messages of

      type Acknowledgement/Reset to messages of type Confirmable/Non-

      confirmable.  The rules for generating a Message ID and matching

      messages are defined in Section 4<https://tools.ietf.org/html/draft-ietf-core-coap-18#section-4>.

Is it intended?

Thanks and regards,

Michael

---

From: Laurent Toutain <[email-masked]>
Date: Tue, 6 Mar 2018 10:37:43 +0100

Hi Michael,

Thanks for your question, this is an important point we have to discuss on
the list. CoAP defines a message ID to allow acknowledgments.
A value of 16 bits is useful on relatively "high speed networks". Regarding
the defaults CoAP parameters you cannot reuse the same Message
ID during the next 5 minutes.

On LPWAN the number of message a device may sent can be much more limited.
This mean that we can "reduce the size" of the message ID
field. This is not done by changing the CoAP message format, but by using
the MSB Matching Operator. If the device is using  for message ID values
between
0x00 and 0xFF, the rule can be:

TV = 0x0000, MO= MSB(8) and CDA = LSB.

Only the less 8 significant bits will be sent on the radio.

Laurent

On Mon, Mar 5, 2018 at 11:40 AM, Michael Coracin <[email-masked]>
wrote:

> Hello,
>
>
>
> In the “LPWAN Static Context Header Compression (SCHC) for CoAP” document,
> the description of the Message ID field indicates a Field Length of 8 bits,
> whereas the COAP specification indicates a size of 16 bits for this field.
>
>
>
>       messages are defined in Section 4 <https://tools.ietf.org/html/draft-ietf-core-coap-18#section-4>.
>
>
>
> Is it intended?
>
>
>
> Thanks and regards,
>
>
>
> Michael
>
>
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

---

From: Michael Coracin <[email-masked]>
Date: Wed, 7 Mar 2018 15:03:55 +0000

Hi Laurent,

Thank you for your answer.

I understand that we can compress the MID field to 8 bits instead of 16 in our case.

But, in a C/D rule definition, the “Field Length” describes the original length of the field, once decompressed, right?

So if we compress it to 8 bits, that would be a rule like:

|FID| FL | FP | DI | TV  |  MO   |CDA | Sent |

|Mid| 16 | 1  | bi | ??  | MSB(8)|LSB | [8]  |

Whatever the number of bits we actually transmit, it needs to be decompressed to 16 bits to be inline with COAP spec, or have I misunderstood this?

For example, it is how it is described in the IPv6/UDP document here:

|UDP DEVport |16|1 |Bi|8720 | MSB(12)| LSB(4) || [4] |

Best regards,

Michael

From: lp-wan [mailto:[email-masked]] On Behalf Of Laurent Toutain

Sent: mardi 6 mars 2018 10:38

To: Michael Coracin

Cc: [email-masked]

Subject: Re: [lp-wan] COAP - Message ID Field Length

The e-mail below was received from outside Semtech, exercise caution

________________________________________

Hi Michael,

Thanks for your question, this is an important point we have to discuss on the list. CoAP defines a message ID to allow acknowledgments.

A value of 16 bits is useful on relatively "high speed networks". Regarding the defaults CoAP parameters you cannot reuse the same Message

On LPWAN the number of message a device may sent can be much more limited. This mean that we can "reduce the size" of the message ID

field. This is not done by changing the CoAP message format, but by using the MSB Matching Operator. If the device is using  for message ID values between

Laurent

On Mon, Mar 5, 2018 at 11:40 AM, Michael Coracin <[email-masked]> wrote:

Hello,

In the “LPWAN Static Context Header Compression (SCHC) for CoAP” document, the description of the Message ID field indicates a Field Length of 8 bits, whereas the COAP specification indicates a size of 16 bits for this field.

      messages are defined in Section 4.

Is it intended?

Thanks and regards,

Michael

lp-wan mailing list

[email-masked]