Subject: Re: [lp-wan] shephering for draft-ietf-lpwan-ipv6-static-context-hc

From: AUDEBERT Vincent <[email-masked]>
Date: Mon, 2 Jul 2018 08:22:08 +0000

Dear Pascal, Dear all,

No, I'm not aware of any IPR that applies to this draft

Regards

Vincent

Vincent AUDEBERT
Chef de projet
EDF - R&D Lab Saclay
MIRE
7 Bd Gaspard Monge
91120 PALAISEAU
 
[email-masked]
Tél. : + 33 1 78 19 45 64
Tél. mobile : + 33 6 14 13 23 22
     
Un geste simple pour l'environnement, n'imprimez ce message que si vous en avez l'utilité.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : vendredi 29 juin 2018 10:46
À : [email-masked]
Cc : [email-masked]; [email-masked]
Objet : [lp-wan] shephering for draft-ietf-lpwan-ipv6-static-context-hc

Dear all:

This edition concludes the WG process for SCHC/IP, and as shepherd I will now ask for publication. 
Thanks you all for the extraordinary work that was done in a very short time, leading to very quick acceptance by some of the supported LPWAN technologies, more to come from IEEE I expect..

Authors, and anyone who would reply with a yes, please answer the following:

Are you aware of any IPR that applies to drafts identified above?
 
To reply please use either:

 "No, I'm not aware of any IPR that applies to this draft"
 or
 "Yes, I'm aware of IPR that applies to this draft"

Many thanks again;

Pascal

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: vendredi 29 juin 2018 10:25
> To: Laurent Toutain <[email-masked]>; Laurent 
> Toutain <[email-masked]>; Ana Minaburo 
> <[email-masked]>; lpwan- [email-masked]; Dominique Barthel 
> <[email-masked]>; Carles Gomez <[email-masked]>
> Subject: New Version Notification for 
> draft-ietf-lpwan-ipv6-static-context-hc-
> 14.txt
> 
> 
> A new version of I-D, draft-ietf-lpwan-ipv6-static-context-hc-14.txt
> has been successfully submitted by Laurent Toutain and posted to the 
> IETF repository.
> 
> Name:		draft-ietf-lpwan-ipv6-static-context-hc
> Revision:	14
> Title:		LPWAN Static Context Header Compression (SCHC) and
> fragmentation for IPv6 and UDP
> Document date:	2018-06-29
> Group:		lpwan
> Pages:		67
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-lpwan-ipv6-static-
> context-hc-14.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-
> context-hc/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-
> hc-14
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-ipv6-
> static-context-hc
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-lpwan-ipv6-static-
> context-hc-14
> 
> Abstract:
>    This document defines the Static Context Header Compression (SCHC)
>    framework, which provides both header compression and fragmentation
>    functionalities.  SCHC has been tailored for Low Power Wide Area
>    Networks (LPWAN).
> 
>    SCHC compression is based on a common static context stored in both
>    the LPWAN devices and the network side.  This document defines a
>    header compression mechanism and its application to compress IPv6/UDP
>    headers.
> 
>    This document also specifies a fragmentation and reassembly mechanism
>    that is used to support the IPv6 MTU requirement over the LPWAN
>    technologies.  Fragmentation is needed for IPv6 datagrams that, after
>    SCHC compression or when such compression was not possible, still
>    exceed the layer two maximum payload size.
> 
>    The SCHC header compression and fragmentation mechanisms are
>    independent of the specific LPWAN technology over which they are
>    used.  Note that this document defines generic functionalities and
>    advisedly offers flexibility with regard to parameter settings and
>    mechanism choices.  Such settings and choices are expected to be made
>    in other technology-specific documents.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

_______________________________________________
lp-wan mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lp-wan

Ce message et toutes les pièces jointes (ci-après le 'Message') sont établis à l'intention exclusive des destinataires et les informations qui y figurent sont strictement confidentielles. Toute utilisation de ce Message non conforme à sa destination, toute diffusion ou toute publication totale ou partielle, est interdite sauf autorisation expresse.

Si vous n'êtes pas le destinataire de ce Message, il vous est interdit de le copier, de le faire suivre, de le divulguer ou d'en utiliser tout ou partie. Si vous avez reçu ce Message par erreur, merci de le supprimer de votre système, ainsi que toutes ses copies, et de n'en garder aucune trace sur quelque support que ce soit. Nous vous remercions également d'en avertir immédiatement l'expéditeur par retour du message.

Il est impossible de garantir que les communications par messagerie électronique arrivent en temps utile, sont sécurisées ou dénuées de toute erreur ou virus.
____________________________________________________

This message and any attachments (the 'Message') are intended solely for the addressees. The information contained in this Message is confidential. Any use of information contained in this Message not in accord with its purpose, any dissemination or disclosure, either whole or partial, is prohibited except formal approval.

If you are not the addressee, you may not copy, forward, disclose or use any part of it. If you have received this message in error, please delete it and all copies from your system and notify the sender immediately by return message.

E-mail communication cannot be guaranteed to be timely secure, error or virus-free.

---

From: Laurent Toutain <[email-masked]>
Date: Mon, 2 Jul 2018 14:07:59 +0200

Hi,

Laurent

On Mon, Jul 2, 2018 at 10:22 AM AUDEBERT Vincent <[email-masked]>
wrote:

> Thanks you all for the extraordinary work that was done in a very short
> time, leading to very quick acceptance by some of the supported LPWAN
> technologies, more to come from IEEE I expect..
>
> > URL:
> https://www.ietf.org/internet-drafts/draft-ietf-lpwan-ipv6-static-
> > context-hc-14.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-ietf-lpwan-ipv6-static-
> > context-hc/
> > Htmlized:
> https://tools.ietf.org/html/draft-ietf-lpwan-ipv6-static-context-
> > hc-14
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-ietf-lpwan-ipv6-
> > static-context-hc
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-lpwan-ipv6-static-
> > context-hc-14
> >
> > Abstract:
> Ce message et toutes les pièces jointes (ci-après le 'Message') sont
> établis à l'intention exclusive des destinataires et les informations qui y
> figurent sont strictement confidentielles. Toute utilisation de ce Message
> non conforme à sa destination, toute diffusion ou toute publication totale
> ou partielle, est interdite sauf autorisation expresse.
>
> Si vous n'êtes pas le destinataire de ce Message, il vous est interdit de
> le copier, de le faire suivre, de le divulguer ou d'en utiliser tout ou
> partie. Si vous avez reçu ce Message par erreur, merci de le supprimer de
> votre système, ainsi que toutes ses copies, et de n'en garder aucune trace
> sur quelque support que ce soit. Nous vous remercions également d'en
> avertir immédiatement l'expéditeur par retour du message.
>
> Il est impossible de garantir que les communications par messagerie
> électronique arrivent en temps utile, sont sécurisées ou dénuées de toute
> erreur ou virus.
> This message and any attachments (the 'Message') are intended solely for
> the addressees. The information contained in this Message is confidential.
> Any use of information contained in this Message not in accord with its
> purpose, any dissemination or disclosure, either whole or partial, is
> prohibited except formal approval.
>
> If you are not the addressee, you may not copy, forward, disclose or use
> any part of it. If you have received this message in error, please delete
> it and all copies from your system and notify the sender immediately by
> return message.
>

---

From: Alexander Pelov <[email-masked]>
Date: Mon, 9 Jul 2018 18:40:54 +0200

Dear Pascal, all,

For completeness, I'm adding my clarification on the IPR status of SCHC :

Best,
Alexander

> On 29 Jun 2018, at 10:46, Pascal Thubert (pthubert) <pthubert=[email-masked]> wrote:
> 
> Dear all:
> 
>> To: Laurent Toutain <[email-masked]>; Laurent Toutain
>> <[email-masked]>; Ana Minaburo <[email-masked]>; lpwan-
>> [email-masked]; Dominique Barthel <[email-masked]>;
>> Carles Gomez <[email-masked]>
>> Subject: New Version Notification for draft-ietf-lpwan-ipv6-static-context-hc-
>> 14.txt
>> 
>> 
>> has been successfully submitted by Laurent Toutain and posted to the IETF
>> repository.
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> The IETF Secretariat
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 Jul 2018 16:44:04 +0000

Dear all :

The IETF tightening some screws on IPR, and considering your active participation to the design, I’d appreciate that you make the below statement as well

Many thanks in advance,

Pascal, Shepherd’s hat on

Début du message transféré :
Expéditeur: ana minaburo <[email-masked]<mailto:[email-masked]>>
Date: 29 juin 2018 à 19:11:33 UTC+2
Destinataire: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Suresh Krishnan <[email-masked]<mailto:[email-masked]>>, lp-wan <[email-masked]<mailto:[email-masked]>>
Objet: Rép :⁨ shephering for draft-ietf-lpwan-ipv6-static-context-hc⁩
Hello Pascal, and all

Ana

On Fri, Jun 29, 2018 at 3:46 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all:

Many thanks again;

Pascal

> From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> To: Laurent Toutain <[email-masked]<mailto:[email-masked]>>; Laurent Toutain
> <[email-masked]<mailto:[email-masked]>>; Ana Minaburo <[email-masked]<mailto:[email-masked]>>; lpwan-
> [email-masked]<mailto:[email-masked]>; Dominique Barthel <[email-masked]<mailto:[email-masked]>>;
> Carles Gomez <[email-masked]<mailto:[email-masked]>>
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 9 Jul 2018 16:46:07 +0000

Hello Alex:

Thanks for this. For completeness, I resent to a few active participants.
Since I'm one:
"No, I'm not aware of any IPR that applies to this draft"

Cheers,

Pascal
> From: Alexander Pelov <[email-masked]>
> Sent: lundi 9 juillet 2018 18:41
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]; lp-wan <lp-
> [email-masked]>; Suresh Krishnan <[email-masked]>
> Subject: Re: [lp-wan] shephering for draft-ietf-lpwan-ipv6-static-context-hc
> 
> Dear Pascal, all,
> 
> > On 29 Jun 2018, at 10:46, Pascal Thubert (pthubert)
> <pthubert=[email-masked]> wrote:
> >
> > Dear all:
> >

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 9 Jul 2018 10:18:50 -0700

Hello folks,

No, I'm not aware of any IPR that applies to this draft.

Regards,
Charlie P.

On 7/9/2018 9:44 AM, Pascal Thubert (pthubert) wrote:
>
> Dear all :
>
> The IETF tightening some screws on IPR, and considering your active 
> participation to the design, I’d appreciate that you make the below 
> statement as well
>
> Many thanks in advance,
>
>     *Expéditeur:* ana minaburo <[email-masked] <mailto:[email-masked]>>
>     *Date:* 29 juin 2018 à 19:11:33 UTC+2
>     *Destinataire:* "Pascal Thubert (pthubert)" <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* "[email-masked]
>     <mailto:[email-masked]>"
>     <[email-masked]
>     <mailto:[email-masked]>>, Suresh
>     Krishnan <[email-masked]
>     <mailto:[email-masked]>>, lp-wan <[email-masked]
>     <mailto:[email-masked]>>
>     *Objet:* *Rép :⁨ shephering for
>     draft-ietf-lpwan-ipv6-static-context-hc⁩*
>
>     Hello Pascal, and all
>
>     On Fri, Jun 29, 2018 at 3:46 AM, Pascal Thubert (pthubert)
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Dear all:
>
>         Thanks you all for the extraordinary work that was done in a
>         very short time, leading to very quick acceptance by some of
>         the supported LPWAN technologies, more to come from IEEE I
>         expect..
>
>         > From: [email-masked]
>         <mailto:[email-masked]> <[email-masked]
>         <mailto:[email-masked]>>
>         > To: Laurent Toutain <[email-masked]
>         <mailto:[email-masked]>>; Laurent Toutain
>         > <[email-masked]
>         <mailto:[email-masked]>>; Ana Minaburo
>         <[email-masked] <mailto:[email-masked]>>; lpwan-
>         > [email-masked] <mailto:[email-masked]>; Dominique Barthel
>         <[email-masked]
>         <mailto:[email-masked]>>;
>         > A new version of I-D,
>         draft-ietf-lpwan-ipv6-static-context-hc-14.txt
>         > until the htmlized version and diff are available at
>         tools.ietf.org <http://tools.ietf.org>.
>         >
>         > The IETF Secretariat
>

---

From: Edgar Ramos <[email-masked]>
Date: Tue, 10 Jul 2018 06:39:20 +0000

Hi Pascal,

Best Regards

Edgar Ramos

From: Pascal Thubert (pthubert) <[email-masked]>
Sent: Monday, July 09, 2018 19:44
To: Edgar Ramos <[email-masked]>; Charlie Perkins <[email-masked]>; Diego Dujovne <[email-masked]>; ivaylo petrov <[email-masked]>; Julien Catalano <[email-masked]>
Cc: lp-wan <[email-masked]>
Subject: FW: shephering for draft-ietf-lpwan-ipv6-static-context-hc

Dear all :

Many thanks in advance,

Ana

Many thanks again;

Pascal