Subject: [lp-wan] Decoupled Fragmentation/Compression

From: Bart Moons <[email-masked]>
Date: Mon, 23 Jul 2018 13:25:09 +0200

Dear,

Figure 3 (in v16 of the draft) shows that the Compression and Fragmentation mechanism are decoupled.
The decision to use Fragmentation or not is left to each LPWAN technology over which SCHC is applied.
Does this mean that a sender and receiver must agree upon Fragmentation beforehand? Or should this be applied dynamically?

If not done dynamically, unfragmented packets (which are very likely to happen), will add a serious overhead (DTAG, W, FCN and MIC (because each unfragmented packet will be the last one)).
If done dynamically, one could add a bit in front of the Rule ID to inform the receiving side about a fragmented packet.
This would limit the number of rules that can be applied, but without any overhead.

Kind regards,
Bart

Bart Moons
Ghent University - imec
IDLab
iGent Tower - Department of Information Technology
Technologiepark-Zwijnaarde 15, B-9052 Ghent, Belgium
T: +32 472 42 23 91
E: [email-masked]
W: http://IDLab.UGent.be
W: http://idlab.technology

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Mon, 23 Jul 2018 13:38:18 +0200

Dear Bart,

Thanks for your message.

Please find below my inline responses.

> over which SCHC is applied.

Rather, fragmentation needs to be used if a SCHC Packet exceeds the
maximum payload size of the underlying LPWAN technology.

> Does this mean that a sender and receiver must agree upon Fragmentation
> beforehand? Or should this be applied dynamically?
>
> If not done dynamically, unfragmented packets (which are very likely to
> happen), will add a serious overhead (DTAG, W, FCN and MIC (because each
> unfragmented packet will be the last one)).

The point here is that the Rule ID is set by the sender to indicate
whether the PDU being sent is a SCHC Fragment or not. If a SCHC Packet
does not need to be fragmented, it will not use the fragmentation header.

The receiver needs to know beforehand the Rule IDs that may be used by the
sender.

> If done dynamically, one could add a bit in front of the Rule ID to inform
> the receiving side about a fragmented packet.

In fact it is not necessary to dedicate a whole bit for that. As explained
in my previous comment, the Rule ID bits are used to indicate whether the
PDU being sent is a SCHC Fragment or not.

I hope this helps.

Cheers,

Carles

> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>