Subject: [Lsr] [Editorial Errata Reported] RFC7810 (5293)

From: RFC Errata System <[email-masked]>
Date: Thu, 22 Mar 2018 03:45:41 -0700 (PDT)

The following errata report has been submitted for RFC7810,
"IS-IS Traffic Engineering (TE) Metric Extensions".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5293

--------------------------------------
Type: Editorial
Reported by: Jeffrey Haas <[email-masked]>

Section: 4.5-4.7

Original Text
-------------
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |   Type        |     Length    |  RESERVED     |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                          Residual Bandwidth                   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   where:

   Type: 37

   Length: 4

   RESERVED: This field is reserved for future use

Corrected Text
--------------
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |   Type        |     Length    |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                          Residual Bandwidth                   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   where:

   Type: 37

   Length: 4

Notes
-----
In sections 4.5, 4.6 and 4.7, a RESERVED field is in the diagram and the text.  However, the length field of each of these TLVs is 4.  The RESERVED field is thus not present and should be removed in future editions of this document.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7810 (draft-ietf-isis-te-metric-extensions-11)
--------------------------------------
Title               : IS-IS Traffic Engineering (TE) Metric Extensions
Publication Date    : May 2016
Author(s)           : S. Previdi, Ed., S. Giacalone, D. Ward, J. Drake, Q. Wu
Category            : PROPOSED STANDARD
Source              : IS-IS for IP Internets
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 22 Mar 2018 11:20:53 +0000

Hi Jeff, et al, 

Speaking as a WG member: 

I agree there should be an Errata here but the interpretation taken by at least one implementation is to update the length to 5 rather than remove the RESERVED octet. I'd like to hear what other implementations have done. 

Thanks,
Acee 

On 3/22/18, 6:49 AM, "Lsr on behalf of RFC Errata System" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Section: 4.5-4.7
    
    Original Text
    -------------
        0                   1                   2                   3
    
       where:
    
       Type: 37
    
       Length: 4

    Corrected Text
    --------------
        0                   1                   2                   3
    
       where:
    
       Type: 37
    
       Length: 4

    Notes
    -----
    
    Instructions:
    -------------

    _______________________________________________
    Lsr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lsr

---

From: Olivier Dugeon <[email-masked]>
Date: Thu, 22 Mar 2018 11:33:54 +0000

Hi Acee,

Within Open Source Free Range Routing project, https://frrouting.org, we 
simply skip this RESERVED byte and use standard TLV header of 4 bytes 
only like the other TE metric Extensions parameters.

Detail are here: 
https://github.com/FRRouting/frr/blob/master/isisd/isis_te.h lines 216 
to 221

So, this errata is fine for me. Adding extra byte will add extra code as 
this TLV becomes not standard regarding the other ones.

Regards,

Olivier

-- 
logo Orange <http://www.orange.com>

Olivier Dugeon
Senior research engineer in QoS and network control
Open Source Referent
Orange/IMT/OLN/WTC/IEE/OPEN

fixe : +33 2 96 07 28 80
mobile : +33 6 82 90 37 85
[email-masked] <mailto:[email-masked]>

---

From: Jeff Haas <[email-masked]>
Date: Thu, 22 Mar 2018 13:55:19 +0000

Acee,

I'm glad you've made this comment.  The motivation for me reading this document and making the comment was the WGLC for
https://tools.ietf.org/html/draft-ietf-idr-te-pm-bgp-09

I'm not familiar with what my employer's implementation does, but I suspect we'll get a public declaration of this shortly.  Meanwhile, you may wish to comment on the IDR WGLC on this since at least one protocol implementor (me) would be confused. :-)

-- Jeff

On Mar 22, 2018, at 11:20 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jeff, et al,

Speaking as a WG member:

Thanks,
Acee

On 3/22/18, 6:49 AM, "Lsr on behalf of RFC Errata System" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

   --------------------------------------
   You may review the report below and at:
   https://urldefense.proofpoint.com/v2/url?u=http-3A__www.rfc-2Deditor.org_errata_eid5293&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=T-sa37bq-QjZoC4jLQ0QAtNyQAPQqGdTNBvhTirOBqc&m=YfnMkYHflKhDv_k5oRXzEJV8Hnk5E4QjWZz4hQTwQe0&s=fdYU897qHDu8U5ShyCdT2Q6kYhkRxOQtHVv00lRQlv4&e=

   --------------------------------------
   Type: Editorial
   Reported by: Jeffrey Haas <[email-masked]<mailto:[email-masked]>>

   Section: 4.5-4.7

   Original Text
   -------------
       0                   1                   2                   3

      where:

      Type: 37

      Length: 4

   Corrected Text
   --------------
       0                   1                   2                   3

      where:

      Type: 37

      Length: 4

   Notes
   -----

   Instructions:
   -------------

   _______________________________________________
   Lsr mailing list
   [email-masked]<mailto:[email-masked]>
   https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_lsr&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=T-sa37bq-QjZoC4jLQ0QAtNyQAPQqGdTNBvhTirOBqc&m=YfnMkYHflKhDv_k5oRXzEJV8Hnk5E4QjWZz4hQTwQe0&s=LBwnWuN3KqtpqzqJcoJmVlzEDx5M-AHqILQBCRssmcI&e=

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 22 Mar 2018 14:53:22 +0000

Jeff,

I agree. It appears the error in the RFC has been interpreted multiple ways and I’m leaning towards the recommending the Errata being accepted as submitted given the format in OSPF (RFC 7471) and the BGP-LS TE-PM draft. It would be interesting to hear what your implementation does.

Thanks,
Acee

From: Jeff Haas <[email-masked]>
Date: Thursday, March 22, 2018 at 9:55 AM
To: Acee Lindem <[email-masked]>
Cc: RFC Errata System <[email-masked]>, "[email-masked]" <[email-masked]>, Spencer Giacalone <[email-masked]>, "David Ward (wardd)" <[email-masked]>, John E Drake <[email-masked]>, "[email-masked]" <[email-masked]>, Alia Atlas <[email-masked]>, Deborah Brungard <[email-masked]>, Alvaro Retana <[email-masked]>, Christian Hopps <[email-masked]>, Hannes Gredler <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lsr] [Editorial Errata Reported] RFC7810 (5293)

Acee,

-- Jeff

Hi Jeff, et al,

Speaking as a WG member:

Thanks,
Acee

   Section: 4.5-4.7

   Original Text
   -------------
       0                   1                   2                   3

      where:

      Type: 37

      Length: 4

   Corrected Text
   --------------
       0                   1                   2                   3

      where:

      Type: 37

      Length: 4

   Notes
   -----

   Instructions:
   -------------

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 23 Mar 2018 05:54:20 +0000

I also believe the Errata should be accepted as is.

This will make IS-IS consistent with OSPF (RFC 7471) as well as the related BGP-LS draft (draft-ietf-idr-te-pm-bgp).

Given there is evidence that implementations have differed in their interpretations it seems important to note that we may have some interoperability issues until all deployed systems are updated to conform to the Errata.
Should a bis version of the RFC be considered??

   Les

From: Lsr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: Thursday, March 22, 2018 7:53 AM
To: Jeff Haas <[email-masked]>
Cc: [email-masked]; Olivier Dugeon <[email-masked]>; [email-masked]; John E Drake <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; RFC Errata System <[email-masked]>
Subject: Re: [Lsr] [Editorial Errata Reported] RFC7810 (5293)

Jeff,

Thanks,
Acee

From: Jeff Haas <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 22, 2018 at 9:55 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: RFC Errata System <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Spencer Giacalone <[email-masked]<mailto:[email-masked]>>, "David Ward (wardd)" <[email-masked]<mailto:[email-masked]>>, John E Drake <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>, Deborah Brungard <[email-masked]<mailto:[email-masked]>>, Alvaro Retana <[email-masked]<mailto:[email-masked]>>, Christian Hopps <[email-masked]<mailto:[email-masked]>>, Hannes Gredler <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lsr] [Editorial Errata Reported] RFC7810 (5293)

Acee,

-- Jeff

Hi Jeff, et al,

Speaking as a WG member:

Thanks,
Acee

   Section: 4.5-4.7

   Original Text
   -------------
       0                   1                   2                   3

      where:

      Type: 37

      Length: 4

   Corrected Text
   --------------
       0                   1                   2                   3

      where:

      Type: 37

      Length: 4

   Notes
   -----

   Instructions:
   -------------

---

From: Jeff Haas <[email-masked]>
Date: Tue, 27 Mar 2018 17:10:09 +0000

Acee,

On Mar 22, 2018, at 10:53 AM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
I agree. It appears the error in the RFC has been interpreted multiple ways and I’m leaning towards the recommending the Errata being accepted as submitted given the format in OSPF (RFC 7471) and the BGP-LS TE-PM draft. It would be interesting to hear what your implementation does.

To close this particular loop, JunOS doesn't currently support RFC 7810.

-- Jeff

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 27 Mar 2018 17:23:01 +0000

Hi Jeff,
I think we’ve agreed that the Errata should be accepted. We’ll need to update our IOS-XR implementation to support the updated interpretation with the single octet Reserved field removed and a TLV length of 4.

All,

When you are reviewing/implementing drafts or RFCs and encounter discrepancies like this, please report them to the appropriate IETF list ASAP.

Thanks,
Acee
P.S. There has also been some discussion of a quick BIS version of RFC 7810.

From: Jeff Haas <[email-masked]>
Date: Tuesday, March 27, 2018 at 1:10 PM
To: Acee Lindem <[email-masked]>
Cc: RFC Errata System <[email-masked]>, "[email-masked]" <[email-masked]>, Spencer Giacalone <[email-masked]>, John E Drake <[email-masked]>, Alia Atlas <[email-masked]>, Deborah Brungard <[email-masked]>, Alvaro Retana <[email-masked]>, "[email-masked]" <[email-masked]>, Olivier Dugeon <[email-masked]>
Subject: Re: [Lsr] [Editorial Errata Reported] RFC7810 (5293)

Acee,

-- Jeff