Subject: [Lsr] Suresh Krishnan's No Objection on draft-ietf-ospf-ospfv3-segment-routing-extensions-20: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Wed, 05 Dec 2018 21:36:36 -0800

Suresh Krishnan has entered the following ballot position for
draft-ietf-ospf-ospfv3-segment-routing-extensions-20: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-ospfv3-segment-routing-extensions/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

* I share Benjamin's confusion regarding the prefix ranges and would like this
to be clarified.

* For the address family, I do have a suggestion. There is an IANA registry for
Address Family Numbers that can provide the extensibility needed. If future
extensibility of this space is desired, this might be an option to consider.

https://www.iana.org/assignments/address-family-numbers/address-family-numbers.xhtml

---

From: Peter Psenak <[email-masked]>
Date: Thu, 06 Dec 2018 12:43:38 +0100

Hi Suresh,

please see inline:

> https://datatracker.ietf.org/doc/draft-ietf-ospf-ospfv3-segment-routing-extensions/

what about following text in section 5:

"The range represents the contiguous set of prefixes with the same 
prefix length as specified by the Prefix Length field. The set starts 
with the prefix that is specified by the Address Prefix field. The 
number of prefixes in the set is equal to Range size."

There are also two examples in section 6, one with /128 and one with 
/120 prefix length.

> extensibility of this space is desired, this might be an option to consider.

no plans to support other AFs, at least not for now.

There are existing implementations and changing the AF code points now 
would result in compatibility issues.

thanks,
Peter
> .

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 6 Dec 2018 15:07:44 +0000

> On Dec 6, 2018, at 6:43 AM, Peter Psenak <[email-masked]> wrote:
> 
> Hi Suresh,
> 
> please see inline:
> 
> "The range represents the contiguous set of prefixes with the same prefix length as specified by the Prefix Length field. The set starts with the prefix that is specified by the Address Prefix field. The number of prefixes in the set is equal to Range size."
> 
> 
> There are also two examples in section 6, one with /128 and one with /120 prefix length.
> 
>> 
> There are existing implementations and changing the AF code points now would result in compatibility issues.

Thanks Peter. It was only a suggestion to address Benjamin’s question about extensibility of the AFs. I fully understand your concern about existing implementations.

Regards
Suresh

---

From: Peter Psenak <[email-masked]>
Date: Thu, 06 Dec 2018 16:15:38 +0100

Hi Suresh,

>> "The range represents the contiguous set of prefixes with the same prefix length as specified by the Prefix Length field. The set starts with the prefix that is specified by the Address Prefix fie…

any comments on the proposed text above?

thanks,
Peter

> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr
>