Subject: [Lsr] Suresh Krishnan's No Objection on draft-ietf-lsr-isis-rfc7810bis-04: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Wed, 19 Dec 2018 19:31:39 -0800

Suresh Krishnan has entered the following ballot position for
draft-ietf-lsr-isis-rfc7810bis-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lsr-isis-rfc7810bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

* Backward compatibility

There is text in Appendix A that provides guidance to implementers on how to
handle TLVs with length 5 from RFC7810. I think this would be much more helpful
inside the main body of the document. I was wondering how the backward
compatibility was handled until I read through the Appendix that lists the
*diffs*.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 20 Dec 2018 04:36:37 +0000

Suresh -

Inline.

> -----Original Message-----
> From: Suresh Krishnan <[email-masked]>
> Sent: Wednesday, December 19, 2018 7:32 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Ketan Talaulikar (ketant)
> <[email-masked]>; [email-masked]; [email-masked]; Ketan
> Talaulikar (ketant) <[email-masked]>; [email-masked]
> Subject: Suresh Krishnan's No Objection on draft-ietf-lsr-isis-rfc7810bis-04:
> (with COMMENT)
> 

[Les:] I REALLY do not want to do this.

There is no intent to legitimize two different encodings. Implementations which encoded the problematic sub-TLVs with a length of 5 and a reserved byte were wrong - though obviously based on the flawed text in RFC 7810 it wasn't easy for a reader to realize that.

The obligation is on the implementations which used the 5 byte encoding to correct themselves and use the 4 byte encoding.
There is no obligation on conformant implementations to be "generous" and allow for interoperating with implementations which used the 5 byte encodings.
There might be business value in doing so - but that is outside the purview of specification. We use the appendix only to suggest that "generosity" be considered.

The main body of the document should not be cluttered with this. It needs to serve as the normative specification independent of the prior existence of RFC 7810.

   Les

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 20 Dec 2018 05:44:14 +0000

Hi Les,
  Thanks for the quick response. Comments inline.

> On Dec 19, 2018, at 11:36 PM, Les Ginsberg (ginsberg) <[email-masked]> wrote:
> 
> Suresh -
> 
> Inline.
> 

No worries. My comment was not blocking :-), but the document certainly does not clearly reflect your position. Either you want to support the old implementations or not. I am fine with either way but the text in the appendix is certainly leaning the other way towards backward compatibility. As long as the guidance is consistent, I certainly have no issues.

> There might be business value in doing so - but that is outside the purview of specification. We use the appendix only to suggest that "generosity" be considered.

This is where you lost me. What is the actual guidance you want to provide? You said earlier “There is no intent to legitimize two different encodings” and then say here that implementations should be generous. That does sound like a “MAY” to me.

> The main body of the document should not be cluttered with this. It needs to serve as the normative specification independent of the prior existence of RFC 7810.

Sure. Your call.

Thanks
Suresh

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 20 Dec 2018 10:38:49 +0000

Hi Suresh,

On 12/20/18, 12:44 AM, "Suresh Krishnan" <[email-masked]> wrote:

    Hi Les,

We only know of one implementation that has the wrong encoding and we have fixed that one.

Thanks,
Acee

    
    
    Sure. Your call.
    
    Thanks
    Suresh

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 20 Dec 2018 07:01:18 -0500

On December 20, 2018 at 5:38:51 AM, Acee Lindem (acee) ([email-masked])
wrote:

We only know of one implementation that has the wrong encoding and we have
fixed that one.

I then see no harm in removing the “generosity” paragraph.  As Suresh
suggests, it will make the document even clearer.

Thanks!

Alvaro.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 20 Dec 2018 15:43:04 +0000

Folks –

Here is the relevant paragraph from the Appendix - some emphasis added.

“As a means of interoperating with implementations which do not
   conform to the corrections defined in this document, implementers may
   wish to consider temporarily supporting sending and/or receiving the
   form of the sub-TLVs using a length of 5 and including the RESERVED
   field.  However, the intent of this revision is to specify one and
   only one normative behavior.  Any existing implementations which
   encode the sub-TLVs using a length of 5 are expected to be revised to
   conform to the normative behavior specified in this document.”

Several things of note regarding this paragraph:

1)It was put in in response to a review comment from the Document shepherd:

<snip>
Hi All,

I was reviewing this draft as the Shepherd. It is a fairly simple and straightforward bis update to RFC7810 to fix an encoding error.

There is one point that I would like the authors and WG to consider.

The draft in the appendix talks about two interpretations of the erroneous sub-TLVs and from the conversation on the list I get the impression that there are at least two implementations out there which did different interpretations. Do we want to consider putting in a suggestion (i.e. not normative perhaps) that implementations updated to this specifications accept the sub-TLV with the Reserved field included and size 5? So they don't consider such an encoding as error or malformed on reception?

Thanks,
Ketan

<end snip>

I agreed with Ketan’s comment and so the text was added.

2)The text is very careful to comply with RFC 8174. It uses lowercase “may” – therefore clearly non-normative.  It also unambiguously states that implementations written using a length of 5 “are expected to be revised”.

3)If you read this from the POV of someone who implements the protocol extensions, I think this text is useful in providing context for what interoperability issues might be encountered in the field. Even though the implementation we know of that used a length of 5 has been fixed – there are still older versions of that code deployed.  It suggests – but clearly does NOT require - what could be done (at the implementer’s discretion) to deal with the non-conformant implementations.

I fail to see how this is in any way confusing.

I think the document is better off as is – but if you folks insist I will remove the text – though clearly I disagree with this choice.

    Les

From: Alvaro Retana <[email-masked]>
Sent: Thursday, December 20, 2018 4:01 AM
To: Acee Lindem (acee) <[email-masked]>; Les Ginsberg (ginsberg) <[email-masked]>; Suresh Krishnan <[email-masked]>
Cc: [email-masked]; [email-masked]; The IESG <[email-masked]>; Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]
Subject: Re: Suresh Krishnan's No Objection on draft-ietf-lsr-isis-rfc7810bis-04: (with COMMENT)

On December 20, 2018 at 5:38:51 AM, Acee Lindem (acee) ([email-masked]<mailto:[email-masked]>) wrote:

I then see no harm in removing the “generosity” paragraph.  As Suresh suggests, it will make the document even clearer.

Thanks!

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 20 Dec 2018 10:46:23 -0500

On December 20, 2018 at 10:43:06 AM, Les Ginsberg (ginsberg) (
[email-masked]) wrote:

I think the document is better off as is – but if you folks insist I will
remove the text – though clearly I disagree with this choice.

Please do.

Thanks!

Alvaro.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 20 Dec 2018 16:58:10 +0000

Done. V5 has been published.

   Les

From: Alvaro Retana <[email-masked]>
Sent: Thursday, December 20, 2018 7:46 AM
To: Les Ginsberg (ginsberg) <[email-masked]>; Acee Lindem (acee) <[email-masked]>; Suresh Krishnan <[email-masked]>
Cc: Ketan Talaulikar (ketant) <[email-masked]>; [email-masked]; The IESG <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: Suresh Krishnan's No Objection on draft-ietf-lsr-isis-rfc7810bis-04: (with COMMENT)

On December 20, 2018 at 10:43:06 AM, Les Ginsberg (ginsberg) ([email-masked]<mailto:[email-masked]>) wrote:

Please do.

Thanks!

Alvaro.