Subject: [Lsr] I-D Action: draft-ietf-isis-segment-routing-extensions-21.txt

From: [email-masked]
Date: Mon, 03 Dec 2018 13:02:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Link State Routing WG of the IETF.

        Title           : IS-IS Extensions for Segment Routing
        Authors         : Stefano Previdi
                          Les Ginsberg
                          Clarence Filsfils
                          Ahmed Bashandy
                          Hannes Gredler
                          Bruno Decraene
	Filename        : draft-ietf-isis-segment-routing-extensions-21.txt
	Pages           : 34
	Date            : 2018-12-03

Abstract:
   Segment Routing (SR) allows for a flexible definition of end-to-end
   paths within IGP topologies by encoding paths as sequences of
   topological sub-paths, called "segments".  These segments are
   advertised by the link-state routing protocols (IS-IS and OSPF).

   This draft describes the necessary IS-IS extensions that need to be
   introduced for Segment Routing operating on an MPLS data-plane.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-isis-segment-routing-extensions/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-21
https://datatracker.ietf.org/doc/html/draft-ietf-isis-segment-routing-extensions-21

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-isis-segment-routing-extensions-21

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 3 Dec 2018 21:07:12 +0000

Folks -

Authors of 

https://datatracker.ietf.org/doc/draft-ietf-isis-segment-routing-extensions/
https://datatracker.ietf.org/doc/draft-ietf-ospf-segment-routing-extensions/
https://datatracker.ietf.org/doc/draft-ietf-ospf-ospfv3-segment-routing-extensions/

received private comments that the specification of the use of the V and L bits in prefix/adjacency SID advertisements differed between the three drafts.
Although the differences were not conflicting it might have been confusing to readers of the three specifications and suggest (unintentionally) that the three protocols used these bits in different ways.

To eliminate any confusion we have updated all three of these drafts. They all now explicitly state which combinations of V and L bits are valid, what each combination means, and require that invalid combinations MUST be discarded on receive.

We emphasize that this is not a specification change - but a clarification. We believe all existing implementations are compatible with the revised language.

   Les (on behalf of all the drafts)

> -----Original Message-----
> From: Lsr <[email-masked]> On Behalf Of [email-masked]
> Sent: Monday, December 03, 2018 1:03 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Lsr] I-D Action: draft-ietf-isis-segment-routing-extensions-21.txt
> 
> 
> _______________________________________________
> Lsr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lsr

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 3 Dec 2018 21:10:14 +0000

(Resending w/o the ID announce list - please post any replies against this email please)

Folks -

Authors of