Subject: [Lsr] Benjamin Kaduk's No Objection on draft-ietf-lsr-isis-rfc7810bis-04: (with COMMENT)

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 19 Dec 2018 19:34:49 -0800

Benjamin Kaduk has entered the following ballot position for
draft-ietf-lsr-isis-rfc7810bis-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lsr-isis-rfc7810bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The nice tidy diff against RFC 7810 and description in Appendix A made this
document very easy to review; thank you!

That said, I think that there are some lingering factual errors that will
require some text changes; in particular, relating to the IANA
registrations.  E.g,. Section 2 shouldn't say "this document registers new
IS-IS TE sub-TLVs" and "this document registers several sub-TLVs", since
the sub-TLVs are not new.  Similarly, one could make a case that the IANA
considerations should request for IANA to update the registrations for the
indicated sub-TLVs to point to this document instead of RFC 7810.

(I'm still balloting No Objection and not Discuss, because I trust the
responsible AD to make the right thing happen.)

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 20 Dec 2018 04:42:13 +0000

Benjamin -

Inline.

> -----Original Message-----
> From: Benjamin Kaduk <[email-masked]>
> Sent: Wednesday, December 19, 2018 7:35 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Ketan Talaulikar (ketant)
> <[email-masked]>; [email-masked]; [email-masked]; Ketan
> Talaulikar (ketant) <[email-masked]>; [email-masked]
> Subject: Benjamin Kaduk's No Objection on draft-ietf-lsr-isis-rfc7810bis-04:
> (with COMMENT)
> 

[Les:] Thanx.

> indicated sub-TLVs to point to this document instead of RFC 7810.

[Les:] I think we are discussing small matters here - though I appreciate your desire for diligence.
I would argue that once this document is published no one should have to read RFC 7810 ever again (unless you are a history buff). Which means it really then does become "this document" which introduces the new sub-TLVs.
So using language which requires the existence of the obsoleted document seems wrong to me.

Regarding the IANA registry, there has already been an email exchange with the IANA folks and the registry will be updated to point to this document.

   Les

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 20 Dec 2018 18:26:43 -0600

> So using language which requires the existence of the obsoleted document seems wrong to me.

Re-reading, I see I wrote this in a bit of haste.  Of the actual text I
quoted, I would suggest only removing the word "new"...

> Regarding the IANA registry, there has already been an email exchange with the IANA folks and the registry will be updated to point to this document.

... and am happy to hear this is already in progress.  (My travel schedule
did not allow me to keep up on all the other email traffic for this
document prior to the telechat, so I had missed it.)

-Benjamin