Subject: [Lsr] Mirja Kühlewind's No Objection on draft-ietf-ospf-ospfv3-segment-routing-extensions-19: (with COMMENT)

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 03 Dec 2018 06:42:02 -0800

Mirja Kühlewind has entered the following ballot position for
draft-ietf-ospf-ospfv3-segment-routing-extensions-19: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ospf-ospfv3-segment-routing-extensions/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Minor comments:
1) In intro: "...while an adjacency segment, in
   most cases, is a one-hop path."
Is that true, that in _most_ cases it is one hop? I though SR makes most sense
in order to specify routers/hops that need to be visited, not matter how many
hops are in between.

2) The contributor section has the following statement:
"The following people gave a substantial contribution to the content
   of this document and should be considered as co-authors:"
Should this section then not be called "Authors" instead?

---

From: Peter Psenak <[email-masked]>
Date: Mon, 03 Dec 2018 16:01:21 +0100

Hi Mirja,

please see inline:

On 03/12/18 15:42 , Mirja Kühlewind wrote:
> Is that true, that in _most_ cases it is one hop?

the text is referring to adjacency segment, which is local and only 
programmed on the node where the adjacency exists and its path is 
representing the path to the adjacent neighbor. This is contrary to 
prefix segment, which is global and programmed on all routers, so can 
represent a multi-hop path.

> I though SR makes most sense

we had too many authors and Alvaro suggested we move them to 
Contributors section.

thanks,
Peter

> .

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 3 Dec 2018 16:23:43 +0100

> Am 03.12.2018 um 16:01 schrieb Peter Psenak <[email-masked]>:
> 
> we had too many authors and Alvaro suggested we move them to Contributors section.

We do have both Contributors and Authors section in some published RFC. Contributors is often used if the doc is a collection on (independent) contributions (e.g. some kind of survey docs), while if the intention was to just move the authors from the front page to the back, the section should probably be called „Authors“ or „Additional Authors“. Please double-check with Alvaro.

Mirja

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 3 Dec 2018 16:31:19 +0100

> the text is referring to adjacency segment, which is local and only programmed on the node where the adjacency exists and its path is representing the path to the adjacent neighbor. This is contrary to prefix segment, which is global and programmed on all routers, so can represent a multi-hop path.

Ah, wasn’t really aware that adjacency segment is a well-defined term here. 

Thanks!
Mirja