Subject: [Lsr] draft-ietf-isis-segment-routing-extensions

From: Mobashshera Rasool <[email-masked]>
Date: Wed, 3 Apr 2019 13:06:48 +0000

Dear Authors,

I have a suggestion. Have a look :)

As per section 3.2.  SR-Algorithm Sub-TLV of this draft,  a router must advertise algorithm 0 if it advertises SR Algorithm Sub TLV.

Therefore if a router does not advertises algorithm 0 in this sub TLV, then we MUST discard the SUB TLV.

Suggestion: Algorithm 0 can be added as the first Algorithm in the below sub-tlv (Check if we can make this as must condition in the draft).

So that we can avoid parsing and searching for Algorithm 0 in the complete sub-tlv, and can decide to discard the sub TLV by reading only the first byte.

:)

Regards,
Mobashshera Rasool

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 3 Apr 2019 15:01:18 +0000

Mobashshera -

Thanx for your interest.

While there is nothing wrong with advertising Algo 0 first, the benefits of doing so are minimal. This is because when SR algorithm sub-TLV is received all the algorithms advertised need to be parsed by the receiver. If your argument is that having algorithm 0 advertised first would speed detection of an invalid sub-TLV my comment is that you are optimizing for the error case - which practically speaking should never occur.

In any case it is too late to make advertisement of Algo 0 first a requirement as this would not be backwards compatible with existing implementations.

   Les

From: Mobashshera Rasool <[email-masked]>
Sent: Wednesday, April 03, 2019 6:07 AM
To: [email-masked]; [email-masked]
Subject: draft-ietf-isis-segment-routing-extensions

Dear Authors,

:)

Regards,
Mobashshera Rasool