Subject: [Lsr] [Editorial Errata Reported] RFC2328 (5684)

From: RFC Errata System <[email-masked]>
Date: Thu, 4 Apr 2019 04:00:08 -0700 (PDT)

The following errata report has been submitted for RFC2328,
"OSPF Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5684

--------------------------------------
Type: Editorial
Reported by: jonathan natale <[email-masked]>

Section: 9.4

Original Text
-------------
These two alternatives (~=">=1 BDRs" vs. ~="no BDRs") seem (to me at
least, maybe I missed the point) to have the same outcome (~="highest
becomes BDR")--please clarify it:
If one or more of these
            routers have declared themselves Backup Designated
Router[alternative1]
            (i.e., they are currently listing themselves as Backup
            Designated Router, but not as Designated Router, in their
            Hello Packets) the one having highest Router Priority is
            declared to be Backup Designated Router.  In case of a tie,
            the one having the highest Router ID is chosen.  If no
            routers have declared themselves Backup Designated
Router[alternative2],

Moy                         Standards Track                    [Page 75]
 
RFC 2328                     OSPF Version 2                   April 1998

            choose the router having highest Router Priority, (again
            excluding those routers who have declared themselves
            Designated Router), and again use the Router ID to break
            ties.

Corrected Text
--------------
TBD

Notes
-----
It is unclear to me if a BDR should get preempted (I know the BDR should not).

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2328 (no draft string recorded)
--------------------------------------
Title               : OSPF Version 2
Publication Date    : April 1998
Author(s)           : J. Moy
Category            : INTERNET STANDARD
Source              : Open Shortest Path First IGP
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 4 Apr 2019 11:14:39 +0000

Hi Jonathan, 

I don't see that there is a problem here. In the case where routers on the multi-access network are declaring themselves BDR, only those routers are included in the election process. In the case where there aren't any, all routers are included.

I recommend this errata be rejected.  

Thanks,
Acee 

On 4/4/19, 7:00 AM, "RFC Errata System" <[email-masked]> wrote:

    
    
    Section: 9.4
    
    Original Text
    -------------

     

    Corrected Text
    --------------
    TBD
    
    Notes
    -----
    
    Instructions:
    -------------

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 4 Apr 2019 15:36:55 +0000

Hi Jonathan,
Thanks for your interest and engagement.
Acee

From: Jonathan Natale <[email-masked]>
Date: Thursday, April 4, 2019 at 9:09 AM
To: Acee Lindem <[email-masked]>
Cc: RFC Errata System <[email-masked]>, "[email-masked]" <[email-masked]>, Deborah Brungard <[email-masked]>, Alvaro Retana <[email-masked]>, Martin Vigoureux <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Editorial Errata Reported] RFC2328 (5684)

Thanks for the prompt reply, Acee.  I think that answers my confusion; please close the errata.

Sorry for the noise.

On Thu, Apr 4, 2019 at 7:14 AM Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Jonathan,

Thanks,
Acee

On 4/4/19, 7:00 AM, "RFC Errata System" <[email-masked]<mailto:[email-masked]>> wrote:

    --------------------------------------
    Type: Editorial
    Reported by: jonathan natale <[email-masked]<mailto:[email-masked]>>

    Section: 9.4

    Original Text
    -------------

    Corrected Text
    --------------
    TBD

    Notes
    -----

    Instructions:
    -------------

--
Jonathan Natale
Technical Solutions Engineer - Arista Networks (NAR)
Direct line: 603 686-8518 or 408 547 5500 x68518    9am to 5pm EDT (GMT-4)
Toll-free support line: +1 866 476 0000 (US), +44 808 234 0722 (UK)
International support line: +1 408 547 5502 or +44 207 023 9352
Please call support if immediate assistance is required.
If you have feedback or concerns at any point during the course of this case, please contact [email-masked]<mailto:[email-masked]>