Subject: [Lsr] Benjamin Kaduk's No Objection on draft-ietf-isis-yang-isis-cfg-41: (with COMMENT)

From: Benjamin Kaduk via Datatracker <[email-masked]>
Date: Mon, 14 Oct 2019 22:38:26 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-isis-yang-isis-cfg-41: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-isis-yang-isis-cfg/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for the updates in the -41!
I think that "i-e" in the following got missed, but that can probably be done with an
RFC Editor note, so I'm clearing my Discuss:

     grouping neighbor {
       description  "IS-IS standard neighbor grouping.";
       leaf neighbor-id {
         type extended-system-id;
         description "IS-IS neighbor system-id";
       }
      container instances {
         description "List of all adjacencies between the local
                      system and the neighbor system-id.";
         list instance {
           key id;

           leaf id {
             type uint32;
             description "Unique identifier of an instance of a
                          particular neighbor.";
           }
           leaf i-e {
             type boolean;
             description
               "Internal or External (I/E) Metric bit value";
           }

Also, I think that a spurious 'd' got added into "Routing Information Based".

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 15 Oct 2019 21:22:51 +0000

Hi Ben,
Thanks again for the detailed review. I've made the editorial changes below in the -42 version.
Thanks,
Acee

On 10/15/19, 1:38 AM, "Benjamin Kaduk via Datatracker" <[email-masked]> wrote:

    

         grouping neighbor {
    
               leaf id {
                 type uint32;