Subject: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

From: Veerendranatha Reddy V <[email-masked]>
Date: Tue, 18 Aug 2020 14:40:02 +0000

Hi Authors, All,
OSPF Extended Prefix Range TLV defined in RFC 8665 has IA flag to distinguish between Intra and Inter Area scope prefixes.
Whether any restrictions to not to use Prefix Range TLV for external/NSSA prefixes ?
For External Prefixes, we can able to use  Prefix Range TLV  by using LSA type (based on AS scope Opaque Type , so the TLV is for External Prefixes)
But If we need to use the Prefix Range TLV for NSSA prefixes (Type-7) , which are in area scope, there is no flag/route-type field in this TLV to distinguish between Intra or NSSA prefixes( as IA flag will not be set anyway).

Thanks & Regards,
Veerendranath

---

From: Peter Psenak <[email-masked]>
Date: Tue, 18 Aug 2020 19:35:49 +0200

Veerendranath,

On 18/08/2020 16:40, Veerendranatha Reddy V wrote:
> Hi Authors, All,
> 
> OSPF Extended Prefix Range TLV defined in RFC 8665 has IA flag to 
> distinguish between Intra and Inter Area scope prefixes.
> 

I don't see how you can use OSPF Extended Prefix Range TLV for NSSA, the 
usage of OSPF Extended Prefix Range TLV has only been defined in the 
context of RFC 8665.

thanks,
Peter

> 
> For External Prefixes, we can able to use  Prefix Range TLV  by using 
> LSA type (based on AS scope Opaque Type , so the TLV is for External 
> Prefixes)
> 
> But If we need to use the Prefix Range TLV for NSSA prefixes (Type-7) , 
> which are in area scope, there is no flag/route-type field in this TLV 
> to distinguish between Intra or NSSA prefixes( as IA flag will not be 
> set anyway).
> 
> Thanks & Regards,
> 
> Veerendranath
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 18 Aug 2020 17:57:38 +0000

The IA flag in the OSPF Extended Prefix Range TLV does not indicate that the prefix-SID mapping advertised via it is for use for only intra or inter area prefixes. The mappings can be used for assignment of SIDs for ALL types of OSPF prefixes - regardless of the IA bit.

The IA flag is only to prevent looping during flooding of area-scoped LSAs with OSPF Extended Prefix Range TLVs when they are propagated across areas.

When OSPF Extended Prefix Range TLVs are advertised using AS-scope, the NSSA notion does not apply for them and does not restrict their flooding into or from NSSA areas (or stub areas for that matter).

I am not sure if that answers your question.

Thanks,
Ketan

-----Original Message-----
From: Lsr <[email-masked]> On Behalf Of Peter Psenak
Sent: 18 August 2020 23:06
To: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

> Whether any restrictions to not to use Prefix Range TLV for 

I don't see how you can use OSPF Extended Prefix Range TLV for NSSA, the usage of OSPF Extended Prefix Range TLV has only been defined in the context of RFC 8665.

thanks,
Peter

> But If we need to use the Prefix Range TLV for NSSA prefixes (Type-7) 
> , which are in area scope, there is no flag/route-type field in this 
> TLV to distinguish between Intra or NSSA prefixes( as IA flag will not 
> be set anyway).
> 
> Thanks & Regards,
> 
> Veerendranath
> 

_______________________________________________
Lsr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lsr

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 19 Aug 2020 04:56:39 +0000

Hi Veerendranatha,

Please check inline below.

-----Original Message-----
From: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]> 
Sent: 19 August 2020 10:03
To: Ketan Talaulikar (ketant) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Ketan,
Please find the response in line.
The IA flag in the OSPF Extended Prefix Range TLV does not indicate that the prefix-SID mapping advertised via it is for use for only intra or inter area prefixes. The mappings can be used for assignment of SIDs for ALL types of OSPF prefixes - regardless of the IA bit.
The IA flag is only to prevent looping during flooding of area-scoped LSAs with OSPF Extended Prefix Range TLVs when they are propagated across areas.

[V] As per RFC,
IA-Flag:  Inter-Area Flag.  If set, advertisement is of
               inter-area type.  An Area Border Router (ABR) that is
               advertising the OSPF Extended Prefix Range TLV between
               areas MUST set this bit.
I thought, when prefix Ranges with SID are advertised from Intra to Inter, we need to set this flag. So that it indicates the prefixes are of inter area type. Please let me know if my understanding is not correct.
[KT] What is says is "the prefix range advertisement is of type inter-area or intra-area" (think of it as somewhat equivalent of the D bit in ISIS when leaking across levels). That does not mean that the advertised mappings need to be used for only for intra or inter area prefixes respectively.

When OSPF Extended Prefix Range TLVs are advertised using AS-scope, the NSSA notion does not apply for them and does not restrict their flooding into or from NSSA areas (or stub areas for that matter).
[V] If ASBR is part of NSSA, and if we redistributed Prefix SIDs learnt form other protocols or other instance of OSPF, and those prefixes are result of Range TLV  in that protocol, we can apply range in dest  ospf instance 
[KT] I do not follow above statement - can you please try to elaborate/re-phrase?

Thanks,
Ketan

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Ketan Talaulikar (ketant) <ketant=[email-masked]>
Sent: Tuesday, August 18, 2020 11:28 PM
To: Peter Psenak <[email-masked]>; Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Thanks,
Ketan

-----Original Message-----
From: Lsr <[email-masked]> On Behalf Of Peter Psenak
Sent: 18 August 2020 23:06
To: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Wed, 19 Aug 2020 09:53:02 +0200

Hi Veerendranatha,

On 19/08/2020 06:23, Veerendranatha Reddy V wrote:
> Hi Peter,
> While redistributing prefix Sid for the prefixes from other protocols (Ex: from ISIS or other OSPF instances), we can consider as range TLV for the prefixes which are advertised in the range TLV in that protocol.

I don't follow. Are you talking about redistribution of SRMS 
advertisement between protocols? Such thing has not been defined.

thanks,
Peter

> If it is NSSA, then we need to advertise these redistributed prefixes as area scope, so Range TLV also need to be part of area scope Opaque LSA.
> 
> Thanks & Regards,
> Veerendranath
> 
> From: Peter Psenak <ppsenak=[email-masked]>
> Sent: Tuesday, August 18, 2020 11:06 PM
> To: Veerendranatha Reddy V <[email-masked]>; [email-masked]

---

From: Peter Psenak <[email-masked]>
Date: Wed, 19 Aug 2020 10:09:02 +0200

Veerendranath,

On 19/08/2020 10:03, Veerendranatha Reddy V wrote:
> Hi Peter,
> It is not related to SRMS.
> If there exist ISIS/OSPF or two instances of OSPF in same device, and all are supporting ST, then I can redistribute SR Prefix information to OSPF from other OSPF instance or from ISIS.

yes, you can.

> In this case, I may use range TLV to reduce the number of Prefix TLVs, by using  Range TLV, if prefixes and SID are able to convert to Range TLV.

you would have to generate one somewhere (on ABR?), but it would not be 
of NSSA type.

Peter

> Sent: Wednesday, August 19, 2020 1:23 PM
> I don't follow. Are you talking about redistribution of SRMS advertisement between protocols? Such thing has not been defined.
> 
> thanks,
> Peter
> 
> 
>> Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for
>> External/NSSA prefixes defined in RFC 8665
>>
>> Veerendranath,
>>
>>> TLV to distinguish between Intra or NSSA prefixes( as IA flag will
>>> not be set anyway).
>>>
>>> Thanks & Regards,
>>>
>>> Veerendranath
>>>
>>
>>
>>
> 
> 
>

---

From: Peter Psenak <[email-masked]>
Date: Wed, 19 Aug 2020 11:33:33 +0200

Veerendranatha,

On 19/08/2020 11:19, Veerendranatha Reddy V wrote:
> Hi Peter,
> Thanks for the reply.
> For OSPFv2 Extended Prefix TLV  (defined in RFC 7684) has route type and it supports NSSA External Prefixes to carry SID information.
> In the same way, if Range TLV has Route-Type , we can extend to support for NSSA ASBR to send Range TLVs for redistributed prefixes.

no. NSSA route type is used for redistribution of prefixes to NSSA 
areas. There is no such thing as redistribution of SRMS entries. So 
using NSSA type with SRMS advertisement is not valid.

Peter

> Sent: Wednesday, August 19, 2020 1:39 PM
> you would have to generate one somewhere (on ABR?), but it would not be of NSSA type.
> 
> Peter
> 
> 
>>
>> Thanks & Regards,
>> Veerendranath
>>
>>
>>>> For External Prefixes, we can able to use  Prefix Range TLV  by
>>>> using LSA type (based on AS scope Opaque Type , so the TLV is for
>>>> External
>>>> Prefixes)
>>>>
>>>> But If we need to use the Prefix Range TLV for NSSA prefixes
>>>> (Type-7) , which are in area scope, there is no flag/route-type
>>>> field in this TLV to distinguish between Intra or NSSA prefixes( as
>>>> IA flag will not be set anyway).
>>>>
>>>> Thanks & Regards,
>>>>
>>>> Veerendranath
>>>>
>>>
>>>
>>>
>>
>>
>>
> 
> 
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Wed, 19 Aug 2020 10:11:32 +0000

Hi Veerendranatha,

Please check inline below with [KT2]

-----Original Message-----
From: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]> 
Sent: 19 August 2020 13:07
To: Ketan Talaulikar (ketant) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Ketan,

[V] As per RFC,
IA-Flag:  Inter-Area Flag.  If set, advertisement is of
               inter-area type.  An Area Border Router (ABR) that is
               advertising the OSPF Extended Prefix Range TLV between
               areas MUST set this bit.
I thought, when prefix Ranges with SID are advertised from Intra to Inter, we need to set this flag. So that it indicates the prefixes are of inter area type. Please let me know if my understanding is not correct.
[KT] What is says is "the prefix range advertisement is of type inter-area or intra-area" (think of it as somewhat equivalent of the D bit in ISIS when leaking across levels). That does not mean that the advertised mappings need to be used for only for intra or inter area prefixes respectively.
[V] When we receive the range TLV received at ABR, while it is originating opaque LSA for that range TLV across the other areas, whether it is required to set IA or not?
[KT2] Yes - please check the RFC8665 Sec 4 - right after where the IA flag is described. 

When OSPF Extended Prefix Range TLVs are advertised using AS-scope, the NSSA notion does not apply for them and does not restrict their flooding into or from NSSA areas (or stub areas for that matter).
[V] If ASBR is part of NSSA, and if we redistributed Prefix SIDs learnt form other protocols or other instance of OSPF, and those prefixes are result of Range TLV  in that protocol, we can apply range in dest  ospf instance 
[KT] I do not follow above statement - can you please try to elaborate/re-phrase?
[V] When redistributing  Prefix SID information to NSSA from other protocols , it may possible to generate Range TLV, if multiple prefixes can be aggregated as range., instead of generating extended Prefix TLV for each prefix. So while originating this range TLV, how we can differentiate whether it is intra Scope or NSSA scope. So that when it is received at ABR, he will consider to translate to inter area Opaque or External Opaque for that range.
[KT2] I believe Peter answered and clarified this part. There is no notion of NSSA area or NSSA-scope flooding for the Extended Prefix Range TLV. 

Thanks,
Ketan 

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Ketan Talaulikar (ketant) <ketant=[email-masked]>
Sent: Wednesday, August 19, 2020 10:27 AM
To: Veerendranatha Reddy V <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Veerendranatha,

-----Original Message-----
From: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>
Sent: 19 August 2020 10:03
To: Ketan Talaulikar (ketant) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Ketan,

[V] As per RFC,

When OSPF Extended Prefix Range TLVs are advertised using AS-scope, the NSSA notion does not apply for them and does not restrict their flooding into or from NSSA areas (or stub areas for that matter).
[V] If ASBR is part of NSSA, and if we redistributed Prefix SIDs learnt form other protocols or other instance of OSPF, and those prefixes are result of Range TLV  in that protocol, we can apply range in dest  ospf instance [KT] I do not follow above statement - can you please try to elaborate/re-phrase?

Thanks,
Ketan

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Ketan Talaulikar (ketant) <ketant=[email-masked]>
Sent: Tuesday, August 18, 2020 11:28 PM
To: Peter Psenak <[email-masked]>; Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Thanks,
Ketan

-----Original Message-----
From: Lsr <[email-masked]> On Behalf Of Peter Psenak
Sent: 18 August 2020 23:06
To: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

thanks,
Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Wed, 19 Aug 2020 04:23:49 +0000

Hi Peter,

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]> 
Sent: Tuesday, August 18, 2020 11:06 PM
To: Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

thanks,
Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Wed, 19 Aug 2020 04:33:18 +0000

Hi Ketan,

[V] As per RFC,

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Ketan Talaulikar (ketant) <ketant=[email-masked]> 
Sent: Tuesday, August 18, 2020 11:28 PM
To: Peter Psenak <[email-masked]>; Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Thanks,
Ketan

-----Original Message-----
From: Lsr <[email-masked]> On Behalf Of Peter Psenak
Sent: 18 August 2020 23:06
To: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

thanks,
Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Wed, 19 Aug 2020 07:37:01 +0000

Hi Ketan,

[V] As per RFC,

When OSPF Extended Prefix Range TLVs are advertised using AS-scope, the NSSA notion does not apply for them and does not restrict their flooding into or from NSSA areas (or stub areas for that matter).
[V] If ASBR is part of NSSA, and if we redistributed Prefix SIDs learnt form other protocols or other instance of OSPF, and those prefixes are result of Range TLV  in that protocol, we can apply range in dest  ospf instance [KT] I do not follow above statement - can you please try to elaborate/re-phrase?
[V] When redistributing  Prefix SID information to NSSA from other protocols , it may possible to generate Range TLV, if multiple prefixes can be aggregated as range., instead of generating extended Prefix TLV for each prefix. So while originating this range TLV, how we can differentiate whether it is intra
Scope or NSSA scope. So that when it is received at ABR, he will consider to translate to inter area Opaque or External Opaque for that range.

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Ketan Talaulikar (ketant) <ketant=[email-masked]> 
Sent: Wednesday, August 19, 2020 10:27 AM
To: Veerendranatha Reddy V <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Veerendranatha,

-----Original Message-----
From: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>
Sent: 19 August 2020 10:03
To: Ketan Talaulikar (ketant) <[email-masked]>; Peter Psenak (ppsenak) <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Ketan,

[V] As per RFC,

Thanks,
Ketan

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Ketan Talaulikar (ketant) <ketant=[email-masked]>
Sent: Tuesday, August 18, 2020 11:28 PM
To: Peter Psenak <[email-masked]>; Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: RE: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Thanks,
Ketan

-----Original Message-----
From: Lsr <[email-masked]> On Behalf Of Peter Psenak
Sent: 18 August 2020 23:06
To: Veerendranatha Reddy V <veerendranatha.reddy.v=[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

thanks,
Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Wed, 19 Aug 2020 08:03:21 +0000

Hi Peter,

Thanks & Regards,
Veerendranath  

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]> 
Sent: Wednesday, August 19, 2020 1:23 PM
To: Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Veerendranatha,

thanks,
Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Wed, 19 Aug 2020 09:19:46 +0000

Hi Peter,
Thanks for the reply.

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]> 
Sent: Wednesday, August 19, 2020 1:39 PM
To: Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranath,

yes, you can.

Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Wed, 19 Aug 2020 09:48:06 +0000

Hi Peter,
Thanks for the reply.
As per the discussion, my understanding is Range TLV  defined mainly be used for SRMS entries (to get entries from LDP , for LDP Interoperability).
The use case mentioned  is different from SRMS (redistribution across IGP protocols) , Range TLV is not applicable to use in that use case?

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]> 
Sent: Wednesday, August 19, 2020 3:04 PM
To: Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Veerendranatha,

> In the same way, if Range TLV has Route-Type , we can extend to support for NSSA ASBR to send Range TLVs for redistributed prefixes.

no. NSSA route type is used for redistribution of prefixes to NSSA areas. There is no such thing as redistribution of SRMS entries. So using NSSA type with SRMS advertisement is not valid.

Peter

>>> Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage 
>>> for External/NSSA prefixes defined in RFC 8665
>>>
>>> Veerendranath,
>>>

---

From: Peter Psenak <[email-masked]>
Date: Wed, 19 Aug 2020 14:02:12 +0200

Hi Veerendranatha,

> The use case mentioned  is different from SRMS (redistribution across IGP protocols) , Range TLV is not applicable to use in that use case?

no. At this point, Range TLV is defined only for SRMS mapping advertisement.

thanks,
Peter

---

From: Veerendranatha Reddy V <[email-masked]>
Date: Thu, 20 Aug 2020 06:13:42 +0000

Thanks Peter for the clarification.

Thanks & Regards,
Veerendranath

-----Original Message-----
From: Peter Psenak <ppsenak=[email-masked]> 
Sent: Wednesday, August 19, 2020 5:32 PM
To: Veerendranatha Reddy V <[email-masked]>; [email-masked]
Subject: Re: [Lsr] Regarding OSPF Extended Prefix Range TLV usage for External/NSSA prefixes defined in RFC 8665

Hi Veerendranatha,

thanks,
Peter

>>>>> field in this TLV to distinguish between Intra or NSSA prefixes( 
>>>>> as IA flag will not be set anyway).
>>>>>
>>>>> Thanks & Regards,
>>>>>
>>>>> Veerendranath
>>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>>
>>
>>
>>
> 
> 
>