Subject: RE: [Ltru] [psg.com #941] determining currency of registry versions

From: "Addison Phillips" <[email-masked]>
Date: Tue, 10 May 2005 21:16:41 -0700

See below.

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?5?10? 20:55
> To: LTRU Working Group
> Subject: Re: [Ltru] [psg.com #941] determining currency of registry
> versions
> 
> Hi -
> 
> (as a technical contributor)
> 
> > From: "Addison Phillips" <[email-masked]>
> > To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group"
> <[email-masked]>
> > Sent: Tuesday, May 10, 2005 9:03 AM
> > Subject: RE: [Ltru] [psg.com #941] determining currency of registry
> versions
> >
> 
> > You can extract the codes without any reference to the registry
> > (current or otherwise) based on length and position.
> 
> This still doesn't address the requirement from the charter that
> "it is to provide a mechanism for easily determining whether a
> particular subtag is valid as of a given date, without onerous
> reconstruction of the state of the underlying standard
> as of that time"
[Addison Phillips] 

Yes, it does. If you have a registry as of some date (File-Date record), you can determine if a subtag is valid as at that date (or not)--or any given date prior to that date. Subtags invalid as at that date may still be well-formed. Note the careful use of the terms 'valid' and 'well-formed'. An implementation CAN determine whether a subtag is valid as of some given date prior to the registry date (the records in the registry are dated, please note). You don't have to reconstruct ISO-xxxx as you do today.
> 
> > The currency of the registry is determined by the File-Date field.
> > The one on the IANA website is the most current. Ones with an
> > older date than that one are not current.
> 
> The current (-01) text says:
>    The first record in the file contains the single field whose field-
>    name is "File-Date" and whose field-body contains the last
>    modification date of the registry:
> 
> Would it make sense to amend it to say something like:
>    The first record in the file contains the single field whose field-
>    name is "File-Date". The field-body contains the last
>    modification date of the registry.  The currency of the registry
>    is determined by this field.  The registry on the IANA website is
>    the most current.   Versions with an older date than that one
>    are not current.
[Addison Phillips] 

We could do that, but it is redundant to do so, don't you think? What version of the registry would be on the IANA website besides the most current?!?

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 10 May 2005 22:49:20 -0700

Hi -

> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, May 10, 2005 9:16 PM
> Subject: RE: [Ltru] [psg.com #941] determining currency of registry versions
...
> An implementation
>  CAN determine whether a subtag is valid as of some given date prior to the
> registry date (the records in the registry are dated, please note).
> You don't have to reconstruct ISO-xxxx as you do today.

This is the important point, and satisfies my query.

...
> We could do that, but it is redundant to do so, don't you think?
> What version of the registry would be on the IANA website besides
> the most current?!?

The last sentence was intended to include not only versions on the
IANA website, but those that might end up on mirrors and the like.

Randy