Subject: [Ltru] [psg.com #957] compatibility of description format with ISO table format

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 10 May 2005 15:06:29 -0700

Hi -

> Comment 29 in message
> http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html
> reads
> "29. 3.1: Description of "description" is clueless. It is a description
> but
> does not intend to be an English description but it is one. The
> addition
> made in the IANA file are intended to be additions to  corresponding
> documented ISO tables. They MUST comply with the format of these tables
> otherwise they add a disparity between the table and their
> IANA "appendix"."

Randy, ltru co-chair

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 May 2005 06:46:55 +0200

>> http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html

Apparently that's something you already have as two separate
issues, and if that's the case this ticket is "redundant": 

1 - use source description as is not restricted to Latin-1 or
    Latn (IMHO we have rough consensus for this)

2 - use also the French names.  After a poll you have already
    decided what to do with this part of the problem.

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 10 May 2005 22:02:08 -0700

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, May 10, 2005 9:46 PM
> Subject: [Ltru] Re: [psg.com #957] compatibility of description format withISO table format
>

>     decided what to do with this part of the problem.
...

I thought the comment was about *format* compatibility, since
it was in terms of the (IMO mistaken) notion that this information
was an extension to the ISO specifications.

The other two issues were about repertoire and translations.

That's why I made it a separate item.  However, I freely admit
that figuring out the commits involved considerable guesswork,
so I could well have gotten it wrong.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 May 2005 09:42:12 +0200

Randy Presuhn wrote:

> I freely admit that figuring out the commits involved
> considerable guesswork, so I could well have gotten it wrong.

You extracted sense out of what I considered as nebulous
rants.  It's not that I generally disagree with Jefsey:

Of course homographs in IDNs are bad, but that's irrelevant
here.  Of course a concept of regions based only on country
codes is stupid for say the US or GB, but if we want to be
compatible with 3066 we're damned to stick to it.  Of course
before Unicode scripts where less important, but now is now,
and all these funny charsets will be soon only "legacy" - in
HTML 4 and later that's already the case.  In theory I could
create a text/html mail, declare a Greek or Cyril charset,
and then use only NCRs for Korean.  Not exactly conforming
to "W3C charmod", but otherwise perfectly legal and valid.

But for one point in Jefsey's numerous objections I'm still
curious:  If we already know that there will be a 3066ter to
get the 7000+ languages, is it really necessary to stick to
the "BCP 47" concept ?  The normal standards track procedure
would allow 3066bis = proposed, 3066ter = draft, and if they
still like it a full standard later.

I've a serious problem with all kinds of "forever", a "once
BCP, always BCP" strikes me as odd for something that didn't
survive five years like 3066.
                               Bye, Frank

---

From: John Cowan <[email-masked]>
Date: Wed, 11 May 2005 08:11:27 -0400

> still like it a full standard later.

It's not really necessary to use the draft/proposed/full standard
machinery just to add stuff to a registry, even a whole mountain of
stuff.  Nothing really changes except for activating the extlang
option, which we are already discussing.

> survive five years like 3066.

The point of a BCP is that no staged implementation is necessary.

-- 
John Cowan  [email-masked]  www.ccil.org/~cowan  www.reutershealth.com
And now here I was, in a country where a right to say how the country should
be governed was restricted to six persons in each thousand of its population.
For the nine hundred and ninety-four to express dissatisfaction with the
regnant system and propose to change it, would have made the whole six
shudder as one man, it would have been so disloyal, so dishonorable, such
putrid black treason.  --Mark Twain's Connecticut Yankee

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 11 May 2005 14:35:43 -0700

Hi -

> From: "Randy Presuhn" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, May 10, 2005 10:02 PM
> Subject: Re: [Ltru] Re: [psg.com #957] compatibility of description formatwithISO table format
...

The original comment reads:

| 29. 3.1: Description of "description" is clueless. It is a description
| but does not intend to be an English description but it is one.
| The addition made in the IANA file are intended to be additions
| to corresponding documented ISO tables. They MUST comply with the format
| of these tables otherwise they add a disparity between the table and
| their IANA "appendix".

As a technical contributor:
I believe the comment represents a fundamental misunderstanding of the
registry and its fields.  Just as the use of a foreign key in a relational
database table does not constrain the type or content of that table's
columns, we are not making additions to the ISO tables, and are not
constrained by their format.

As WG co-chair:
I've seen no support for this proposal, and there are arguments against it,
so I plan to mark it "rejected".

Randy, ltru co-chair