Subject: RE: [Ltru] use of region subtags

From: "Addison Phillips" <[email-masked]>
Date: Fri, 27 May 2005 11:03:51 -0700

No.

Nor a Suppress-Variant.

We might consider a Suppress-Extlang, but I can't think why.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: vendredi 27 mai 2005 10:43
> To: [email-masked]
> Subject: [Ltru] use of region subtags
> 
> We've agreed to include a Suppress-Script field to avoid things like "en-
> Latn" or "en-Latn-US". Part of the concern over the script subtag had to
> do with interaction with existing usage of tags like "en-US".
> 
> 
> 
> A case like "iu-CA" or "iu-Latn-CA" for which the region is considered
> undesirable because it's considered redundant (for the 99% case) is
> similar in that it's considered best practice not to use a subtag that can
> be assumed by default, though it doesn't have the same compat-with-
> existing-usage issue. Would we ever want to consider a Suppress-Region
> field for lang subtags?
> 
> 
> 
> 
> 
> 
> 
> Thanks.
> 
> 
> 
> Peter Constable
> 
> GIFT | GPTS | MICROSOFT
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 27 May 2005 14:18:55 -0400

Addison Phillips scripsit:

> No [Suppress-Region].

"No" to each.  Suppress-Script is not part of a general method for expressing
best practices in language tagging, but a hack applicable to existing ISO 639-1/2
based tags to prevent gratuitous matching errors.

-- 
John Cowan                                   [email-masked]
        "You need a change: try Canada"  "You need a change: try China"
                --fortune cookies opened by a couple that I know

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 27 May 2005 11:53:13 -0700

Hi -

I've created a ticket for this proposal: [psg.com #1011]

Randy, ltru co-chair

> From: "John Cowan" <[email-masked]>
> To: "Addison Phillips" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, May 27, 2005 11:18 AM
> Subject: Re: [Ltru] use of region subtags
>

---

From: Martin Duerst <[email-masked]>
Date: Sat, 28 May 2005 18:06:42 +0900

I'd be happy either way. But we should make sure that we are very
clear about the fact that regions and similar stuff can be omited
and is best omited if it doesn't actually contribute any substantial
information, even if we choose not to list the combinations where
this applies.

Regards,    Martin.