Subject: RE: [Ltru] Editorial error in BNF

From: "Addison Phillips" <[email-masked]>
Date: Mon, 23 May 2005 16:52:43 -0700

2*3ALPHA describes assigned subtags (i.e. subtags that are valid). 4ALPHA is reserved for future standardization and are not valid currently. That's the reason I didn't change the ABNF, although I'm not religious about it. The opposite case is easy enough to make.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: 2005?5?23? 16:42
> To: [email-masked]
> Subject: [Ltru] Editorial error in BNF
> 
> The BNF rule for lang still says 2*3ALPHA instead of 2*4ALPHA, even though
> section 2.2.1 bullet 4 says that 4ALPHA tags are reserved for future
> standardization.
> 
> The BNF should be fixed.
> 
> 
> --
> John Cowan <[email-masked]>     http://www.reutershealth.com
> But no living man am I!  You look upon a woman.  Eowyn I am, Eomund's
> daughter.
> You stand between me and my lord and kin.  Begone, if you be not deathless.
> For living or dark undead, I will smite you if you touch him.
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 23 May 2005 17:02:45 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "John Cowan" <[email-masked]>; <[email-masked]>
> Sent: Monday, May 23, 2005 4:52 PM
> Subject: RE: [Ltru] Editorial error in BNF
>

> 2*3ALPHA describes assigned subtags (i.e. subtags that are valid).
> 4ALPHA is reserved for future standardization and are not valid currently.
> That's the reason I didn't change the ABNF, although I'm not religious about it.
> The opposite case is easy enough to make.
...

As a contributor I think the question is whether we want things using
4ALPHAs to be considered well-formed, rather than whether there
are (or will be) valid ones with that form.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 24 May 2005 03:01:56 +0200

Randy Presuhn wrote:

> I think the question is whether we want things using
> 4ALPHAs to be considered well-formed

It is both ways, either as <lang> case 2*4ALPHA or as <lang>
case <registered-lang> 4*8ALPHA.  We could move the 4 from
<registered-lang> to 2*4ALPHA with 5*8 for <registered-lang>,
or we keep it where it is with 2*3ALPHA as it is.

Moving it would need various minor editorial fixes without
a clear advantage.  The "reserved for whatever Debbie does"
works in both cases for a future 3066ter or a separate spec.
extending 3066bis.
                    Bye, Frank

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 23 May 2005 18:55:36 -0700

One of the goals of the project was that the BNF never needs to be changed
in the future; that every current parser must be able to read every future
tag. (You've reminded me of this on occasion!) So it must be changed to 2*4

‎Mark

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "John Cowan" <[email-masked]>; <[email-masked]>
Sent: Monday, May 23, 2005 16:52
Subject: RE: [Ltru] Editorial error in BNF

2*3ALPHA describes assigned subtags (i.e. subtags that are valid). 4ALPHA is
reserved for future standardization and are not valid currently. That's the
reason I didn't change the ABNF, although I'm not religious about it. The
opposite case is easy enough to make.

Addison

Addison P. Phillips