Subject: RE: [Ltru] Re: [psg.com #951] extensibility via codes not maintained byISO

From: "Addison Phillips" <[email-masked]>
Date: Wed, 11 May 2005 09:43:12 -0700

I agree, although I would add to Doug's last sentence thusly:

Variant subtags
can be registered to capture scripts or regions that are inexplicably
not covered by ISO 15924, ISO 3166, or UN M.49 and which those standards bodies somehow refuse to consider.

The draft has a preference built into it for language, script, and region codes coming from the relevant maintenance organizations. Variants are a kind of last resort and mostly for items (dialects, etc.) that are not scripts or regions. Like the Slovenian dialect variant subtags.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 2005年5月10日 22:49
> To: LTRU Working Group
> Subject: [Ltru] Re: [psg.com #951] extensibility via codes not maintained
> byISO
> 
> > Comments 45 and 53 in message
> > http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html
> > raise the question of supporting language, country, and region
> > codes not maintained by ISO.
> 
> I propose rejecting this item.
> 
> Language subtags can be registered in the unlikely event that the
> various flavors of ISO 639 completely miss a language.  Variant subtags
> can be registered to capture scripts or regions that are inexplicably
> not covered by ISO 15924, ISO 3166, or UN M.49.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 11 May 2005 14:16:39 -0700

Hi -

Ok, I've marked this one "rejected".

Randy, ltru co-chair

> From: "Addison Phillips" <[email-masked]>
> To: "Doug Ewell" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, May 11, 2005 9:43 AM
> Subject: RE: [Ltru] Re: [psg.com #951] extensibility via codes not maintainedbyISO
>

> The draft has a preference built into it for language, script, and region codes coming from the relevant maintenance
organizations. Variants are a kind of last resort and mostly for items (dialects, etc.) that are not scripts or regions. Like the
Slovenian dialect variant subtags.
> > Sent: 2005?5?10? 22:49

--------------------------------------------------------------------------------