Subject: RE: [Ltru] Re: [psg.com #954] all aliases must be equally support ed

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 20 May 2005 09:52:41 -0700

Hi,

Doug's right - we need to find concensus here and move on.

I think I've been guilty of a mis-conception here.  I admit my
comments were colored by having worked on specifications and
software based on the IANA Charset Registry - which has a 10-to-1
ratio of aliases to base charset tags - the use of charset tags
in MIME content has been a thorough failure.

If indeed language subtag aliases are _rare_, then the requirement 
for support of all aliases is fine.

Canonicalization of langugage tags (by exercise of an algorithm, 
not by reference to a copy of the IANA Language Subtag Registry) 
should be a SHOULD for content generation and content queries
(because it's likely to reduce processing errors by less than
perfect software).

I'm perfectly happy to lose the problematic 'Canonical:' field
in the registry and replace it with 'Use:'.  The idea of 'once
canonical, forever canonical' is wrapping us all around the
axle, but not visibly helping.

The problem we're wrestling with is that our ISO/UN sources are
_not_ entirely stable and we intuitively think we should try to
achieve better stability in the IANA Language Subtag Registry.
We're probably catching at moonbeams...

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Doug Ewell
> Sent: Friday, May 20, 2005 2:47 AM
> To: LTRU Working Group
> Subject: [Ltru] Re: [psg.com #954] all aliases must be 
> equally supported
> 
> 
> McDonald, Ira <imcdonald at sharplabs dot com> wrote:
> 
> > Whenever possible, the language tag registry draft should not
> > encourage the proliferation of aliases for tags or subtags.
> 
> Misha Wolf <Misha dot Wolf at reuters dot com> wrote:
> 
> > We must insist that those creating tags use canonical values.
> > Any other approach will lead to a broken Internet.
> 
> and yet Frank Ellermann <nobody at xyzzy dot claranet dot de> says:
> 
> > The complete concept of "Canonical:" appears to be
> > wrong, if you even think about any "let's forget the rest".
> > ...
> > Supporting only an obsolete idea of "Canonical:" as stated in
> > an obscure IANA registry not reflecting the state of the art
> > in the source standards after date-B was a worse idea.
> 
> IMHO, this is the single biggest technical stumbling block in the
> project.  The draft has always taken the middle road by saying that
> there were canonical subtags, which would not change dammit, and then
> there were aliases which could be used (but shouldn't), and must be
> recognized as equivalent to the canonical.
> 
> Now we have some saying there should be no aliases at all, only
> canonicals, and others saying the whole notion of canonical 
> stability is
> "an obsolete idea."  Folks, if we don't find a way to resolve this, we
> are nowhere.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 20 May 2005 10:26:51 -0700

Hi -

> From: "McDonald, Ira" <[email-masked]>
> To: "'Doug Ewell'" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Friday, May 20, 2005 9:52 AM
> Subject: RE: [Ltru] Re: [psg.com #954] all aliases must be equally support ed
...
...

(as a contributor)
Consider the motivations:

    (1) Re-tagging data (now or further in the future) is
        (a) expensive and
        (b) unlikely to be complete;

    (2) We don't want ambiguity in the interpretaion of a
        (sub)tag resulting from that string having meant
        substantially different things at different points
        in time;

    (3) Having multiple representations for "the same thing"
        complicates tagging and matching, both in the specification
        and the implementation.

Although (3) appears inevitable, we can at least take steps to
minimize it.  I think we can and should take a strong position on (2),
because the realities of (1).  For tagging this means: "MUST NOT" re-use
a (sub)tag string, "SHOULD NOT" tag with non-canonical form.  (Calling
the field "Use:" is fine with me.)  For matching to work, this would
mean that an implementation "MUST" treat as equivalent *all* the aliases
(as of the implementation date) for its supported set of (sub)tags.

At the same time, we need to be mindful of the fact that languages
change and orthographies change, sometimes with surprising speed.
The borders and names of countries and regions can change even faster.
Ironically, scripts seem to be the most stable thing in the mix.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 21 May 2005 09:23:03 +0200

McDonald, Ira wrote:

> The problem we're wrestling with is that our ISO/UN sources
> are _not_ entirely stable and we intuitively think we should
> try to achieve better stability in the IANA Language Subtag
> Registry.

My intuition was and is "mirror the sources as long as possible
under the rule of stability".  Plus an emergency exit for cases
like CS etc.

> We're probably catching at moonbeams...

...some cosmic event like the CS disaster, yes.  It's rare.
The "Use:" concept is IMHO a pretty simple way to survive it.
But "Use:" is dynamic, not static, and Mark hates it.  Bye.