Subject: [Ltru] Re: [psg.com #954] all aliases must be equally supported

From: "Doug Ewell" <[email-masked]>
Date: Wed, 11 May 2005 06:50:05 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> For point (1) Doug and Addison apparently prefer to get an
> RfC for the registry draft _before_ discussing the final
> draft registry (i.e. determine more / other Suppress-Scripts).

I have never, ever argued in favor of making the registry draft an RFC.
Check the archives.  At some times I have argued against it; at other
times I have shrugged and said "whatever."

What I did propose is that we stop fussing over the minute details of
the contents of the registry and focus on the draft itself, as we are
doing right now.  If we wait until the Suppress-Script entries are
perfect before moving the draft to Last Call, we'll never get done.

> BTW, if GG and JE would be
> added this cries for a judgement call.  Insisting on 830 as a
> canonical value for both GG and JE would be ridiculous.  And
> not reflect Doug's undocumented "same piece of land" concept.

You still haven't read what I wrote on 2005-04-24:

http://www1.ietf.org/mail-archive/web/ltru/current/msg01389.html

To repeat, the "same piece of land" concept I mentioned months ago was
ONLY meant for establishing the relationship between deprecated region
subtags and their canonical equivalents (if any).  It explained why BU
was mapped to MM but DD was not mapped to DE.  You convinced us that
following ISO 3166-3 strictly was a better idea, and that is what the
registry now does.  Please do not bring up this historical relic again.
Thank you.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 11 May 2005 07:02:02 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>> the accusations of treachery and skulduggery are completely
>> uncalled for.
>
> What are you talking about ?  You haven't quoted any context,

I'm deliberately trying to keep the responses short.  They can be
identified by ticket number (952 in this case).  I thought this was what
Randy wanted, and I'm certainly trying not to contribute to the
quotational overload.

The message I was responding to is at
http://www1.ietf.org/mail-archive/web/ltru/current/msg01571.html.

> and I don't find the Message-ID in the References:
>
> <[email-masked]>
>
> Outlook isn't suited for Internet usage, but this References
> issue must be something else, a broken gateway somewhere (?)

I receive and reply to the Digest.  If you see a mysterious Message-ID,
it probably refers to the Digest, not an individual message.  In the
case of my responses to these tickets, just look for Randy's original
message, where the Subject line starts with "[psg.com #xxx]" with no
"Re:".

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 May 2005 17:24:20 +0200

> I have never, ever argued in favor of making the registry

Registry draft => Addison and Mark, draft registry => you.

Addison and you want the "last call" for the registry draft
(3066bis) before "whatever" happens with the draft registry.

My original idea was that it's more or less simultaneous.

> Check the archives.

The last discussion about this issue was in conjunction with
the idea to move the redundant tags to an appendix D in the
registry draft, because they are irrelevant in the draft
registry.  I don't need to check this, I still recall it.
We found that that's possible, because the old 3066 registry
is closed as soon as the 3066bis registry draft is approved.

Last minute registrations could be added to an appendix D
in the "48 hours".  It doesn't affect "whatever procedure"
for the draft registry, as long as "whatever" is NOT what I
thought, i.e. simultaneously.

> If we wait until the Suppress-Script entries are perfect
> before moving the draft to Last Call, we'll never get done.

IBTD.  But that's not more relevant at the moment, because
it's already clear that the registry draft gets its "last
call" before "whatever".

Where "whatever" is simply another "last call" for the draft
registry after filling the Suppress-Script gaps.  You only
supported the "separate last call before whatever" part, not
its "whatever = another last call" incarnation, I know this.

> the "same piece of land" concept I mentioned months ago
> was ONLY meant for establishing the relationship between
> deprecated region subtags and their canonical equivalents
> (if any).

830 is the "same piece of land" as GG + JE, so if GG + JE are
introduced after the final date-B there's a potential problem.
This is true no matter who said it why and where first, it has
to work.  Deprecating 830 is not allowed under the -01 rules.

Even if the UN invents 838 (GG) + 839 (JE) it's not allowed,
but that's already the second problem.  The first problem is
adding GG + JE.  Adding them as "deprecated" right from the
start with a "canonical: 830" makes no sense.  Therefore they
are added as is, after all GG alone is not 830, dito JE.

So then some old content is tagged ??-830, new content could
use ??-GG or ??-JE.  That's not optimal, for starters I very
much doubt that there are interesting differences between GG
and JE for any language ?? (en, fr, br (?)).

In theory each region can only have one non-deprecated tag.
Won't work for GG + JE, 830 cannot be deprecated.  One chance
is "let's pretend that 830 is a macro-geographical region",
that's allowed.

| For ISO 3166 codes, if the newly assigned code's meaning is
| associated with the same UN M.49 code as another 'region'
| subtag, then the existing region subtag remains as the
| canonical entry for that region and no new entry is created.

That's the "same piece of land" defined by UN numbers, it's in
the *actual* draft -01.  It's used in several rules to resolve
conflicts.

> Please do not bring up this historical relic again.

That's no "historic relic", it's in -01 chapter 3.3 section 11,
clauses 4, 5, and 6.  BTW, for a very long chapter like 3.3 a
numbered list instead of a bullet list might be better.  Bye.

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 May 2005 18:41:14 +0200

Doug Ewell wrote:

> identified by ticket number (952 in this case).

That doesn't work for me, I read the list "online", like a
news group, only the unread articles.  If "threading" by
references doesn't work I'd still see a "same subject" in
the relevant thread of unread articles.  But in that case
Randy's article was not more visible from my POV because
I read it before.

Still no problem if the references are okay, I could get
the original article with a sigle click.  But in that case
your references pointed to the digest and not an article
on the list.

Of course I could reload old articles and try to find the
same subject, but that's a major effort (= load the last
say 100 read articles, disable threading, sort by subject
instead of date, and later reset sorting and threading to
normal).

> I thought this was what Randy wanted

Yes, he said "keep the subject".  Tricky, normally replies
to a digest are obvious, with a special subject.  But you
fix these subjects, and so I was confused what's going on.

> I'm certainly trying not to contribute to the quotational
> overload.

Normally I'd second this, but if your References point to
the digest Message-IDs I don't "see" what you're quoting.

> http://www1.ietf.org/mail-archive/web/ltru/current/msg01571.html

Yes, thanks, John also found it for me.  With this context
I've no further questions about what you said.  Bye, Frank

---

From: John Cowan <[email-masked]>
Date: Wed, 11 May 2005 12:56:24 -0400

> and JE for any language ?? (en, fr, br (?)).

There are indeed differences between Dgèrnésiais and Jèrriais, though
the Ethnologue (rather surprisingly, to me) treats all the _langues
d'oïl_ as simply dialects of French, except for Picard and Walloon
(probably because they are recognized as distinct in Belgium).
In contrast, no less than five _langues d'oc_ are recognized.

> is "let's pretend that 830 is a macro-geographical region",

It clearly is.  Juridically there is no connection between Guernsey and
Jersey at all, except that they share the same Duke, namely Elizabeth II.
Economically (and the M.49 codes are fundamentally economic/statistical
in purpose) they can be treated jointly, and are.  In order for them to
be assigned distinct ISO 639-1 codes, they would have to have distinct
M.49 codes first, and that strikes me as unlikely to happen.

Still, if it did happen, we would have the three distinct region codes
GG, JE, and 830, all valid.

(The whole business is horridly arbitrary.  Pitcairn has far less juridical
independence than either Guernsey or Jersey, but it gets its own M.49
and ISO 3166-1 codes due to its physically remote location in Oceania.)

-- 
A witness cannot give evidence of his           John Cowan
age unless he can remember being born.          [email-masked]
  --Judge Blagden                               http://www.ccil.org/~cowan