Subject: [Ltru] use of region subtags

From: "Peter Constable" <[email-masked]>
Date: Fri, 27 May 2005 10:42:35 -0700

We've agreed to include a Suppress-Script field to avoid things like
"en-Latn" or "en-Latn-US". Part of the concern over the script subtag
had to do with interaction with existing usage of tags like "en-US".

A case like "iu-CA" or "iu-Latn-CA" for which the region is considered
undesirable because it's considered redundant (for the 99% case) is
similar in that it's considered best practice not to use a subtag that
can be assumed by default, though it doesn't have the same
compat-with-existing-usage issue. Would we ever want to consider a
Suppress-Region field for lang subtags? 

Thanks.

Peter Constable

GIFT | GPTS | MICROSOFT

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Mon, 30 May 2005 09:18:20 -0700

Hi Martin,

I believe this is pretty clear. See section 4.1 (although you are correct that region subtags are not specifically cited there). Perhaps we should add this paragraph between the second and third paragraph of that section:

---
<t>The application and content where the language tag is being used should be carefully considered when selecting the tag. Methods of matching tags and variation in the content may influence this choice. Generally, additional subtags beyond the primary language subtag, such as scripts, regions, or variants, should only be used when they serve to directly distinguish one piece of content from some other content. Some applications of language tag, however, produce better results with more specific tags.</t>
---

The text then continues with the text about scripts ("Of particular note...")

Notice that this would be a useful place for a forward reference to matching. Notice also that this is a paraphrase of the much loved Rule Zero: "Tag content wisely."

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Martin Duerst [mailto:[email-masked]]
> Sent: samedi 28 mai 2005 02:07
> To: Addison Phillips; Peter Constable; [email-masked]
> Subject: RE: [Ltru] use of region subtags
> 
> I'd be happy either way. But we should make sure that we are very
> clear about the fact that regions and similar stuff can be omited
> and is best omited if it doesn't actually contribute any substantial
> information, even if we choose not to list the combinations where
> this applies.
> 
> Regards,    Martin.
> 
> At 03:03 05/05/28, Addison Phillips wrote:
>  >No.
>  >
>  >Nor a Suppress-Variant.
>  >
>  >We might consider a Suppress-Extlang, but I can't think why.
>  >
>  >Addison
>  >
>  >Addison P. Phillips
>  >Globalization Architect, Quest Software
>  >Chair, W3C Internationalization Core Working Group
>  >
>  >Internationalization is not a feature.
>  >It is an architecture.
>  >
>  >> -----Original Message-----
>  >> From: [email-masked] [mailto:[email-masked]]
> On
>  >> Behalf Of Peter Constable
>  >> Sent: vendredi 27 mai 2005 10:43
>  >> To: [email-masked]
>  >> Subject: [Ltru] use of region subtags
>  >>
> "en-
>  >> Latn" or "en-Latn-US". Part of the concern over the script subtag had
> to
>  >> do with interaction with existing usage of tags like "en-US".
>  >>
>  >>
>  >>
> can
>  >> be assumed by default, though it doesn't have the same compat-with-
>  >> existing-usage issue. Would we ever want to consider a Suppress-Region
>  >> field for lang subtags?
>  >>
>  >>
>  >>
>  >>
>  >>
>  >>
>  >>
>  >> Thanks.
>  >>
>  >>
>  >>
>  >> Peter Constable
>  >>
>  >> GIFT | GPTS | MICROSOFT
>  >>
>  >>
>  >
>  >
>  >