Subject: [Ltru] [psg.com #964] section 3.4 of -00 is hard to understand

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 11 May 2005 23:36:12 -0700

Hi -

> Comment 36 in
> http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html
> reads:
> "36. 3.4. Difficult to understand. The first sentence is probably
> inherited from the former versions of the draft. "compatible with
> applications that process language tags according to this
> specification" seems to refer to filtering which should be part of the
> of the second document produced by the WG-ltru."
>

Has this been accommodated by the changes in the -01 draft?

Randy, ltru co-chair

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Peter Constable" <[email-masked]>
Date: Thu, 12 May 2005 08:40:36 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
On
> Behalf Of Addison Phillips

> Yes. The new text reads...

Suggested slight revision:

<q>Extension subtags are those introduced by single-letter subtags other
than 'x-'. They are reserved for the generation of identifiers for data
categories other than language, but which contain a language component
and are compatible with applications that understand language tags. For
example, they might be used to define locale identifiers, which are
generally based on language.</q>

Peter Constable

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 12 May 2005 09:09:01 -0700

I don't like that revision for a simple reason: it excludes extensions that do identify languages or aspects of languages. For example, an extension might be used for transliteration schemes or for very specialized kinds of categorization applied by linguists. The requirement is that extensions be compatible with language tags and that they be related in some meaningful, non-trivial way. But we shouldn't be too specific IMO.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: 2005?5?12? 8:41
> To: LTRU Working Group
> Subject: RE: [Ltru] [psg.com #964] section 3.4 of -00 is hard to
> understand
>