Subject: RE: [Ltru] [psg.com #954] all aliases must be equally supported

From: Misha Wolf <[email-masked]>
Date: Fri, 20 May 2005 18:32:17 +0100

Randy Presuhn wrote:

> For matching to work, this would mean that an implementation 
> "MUST" treat as equivalent *all* the aliases (as of the 
> implementation date) for its supported set of (sub)tags.

I regret that my current workload does not allow me to analyse 
the text of the ID to get at the precise meaning.  So please 
help me: Does this imply that all implementations must support 
the ISO 639-2 codes even where there exists a long-established 
ISO 639-1 code?  I very much hope that the answer is No.

Thanks,
Misha

-----------------------------------------------------------------
        Visit our Internet site at http://www.reuters.com

To find out more about Reuters Products and Services visit http://www.reuters.com/productinfo 

Any views expressed in this message are those of  the  individual
sender,  except  where  the sender specifically states them to be
the views of Reuters Ltd.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 20 May 2005 13:57:20 -0400

Misha Wolf scripsit:

> So please

No, no, a thousand times no.  A language with both a 639-1 and a 639-2
code must *always* use the 639-1 code in RFC 3066 and all its future
successors.  The ISO 639 RA/JAC has guaranteed that no existing language
with a 639-2 code will ever be assigned a novel 639-1 code.  In effect,
the list of 639-1 codes is frozen at least until 639-3 comes on line
(and I bet it's still in fact frozen then).

Peter, do you have any idea whether any of the new languages in 639-3 (new
to ISO, that is) would be plausible candidates for ISO 639-1 registration?
This is going to matter in RFC 3066ter.

-- 
If you understand,                      John Cowan
   things are just as they are;         http://www.ccil.org/~cowan
if you do not understand,               http://www.reutershealth.com
   things are just as they are.         [email-masked]