Subject: RE: [Ltru] Re: ISO 3166-1 DIS ballot

From: "Addison Phillips" <[email-masked]>
Date: Sun, 1 May 2005 08:51:35 -0700

I don't think you guys are saying anything different from one another. Actually, I'm a bit baffled by this thread. Frank's note seems to indicate that coupled with the 50-year period the general approach to handling region codes will work. He then goes on to suggest what he has consistently advocated: that canonical mappings should follow country code assignments.

The contrary opinion has been stated by several people on this list (most recently by John Cowan), which is that we shouldn't be forced by ISO 3166 to create instability in language tags by constantly assigning and withdrawing codes.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Doug Ewell
> Sent: 2005年4月30日 18:55
> To: LTRU Working Group
> Subject: [Ltru] Re: ISO 3166-1 DIS ballot
> 
> Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:
> 
> > In other words 3066bis draft -01 should work without problems
> > at least until date A plus 50 years (2038).  And maybe we can
> > improve this situation in draft -02 with a new "canonical" rule
> > following 3166-1 as long as possible - until the registry is
> > finally forced to take the emergency exit "UN number".
> 
> and Randy responded:
> 
> > Do you have specific text you'd like to propose?
> > Keep in mind that we don't want to make a normative reference
> > to work-in-progress.
> 
> There's more to it than that.
> 
> The draft contains SPECIFIC, EXPLICIT steps for what to do if and when
> ISO 3166/MA ever reuses a code element.  This is one of the basic
> rationales for the whole LTRU project.
> 
> To state that the draft will "work without problems" only until ISO
> 3166/MA reuses a code element, and that at that point the registry will
> be "forced to take an emergency exit," demonstrates complete
> misunderstanding of the mechanism described in the draft.
> 
> Please read Section 3.3 again, in particular the next-to-last bullet
> point (the one with six sub-bullet points):
> 
> http://www.inter-locale.com/ID/draft-ietf-ltru-registry-
> 01.html#ianastability
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 1 May 2005 15:10:58 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> I don't think you guys are saying anything different from one another.
> Actually, I'm a bit baffled by this thread. Frank's note seems to
> indicate that coupled with the 50-year period the general approach to
> handling region codes will work. He then goes on to suggest what he
> has consistently advocated: that canonical mappings should follow
> country code assignments.
>
> The contrary opinion has been stated by several people on this list
> (most recently by John Cowan), which is that we shouldn't be forced by
> ISO 3166 to create instability in language tags by constantly
> assigning and withdrawing codes.

Then I agree with John.  I don't think changing the subtags people
"should" use because of changes in ISO 3166 does anything to solve the
stability problem.  The approach described by the draft requires no
"emergency exit" to handle ISO changes; on the contrary, it carefully
plans for them.