Subject: RE: [Ltru] Editorial error in BNF

From: "Addison Phillips" <[email-masked]>
Date: Tue, 24 May 2005 09:38:13 -0700

We wouldn't define the syntax or even the source for alpha4 primary language subtags. It would work thusly:

1. The ABNF defines lang=2*4ALPHA / 5*8alphanum
2. The text defines that ALPHA2 and ALPHA3 subtags are defined by ISO 639-1 and ISO 639-2.
3. The text says that ALPHA4 subtags are reserved for future standardization. Implementations know that four letter subtags might be added to the registry in the future. 

Implementations know already how to deal with the primary language subtag(the semantics of ISO 639-6 are not important here) and must be written to handle registered subtags with length two through eight. Ultimately this has no impact on implementations: the only effect this has is that there won't be any four letter primary language subtags in the registry. Well, it has one effect: a primary language subtag with a length of four that contains a digit is illegal.

In other words, your caution that we should wait to see ISO 639-6 before standardizing it in language tags is well taken, but not important at this juncture. We are merely reserving a location in the registry for those values. Standardization of 3066-based language tags on ISO 639-6 might never happen or will at least happen in its own time. The exact same can be said about ISO 639-3.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: 2005?5?24? 9:10
> To: [email-masked]
> Subject: RE: [Ltru] Editorial error in BNF
> 
> > From: [email-masked] [mailto:[email-masked]]
> On
> > Behalf Of Mark Davis
> 
> 
> > One of the goals of the project was that the BNF never needs to be
> changed
> > in the future; that every current parser must be able to read every
> future
> > tag. (You've reminded me of this on occasion!) So it must be changed
> to
> > 2*4
> 
> See my comments in another msg just sent: I do not think at this point
> we can know what the syntax for language tags that incorporate an ISO
> 639-6 standard would look like, so I think the requirement that devs be
> able to anticipate that future syntax with certainty now is impossible.
> 
> 
> 
> Peter Constable
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Tue, 24 May 2005 13:41:14 -0400

Addison Phillips scripsit:

> Implementations know already how to deal with the primary language
> subtag(the semantics of ISO 639-6 are not important here) and must
> be written to handle registered subtags with length two through
> eight. Ultimately this has no impact on implementations: the only
> effect this has is that there won't be any four letter primary language
> subtags in the registry. Well, it has one effect: a primary language
> subtag with a length of four that contains a digit is illegal.

+1

-- 
John Cowan  [email-masked]  www.reutershealth.com  www.ccil.org/~cowan
The present impossibility of giving a scientific explanation is no proof
that there is no scientific explanation. The unexplained is not to be
identified with the unexplainable, and the strange and extraordinary
nature of a fact is not a justification for attributing it to powers
above nature.  --The Catholic Encyclopedia, s.v. "telepathy" (1913)