Subject: RE: [Ltru] Re: [psg.com #938] should introduction allude to intendedbcp status?

From: "Addison Phillips" <[email-masked]>
Date: Wed, 11 May 2005 13:35:43 -0700

There is no way that I know of to insert this value except by editing the generated document by hand.

I'm not sure that I would *want* to insert it. We allude only to RFC status in the document. Surely RFC 3066's successor, whatever track the IESG puts it on, will obsolete the current BCP 47 too. Debate about whether to pursue the STD track or not might be interesting to have in this WG, but has no practical effect on the contents of the document except for that one phrase, no? And in practice, the track the document follows has no impact on what we put into it either.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?5?11? 13:17
> To: LTRU Working Group
> Subject: Re: [Ltru] Re: [psg.com #938] should introduction allude to
> intendedbcp status?
> 
> Hi -
> 
> > From: "Doug Ewell" <[email-masked]>
> > To: "LTRU Working Group" <[email-masked]>
> > Sent: Tuesday, May 10, 2005 9:56 PM
> > Subject: [Ltru] Re: [psg.com #938] should introduction allude to
> intendedbcp status?
> >
> 
> > > The question of whether the introduction to the registry draft
> > > should allude to its intended BCP status was raised in comment #9 in
> > > http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html
> > >
> > > There was no support on the mailing list for this proposed change,
> > > so the proposal is marked "rejected".
> >
> > No opinion.  This is a process question, best settled between the chairs
> > and editors.
> ...
> 
> The last paragraph of section 2 of http://www.ietf.org/ietf/1id-
> guidelines.html
> states:
> 
> | The Internet-Draft should neither state nor imply that it has any
> standards status;
> | to do so conflicts with the role of the RFC Editor and the IESG. The
> title of the
> | document should not imply a status. Avoid the use of the terms Standard,
> Proposed,
> | Draft, Experimental, Historic, Required, Recommended, Elective, or
> Restricted in
> | the title of the Internet-Draft. Indicating what status the document is
> aimed for
> | is OK, but should be done with the words "Intended status: <status>".
> 
> With nroff, it would be easy to put "Intended status: BCP" among the items
> in the
> upper left corner of the first page.  I don't know how to do it with
> xml2rfc.
> I encourage the editors to include "Intended status: BCP" if they can do
> so
> without expending too much time (more than five minutes) on figuring out
> how
> to get the tools to do it.
> 
> The abstract already (-01) states "This document obsoletes RFC 3066 (which
> replaced RFC 1766)."  That's the important part, which I believe satisfies
> the heart of the comment.  Whether this ultimately becomes a BCP or not is
> up to the IESG; we as a WG will only make a recommendation.
> 
> Randy, ltru co-chair
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Wed, 11 May 2005 16:53:53 -0400

> editing the generated document by hand.

Actually, I believe it *is* doable with xml2rfc.  I don't have access to my
references to confirm my suspicion, but I can check in the morning.

-Scott-

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 11 May 2005 13:58:35 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, May 11, 2005 1:35 PM
> Subject: RE: [Ltru] Re: [psg.com #938] should introduction allude to intendedbcp status?
>

> There is no way that I know of to insert this value except by editing the generated document by hand.

It's not worth the effort.

> I'm not sure that I would *want* to insert it. We allude only to RFC status in the document.
> Surely RFC 3066's successor, whatever track the IESG puts it on, will obsolete the current
> BCP 47 too. Debate about whether to pursue the STD track or not might be interesting to
> have in this WG, but has no practical effect on the contents of the document except for
> that one phrase, no? And in practice, the track the document follows has no impact on
> what we put into it either.

> up to the IESG; we as a WG will only make a recommendation.

The BCP vs STD debate isn't really ours to have.  We can make a recommendation
when we pass it to the IESG, but the decision is theirs to make.  Since the technical
content is already out there as a BCP, I think we'd need a fairly compelling argument
to ask for something else.  In any case, I'd prefer to defer discussion of BCP/STD
until all other issues are resolved, since it really doesn't impact the content of the
document.

Randy, ltru co-chair