Subject: RE: [Ltru] Re: [psg.com #944] MAY a conformant implementation impose length constraints?

From: "Addison Phillips" <[email-masked]>
Date: Tue, 10 May 2005 21:25:49 -0700

That makes sense.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: 2005?5?10? 21:03
> To: [email-masked]
> Subject: [Ltru] Re: [psg.com #944] MAY a conformant implementation impose
> length constraints?
> 
> Addison Phillips wrote:
> 
> > A conformant implementation MAY refuse to support the storage
> > of language tags which exceed a specified length. For an
> > example, see [RFC 2231] (Freed, N. and K. Moore, "MIME
> > Parameter Value and Encoded Word Extensions: Character Sets,
> > Languages, and Continuations," November 1997.)[22].
> 
> The real problem is 2231 in conjunction with 2047 encoded
> words, the 2047 limit 76 is not mentioned in 2231.  Please
> add RfC 2047.
> 
> While 2231 multiline-parameters are a pain they have almost
> no length problems - in fact that's the idea of multiline
> parameters, and any remaining limit 9?? (below 998) is no
> real problem for LTRU.  BTW, 998 is documented in RfC 2045,
> not in RfC 2231.
> 
> > Any such limitation MUST be clearly documented, and such
> > documentation SHOULD include the disposition of any longer
> > tags (for example, whether an error value is generated or
> > the language tag is truncated). If truncation is permitted
> > it SHOULD NOT permit a subtag to be divided.
> 
> Please swap the MUST and the second SHOULD.  It SHOULD be
> clearly documented (and we know that this is not the case
> from our POV for 2231 + 2047), and any truncation MUST at
> least syntactically make sense,
>                                Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 31 May 2005 20:49:42 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

>> Won't work: Variants and private use subtags are not bounded in
>> number. Neither can extension lengths be known in advance.
>
> Then I think we really need to add something like the following to the
> security considerations section, as part of this issue's resolution /
> rejection:
>
> Since there is no limit to the number of variant and private use
> subtags, and consequently no limit on the possible length of a tag,
> implementations need to guard against buffer overflow attacks.  See
> section ## for details on tag truncation, which can occur as a
> consequence of defenses against buffer overflow.

Yes.  Excellent.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/