Subject: RE: [Ltru] 5 - Appendix D: Redundant Tags (was: Open points before -02)

From: "Addison Phillips" <[email-masked]>
Date: Mon, 2 May 2005 12:09:40 -0700

One reason we haven't done this is that there are still tags getting registered (up to Date B, right?)

Another is that not listing them might lead to the "where did my registry go?" questions in the future. The redundant entries are not actually useful for anything other than answering this question, if you think about it.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: 2005?5?2? 11:40
> To: [email-masked]
> Subject: [Ltru] 5 - Appendix D: Redundant Tags (was: Open points before -
> 02)
> 
> Hi, the details for:
> 
> | 5 - move redundant tags from draft registry to an appendix
> 
> At the moment the draft registry contains 64 redundant tags
> in 320 lines or about 6 KB.
> 
> Adding the explanation in the registry draft, and the code in
> all future 3066bis parsers to ignore these 64 really redundant
> tags I prefer to move them to a new "appendix D" enumeration.
> 
> Proposed text for the "IANA Considerations":
> 
>    Appendix D (Redundant Tags) lists all tags registered under
>    the rules of [RfC 3066] which are now covered by identical
>    and fully compatible tags composed of subtags.  Unlike all
>    other "grandfathered" tags these redundant tags and their
>    registration forms should not be kept in the IANA registry.
> 
> Proposed text for "Appedix D: Redundant Tags"
> 
>    The following valid tags were registered under the rules of
>    [RfC 3066] and are now covered by identical tags composed
>    of subtags.  They are therefore not copied to the list of
>    "grandfathered" tags defined in Section 2.2.8.
> 
>    Redundant tags: az-Arab, az-Cyrl, az-Latn, be-Latn, bs-Cyrl,
>    bs-Latn, cel-gaulish, de-1901, de-1996, de-AT-1901, de-AT-1996,
>    de-CH-1901, de-CH-1996, de-DE-1901, de-DE-1996, en-boont,
>    en-scouse, iu-Cans, iu-Latn, mn-Cyrl, mn-Mong, sgn-BR, sgn-CO,
>    sgn-DE, sgn-DK, sgn-ES, sgn-FR, sgn-GB, sgn-GR, sgn-IE, sgn-IT,
>    sgn-JP, sgn-MX, sgn-NI, sgn-NL, sgn-NO, sgn-PT, sgn-SE, sgn-US,
>    sgn-ZA, sl-nedis, sl-rozaj, sr-Cyrl, sr-Latn, tg-Arab, tg-Cyrl,
>    uz-Cyrl, uz-Latn, yi-latn, zh-guoyu, zh-hakka, zh-Hans,
>    zh-Hans-CN, zh-Hans-HK, zh-Hans-MO, zh-Hans-SG, zh-Hans-TW,
>    zh-Hant, zh-Hant-CN, zh-Hant-HK, zh-Hant-MO, zh-Hant-SG,
>    zh-Hant-TW, zh-xiang.
> 
> About 25 lines in less than 2 KB text, and no sweat for developers
> of 3066bis code.
>                             Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 02 May 2005 23:10:06 +0200

Addison Phillips wrote:

> One reason we haven't done this is that there are still tags
> getting registered (up to Date B, right?)

Doug apparently wants a date B _after_ date Y, where Y is the
day whe the IESG moving the registry draft to the queue of
the RfC editor.  After date Y the old registry is closed.

If there's another landrush of redundant tags on day Y-1 you
could add them to appendix D in your 48 hours.

> Another is that not listing them might lead to the "where
> did my registry go?" questions in the future.

They are in appendix D.

> The redundant entries are not actually useful for anything
> other than answering this question, if you think about it.

Unfortunately they do require code, copied from a REXX script:

   if sign( wordpos( Y, 'REDUNDANT GRANDFATHERED' ))
      then  parse upper var REC 'TAG:' X
      else  parse upper var REC 'SUBTAG:' X

   if Y = 'REDUNDANT'   then  XREF = XREF + PREF( X )

Okay, I wanted to check all referecend tags.  But without any
"Redundant:" I'd have done it inline without a procedure PREF,
near the place where I see a "Recommended-Prefix".  Bye, Frank