Subject: RE: [Ltru] [psg.com #941] determining currency of registry versions

From: "Addison Phillips" <[email-masked]>
Date: Tue, 10 May 2005 09:03:50 -0700

You can extract the codes without any reference to the registry (current or otherwise) based on length and position.

The currency of the registry is determined by the File-Date field. The one on the IANA website is the most current. Ones with an older date than that one are not current.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?5?13? 23:46
> To: LTRU Working Group
> Subject: [Ltru] [psg.com #941] determining currency of registry versions
> 
> Hi -
> 
> This issue was raised in item 12 in
>  http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html
> 
>  A mechanism describing how one determines whether a registry
> version is "current" needs to be spelled out.
> 
>  This is related to the charter requirement "For accessibility,
> it is to provide a mechanism for easily
> determining whether a particular subtag is valid as of a given date,
> without onerous reconstruction of the state of the underlying standard
> as of that time."
> 
>  This is also somewhat related to the charter requirement
> "It is expected to specify a mechanism for easily identifying the role
> of each subtag in the language tag, so that, for example, whenever a
> script code or country code is present in the tag it can be extracted,
> even without access to a current version of the registry."
> (This last phrase naturally leads one to ask the question, "how do I know
> whether what I have is current.")
> 
> Randy
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 10 May 2005 20:54:32 -0700

Hi -

(as a technical contributor)

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, May 10, 2005 9:03 AM
> Subject: RE: [Ltru] [psg.com #941] determining currency of registry versions
>

> You can extract the codes without any reference to the registry
> (current or otherwise) based on length and position.

This still doesn't address the requirement from the charter that
"it is to provide a mechanism for easily determining whether a
particular subtag is valid as of a given date, without onerous
reconstruction of the state of the underlying standard
as of that time"

> The currency of the registry is determined by the File-Date field.
> The one on the IANA website is the most current. Ones with an
> older date than that one are not current.

The current (-01) text says:
   The first record in the file contains the single field whose field-
   name is "File-Date" and whose field-body contains the last
   modification date of the registry:

Would it make sense to amend it to say something like:
   The first record in the file contains the single field whose field-
   name is "File-Date". The field-body contains the last
   modification date of the registry.  The currency of the registry
   is determined by this field.  The registry on the IANA website is
   the most current.   Versions with an older date than that one
   are not current.

Randy