Subject: [Ltru] [psg.com #946] use of both length and position to identify subtag problematic

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 13 May 2005 23:53:47 -0700

Hi -

Comment #17 in message
 http://www.ietf.org/mail-archive/web/ltru/current/msg00540.html
states that the use of both length and position to identify
subtags would be problematic.

A response to this concern is in message
http://www.ietf.org/mail-archive/web/ltru/current/msg00628.html
No alternative garnered significant support.

Can we mark this one "rejected"?

Randy, ltru co-chair

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 10 May 2005 12:20:45 +0200

Randy Presuhn wrote:
 
 [psg.com #946] 
> Can we mark this one "rejected"?

I've found that splitting tags before the hyphen (excl. any
stuff introduced by a singleton) results in a set of unique
"tokens", and it's possible to identify the type of these
"tokens" without noting their former position.

With several extlang "tokens", and if the order of extlang
"tokens" is significant, it starts to get ugly.  If you have
a separate ticket for extlang I've no problem with rejecting
[psg.com #946]
                      Bye, Frank

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 10 May 2005 07:42:05 -0700

Agree to reject.

‎Mark

----- Original Message ----- 
From: "Randy Presuhn" <[email-masked]>
To: "LTRU Working Group" <[email-masked]>
Sent: Friday, May 13, 2005 23:53
Subject: [Ltru] [psg.com #946] use of both length and position to
identifysubtag problematic

---

From: John Cowan <[email-masked]>
Date: Tue, 10 May 2005 11:26:19 -0400

> "tokens" is significant, it starts to get ugly.  If you have

A good insight.

> a separate ticket for extlang I've no problem with rejecting

I agree on both counts: we need a ticket for the issue
"Shall multiple extlang tags be permitted in the syntax?"

-- 
John Cowan  [email-masked]  www.reutershealth.com  www.ccil.org/~cowan
"The exception proves the rule."  Dimbulbs think: "Your counterexample proves
my theory."  Latin students think "'Probat' means 'tests': the exception puts
the rule to the proof."  But legal historians know it means "Evidence for an
exception is evidence of the existence of a rule in cases not excepted from."

---

From: Marion Gunn <[email-masked]>
Date: Tue, 10 May 2005 18:03:41 +0100

Is that an argument for replacing hypens with underlines? 

If so, I agree. 

(Attending ISO conf. all this wk, with no time to check ref. given
below, and v. little time for e-mail, and offering apol's if this is not
what you meant, Frank.)
mg

Scríobh. Frank Ellermann:
> "tokens"...
-- 

Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an 
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 May 2005 10:26:17 +0200

> Is that an argument for replacing hypens with underlines?

No.  Or is this an idea to build groups of sub-subtags with
an intra-subtag separator ?  That could make sense for the
case "one or more extlang".

What we have is (example):  lng-exa-exb-exc-exd-Latn-ZZ
With an "extlang group":    lng-exa:exb:exc:exd-Latn-ZZ

One consequence would be, that the subtag length limit
is then 15 for a maximum four extlang sub-substags.

For an "extlang group" the lenghts are 3, 7, 11, and 15.
No problem if we disallow length 7 for variants and any
future registered-lang.

One variant "gaulish" already has length 7, so we better
pick an unambiguous sub-separator, anything is possible,
colon, dot, underscore, etc. (excl. hyphen/alpha/digit).

But that's then unfortuately not more 3066 compatible.
Dreaming about simply declaring 3066 as historic FUBAR.

Okay, back to reality, one of the ugly like hell hacks,
the only interesting "group" are the extlangs.  That's
3ALPHA.  So we could abuse "0" as sub-separator:

lng-exa0exb0exc0exd-Latn-ZZ

But then we would have a serious problem with "gaulish".
Sigh, I give up.  Bye, Frank

---

From: John Cowan <[email-masked]>
Date: Wed, 11 May 2005 08:31:18 -0400

> is then 15 for a maximum four extlang sub-substags.

And unfortunately RFC 3066 limits us to 8 characters per subtag.  One of
our constraints is RFC 3066 compatibility, so all such tricks involving
ad hoc separators are out.

In any case, I think four extlang tags is well beyond the limit of
plausibility.  Even two is unlikely: that would require that one of the
360+ 639-3 individual languages that are encompassed by a macrolanguage
is changed in the future to itself be a macrolanguage.

As I have noted, ISO 639-3 is based on an extreme "splitter" (as
opposed to "lumper") view of language distinctions, so further splits
are unlikely.

-- 
Knowledge studies others / Wisdom is self-known;      John Cowan
Muscle masters brothers / Self-mastery is bone;       [email-masked]
Content need never borrow / Ambition wanders blind;   www.ccil.org/~cowan
Vitality cleaves to the marrow / Leaving death behind.    --Tao 33 (Bynner)