Subject: RE: [Ltru] Re: [psg.com #954] all aliases must be equally support ed

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 18 May 2005 11:53:29 -0700

Hi,

First, aliases are _bad_ for the reliability of any protocol
or interface.  The so-called 'preferred MIME name' label on
aliases in the IANA Charset Registry is useless and dangerous.

Whenever possible, the language tag registry draft should not encourage the
proliferation of aliases for tags or subtags.

The registry draft and the matching draft should make clear
that support for the Canonical subtags is REQUIRED, but
support for Alias subtags is merely RECOMMENDED.  Your mileage
may vary.  Required support for all registered aliases is a
bad idea and it will be ignored by the majority of implementors.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Doug Ewell
> Sent: Wednesday, May 18, 2005 1:56 AM
> To: LTRU Working Group
> Subject: [Ltru] Re: [psg.com #954] all aliases must be 
> equally supported
> 
> 
> I don't know if this particular issue got resolved yet, but I'm
> concerned about an informative "Use" field that seems to run 
> counter to
> the normative "Canonical" field.  We have text all over the draft that
> says processors should use a canonical subtag instead of an alias
> whenever possible.  This proposal would turn that on its ear; 
> you would
> have situations where one tag would be canonical, yet processors would
> actually be encouraged to use the other one.
> 
> Or, alternatively, there would be only a "Use" field and no 
> "Canonical"
> field.  That would make "Use" into sort of an ersatz "Canonical," but
> with none of the stability that the word "canonical" implies.
> 
> I agree that the whole matter of "deprecated but canonical" subtags is
> weird, but I'm not at all convinced this is the right solution.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 18 May 2005 13:07:54 -0700

Hi -

> From: "McDonald, Ira" <[email-masked]>
> To: "'Doug Ewell'" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, May 18, 2005 11:53 AM
> Subject: RE: [Ltru] Re: [psg.com #954] all aliases must be equally support ed
...
> bad idea and it will be ignored by the majority of implementors.
...

This has been a long and winding (if not windy) thread.

>From a technical perspective, I think there's been a lack of
clarity on the distinction between support for a specific alias
(whether an application knows what a particular subtag alias
means) and support for alias subtags (meaning that an application
that has a copy of the registry will know how to chase down the
canonical data associated with an alias, and the application will
be able to handle that alias as well (or as badly) as the canonical
form.)

>From a process perspective, after all this discussion, I'd like to
see a proposal with specific text, since the finer points of the
wording seem to be where the disagreements originate.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 19 May 2005 13:18:06 +0200

McDonald, Ira wrote:

 [aliases]
> The so-called 'preferred MIME name' label on aliases in the
> IANA Charset Registry is useless and dangerous.

We don't make them up for fun, they just happen, like YU -> CS
or jw -> jv.  Or the grandfathered cases like i-klingon -> tlh.

> Whenever possible, the language tag registry draft should not
> encourage the proliferation of aliases for tags or subtags.

It doesn't, actually it tries to avoid them like hell.

> support for the Canonical subtags is REQUIRED, but support
> for Alias subtags is merely RECOMMENDED.

IBTD, the subject says it all.

> Your mileage may vary.

Certainly.  The complete concept of "Canonical:" appears to be
wrong, if you even think about any "let's forget the rest".

The more flexible "Use:" concept (all aliases pointing to the
same "best current practice" tag) is better.

> Required support for all registered aliases is a bad idea and
> it will be ignored by the majority of implementors.

Supporting only an obsolete idea of "Canonical:" as stated in
an obscure IANA registry not reflecting the state of the art
in the source standards after date-B was a worse idea.

With 7000+ languages our few aliases can't be the showstopper.

                         Bye, Frank