Subject: [Ltru] RE: Some comments on draft-ietf-ltru-matching-00

From: "Addison Phillips" <[email-masked]>
Date: Tue, 17 May 2005 15:48:12 -0700

Hi Michael,

Thanks for the comments.

You should probably make future comments on the LTRU mailing list: Mark and I are merely the editors. I've copied the list on this message. Some responses inter-linearly below.

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: Michael A. Patton [mailto:[email-masked]]
> Sent: 2005?5?17? 14:34
> To: Addison Phillips; [email-masked]
> Subject: Some comments on draft-ietf-ltru-matching-00
> 
> Here are some comments on draft-ietf-ltru-matching-00, original
> text is indented (by four spaces, in addition to any original
> indentation), my comments are at the left margin (special note ">>>"
> at the left margin points in to a short comment, often a simple typo).
> Where alternate text is offered, it is indented as the original was in
> the document.  Usually, the last section heading is left in place to
> help identify where the comments apply.
> 
> Most of the comments are typos, but there are two important errors (a
> ref to a non-existant example and a syntax error in the ABNF) amongst
> the typos
> 
> 
> In Section 1 third paragraph there is a mention of RFC3066bis but no
> reference mark.  Should add "[1]" (I think), i.e.
> 
>        Given a set of language identifiers, such as those defined in
>        RFC3066bis [1], various mechanisms ...
[Addison Phillips] 

I used xml2rfc to generate the text. I'll check on how the reference is tagged so that it is generated correctly in the next version.
> 
> ---
> 
> In this paragraph, I'm not sure why the RFC is delimited as it is:
> 
>        The keywords "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
>        "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in
> this
>        document are to be interpreted as described in [RFC 2119] [5].
> 
> I.e. it should read:
> 
>        The keywords "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
>        "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in
> this
>        document are to be interpreted as described in RFC2119 [5].
[Addison Phillips] 

Ditto.
> 
> ---
> 
>     2.1  Basic Language Range
> 
>        1.  ... as the example above.
> 
> There's no example in the document before this , so what does this
> refer to?
[Addison Phillips] 

This document was made by splitting another document (draft-phillips-langtags-10) into two documents. I have subsequently corrected some of the oversights you mention (such as this one) in the editor's copy and you'll see them in a draft-01 shortly. For reference, the editor's copy is at:

http://www.inter-locale.com/ID/draft-ietf-ltru-matching-01.html
http://www.inter-locale.com/ID/draft-ietf-ltru-matching-01.txt

> 
>        2.  ...
> 	   by that protocol.  This should be done with caution, since it it
> >>>                                                                   ^^
> dup
> 	   is removing information that may be relevant if services on the
[Addison Phillips] 

Yup. Thanks.
> 
> ---
> 
>     2.2  Extended Language Range
> 
>        lang    = ( 2*8ALPHA *[ *( "-" extlang ] ) ) / "*"
> 
> This rule has a syntax error, the parens and brackets don't nest
> correctly.  I think you meant:
> 
>        lang    = ( 2*8ALPHA *[ *( "-" extlang ) ] ) / "*"
> 
> but even though that's now syntactically correct, it seems that having
> the two nested repeats is unduly redundant.
[Addison Phillips] 

This was the result of taking Bill Fenner's ABNF checker-tool output and pasting it in. My bad for not checking it more carefully.
> 
> ---
> 
>     2.2.1  Extended Range Matching
> 
>        Subtags not specified, included those at the end of the language
> >>>                           ^^^^^^^^ including
>        range, are assigned the value "*".  This makes each range into a
[Addison Phillips] 

Good catch. Thanks.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 18 May 2005 04:17:53 +0200

Addison Phillips wrote:

> Bill Fenner's ABNF checker-tool

That's already fixed... :-)  Bye.

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 20 May 2005 17:30:07 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Michael A. Patton" <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, May 17, 2005 3:48 PM
> Subject: [Ltru] RE: Some comments on draft-ietf-ltru-matching-00

...
> I used xml2rfc to generate the text. I'll check on how the reference
> is tagged so that it is generated correctly in the next version.
...

My personal preference when using xml2rfc is to use the option
   <?rfc symrefs='yes'?>

It gets rid of some of the redundancy, both in the XML source and in the
formatted output.  The complete option set I use is:
<? set up non-default formatting options. ?>
<?rfc compact='yes'?>
<?rfc strict='yes'?>
<?rfc toc='yes'?>
<?rfc tocindent='yes'?>
<?rfc sortrefs='yes'?>
<?rfc symrefs='yes'?>
<rfc> ... </rfc>

These are (other than toc) a matter of editorial preference, unless the WG
should feel strongly about some aspect of the formatting.

Randy