Subject: [Ltru] Re: 003 vs. 021

From: "Doug Ewell" <[email-masked]>
Date: Sun, 1 May 2005 18:52:06 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>>> Maybe Doug can use ZZ as an additional plausibilty test.
>>
>> Plausibility of what?
>
> Of the output of your region code generator.  Mark's ZZ-
> codes plus TW should match all non-deprecated alpha-2
> codes without UN number.  It's about something I don't
> see, somewhere hidden in the generator you match numbers
> and alpha-2 codes to catch the remaining UN numbers for
> the registry.  Or do you do this manually ?  Not really
> important, but with this zoo of codes it's easy to miss
> something.

I don't have a region code generator.  I do what we've been talking
about, manually: start with the current ISO 3166-1 codes, then add the
ones that were withdrawn since 1988, then add the UN codes for
macrogeographic regions, plus 830 and 833 because the represent
country-like regions that don't have an ISO code, plus 200 because we
haven't yet reached consensus to remove it.

In particular, I don't cross-check the set of region codes with CLDR,
MARC, the CIA Factbook, or any other reference.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 02 May 2005 16:08:57 +0200

Doug Ewell wrote:

> I don't cross-check the set of region codes with CLDR,

I'll try this one when I've time.  The difference should
be something like ZZ, 003. 021, 200, 830, and 833.

> the CIA Factbook

That won't work, it's based on the different FIPS 10-4:

All parts of UM (Wake, Johnston, Midland, Navassa, etc.)
separately, some French islands like Europe and Glorioso
near Madagascar, the Spratly- and Paracel Islands, PS as
West Bank + Gaza strip <http://www.statoids.com/wab.html>

                        Bye, Frank

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 2 May 2005 18:56:21 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Some "Added" are newer than the "Deprecated", that's
> an odd side-effect, see below.

"Added" is the date the subtag was added to the registry.

"Deprecated," for those subtags that already have such a field, is the
date the underlying ISO code was withdrawn or deprecated in its
respective standard.  The idea is that the subtag was actually
discouraged from use in RFC 1766 or 3066 as of that date, although those
RFCs did not have a formal mechanism for deprecating tags or subtags.

Future "Deprecated" dates would be equivalent to the "Added" date; that
is, the subtag would be considered deprecated at the moment it was
added.

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 2 May 2005 19:04:52 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> Quite the contrary, the draft demonstrates a complete lack
> of understanding of what was wrong with RfC 3066.  The draft
> indirectly says "tags ougt to be stable, and if ISO 3166-1
> isn't then ISO 3166-1 is wrong".  But the opposite is true,
> ISO 3166-1 was never stable, will never be stable, is not
> meant to be stable, and attempts to abuse it as source for
> stable codes are doomed.  See CS, GE, SK, etc.

No matter how right or wrong the decision may have been to use ISO
3166-1 codes in language tags, that decision was made ten years ago, and
it is a primary goal of this project for existing tags to be compatible
with the new mechanism.