Subject: RE: [Ltru] [psg.com #967] addresshomographissuesinsecurityconsiderations

From: "Addison Phillips" <[email-masked]>
Date: Tue, 24 May 2005 13:18:16 -0700

The simplest possibility would eliminate all of this (pointless) text: we can eliminate the homograph problem altogether in a very simple manner. Require subtags to be all ALPHA or all DIGIT. This actually affects only registered primary language subtags and registered variants and *no* extant subtags.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Martin Duerst [mailto:[email-masked]]
> Sent: 2005?5?23? 18:07
> To: Addison Phillips; Randy Presuhn; [email-masked]
> Subject: RE: [Ltru] [psg.com #967]
> addresshomographissuesinsecurityconsiderations
> 
> At 07:29 05/05/24, Addison Phillips wrote:
>  >Since this is a rule that is unlikely to come into play often (if ever),
>  >making it a MUST is hardly a hardship.
> 
> Well, yes and no. Will somebody be able to provide some kind of
> software to IANA for checking this? Doing this kind of check by
> hand is extremely tedious, and the fact that the problem occurs
> very rarely makes it easy to just leave the check out.
> 
> Regards,    Martin.
> 
>  >In fact, it is nice and crisp (and
>  >applies to a very small set of subtags---exactly none as of draft-03).

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 24 May 2005 14:25:05 -0700

I am wary of this step -- it could be dangerous. If, say, 3166 starts using,
say, C3 because they run out of codes, it will cause a problem. It also
doesn't allow for alternatives like 1996a 1996b, which I can perhaps see a
need for.

‎Mark

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "Martin Duerst" <[email-masked]>; "Randy Presuhn"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, May 24, 2005 13:18
Subject: RE: [Ltru] [psg.com
#967]addresshomographissuesinsecurityconsiderations

The simplest possibility would eliminate all of this (pointless) text: we
can eliminate the homograph problem altogether in a very simple manner.
Require subtags to be all ALPHA or all DIGIT. This actually affects only
registered primary language subtags and registered variants and *no* extant
subtags.

Addison

Addison P. Phillips

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 25 May 2005 01:17:08 +0200

Mark Davis wrote:

> It also doesn't allow for alternatives like 1996a 1996b,
> which I can perhaps see a need for.

Me too, the scouse21 example for scouse in the 21st century.

But I really don't see any need to mention that sc0use2l is
a profoundly bad idea, the tag reviewer isn't some script,
(s)he can judge this.

Jefsey's concern, the script abused to cause confusion with
misleadingly tagged content, was more realistic.  Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 25 May 2005 22:18:26 -0700

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, May 24, 2005 4:17 PM
> Subject: [Ltru] Re: [psg.com#967]addresshomographissuesinsecurityconsiderations
>
> Mark Davis wrote:
>
...

Ok, so it looks like the proposal to address the concern by limiting
the repertoire doesn't have sufficient traction.  That takes us back to
the proposal to add

> > The language tag associated with a particular bit of content is of no
> > consequence whatsoever in determining whether that content might
> > contain possible homographs.  The fact that a text is tagged as being
> > in one language provides no assurance whatsoever that it doesn't
> > contain characters from scripts other than the one(s) associated with
> > that language.

My reading is that we have a rough consensus to add words to this effect
to the security considerations section, and I'll mark this issue "resolved."

Randy, ltru co-chair