Subject: [Ltru] Re: add internationalization considerations to initial registry draft?

From: "Doug Ewell" <[email-masked]>
Date: Fri, 5 Aug 2005 07:55:16 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> Regarding the confusion of who does what where, I note that Doug
> (the editor of draft-initial) put IANA into both the abstract and
> introduction, although he then reverts from "IANA Language Subtag
> Registry" to just "Language Subtag Registry" in the second paragraph.

And in some places I reduced it to "the registry."

I'm not really convinced there is any genuine confusion over which
registry is implied.

> It's an editorial change, and not a very important one in my view.

+1

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Fri, 5 Aug 2005 07:59:46 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

>> 2. Will all the "added" dates be changed to that of the date when
>> the actual registry goes "live"? (As well for the initial value
>> of the "File-Date".)
>>
> [Addison Phillips]
>
> No. The initial value of File-Date should change, but not the added
> dates.

Oops.  This was not my understanding, and so I've been advancing all the
Added dates with each revision.

What should the dates be?  Fixed at the date when draft-initial passes
WGLC and moves into IETF Last Call?  Something previous to that?

---

From: r&d afrac <[email-masked]>
Date: Fri, 05 Aug 2005 19:12:08 +0200

>I'm not really convinced there is any genuine confusion over which 

In that case I suggest you put IANA everywhere. The other registries will 
refer to then current ISO 11179 conformant ISO codes version at their 
creation date. This may lead to discrepancies as the Registry is not 
intended to be ISO 11179 conformant.

At least you will have claified your intent and we will build a conversion 
table when necessary.
jfc

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 06 Aug 2005 15:10:35 +0200

Doug Ewell wrote:

>> The initial value of File-Date should change, but not the
>> added dates.

> Oops.  This was not my understanding, and so I've been
> advancing all the Added dates with each revision.

One consistent way to do it, IMHO okay, it's the fiction that
you created the initial registry at "date B".  

Another way would be to get the "real" dates of the additions
(more or less, e.g. using available 3166 newsletters) with a
fiction, that the initial registry existed since 1988 "date A"
and was updated a.s.a.p.

Probably you'd have a hard time to get the latter right, so I
think you better stick to the former strategy.  In theory I'd
prefer the latter, because "deprecated" before "added" is ugly,
but in practice it would force you to guess in too many cases.

Better stick to your original strategy.

> What should the dates be?  Fixed at the date when
> draft-initial passes WGLC and moves into IETF Last Call?

Pick the last possible "date B" where you're confident to have
_all_ changes in _all_ sources.  If that's in your AUTH48 in
some months it's okay.  But tf they introduce GG, IM, and JE
next week (example) use a "date B" in this week, because it
would confuse several parts of the text if you try to integrate
these changes in the initial registry:

Let the normal specified update procedure handle GG, IM, JE,
and pick a "date B" before this change.  OTOH don't pick a
"date B" before the introduction of 831 and 832, because this
could again confuse the existing text.

                        Bye, Frank

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 06 Aug 2005 15:37:20 +0200

Addition:

> in practice it would force you to guess in too many cases.

Hm...  not necessarily, you could use 2001-01-01 as default
"added" date (= publication of RfC 3066), and "real" dates
for all modifications between 2001-01-01 and "date B".

                              Bye, Frank