Subject: RE: [Ltru] WGLC security considerations

From: "Peter Constable" <[email-masked]>
Date: Tue, 16 Aug 2005 11:43:38 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jefsey Morfin

> The concern of security is only related in this text to the sending host -
> which is the least threat since it may be identified in many other ways.

While I agree that there is greater concern in content negotiation in relation to the requester than the provider, "sender" in this case may be either party: the requester sends a request that includes a particular language tag, and the provider sends a response (a negotiation header or content) that includes a language tag.

> This text does not consider the intelligence which may be gathered on the
> receiver and the impact on the content.

True, inferences might also be made about the receiver.

> I think the following text would be more appropriate:

I'd be open to a change along the lines suggested.‎ I don't think a change is essential for completion of this milestone, though. I agree with Randy's recent comment that will always be improvements that can be made, and we just need to cut things off at some point. ‎If there are other changes pending, I'd suggest the text below. If there are no other ‎changes to be made, however, I'd suggest the following text be used for revision in ‎‎3066ter.‎

‎"Like any other information exchanged on the Internet, language tags exchanged with content or in content negotiation may present a security risk to the extent that they might be ‎used to infer information about the sender or receiver. Specifically, they may be used to infer linguistic, ethnic or national identity of users, or the interests of users or content providers. They could be used as a basis for selecting targets of information gathering, for controlling information exchange for political or other such purposes, or for other actions outside of the network context."

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 16 Aug 2005 12:17:41 -0700

Hi -

> From: "Peter Constable" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, August 16, 2005 11:43 AM
> Subject: RE: [Ltru] WGLC security considerations
...
> ý"Like any other information exchanged on the Internet, language tags exchanged with
> content or in content negotiation may present a security risk to the extent that they might
> be ýused to infer information about the sender or receiver. Specifically, they may be used
...

As a technical contributor, I strongly object to the addition of such text.
The receipt of a language tag permits no inferences about the recipient.
If I were to start posting to this list in, for example, Vietnamese, it would
not support any inferences about the other members of this list unless someone
were to respond in Vietnamese, in which case the inference would be about
another sender, not a receiver.

If security considerations need to include things like "attackers may draw
unfounded conclusions from a monitored stream", we've gone to a truly
surreal threat model.

Randy