Subject: [Ltru] Re: Minor regret

From: "Doug Ewell" <[email-masked]>
Date: Sat, 27 Aug 2005 22:15:31 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

> 1. As an implementer I don't like the idea having to analyze the
> content of each character in a subtag in order to recognize the subtag
> type. All subtags distinguished by content in the current grammar are
> distinguished on the first character. There are two such cases now:
>
> - 4 characters: Variant (initial digit) vs. script (initial alpha)
> - 3 characters: extlang (initial alpha) vs. UN M.49 code (initial
>   digit)

You have to look at every character anyway if you are going to check for
well-formedness.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 27 Aug 2005 22:36:33 -0700

John.Cowan <jcowan at reutershealth dot com> wrote:

> Indeed.  We'll probably want to issue another I-D to reload the
> registry with all the thousands of new values.  Another reason for
> going dormant rather than shutting up shop when RFC 3066bis and
> friends are finished.

I've already built a hypothetical RFC 3066ter registry.  The changes
alone add up to 35,700 lines, or more than 740 pages in RFC format.  It
might reopen the question of whether an I-D is the best vehicle for
delivering this amount of information to IANA.

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 28 Aug 2005 18:51:16 +0200

Doug Ewell wrote:

> It might reopen the question of whether an I-D is the best
> vehicle for delivering this amount of information to IANA.

An I-D is only the best vehicle for a proper "last call".
 
Because the initial registry mixes various sources we want
"last call" reviews to find potential remaining problems - 
something like 003 that escaped us.

639-3 will be a single source, except from filtering dupes
and getting the extlang(s) right it will be simpler than the
initial registry.

It's possible to do it again as I-D (as an unscheduled test
for xml2rfc maybe ;-) but not necessary.  I'm pretty sure
that IANA won't complain if it's submitted as a text/plain,
u+A0 and above escaped.
                            Bye, Frank