Subject: RE: [Ltru] Minor regret

From: "Addison Phillips" <[email-masked]>
Date: Wed, 24 Aug 2005 09:00:32 -0700

Actually, I don't regret this.

Yes, there are a few subtag forms that could be exploited in the future, but I have to admit that:

1. As an implementer I don't like the idea having to analyze the content of each character in a subtag in order to recognize the subtag type. All subtags distinguished by content in the current grammar are distinguished on the first character. There are two such cases now:

- 4 characters: Variant (initial digit) vs. script (initial alpha)
- 3 characters: extlang (initial alpha) vs. UN M.49 code (initial digit)

2. I think the "zoo" of potential subtags is exotic enough. Any additional subtag types will fall into the realm of extensions (and good riddance). The subtag scheme should be as simple as possible. The existing 3066bis grammar is complex enough to be powerful, but simple enough that users can grasp it. More subtag types will make tags more difficult to work with.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Mark Davis
> Sent: 2005年8月24日 8:31
> Cc: LTRU Working Group
> Subject: [Ltru] Minor regret
> 
> I'll send this out just so it is on record. I am not proposing any
> change at this point in the game; just regretting slightly that we did
> not include the following text, to allow us some wriggle-room in the
> future.
> 
> "All non-initial 4 character subtags that are not legal according to the
> above ABNF are reserved for possible future use as script or orthography
> subtags. Examples: Lat1, B123
> 
> All non-initial 2 and 3 character subtags that are not legal according
> to the above ABNF are reserved for possible future use as region
> subtags. Examples: C1, 12, C34, UZ5, 6AB"
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis <[email-masked]>
Date: Sun, 28 Aug 2005 14:57:40 -0700

I don't want to rock the boat, so this is only an academic discussion.

Region is not so interesting, but script/orthography would have been 
interesting because of fallback; look at polytonic Greek, which we have 
to use a private-use script code for in CLDR. If one really wanted to 
key off of first letter, then it would work to reserve all 4-character 
codes starting with a letter for future use.

And as Doug said, you have to look at the contents anyway for 
well-formedness.

Mark