Subject: Re: [Ltru] revised editor's copy online

From: "Kent Karlsson" <[email-masked]>
Date: Tue, 2 Aug 2005 17:26:42 +0200 (CEST)

Addison wrote:

> incorporate Kent's suggestions for the ISO references (and
> think I might have succeeded). The HTML of the references
> isn't very nice looking, but the text version (which is what
> counts, after all) looks more-or-less like Kent's
> suggestions. I opted for consistency in doing the formatting,

Hmm, I do *not* notice that...

http://www.inter-locale.com/ID/draft-ietf-ltru-registry-10.html

-----> What is the sort order for the references?? ISO references should
be in numeric order
(by standard number).

[ISO639-1] International Organization for Standardization, “ISO
639-1:2002. Codes for the representation of names of languages -- Part 1:
Alpha-2 code,” 2002.

-----> Delete the "International Organization for Standardization, " part;
replace the
"--" by an em dash; the comma should be after the quote mark; replace the
redundant "2002"
by "first edition" (also redundant, but not obviously so).

[ISO639-2] International Organization for Standardization, “ISO
639-2:1998. Codes for the representation of names of languages - Part 2:
Alpha-3 code, first edition,” 1998.

-----> Delete the "International Organization for Standardization, " part;
replace the
single "-" by an em dash; replace ', first edition,”' by '", first
edition"; delete the
redundant "1998".

[ISO15924] International Organization for Standardization, “ISO
15924:2004. Information and documentation -- Codes for the representation
of names of scripts,” January 2004.

-----> Delete the "International Organization for Standardization, " part;
replace the
"--" by an em dash; the comma should be after the quote mark; replace the
"January 2004"
by "first edition".

[ISO3166] International Organization for Standardization, “ISO 3166:1988.
Codes for the representation of names of countries, 3rd edition,” August
1988.

-----> Delete the "International Organization for Standardization, " part;
the comma
should be after the quote mark; replace the "August 1988" by "first edition".

[UN_M.49] Statistical Division, United Nations, “Standard Country or Area
Codes for Statistical Use,” UN Standard Country or Area Codes for
Statistical Use, Revision 4 (United Nations publication, Sales No.
98.XVII.9, June 1999.

[ISO10646] International Organization for Standardization, “ISO/IEC
10646-1:2000. Information technology — Universal Multiple-Octet Coded
Character Set (UCS) — Part 1: Architecture and Basic Multilingual Plane
and ISO/IEC 10646-2:2001. Information technology — Universal
Multiple-Octet Coded Character Set (UCS) — Part 2: Supplementary Planes,
as, from time to time, amended, replaced by a new edition or expanded by
the addition of new parts,” 2000.

-----> Delete the "International Organization for Standardization, " part;
replace "-1:2000"
by ":2003"; delete  "— Part 1: Architecture and Basic Multilingual Plane
and ISO/IEC 10646-2:2001. Information technology — Universal
Multiple-Octet Coded Character Set (UCS) — Part 2: Supplementary Planes,
as, from time to time, amended, replaced by a new edition or expanded by
the addition of new parts,” 2000"; add "first edition" (yes, it is the
first *merged* edition).

[RFC2234bis] Crocker, D. and P. Overell, “Augmented BNF for Syntax
Specifications: ABNF,” draft-crocker-abnf-rfc2234bis-00 (work in
progress), March 2005.

-----> this one seems out of sort order.

[ISO646] ISO/IEC 646 JTC 1/SC 2, “ISO/IEC 646:1991, Information technology
-- ISO 7-bit coded character set for information interchange.,” 1991.

-----> delete the "ISO/IEC 646 JTC 1/SC 2, " part; replace the ".,” 1991",
by '", third edition'.

		/kent k

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Tue, 2 Aug 2005 08:56:19 -0700

Notes follow.

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Kent Karlsson [mailto:[email-masked]]
> Sent: 2005?8?2? 8:27
> To: Addison Phillips
> Cc: LTRU Working Group; Doug Ewell
> Subject: Re: [Ltru] revised editor's copy online
> 
> Addison wrote:
> 
[Addison Phillips] 

Not all of your requested changes are possible.
> -----> What is the sort order for the references?? ISO references should
[Addison Phillips] 

The ISO references are in an order: the ones used as subtag sources are grouped together at the top in the order they are used in a language tag. The remaining references could be grouped differently (e.g. with ISO 646 appearing before ISO 10646).
> 
> [ISO639-1] International Organization for Standardization, "ISO
> Alpha-2 code," 2002.
[Addison Phillips] 

The XML format requires an author.

> by "first edition" (also redundant, but not obviously so).
[Addison Phillips] 

"em dash" is not an ISO 646 ASCII character and is forbidden by rule in an RFC. The double-dash is preserved as the way of representing the em dash in text from RFC 3066, etc.

The date is required by the XML format used to author the document. I *must* put in a date, so this date makes sense.

All of these apply to the other ISO standards referenced.

> 
> [ISO10646] International Organization for Standardization, "ISO/IEC
> 10646-1:2000. Information technology - Universal Multiple-Octet Coded
> Character Set (UCS) - Part 1: Architecture and Basic Multilingual Plane
> and ISO/IEC 10646-2:2001. Information technology - Universal
> Multiple-Octet Coded Character Set (UCS) - Part 2: Supplementary Planes,
> the addition of new parts," 2000.
> 
>
> replace "-1:2000"
> by ":2003"; 
[Addison Phillips] 

Okay.

delete  "- Part 1: Architecture and Basic Multilingual Plane
> and ISO/IEC 10646-2:2001. Information technology - Universal
> Multiple-Octet Coded Character Set (UCS) - Part 2: Supplementary Planes,
> the addition of new parts," 2000"; add "first edition" (yes, it is the
> first *merged* edition).
[Addison Phillips] 

Okay.
> 
> [RFC2234bis] Crocker, D. and P. Overell, "Augmented BNF for Syntax
> Specifications: ABNF," draft-crocker-abnf-rfc2234bis-00 (work in
> progress), March 2005.
> 
[Addison Phillips] 

It is.
> 
> [ISO646] ISO/IEC 646 JTC 1/SC 2, "ISO/IEC 646:1991, Information technology
> -- ISO 7-bit coded character set for information interchange.," 1991.
> 
> -----> delete the "ISO/IEC 646 JTC 1/SC 2, " part; replace the ".," 1991",
> by '", third edition'.
> 
This one should have an author of "International Organization for Standardization" too :-)

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 2 Aug 2005 10:58:21 -0500 (GMT-05:00)

Hi -

As someone with some experience in references sections:

(1) em-dash, etc. are not available to us.  internet drafts and RFCs are limited
to 7-bit ASCII, so "-" will have to do.

(2) long-standing convention for references in IETF documents is to provide a
date, rather than things like "first edition".  If we were to depart from that convention,
we would probably end up having to explain why we were omitting that date information.

(3) to the extent that the order of quote marks and commas is determined by
xml2rfc in these entries, we should go with whatever the tool does, to avoid
creating pain for ourselves and the RFC editor.  To the extent that we have
control over them, we should stick to what is used in
http://www.ietf.org/internet-drafts/draft-rfc-editor-rfc2223bis-08.txt
even if that is at odds with scholarly English usage.

(4) I see no harm to including
"International Organization for Standardization" where it makes sense,
particularly if it would be extra work to get rid of it.

Randy

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 2 Aug 2005 11:28:21 -0500 (GMT-05:00)

Hi -

> From: Addison Phillips <[email-masked]>
> Sent: Aug 2, 2005 10:56 AM
> To: Kent Karlsson <[email-masked]>
> Cc: Doug Ewell <[email-masked]>, LTRU Working Group <[email-masked]>
> Subject: RE: [Ltru] revised editor's copy online
...
> The ISO references are in an order: the ones used as subtag sources are
> grouped together at the top in the order they are used in a language tag.
> The remaining references could be grouped differently (e.g. with ISO 646
> appearing before ISO 10646).
...

As someone who has been through this too many times...
I strongly recommend using the "sortrefs" option (see
http://xml.resource.org/authoring/README.html ) for xml2rfc.

Randy

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 3 Aug 2005 13:57:29 -0700

Good grief, why didn't I think of that!?! I already have those on disk locally. I think I'll import those right now and end this thread here.

Addison

Addison P. Phillips

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Scott Hollenbeck
> Sent: Wednesday, August 03, 2005 1:54 PM
> To: 'Kent Karlsson'
> Cc: [email-masked]
> Subject: RE: [Ltru] Re: revised editor's copy online
> 
> FWIW you can get already-formatted versions of ISO references online:
> 
> http://xml.resource.org/public/rfc/bibxml2/
> 
> (look for the "reference.ISO" files)
> 
> xml2rfc can even import these directly if you wish to avoid copying them.
> It might make sense to just use whatever convention is followed in the
> online versions so that they match what the rest of the xml2rfc community
> is
> using.
> 
> -Scott-
> 
>

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 3 Aug 2005 14:07:12 -0700

Ah... I see... because I can't. I need the specific ISO 639 parts and the updated ISO 10646 reference.

However... I do see that my <reference> elements use the exact format that bibxml uses.

Let's go with that.

Addison

Addison P. Phillips

> Behalf Of Addison Phillips
> Sent: Wednesday, August 03, 2005 1:57 PM
> To: Scott Hollenbeck; Kent Karlsson
> Cc: [email-masked]
> Good grief, why didn't I think of that!?! I already have those on disk
> locally. I think I'll import those right now and end this thread here.
> 
> Addison
> 
> Addison P. Phillips

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 4 Aug 2005 06:25:02 -0700

> not quite the right place for it). (And the current DTD required a "year",
> which is written after the title, so I put the edition number as "year".)

Please note that the DTD requires a <date> element whose attributes (day, month, and year) must be numeric values with a specific length. That is, the "year" must be a four digit year such as 2005 and cannot be a string such as "first edition".

> Nobody has commented on that ISO 3166 (without parts) is outdated
> (withdrawn), and that the current parts 1 and 3 may be what should
> be referenced.

In fixing draft-registry I have repaired this (I used the ISO website to get the dates, titles, and numbers correct). A power outage has prevented me from finalizing this, but now (as you can see) the bits are flowing.

Addison

Addison P. Phillips

> Behalf Of Kent Karlsson
> Sent: 2005?8?4? 3:07
> To: Randy Presuhn
> Subject: Re: [Ltru] Re: revised editor's copy online
> 
> > This is really outside the scope of this WG.  I suggest that you forward
> > your
> > concerns regarding the general format of entries to the editors of
> > This document is currently in the "IESG Evaluation" state, so going
> > to [email-masked] would make sense if its editors' rationale isn't
> > satisfactory.
> >
> > For DTD issues, there is another list.  Look for "xml2rfc" on the web
> page
> > https://datatracker.ietf.org/public/nwg_list.cgi; I wouldn't expect much
> > support
> > there for formats not reasonably well aligned with 2223bis.
> 
> Ok. Thanks for the referal. But none of those updates (nor any updates
> of the readymade references) will be done before 8th of August (or
> whatever the real final date will be for -registry).
> 
> > As a technical contributor, I'd be interested in learning why "first
> > edition" would
> > ever be more useful than a specific date for a document.
> 
> It's not. But the date (year) is already included after the colon in
> "ISO/IEC 10646:2003". National standards organisations have similar
> conventions. For instance, ANSI uses a hyphen and year number just after
> the standard's number. Giving the year number later on is more than
> redundant, it's repetition. I think it is better to follow the convention
> given by the publisher in this case, rather than moving things around.
> It is well established practice to have the publication year just after
> the standard's number.
> 
> The edition number is redundant, but is usually mentioned anyway. This
> is not just for ISO standards. Look at the XML standards for instance;
> they include the edition number, even in the title (which I think is
> not quite the right place for it). (And the current DTD required a "year",
> which is written after the title, so I put the edition number as "year".)
> 
> B.t.w., within ISO, at least, undated (normative) references refers to
> the latest edition, including future editions when issued; while dated
> references refers to that specific version, while later editions may
> (or may not) apply.
> 
> Nobody has commented on that ISO 3166 (without parts) is outdated
> (withdrawn), and that the current parts 1 and 3 may be what should
> be referenced.
> 
>      /kent k
> 
> 
>

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 4 Aug 2005 07:16:20 -0700

Kent Karlsson <kentk at cs dot chalmers dot se> wrote:

> not quite the right place for it).

To the extent draft-initial is involved in this discussion, I took the
names of ISO standards directly from their listing in the online ISO
catalog (per Kent's suggestion), including the ordinal version number
where given.

> (And the current DTD required a "year", which is written after the
> title, so I put the edition number as "year".)

To me, that constitutes playing games with xml2rfc.  A document number
is not an author, and an edition number is not a year.

> (withdrawn), and that the current parts 1 and 3 may be what should

If some part of draft-registry refers to the old ISO 3166, and some
other part refers to the new ISO 3166-1 and 3166-3 (for whatever
reason), then both should be cited.  If this is not the case, then the
superfluous reference(s) should be removed.

I don't disagree that the flexibility of xml2rfc may be less than
perfect.  I also don't disagree that perhaps there should be a formal
description of exactly how ISO and other external standards should be
cited within RFCs, if there isn't one already, and that xml2rfc should
allow an author or editor to format references according to this
description.

What I do disagree with is that this WG Last Call is the time or place
to do this.  There must be many, many RFCs in existence that use the
formatting imposed by xml2rfc to refer to ISO standards, and the
respective WGs and IETF and RFC editor have apparently considered them
to be valid references.  Formally, we would like to have the best and
most consistent bibliographic style we can, but informally, the
references are there to guide readers to the correct document, and if
they do that -- apart from questions of redundancy and comma
placement -- then they should be considered good enough for now.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 4 Aug 2005 17:09:48 +0200 (GMT+02:00)

Hi -

This seems reasonable to me, though it could in my opinion also be
merged with any IESG comments or IETF last call comments, since in
this case it's an editorial change to a non-normative reference.

Randy, ltru co-chair

BTW, mail for Martin's is bouncing due to a too-many-hops problem, so we
might have to wait until he returns to Japan before we hear from him.

-----Original Message-----
From: Doug Ewell <[email-masked]>
Sent: Aug 4, 2005 4:22 PM
To: LTRU Working Group <[email-masked]>
Subject: [Ltru] Re: revised editor's copy online

I noticed that the reference to ISO 3166-1 in draft-registry-10 is to
the 1997 edition, while the reference in draft-initial-03 is to the 1988
edition.  I'll be happy to change this in draft-initial as a Second Last
Call item (text not reflecting agreed-upon changes), if the co-chairs
wish.

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 4 Aug 2005 17:09:51 +0200 (GMT+02:00)

Hi -

Randy, ltru co-chair

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 4 Aug 2005 22:23:58 -0700

Mark Davis <mark dot davis at icu dash project dot org> wrote:

>> the 1997 edition, while the reference in draft-initial-03 is to the
>> 1988 edition.  I'll be happy to change this in draft-initial as a
>> Second Last Call item (text not reflecting agreed-upon changes), if
>> the co-chairs wish.
>
> Doug, can you update the (more readable) html version on
> http://users.adelphia.net/~dewell/draft-ietf-ltru-initial-03.html?

I can do that, but I thought Randy (while agreeing with the change) had
sort of casually suggested that it should be batched with other changes.

This would be draft-initial-04, right?