Subject: Re: [Ltru] [psg.com #1092] WGLC treat 0- as escape from syntax

From: Randy Presuhn <[email-masked]>
Date: Tue, 2 Aug 2005 12:10:08 -0500 (GMT-05:00)

Hi -

> From: r&d afrac <[email-masked]>
> Sent: Aug 2, 2005 11:23 AM
> To: Erkki Kolehmainen <[email-masked]>, 
>	Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Ltru] [psg.com #1092] WGLC treat 0- as escape from syntax
>
> At 15:24 02/08/2005, Erkki Kolehmainen wrote:
> >As this 0- would not be understood by any current implementation to be an 
> >absolute escape sequence, which could be followed by any syntax, I'm 
> >against its inclusion in the present memo.
>
> ??? Why? It conforms to the ABNF. Then what would be the result?

The string "0-" conforms to the ABNF.  The rest of your proposal does not.

> Interesting since people are going to use it anyway.

Fine; they'd just not be in conformance to the spec.
Time will tell whether the market will endorse non-conformance.

> And Randy just said he would not oppose. Or you mean that Randy is joking 
> at me?
...

Submitting an i-d requesting registration of 0- is the correct procedural
path, as outlined in the current registry i-d.  As for the content of your
i-d, I reserve comment until it appears.

Randy

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: r&d afrac <[email-masked]>
Date: Wed, 03 Aug 2005 03:46:20 +0200

>The string "0-" conforms to the ABNF.  The rest of your proposal does not.

??? Most surprising since there is nothing else to consider after "0-" :-)

>Time will tell whether the market will endorse non-conformance.

Which specs? Oh you mean the Draft? Do you really believe that it will make 
an RFC withough the "0-" escape sequence?

>i-d, I reserve comment until it appears.

Oh! you were right, God the Randy was joking at me!
jfc