Subject: [Ltru] Re: [psg.com #1099] WGLC add empty extension registry

From: "Doug Ewell" <[email-masked]>
Date: Sat, 13 Aug 2005 12:11:39 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

> If I got it right it doesn't need dummy entries for i- or x-
>
> The old i- is only used to start grandfathered tags, never as
> extension,

"i" certainly can be used for an extension.  There is no ambiguity
between "i-ami", which is a grandfathered tag meaning 'Amis, and
"de-i-ami", which means whatever the authors of the "i" extension
mechanism intended it to mean.

> x- is explained in the core document, and formally
> it's also no extension tag.

The difference here is that "x" always means "private use" regardless of
its position, so it could not be an extension singleton.  "i" has no
such restriction.

> BTW, apparently...
>
> draft-ietf-proto-wgchair-doc-shepherding-05.txt
>
> ...is not yet an RfC.  Have fun with testing it.  Will the
> questionnaire you're supposed to send to Scott be published
> in the tracker ?

I think Randy has established by now that he understands which draft
documents may be used in the process, or referenced in another draft,
and under what circumstances.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 14 Aug 2005 00:14:01 +0200

Doug Ewell wrote:
 
> "i" certainly can be used for an extension.

Yes, I only was thinking loud - i.e. why is there
no "X" in the initial extension registry.

> I think Randy has established by now that he
> understands which draft documents may be used in
> the process

Pardon ?  Somewhat unrelated to my question, it's
me who doesn't know how PROTO will work, but Scott 
already answered it.

We can see it at http://purl.net/xyzzy/-ietf/ltru

                        Bye, Frank