Subject: RE: [Ltru] [psg.com #1095] reference section cleanup

From: "Addison Phillips" <[email-masked]>
Date: Fri, 12 Aug 2005 17:06:35 -0700

I can't use the reference.ISO files directly: they don't reference the right things. I can ape their style (I did so in draft-10).

Kent's comments seemed reasonable and I found a way to make the XML work that is consistent with many extant RFCs. Having six references in a row with the same superfluous author seems odd, but I suppose I could resort to making the author Mr. Ibid :-)... I can put it back too.

Note that I did NOT put the standard into the author or organization element or abuse the XML.

(FWIW I had to revise the CSS that a certain co-chair and I both use in XMetal--it hid the organization element).

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?8?12? 16:40
> To: [email-masked]
> Subject: [Ltru] [psg.com #1095] reference section cleanup
> 
> Hi -
> 
> > From: "Addison Phillips" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Friday, August 12, 2005 3:58 PM
> > Subject: [Ltru] new editor's copy online
> ...
> >    a. Removed author "International Organization for Standardization"
> from all ISO values.
> ...
> 
> I am surprised by this change.  I don't believe there was anything like
> a consensus to make it.  It's a departure from the style of
> http://www.ietf.org/internet-drafts/draft-rfc-editor-rfc2223bis-08.txt,
> and
> I would not be surprised if the RFC editor restores the "author" fields.
> Though I'm content to consider layout a matter of editorial discretion,
> I think abusing the xml2rfc fields (putting the standard number into the
> author field) is just asking for trouble.  I *thought* you had agreed
> to use the reference.ISO files (where possible).  Did I miss something?
> 
> Randy
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 12 Aug 2005 17:33:28 -0700

Hi -

> To: "Randy Presuhn" <[email-masked]>; <[email-masked]>
> Sent: Friday, August 12, 2005 5:06 PM
> Subject: RE: [Ltru] [psg.com #1095] reference section cleanup
..
> Kent's comments seemed reasonable and I found a way to make the XML
> work that is consistent with many extant RFCs. Having six references in a
> row with the same superfluous author seems odd, but I suppose I could
> resort to making the author Mr. Ibid :-)... I can put it back too.

Please, no Ibid.

> Note that I did NOT put the standard into the author or organization element or abuse the XML.

Strange, when I look at
http://www.inter-locale.com/ID/draft-ietf-ltru-registry-11.xml
I see:

<reference anchor="ISO15924">
    <front>
      <title abbrev="ISO15924">ISO 15924:2004. Information and documentation -- Codes for the representation of names of
scripts</title>
      <author fullname="ISO 15924:2004">
      <organization abbrev="ISO"></organization></author>

      <date year="2004" month="January" day="9"/>
    </front>
  </reference>

That's a rather odd fullname for an author to have.

Randy