Subject: RE: [Ltru] revised editor's copy online

From: "Kent Karlsson" <[email-masked]>
Date: Tue, 2 Aug 2005 22:46:42 +0200 (CEST)

1. You used en dash in the 10646 reference, and a single - in the 639-2
reference...

2. Use ISO/IEC or ISO as "author", remove the date after the standards
number, keeping it at the end (the repetition is annoying), just the
year number. If it is an ISO/IEC standard, using just
"International Oragization for Standardisation" as author would be
inappropriate.

3. Include edition number as well (I see no reason not to), outside
of the quoted title (it is not part of the title). Preferebly the
standards number should be outside of (before) the quoted title too.

4. Sort all the ISO/IEC (and ISO and IEC) references by number.
I see no reason to do otherwise here (like grouping related standards
together).

   /kent k

> -----Original Message-----
> From: Addison Phillips [mailto:[email-masked]]
> Sent: Tuesday, August 02, 2005 5:56 PM
> To: Kent Karlsson
> Cc: LTRU Working Group; Doug Ewell
> Subject: RE: [Ltru] revised editor's copy online
>
>
> Notes follow.
>
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
>
> Internationalization is not a feature.
> It is an architecture.
>
> > -----Original Message-----
> > From: Kent Karlsson [mailto:[email-masked]]
> > Sent: 2005?8?2? 8:27
> > To: Addison Phillips
> > Cc: LTRU Working Group; Doug Ewell
> > Subject: Re: [Ltru] revised editor's copy online
> >
> > Addison wrote:
> >
> > > incorporate Kent's suggestions for the ISO references (and
> > > think I might have succeeded). The HTML of the references
> > > isn't very nice looking, but the text version (which is what
> > > counts, after all) looks more-or-less like Kent's
> > > suggestions. I opted for consistency in doing the formatting,
> >
> > Hmm, I do *not* notice that...
> >
> > http://www.inter-locale.com/ID/draft-ietf-ltru-registry-10.html
> [Addison Phillips]
>
> Not all of your requested changes are possible.
> >
> > -----> What is the sort order for the references?? ISO
> references should
> > be in numeric order
> > (by standard number).
> [Addison Phillips]
>
> The ISO references are in an order: the ones used as subtag
> sources are grouped together at the top in the order they are
> used in a language tag. The remaining references could be
> grouped differently (e.g. with ISO 646 appearing before ISO 10646).
> >
> > [ISO639-1] International Organization for Standardization, "ISO
> > 639-1:2002. Codes for the representation of names of
> languages -- Part 1:
> > Alpha-2 code," 2002.
> >
> > -----> Delete the "International Organization for
> Standardization, " part;
> [Addison Phillips]
>
> The XML format requires an author.
>
> > replace the
> > "--" by an em dash; the comma should be after the quote
> mark; replace the
> > redundant "2002"
> > by "first edition" (also redundant, but not obviously so).
> [Addison Phillips]
>
> "em dash" is not an ISO 646 ASCII character and is forbidden
> by rule in an RFC. The double-dash is preserved as the way of
> representing the em dash in text from RFC 3066, etc.
>
> The date is required by the XML format used to author the
> document. I *must* put in a date, so this date makes sense.
>
> All of these apply to the other ISO standards referenced.
>
> >
> > [ISO10646] International Organization for Standardization, "ISO/IEC
> > 10646-1:2000. Information technology - Universal
> Multiple-Octet Coded
> > Character Set (UCS) - Part 1: Architecture and Basic
> Multilingual Plane
> > and ISO/IEC 10646-2:2001. Information technology - Universal
> > Multiple-Octet Coded Character Set (UCS) - Part 2:
> Supplementary Planes,
> > as, from time to time, amended, replaced by a new edition
> or expanded by
> > the addition of new parts," 2000.
> >
> >
> > replace "-1:2000"
> > by ":2003";
> [Addison Phillips]
>
> Okay.
>
>
> delete  "- Part 1: Architecture and Basic Multilingual Plane
> > and ISO/IEC 10646-2:2001. Information technology - Universal
> > Multiple-Octet Coded Character Set (UCS) - Part 2:
> Supplementary Planes,
> > as, from time to time, amended, replaced by a new edition
> or expanded by
> > the addition of new parts," 2000"; add "first edition"
> (yes, it is the
> > first *merged* edition).
> [Addison Phillips]
>
> Okay.
> >
> > [RFC2234bis] Crocker, D. and P. Overell, "Augmented BNF for Syntax
> > Specifications: ABNF," draft-crocker-abnf-rfc2234bis-00 (work in
> > progress), March 2005.
> >
> > -----> this one seems out of sort order.
> [Addison Phillips]
>
> It is.
> >
> > [ISO646] ISO/IEC 646 JTC 1/SC 2, "ISO/IEC 646:1991,
> Information technology
> > -- ISO 7-bit coded character set for information
> interchange.," 1991.
> >
> > -----> delete the "ISO/IEC 646 JTC 1/SC 2, " part; replace
> the ".," 1991",
> > by '", third edition'.
> >
> This one should have an author of "International Organization
> for Standardization" too :-)
>
>
>

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 2 Aug 2005 14:48:21 -0700

These are all "nice to haves", not showstoppers.

‎Mark

----- Original Message ----- 
From: "Kent Karlsson" <[email-masked]>
To: "LTRU Working Group" <[email-masked]>
Sent: Tuesday, August 02, 2005 13:46
Subject: RE: [Ltru] revised editor's copy online

   /kent k