Subject: [Ltru] Re: [psg.com #1098] WGLC distinguish subtag and extensions registries

From: "Doug Ewell" <[email-masked]>
Date: Sat, 13 Aug 2005 17:04:51 -0700

Addison Phillips <addison dot phillips at quest dot com> wrote:

>> I have a slight preference to put the initializing text in the
>> initial registry draft, rather than the registry draft.
> ...
> I don't mind having the initial registry appear in the other draft,
> although it seems small enough to put into this draft and save some
> cross referencing.

Initially <g> I was in favor of having the (vestigial) initial extension
registry appear in draft-initial, rather than draft-registry.  But based
on:

* the size of the initial extension registry,
* the size of the two drafts,
* the ease with which Addison showed he could add it to draft-registry,
* the effort I estimate would be needed to add it to draft-initial, and
* the editorial-only nature of Second WGLC changes,

I've come to prefer adding it to draft-registry instead.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 13 Aug 2005 17:25:13 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

> This looks ok to me, except that "REQUIRE" isn't a 2119 keyword. I
> suggest:
>
> Adoption of this document will also entails initialization of the
> Language Extension Registry described in Section 3.6...

Recte: "will also entail," or "also entails."

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 13 Aug 2005 17:59:59 -0700

Frank Ellermann <nobody at xyzzy dot claranet dot de> wrote:

>> "i" certainly can be used for an extension.
>
> Yes, I only was thinking loud - i.e. why is there
> no "X" in the initial extension registry.

Because "x" is a special case, as you've probably answered yourself.

>> I think Randy has established by now that he
>> understands which draft documents may be used in
>> the process
>
> Pardon ?  Somewhat unrelated to my question, it's
> me who doesn't know how PROTO will work, but Scott
> already answered it.

Sorry, I think I misunderstood you.  There have been various complaints
through the months that draft documents could not be referenced in an
RFC, and Randy has replied that in some cases -- for example, RFC
2234bis -- it is OK because the draft is scheduled to be approved in the
very near future, and the RFC editor will fix things up.  I thought you
were making a similar statement about Randy's use of
draft-ietf-proto-wgchair-doc-shepherding-05, and I apologize for my
response if that was not the case.

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 14 Aug 2005 23:09:37 +0200

Doug Ewell wrote:

> Randy has replied that in some cases -- for example, RFC
> 2234bis -- it is OK because the draft is scheduled to be
> approved in the very near future, and the RFC editor will
> fix things up.

Yes, actually it was Scott, and 2234bis is already approved.
It's high IETF drama, from my POV more amusing than serious.

But confusing for innocent bystanders, see also the end of
<http://mid.gmane.org/[email-masked]>

> I thought you were making a similar statement about Randy's
> use of draft-ietf-proto-wgchair-doc-shepherding-05

No, and that's different, it's not yet approved, you can see 
see the status of I-Ds in the tracker (redirection, because
the complete minimal URL is a royal PITA): 

http://purl.net/xyzzy/-draft/draft-ietf-proto-wgchair
http://purl.net/xyzzy/-draft/draft-crocker-abnf

The former is in state "I-D exists", the latter has been sent
to the "RFC-Ed-queue" (for more details like "approved" click
"DETAIL").

> I apologize for my response if that was not the case.

No problem, probably Randy and Scott want to test the proposed
procedure.  It's not really needed in our case, the PROTO I-D
is apparently based on the assumption that the AD has no clear
idea what the WG did and why the Chair thinks that a particular
document is ready.
                             Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 14 Aug 2005 18:03:20 -0700

Hi -

I *REALLY* wish the folks in this WG would stick to one topic
per message, and use appropriate subject lines!

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Sunday, August 14, 2005 2:09 PM
> Subject: [Ltru] Re: [psg.com #1099] WGLC add empty extension registry
...
...

That's not my perception at all. These procedures have been use in
other areas, e.g. Operations & Management, for quite a while.
I don't know how long they've been used in the Applications area,
but I strongly suspect they've been in use here for some time, too.
It's not (at least in this case) motivated by a desire to "test" the
procedures.  The primary motivations for these procedures
are to get documents through the IESG more quickly by
offloading the ADs somewhat and ensuring a tighter feedback
loop between the IESG and the WG for handling any DISCUSS
comments that might arise.  Before these procedures were
written down, many of the elements of these procedures were
informally in place.  For example, ad hoc exchanges between
WG chairs and ADs during the process of handing a document
to the IESG would usually cover all the "questionaire" points.

We haven't yet decided whether Martin or I will do the shepherding
for these two documents while the WG finishes up the matching draft.

Randy, ltru co-chair

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 15 Aug 2005 06:45:34 +0200

Randy Presuhn wrote:

> I *REALLY* wish the folks in this WG would stick to one
> topic per message, and use appropriate subject lines!

The Re: [psg.com #1099] tags were certainly not my idea, I
dare not touch them, because you wanted them.  We had normal
threads with Subject: new (was: old) before the ticket flood.
After that I gave up to look at subjects.

 [draft-ietf-proto-wgchair]
> I don't know how long they've been used in the Applications
> area, but I strongly suspect they've been in use here for
> some time, too.

I haven't seen any IETF WG actually producing an RfC from the
inside, therefore I thought that this I-D is a new idea, and
you want to test it.

> The primary motivations for these procedures are to get
> documents through the IESG more quickly by offloading the
> ADs somewhat

Yes, I got that idea from a quick look into it.  If you use
it for real it should be an RfC.  Or it should be noted in
[TAObis], "some really important documents are only available
as drafts", in a section where it also explains "recursion".

> For example, ad hoc exchanges between WG chairs and ADs
> during the process of handing a document to the IESG would
> usually cover all the "questionaire" points.

Apparently you're supposed to post a copy here (excluding 1F),
and a reply with open questions would be also posted here (2E).

The MUST in 2G in conjunction with 2I sounds like a potential
dead loop, does that happen ?
                              Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 14 Aug 2005 23:19:26 -0700

Hi -

> Sent: Sunday, August 14, 2005 9:45 PM
> Subject: [Ltru] Re: Use of shepherding procedures
...
> inside, therefore I thought that this I-D is a new idea, and

As I said, it's been in use in Operations & Management area for
some time, and I know several RFCs have been produced using
these procedures.  For me it's a matter of some indifference
whether we use these procedures; the decision to apply them
is the AD's.

> as drafts", in a section where it also explains "recursion".

That's outside this WG's scope.  I guess [email-masked] would be the
place for followups, or you could go directly to the authors of
http://www.ietf.org/internet-drafts/draft-hoffman-taobis-03.txt
My experience here as well as in ISO/ITU, ANSI, and DMTF-land
is that the procedures and guidelines and organizational culture
are constantly evolving ("continuous improvement") and that the
process documentation, while immensely helpful, often just provides
snapshots from which one might estimate a trajectory.  By the time
something is "done", it's already time for an update.  2223bis is
a classic example of this.  (Perfection precludes completion,
and vice versa.  See also "Optimization hinders evolution."  :-)

> and a reply with open questions would be also posted here (2E).

That will happen once Martin and I have agreed who is handling it.
The time difference between San Jose and Japan, as well as our
travel schedules, sometimes makes it difficult to sync up.

...

Not in my experience.  I have heard of horror stories, but every time
I been through this process myself, whether as a chair, editor, reviewer,
or WG participant, things have worked out to a mutually satisfactory
conclusion.

Anyway, this discussion is getting outside the scope of this particular
WG; these higher-level process concerns belong on [email-masked],
discussion with the authors of the shepherding draft, or possibly the
newtrk working group.

Randy, ltru co-chair