Subject: RE: [Ltru] Re: [psg.com #1103] WGLC Add File-level Description field

From: "Addison Phillips" <[email-masked]>
Date: Mon, 15 Aug 2005 14:11:17 -0700

Based on Randy's email back to Misha, I would say: let's reject this issue outright. We don't need a human readable comment in the header of either file. Adding either comment syntax or a File-Description field will require changes to the text (neither of which I think is very substantial, since they both are about providing a single human-readable comment in the top of the file).

To deal with the extensions registry we can put this paragraph in instead of the text for the registry:

--
An initial version of the Language Extension Registry described in <xref target="extensions"></xref> is also needed. The Language Extension Registry SHALL be initialized with a single record containing a single field of type "File-Date" as a placeholder for future assignments.
--

That way we can be done.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Frank Ellermann
> Sent: 2005?8?15? 13:37
> To: [email-masked]
> Subject: [Ltru] Re: [psg.com #1103] WGLC Add File-level Description field
> 
> Addison Phillips wrote:
> 
> > I note that our reference to record-jar says this nearby:
> 
> >| Use # as an introducer for comments. It is good to have
> >| a way to embed annotations and comments in data files.
> 
> And is that in a variant were lines starting with "#" are
> also used like our "%%" ?  You wanted to specify a general
> ABNF for "record-jar plus UTF-8".  Now that you have done
> this I'm reluctant to destroy it.
> 
> If you say that it's still in the spirit of your original
> idea it's okay, but if you only do it for "lilly-gilding"
> as Randy said it's dubious.
> 
> > In any case, I'm not religious about it.
> 
> Nor me.  If you do it you can also add a dummy "%%" after
> the File-Date of the "empty" extension registry.
> 
> It's more work for Doug if he invents some kind of "sub-
> titles" for the various sections of the initial registry.
> 
>                         Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 15 Aug 2005 23:26:25 +0200

> That way we can be done.

+1