Subject: Re: [Ltru] Re: revised editor's copy online

From: Randy Presuhn <[email-masked]>
Date: Wed, 3 Aug 2005 17:38:16 +0200 (GMT+02:00)

Hi -

> From: Doug Ewell <[email-masked]>
> Sent: Aug 3, 2005 4:30 PM
> To: LTRU Working Group <[email-masked]>
> Subject: Re: [Ltru] Re: revised editor's copy online
>
> Kent Karlsson <kentk at cs dot chalmers dot se> wrote:
>
> > Well, if the tool does not check things that should go unchecked,
> > the XML exerpt below (and attached) should work. (I haven't installed
> > the xml2rfc tool...)
>
> This works if you buy info the semantic notion that "ISO/IEC 646:1991"
> and such are authors, or organizations.
>
> Randy, is this (a) acceptable and (b) recommended?  I wouldn't mind
> doing this if it would end the thread.

For guidance I look to the references section in
http://www.ietf.org/internet-drafts/draft-rfc-editor-rfc2223bis-08.txt
Several of the examples there list standards organizations as the "authors"
of documents.  On (A), the guidelines give wide leeway to authors / editors / WGs,
so the acceptability of omitting the author is something that would probably
be negotiated with the RFC editor during the editing process or AUTH48.  On (B),
omitting the author is clearly not the recommended practice.  The XML hack,
while it might generate acceptible ASCII, leaves misleading tagging in the source,
inviting trouble.  To sum up, I think we should NOT play games with xml2rfc;
doing so invites delay.

To see examples of recent practice, see also
ftp://ftp.rfc-editor.org/in-notes/rfc3629.txt

...
> You've placed "ISO646" before "ISO639-1" and "ISO639-2", which is
> neither alphabetically nor numerically correct.  This demonstrates what
> I said about "preventing manual errors."  Can't we just let the tool do
> its job?
...

We should let the tool do its job.  Anything else will complicate the RFC editor's
job and, consequently, AUTH48.  (By the way, AUTH48 generally requires a lot
more than 48 hours to resolve, so, based on my personal experience as an editor,
I strongly recommended doing as much as possible to avoid AUTH28 changes.)

Randy, ltru co-chair

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Kent Karlsson" <[email-masked]>
Date: Wed, 3 Aug 2005 20:22:32 +0200 (CEST)

> inviting trouble.  To sum up, I think we should NOT play games with

The DTD/tool is in this regard too limited. It does not fit the way
ISO, IEC, and ISO/IEC standards should be referenced. This should
be fixed in the xml2rfc DTD and tool. Meanwhile, it is not completely
out of order to consider e.g. "ISO/IEC 10646:2003" as an "author" (the
WG per se is never given as author), and "first edition" as a "date".

   /kent k

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Wed, 3 Aug 2005 16:53:45 -0400

FWIW you can get already-formatted versions of ISO references online:

http://xml.resource.org/public/rfc/bibxml2/

(look for the "reference.ISO" files)

xml2rfc can even import these directly if you wish to avoid copying them.
It might make sense to just use whatever convention is followed in the
online versions so that they match what the rest of the xml2rfc community is
using.

-Scott-

---

From: "Kent Karlsson" <[email-masked]>
Date: Wed, 3 Aug 2005 23:51:40 +0200 (CEST)

> online versions so that they match what the rest of the xml2rfc community

So them being wrong (I looked at a sample of them) does not matter to you?
(I will not attempt to update all those references...)

   /kent k

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Thu, 4 Aug 2005 01:41:00 -0400

> -----Original Message-----
> From: Kent Karlsson [mailto:[email-masked]] 
> Sent: Wednesday, August 03, 2005 5:52 PM
> To: Scott Hollenbeck
> Cc: 'Kent Karlsson'; [email-masked]
> Subject: RE: [Ltru] Re: revised editor's copy online
> 
> > online versions so that they match what the rest of the 
> xml2rfc community
> > is
> > using.
> >
> > -Scott-
> >
> 

Of course it matters.  If they're wrong someone should let Marshall Rose
know what needs to be changed.  He's usually quite good about updating
references as needed.

-Scott-