Subject: RE: [Ltru] [psg.com #1103] WGLC Add File-level Description field

From: "Addison Phillips" <[email-masked]>
Date: Mon, 15 Aug 2005 12:44:43 -0700

In response to Frank's email...

There is no explicit field ordering in a record.

We can provide a file description as a field or as a comment. I feel that this type of information is not actual data and thus shouldn't be inside a record. Other such information may exist or prove useful. Why not provide for comments in the file format. I note that our reference to record-jar says this nearby:

<q>Use # as an introducer for comments. It is good to have a way to embed annotations and comments in data files. It's best if they're actually part of the file structure, and so will be preserved by tools that know its format. For comments that are not preserved during parsing, # is the conventional start character.</q>

In any case, I'm not religious about it. "File-Description" will do it in this singular case (although I'll have to add a whole paragraph about it instead of just saying "here is what a comment looks like" and letting Doug deal with writing the comment)

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 2005?8?15? 12:13
> To: LTRU Working Group
> Subject: [Ltru] [psg.com #1103] WGLC Add File-level Description field
> 
> Hi -
> 
> > ------------------------------------------------------------------------
> -
> > This issue was raised in several related messages on issues #1098 and
> > #1099, including:
> > http://www1.ietf.org/mail-archive/web/ltru/current/msg03285.html
> > http://www1.ietf.org/mail-archive/web/ltru/current/msg03284.html
> > http://www1.ietf.org/mail-archive/web/ltru/current/msg03286.html
> >
> > The idea is that the ABNF and following text in section 3.1 should
> > result in both the subtag and the extension registries having
> > some additional, human-readable information describing the file
> > as a whole, in addition to the file-date field.
> 
> Please include the issue number (#1103) in you subject line as you
> continue to discuss this issue.
> 
> Randy, ltru co-chair
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 15 Aug 2005 22:37:15 +0200

Addison Phillips wrote:
 
> I note that our reference to record-jar says this nearby:
 
>| Use # as an introducer for comments. It is good to have
>| a way to embed annotations and comments in data files.

And is that in a variant were lines starting with "#" are
also used like our "%%" ?  You wanted to specify a general
ABNF for "record-jar plus UTF-8".  Now that you have done
this I'm reluctant to destroy it.

If you say that it's still in the spirit of your original
idea it's okay, but if you only do it for "lilly-gilding"
as Randy said it's dubious.
 
> In any case, I'm not religious about it.

Nor me.  If you do it you can also add a dummy "%%" after
the File-Date of the "empty" extension registry.

It's more work for Doug if he invents some kind of "sub-
titles" for the various sections of the initial registry.

                        Bye, Frank

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 15 Aug 2005 23:16:58 +0200

> titles" for the various sections of the initial registry.

BTW, it's also more work for IANA if they try to follow
the initial structure.  At the moment they can simply add
all new records at the end.

Sorry Randy, but that could be a bit beyond "lilly-gilding",
we never said that IANA should keep Doug's organization -
therefore adding obscure "comments" suggesting a certain
sort order might be A Bad Thing.  Doug, please don't try it.

                          Bye, Frank