Subject: [Ltru] Identifying correct parts / version of ISO 3166

From: Randy Presuhn <[email-masked]>
Date: Thu, 4 Aug 2005 14:20:40 +0200 (GMT+02:00)

Hi -

> From: Kent Karlsson <[email-masked]>
> Sent: Aug 4, 2005 12:06 PM
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: revised editor's copy online
...
> Ok. Thanks for the referal. But none of those updates (nor any updates
> of the readymade references) will be done before 8th of August (or
> whatever the real final date will be for -registry).

This kind of change is of the sort  that if the RFC editor considers it worthwhile,
it would be made during the RFC editing cycle, and we'd then be able to check
that nothing got broken during AUTH48.  My experience as an editor and WG chair
is that departing from convention is far more likely to cause delay than abiding
by it.

...
> It is well established practice to have the publication year just after
> the standard's number.

Different style sheets impose different requirements.  I don't know whether
there is a consensus among publishers.  If there is, it would be worth bringing
whatever it is to the attention of the rfc editor.  But I wouldn't wait for it to
be settled.  2223 bis has taken too many years as it is.

...
> B.t.w., within ISO, at least, undated (normative) references refers to
> the latest edition, including future editions when issued; while dated
> references refers to that specific version, while later editions may
> (or may not) apply.

There is no such convention in the IETF.

> Nobody has commented on that ISO 3166 (without parts) is outdated
> (withdrawn), and that the current parts 1 and 3 may be what should
> be referenced.
...

It looks like there is a problem here.  The i-d (version
http://www.ietf.org/internet-drafts/draft-ietf-ltru-registry-09.txt)
specifically refers to part 1 of 3166 in section 2.2.4 (2).

Though clearly an editorial nit, the editors should fix this at an
appropriate time.  (My recommendation would be to fold it in with
any changes resulting from IESG review or IETF last call, unless
other issues surface before the second WG last call closes.)

Randy

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: r&d afrac <[email-masked]>
Date: Thu, 04 Aug 2005 15:48:46 +0200

At 14:20 04/08/2005, Randy Presuhn wrote:
>there is a consensus among publishers

This is an ISO 11173 conformant practice. This should not be followed.
jfc