Subject: RE: [Ltru] Re: ABNF typo (Was: News flash)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 13 Oct 2005 05:46:36 -0700

2234bis was replaced by 4234 in my editor's copy previously.

One space added? No, three spaces added per Bill Fenner's ABNF processor canonical format (added spaces replaced by #):

field-name = (ALPHA / DIGIT)#[#*(ALPHA / DIGIT / "-") (ALPHA / DIGIT)#]

I also updated my xml2rfc (don't know what impact that will have) and changed the figure title for the registry ABNF per Elwyn's note, as well as doing the s/then/than from Kent Karlsson's note.

That summarizes the changes in the proto-draft-14, I believe.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Frank Ellermann
> Sent: 2005?10?13? 8:34
> To: [email-masked]
> Subject: [Ltru] Re: ABNF typo (Was: News flash)
> 
> Addison Phillips wrote:
> 
> > sounds good. I'm maintaining a draft-14 as editor's copy.
> 
> One space added ?  While you're at it you could also replace
> 2234bis by 4234 in -14.
>                          Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 13 Oct 2005 15:30:30 +0200

Addison Phillips wrote:

> three spaces added per Bill Fenner's ABNF processor canonical
> format (added spaces replaced by #):

> field-name = (ALPHA / DIGIT)#[#*(ALPHA / DIGIT / "-") (ALPHA / DIGIT)#]

Works (with SP for # of course).  In theory...

| field-name = (ALPHA / DIGIT)#[*(ALPHA / DIGIT / "-") (ALPHA / DIGIT)]

...works also.  Don't laugh, it's critical, with three spaces
you'd get 74 columns, with one space you're still within 72.

> I also updated my xml2rfc (don't know what impact that will
> have)

Better check the ToC for oddities.  If the appendices show up
before the author's address it's fine, that's a feature, the
new experimental xml2rfc sorts sections as the RfC-editor wants
it.  

> changed the figure title for the registry ABNF per Elwyn's
> note

Good, don't forget the date (today), the -14, and a forward of
the I-D announce mail to Bill so that he can clear his DISCUSS
a.s.a.p.

We are at 2+6 : 1+0, Bill's vote shifted, and it's approved :-)

                     Bye, Frank