Subject: [Ltru] draft-14 of draft-ietf-ltru-registry

From: "Addison Phillips" <[email-masked]>
Date: Sun, 16 Oct 2005 08:26:08 -0700

Dear Editor,

Please find attached draft-14 of draft-ietf-ltru-registry in text format. Idnits ran and so did Bill's ANBF parser.

For the editors,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: r&d afrac <[email-masked]>
Date: Tue, 18 Oct 2005 18:46:36 +0200

On 06:20 18/10/2005, Martin Duerst said:
>I think that this is a small oversight. I seem to remember
>proposing to change "Hant" to "Latn" to make sure it
>fits better with x-wadegile (Wade-Giles is a well-known
>romanization for Chinese). Apparently, when this was
>implemented, the first one was forgotten.
>
>Procedurally, I'd like to see confirmation from the authors,
>and make sure that nobody from the WG objects, and then
>have the authors make this change in the RFC Editor's
>AUTH48 period (i.e. shortly before the RFC is being
>published).

Just a minute!

Please precisely dociment what is wrong in the current text?

I am perfectly entitled to consider "x-wadegile" as indicating the 
language stratagems used by Senator Wade to make his Manifesto (with 
another Davis) accepted by the Congress. A mix of 19th century 
Washingtonian and local Ohio images, parabols and syllogisms.

I know this looks absurd, but should I understand that "x-" privatuse 
content may be the reason why a script subtag is predetermined? I 
have nothing against it, but this is a subnamespace leak and a change 
in concept.

Now it is brought-up, the response will be important, as it may be a 
strong argument for my "platform". Thank you Eric.
jfc

At 01:36 05/10/18, Erik van der Poel wrote:
> >Hello everybody,
> >
> >This is just a minor issue, but the truncation example starts with 
> Hant and then has Latn in the following lines:
> >
> >    Tag to truncate: zh-Hant-CN-variant1-a-extend1-x-wadegile-private1
> >    1. zh-Latn-CN-variant1-a-extend1-x-wadegile
> >    2. zh-Latn-CN-variant1-a-extend1
> >    3. zh-Latn-CN-variant1
> >    4. zh-Latn-CN
> >    5. zh-Latn
> >
> >Regards,
> >
> >Erik van der Poel
> >

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 18 Oct 2005 21:30:14 -0700

Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:

>> 2. This example may not be the best. But it is the only one in the
>> document showing the orthoginality between the registered subtags and
>> the privateuse area, and the possibility to have a private scheme
>> with a default. In this example: private1 makes x-wadegile is related
>> to Hant, while the defult (without private1) is related to Latn.
>
> As technical contributor:
>
> That is not the purpose of the example. Anyone familiar with
> romanization schemes for Chinese will find your interpretation highly
> implausible.

It's not even that.  The error in question has nothing to do with using
"x-wadegile" together with "zh-Hans".  It has to do with the fact that
the lines which follow use "zh-Latn" instead, which breaks the
illustration of how truncation works.

--
Doug Ewell
Fullerton, California
http://users.adelphia.net/~dewell/

---

From: "Addison Phillips" <[email-masked]>
Date: Tue, 18 Oct 2005 21:39:21 -0700

+1

Addison P. Phillips

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Doug Ewell
> Sent: 2005年10月19日 8:30
> To: LTRU Working Group
> Subject: [Ltru] Re: draft-14 of draft-ietf-ltru-registry
>