Subject: RE: [Ltru] draft-14 of draft-ietf-ltru-registry

From: "Addison Phillips" <[email-masked]>
Date: Mon, 17 Oct 2005 21:27:51 -0700

It is a good catch. I've corrected my editor's copy and made this the first (and hopefully last) item in my list for AUTH48.

Addison (from ??????)

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Duerst
> Sent: 2005?10?18? 8:21
> To: Erik van der Poel; [email-masked]
> Subject: Re: [Ltru] draft-14 of draft-ietf-ltru-registry
> 
> Hello Eric,
> 
> Great catch!
> 
> I think that this is a small oversight. I seem to remember
> proposing to change "Hant" to "Latn" to make sure it
> fits better with x-wadegile (Wade-Giles is a well-known
> romanization for Chinese). Apparently, when this was
> implemented, the first one was forgotten.
> 
> Procedurally, I'd like to see confirmation from the authors,
> and make sure that nobody from the WG objects, and then
> have the authors make this change in the RFC Editor's
> AUTH48 period (i.e. shortly before the RFC is being
> published).
> 
> Regards,   Martin.
> 
> At 01:36 05/10/18, Erik van der Poel wrote:
>  >Hello everybody,
>  >
>  >This is just a minor issue, but the truncation example starts with Hant
> and then has Latn in the following lines:
>  >
>  >    Tag to truncate: zh-Hant-CN-variant1-a-extend1-x-wadegile-private1
>  >    1. zh-Latn-CN-variant1-a-extend1-x-wadegile
>  >    2. zh-Latn-CN-variant1-a-extend1
>  >    3. zh-Latn-CN-variant1
>  >    4. zh-Latn-CN
>  >    5. zh-Latn
>  >
>  >Regards,
>  >
>  >Erik van der Poel
>  >
>  >_______________________________________________
>  >Ltru mailing list
>  >[email-masked]
>  >https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis <[email-masked]>
Date: Mon, 17 Oct 2005 22:21:50 -0700

So no disagreement from the authors!

Mark

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Tue, 18 Oct 2005 07:30:47 -0400

I can also put a note to the RFC Editor in the ballot write up to tell the
RFC Editor to make the change directly.  I'll do that if someone can provide
an "OLD" vs. "NEW" summary.

-Scott-

> From: Addison Phillips [mailto:[email-masked]] 
> Sent: Tuesday, October 18, 2005 12:28 AM
> To: Martin Duerst; Erik van der Poel; [email-masked]
> Subject: RE: [Ltru] draft-14 of draft-ietf-ltru-registry
> 
> It is a good catch. I've corrected my editor's copy and made 
> this the first (and hopefully last) item in my list for AUTH48.
> 
> Addison (from ??????)
> 
> Addison P. Phillips
> >  >    Tag to truncate: 
> zh-Hant-CN-variant1-a-extend1-x-wadegile-private1

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 18 Oct 2005 18:57:00 +0200

Scott Hollenbeck wrote:

> if someone can provide an "OLD" vs. "NEW" summary.

| RFC editor note:
| Please replace zh-Hant-CN-variant1-a-extend1-x-wadegile-private1
| by zh-Latn-CN-variant1-a-extend1-x-wadegile-private1 on
| page 43 of draft-ietf-ltru-registry-14 in chapter 4.3.2 for
| consistency with the immediately following zh-Latn truncation
| example on the same page.  This typo was found after the IESG
| evaluation and confirmed by the authors.

                           Bye, Frank

---

From: r&d afrac <[email-masked]>
Date: Wed, 19 Oct 2005 04:28:44 +0200

>| evaluation and confirmed by the authors.

Since there is no response to my comment:

1. consensus is requested: I oppose.

2. This example may not be the best. But it is the only one in the 
document showing the orthoginality between the registered subtags and 
the privateuse area, and the possibility to have a private scheme 
with a default. In this example: private1 makes x-wadegile is related 
to Hant, while the defult (without private1) is related to Latn.

This example is correct. Even if it may not be ideal and considered 
as "politcially incorrect", in reference to Harald's mail of apology 
on the privateuse area.

No problem in changing it, however: if an example is added which 
documents the privateuse orthogonalité/default permitted by the Document..
jfc

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 18 Oct 2005 19:39:49 -0700

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, October 18, 2005 9:57 AM
> Subject: [Ltru] Re: draft-14 of draft-ietf-ltru-registry
>
> Scott Hollenbeck wrote:
> 

This looks good to me, both as a technical contributor and as co-chair.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 18 Oct 2005 20:03:06 -0700

Hi -

> From: "r&d afrac" <[email-masked]>
> To: "Frank Ellermann" <[email-masked]>; <[email-masked]>
> Sent: Tuesday, October 18, 2005 7:28 PM
> Subject: Re: [Ltru] Re: draft-14 of draft-ietf-ltru-registry
>

> 1. consensus is requested: I oppose.

As co-chair:
We do not need WG consensus to correct an obvious (once
spotted!) typo in an example.  If you object to the decision to
correct this typo, please feel free to appeal to the AD, etc.

> to Hant, while the defult (without private1) is related to Latn.

As technical contributor:

That is not the purpose of the example. Anyone familiar with romanization
schemes for Chinese will find your interpretation highly implausible.

> documents the privateuse orthogonalité/default permitted by the Document..

As co-chair: at this stage of the process, adding new material would be
inappropriate.

Randy

---

From: Mark Davis <[email-masked]>
Date: Tue, 18 Oct 2005 20:57:50 -0700

I agree.