Subject: [Ltru] lists first or ranges first

From: Martin Duerst <[email-masked]>
Date: Wed, 07 Dec 2005 19:53:14 +0900

[as a co-chair] Making this a separate issue for easier discussion.

[as a technical contributor]
This is picking up a comment of Harald's that is in conflict
with a comment that I made.

[Harald]
 > - The writing is inconsistent about what the inputs and outputs of a
 > matching function is. Sometimes it talks about language ranges, sometimes
 > it talks about language priority lists. I think it needs to always describe
 > the function in terms of language priority lists.

I disagree with the above. I think that a consistent description
is very important, but I think it's much easier to do this bottom-up,
i.e. first describe how a single language range matches (or doesn't
match) a language tag, then talk about how this works for lists.

These are the reasons for my proposal:

- There are some cases (e.g. style application (CSS) where
   there are no lists at all, just a range and a tag to match.
- Language priority lists aren't fully specified in our draft.
   There are both issues of syntax (e.g. what separator to use,...)
   and other issues such as q-values, and so on.
- It helps organize the description. It should also make
   implementation easier.

[Addison Phillips]
 > I completely agree. Actually, the LPL bits come from my efforts to 
change the text in that direction, having recognized that this is how each 
algorithm will be implemented.

Are you saying that implementations don't have code (most probably
some function or method) to compare a single range to a single tag?

Regards,    Martin. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 7 Dec 2005 09:14:06 -0800

Comments follow.

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Duerst
> Sent: Wednesday, December 07, 2005 2:53 AM
> 
> [Harald]
[Addison Phillips] 

By handling it as Harald and I propose, we cover both LPLs and single comparisons. If you read draft-08, the text is fairly elegant in how it transitions: it first covers how the ranges are pulled from the LPL and then proceeds to cover matching each range to the set of tags.
[Addison Phillips] 

It is entirely possible that CSS would choose to make the :lang production into a full-fledge LPL. It would actually make a lot of sense for them to do so.

Even allowing this case, a single range is a case of a list with one item.

[Addison Phillips] 

That's true, but may be irrelevant.

[Addison Phillips] 

Maybe, but see draft-08. I think it does this elegantly enough.
> some function or method) to compare a single range to a single tag?
Of course they do. And this is fully specified. But we go the extra step and say how the result of this function/method relates to other results produced by the LPL.
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru