Subject: [Ltru] implementation, application, protocol

From: Martin Duerst <[email-masked]>
Date: Mon, 05 Dec 2005 18:22:27 +0900

[co-chair hat off]

I have earlier raised an issue about the words
'application' and 'protocol'. I don't think
I talked about 'implementation' then, but that
word is also all over the place, without ever
being clearly grounded.

I propose that we add an explanation somewhere
at the end of section 1. The following text is
a first attempt, I'm sure it can be improved:

The matching schemes defined in this document can
be used by (Internet) protocols, or, in cases where
there is no protocol, directly by applications.
Depending on the matching scheme, there are
various options left to the implementation.
This means that the option is left to the protocol
if the matching scheme is used by a protocol, or
directly by the application in case there is no
protocol. If there is a protocol, the protocol may
select some options, and my leave others open
to implementers of that protocol.

Not sure the text above is very good, but I hope you
at least get the idea I wanted to put out.

Regards,   Martin. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis <[email-masked]>
Date: Mon, 05 Dec 2005 10:02:15 -0800

I think that's a reasonable goal. I agree that the wording needs a bit 
of adjustment; in particular, I'd like to add a conformance requirement 
than any such option (at whatever level) be precisely specified.

Mark

---

From: Martin Duerst <[email-masked]>
Date: Tue, 06 Dec 2005 10:15:19 +0900

At 03:02 05/12/06, Mark Davis wrote:
 >I think that's a reasonable goal. I agree that the wording needs a bit of 
adjustment; in particular, I'd like to add a conformance requirement than 
any such option (at whatever level) be precisely specified.

Good point.     Regards,   Martin.