Subject: RE: [Ltru] Re: harald's comments...

From: "Addison Phillips" <[email-masked]>
Date: Wed, 7 Dec 2005 08:54:06 -0800

I use Bill Fenner's ABNF checker. The IETF one was buggy for a long time and I kept getting burned for using it.

Some decisions were made (per Frank's quoted thread) to make the 3066bis ABNF a certain way. Of course we can revisit this for the matching draft, but we shouldn't, IMHO, fall too far from the draft-registry tree with our ABNF. We have ample commentary from (for example) Kent Karlsson about how confusing the extant differences are. More differences will not be better, provided the ABNF is actually correct.

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Duerst
> Sent: Wednesday, December 07, 2005 2:27 AM
> To: Frank Ellermann; [email-masked]
> Subject: Re: [Ltru] Re: harald's comments...
> 
> At 15:50 05/12/07, Frank Ellermann wrote:
>  >Addison Phillips wrote:
>  >
>  >>> HTA: ABNF error. Case insensitivty means that the two
>  >>> alternatives are equal.
>  >
>  >> Comment: Gee... now you tell us :-). This is a direct
>  >> quote from 3066bis.
>  >
>  >02-21: <http://mid.gmane.org/[email-masked]>
>  >03-17: <http://mid.gmane.org/[email-masked]>
>  >06-14: <http://mid.gmane.org/[email-masked]>
>  >06-15: <http://mid.gmane.org/[email-masked]>
>  >06-15: <http://mid.gmane.org/[email-masked]>
>  >08-09: <http://mid.gmane.org/[email-masked]>
>  >
>  >Well, we discussed it, didn't we ?  <g>
> 
> There are different ABNF checkers around. I'm not sure which
> one Addison used. I'm quite sure which one Harald used: he
> wrote his own. I think there was an IESG discuss on an ABNF
> issue, which came from Bill Fenner, who also has his own
> checker. And the one at http://www.apps.ietf.org/abnf.c
> says it's by Chris Newman.
> 
> It is not really clear to me whether a syntax such as "x" / "X"
> is indeed an error. It depends on whether you want to strictly
> check whether a string is allowed or not (in which case it's
> just redundant, not an error), or if you want to use the ABNF
> to cut the syntax into pieces for further processing, in which
> case you need a deterministic grammar, which the above is not.
> 
> This is an important distinction; it is one of the main
> reasons why we e.g. have XML Schema and RelaxNG, the former
> requiring the schema to be deterministic, whereas the later
> doesn't.
> 
> On a quick reading of http://www.ietf.org/rfc/rfc4234.txt,
> I haven't found any indication that ABNFs have to be
> deterministic. Of course, many if not most of them are,
> because usually being able to process the syntax
> deterministically is the point of the ABNF. But to determine
> in general whether a syntax is deterministic or not isn't
> that easy (the non-determinism can occur on a level much
> higher than constants in the same rule.
> 
> Regards,   Martin.
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 07 Dec 2005 20:48:09 +0100

Addison Phillips wrote:
 
> More differences will not be better, provided the ABNF is
> actually correct.

Yes, if Harald convinces you to say "x" instead of "x" / "X"
in -matching, then you could also update -registry in AUTH48
to reflect this.
                       Bye, Frank