Subject: [Ltru] scored filtering and supress script

From: Martin Duerst <[email-masked]>
Date: Tue, 06 Dec 2005 17:39:58 +0900

[co-chair hat off]
This is a proposal that both Doug and I liked, and that
I don't understand why it shouldn't work, so I'm bringing
it up again here. Doug also pointed out that we need
have the necessary information anyway.

For scored filtering, I propose to exand both ranges
and tags with suppress-script. This means that
de-DE becomes de-Latn-DE, and thus doesn't match
de-Brai-DE, in contrast to de-*-DE, which of course
would match de-Brai-DE.

Regards,   Martin. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 06 Dec 2005 13:53:30 +0100

> de-Brai-DE, in contrast to de-*-DE, which of course

This of course demands access to the registry, and the results will vary 
based on which date the registry was incorporated/consulted.
But since this is already implicit in section 3.2.3:

   First both the extended language range and the language tags to be
   matched to it must be canonicalized by mapping grandfathered and
   obsolete tags into modern equivalents.

I see this as a reasonable thing to do.
Note: draft-ietf-ltru-initial-06 has 125 "Suppress-Script" tags, and 481 
entries with "Type: Language". It's possible that there'll be a number of 
updates requested if this proves popular and useful.

                        Harald

---

From: "John.Cowan" <[email-masked]>
Date: Tue, 6 Dec 2005 09:36:15 -0500

> de-Brai-DE, in contrast to de-*-DE, which of course

+1

-- 
But you, Wormtongue, you have done what you could for your true master.  Some
reward you have earned at least.  Yet Saruman is apt to overlook his bargains.
I should advise you to go quickly and remind him, lest he forget your faithful
service.  --Gandalf             John Cowan <[email-masked]>

---

From: Martin Duerst <[email-masked]>
Date: Wed, 07 Dec 2005 15:33:46 +0900

>But since this is already implicit in section 3.2.3:

Yes, exactly. This is what I meant when I wrote "Doug also pointed
out that we need have the necessary information anyway." above.

Yes indeed. There are a lot of languages that in practice are written
only or highly predominantly with one script, but do not yet have the
appropriate "Suppress-Script" information.

Regards,    Martin.