Subject: RE: [Ltru] harald's comments...

From: "Addison Phillips" <[email-masked]>
Date: Wed, 7 Dec 2005 08:30:56 -0800

Yes, but the chair keeps telling me to hold off....

After today's round, I'm sending in #8.

Addison

Addison P. Phillips
Globalization Architect, Quest Software

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]]
> Sent: Tuesday, December 06, 2005 2:47 PM
> To: Addison Phillips; LTRU Working Group
> Subject: Re: [Ltru] harald's comments...
> 
> 
> 
> --On 6. desember 2005 10:40 -0800 Addison Phillips
> <[email-masked]> wrote:
> 
> > New editor's copy of draft-08 is on my website. It is getting really
> hard
> > to find thing, since several sections have been moved. I suggest we
> > update to draft-08 SOON.
> 
> publish early, publish often. Still 91 versions to go until the 2-digit
> field overflows!
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 7 Dec 2005 13:02:12 -0800

I'm happy to be convinced, see for example Scott's email. The new ABNF will be easier to read and understand. (It is NOT in draft-08, please note.) 

Here is what I propose to use:

--
extended-language-range  = range ; a range
              / privateuse       ; a private-use range
              / grandfathered    ; a grandfathered registration

range         = (language
                 ["-" script]
                 ["-" region]
                 *("-" variant)
                 *("-" extension)
                 ["-" privateuse])

language      = (2*3ALPHA [ extlang ]) ; shortest ISO 639 code
              / 4ALPHA                 ; reserved for future use
              / 5*8ALPHA               ; registered language subtag
              / "*"                    ; ... or wildcard

extlang       = *2("-" 3ALPHA) ("-" ( 3ALPHA / "*"))
                                       ; reserved for future use
                                       ; wildcard can only appear
                                       ;   at the end

script        = 4ALPHA                 ; ISO 15924 code
              / "*"                    ; or wildcard

region        = 2ALPHA                 ; ISO 3166 code
              / 3DIGIT                 ; UN M.49 code
              / "*"                    ; or wildcard

variant       = 5*8alphanum            ; registered variants
              / (DIGIT 3alphanum)      ; 
              / "*"                    ; or wildcard

extension     = singleton *("-" (2*8alphanum)) [ "-*" ]
                                       ; extension subtags
                                       ; wildcard can only appear
                                       ;   at the end

singleton     = "a"-"w" / "y"-"z" / DIGIT
              ; single characters, "x" is reserved for private use

privateuse    = "x" 1*("-" (1*8alphanum))

grandfathered = 1*3ALPHA 1*2("-" (2*8alphanum))
                ; grandfathered registration
                ; Note: I is the only singleton
                ; that starts a grandfathered tag

alphanum      = (ALPHA / DIGIT)       ; letters and numbers
--

Addison P. Phillips

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Frank Ellermann
> Sent: Wednesday, December 07, 2005 11:48 AM
> To: [email-masked]
> Subject: [Ltru] Re: harald's comments...
> 
> Addison Phillips wrote:
> 
> > More differences will not be better, provided the ABNF is
> > actually correct.
> 
> Yes, if Harald convinces you to say "x" instead of "x" / "X"
> in -matching, then you could also update -registry in AUTH48
> to reflect this.
>                        Bye, Frank
> 
> 
>

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 8 Dec 2005 07:51:13 -0800

I don't mind changing the ABNF for private-use at all. It's the singleton production that is a problem, since it uses ranges.

Addison

Addison P. Phillips

> Harald Tveit Alvestrand
> Sent: Thursday, December 08, 2005 2:18 AM
> To: Martin Duerst; Frank Ellermann; [email-masked]
> Subject: Re: [Ltru] Re: harald's comments...
> 
> 
> 
> --On onsdag, desember 07, 2005 19:26:32 +0900 Martin Duerst
> <[email-masked]> wrote:
> 
> > At 15:50 05/12/07, Frank Ellermann wrote:
> >  >Addison Phillips wrote:
> >  >
> >  >>> HTA: ABNF error. Case insensitivty means that the two
> >  >>> alternatives are equal.
> >  >
> >  >> Comment: Gee... now you tell us :-). This is a direct
> >  >> quote from 3066bis.
> >  >
> >  >02-21: <http://mid.gmane.org/[email-masked]>
> >  >03-17: <http://mid.gmane.org/[email-masked]>
> >  >06-14: <http://mid.gmane.org/[email-masked]>
> >  >06-15: <http://mid.gmane.org/[email-masked]>
> >  >06-15: <http://mid.gmane.org/[email-masked]>
> >  >08-09: <http://mid.gmane.org/[email-masked]>
> >  >
> >  >Well, we discussed it, didn't we ?  <g>
> >
> > There are different ABNF checkers around. I'm not sure which
> > one Addison used. I'm quite sure which one Harald used: he
> > wrote his own. I think there was an IESG discuss on an ABNF
> > issue, which came from Bill Fenner, who also has his own
> > checker. And the one at http://www.apps.ietf.org/abnf.c
> > says it's by Chris Newman.
> 
> actually I used my eyeballs... my syntax checker is far less good than the
> newer alternatives.
> 
> And it's not strictly an ABNF error - my objection is to it being
> superfluous - it will leave people who know that ABNF is case insensitive
> about " " strings hunting for the sentence that says "in this case, we're
> using ABNF as if it was case sensitive" (there is none), and making people
> who don't know that ABNF is case insensitive assume that it is.
> 
> I prefer not to have it. But if the WG has reached consensus that this
> should be that way.... sigh; I'll let you have it.
> 
>                     Harald
> 
> 
> 
>