Subject: RE: [Ltru] status of RFC 3066 or RFC 3066bis in relation to HTTP Accept-Language

From: "McDonald, Ira" <[email-masked]>
Date: Sun, 26 Mar 2006 12:08:58 -0800

Peter Constable wrote:
> 
> Yes. I had a generic question about versioning for IETF 
> specs, for which
> I got a somewhat vague answer; but I was also concerned about 
> a specific
> instance of versioning, and for that I figured out an appropriate
> answer.
> 
> I've got someone asking me about Accept-Language, and when writing my
> prior response, I realized that probably underlying their 
> question was a
> concern based on a wrong understanding of RFC 1766 -- thinking that
> Accept-Language can't pass (e.g.) az-Cyrl-AZ because (in 
> their mistaken
> understanding) RFC 1766 doesn't allow such a tag because of the script
> subtag. So, my response to them is, even though 2616 references 1766,
> Accept-Language most certainly can -- and likely will -- past 
> a tag like
> az-Cyrl-AZ.

What RFC 1766 (or 3066) allowed or disallowed is only _part_
of the answer to your question about Accept-Language.

RFC 1766 and RFC 3066 point normatively at the (now defunct)
IANA Language Tag registry.  If you tell your developers to
conform to RFC 1766 (or RFC 3066), then they'll write code
to check that IANA registry.

On the other hand, if you tell your developers to conform to
RFC3066bis, then they'll write code to check the _different_
IANA Language Subtag registry, and to enforce quite different
rules of usage (e.g., no whole language tag is ever listed
in the new registry).

The LTRU WG has (perhaps precipitately?) encourage IANA to
mothball the old registry - newly registered script subtags
for specific languages will NOT also be registered into the
defunct old registry - which means that running code that
checks that registry will NOT explicitly understand that 
those _specific_ subtags are now valid script subtags.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.385 / Virus Database: 268.3.1/292 - Release Date: 3/24/2006

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 27 Mar 2006 09:21:16 +0200

>those _specific_ subtags are now valid script subtags.
Reality checkpoint:

Does anyone know of any production code that parses the old tag registry?
(one-off scripts that generate simplified files that are later updated 
by hand doesn't count)

Unless such code is shown to exist, I'm pretty sure it doesn't make 
sense to bend over backwards to be compatible with it - and even if it 
exists, it's a tradeoff, not a sure thing.

                         Harald