Subject: [Ltru] Exceptionally Reserved Two-letter ISO 3166 Codes

From: Misha Wolf <[email-masked]>
Date: Wed, 08 Mar 2006 18:38:46 +0000

In another place, Jon Hanna wrote:

> Exceptionally Reserved Two-letter ISO 3166 Codes aren't used.

Have we done this?  If so, why have we done it?

<quote
src="http://www.iso.org/iso/en/prods-services/iso3166ma/02iso-3166-code-
lists/iso_3166-1_decoding_table.html">

EU | European Union | | ISO 4217/MA. In March 1998, extension of 
   |                | | scope to ISO 6166 "Securities - 
   |                | | International securities identification 
   |                | | numbering system (ISIN)". In August 1999, 
   |                | | extension of scope to any application 
   |                | | needing to represent the name European Union.

</quote>

Misha

To find out more about Reuters visit www.about.reuters.com

Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of Reuters Ltd.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 20 Mar 2006 23:42:28 -0800

Hi -

> From: "Misha Wolf" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, March 08, 2006 10:38 AM
> Subject: [Ltru] Exceptionally Reserved Two-letter ISO 3166 Codes
>

> Have we done this?  If so, why have we done it?
...

Not having a copy of ISO 3166 handy, I respond with another question:
is this covered by the text of point four on page twelve of 
http://www.ietf.org/internet-drafts/draft-ietf-ltru-registry-14.txt?
It states:

| 4.  Note: The alphanumeric codes in Appendix X of the UN document
|        MUST NOT be entered into the registry and MUST NOT be used to
|        form language tags.  (At the time this document was created these
|        values match the ISO 3166 alpha-2 codes.)

The "exceptionally reserved codes" were mentioned in discussion in March
of 2005, according to a search of my mailbox.

Randy, as a technical contributor

---

From: John Cowan <[email-masked]>
Date: Tue, 21 Mar 2006 07:59:56 -0500

> > Have we done this?  If so, why have we done it?

We have done it, and we have done it because they aren't regularly assigned
ISO 3166 codes, which are the only kind we support.  Exceptionally
reserved codes are ones that are used for something else, and ISO 3166
doesn't want to step on them.

> |        values match the ISO 3166 alpha-2 codes.)

No, that's another thing altogether: it refers to UN M.42 codes, and
clarifies that UN M.42 is not the authoritative source of 2-letter codes.

-- 
MEET US AT POINT ORANGE AT MIDNIGHT BRING YOUR DUCK OR PREPARE TO FACE WUGGUMS
John Cowan   http://www.ap.org   [email-masked]