Subject: [Ltru] Charter - sign(ed) language tag construction ?

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 6 Jul 2006 10:30:29 -0700

Hi -

As a technical contributor...

Would it make sense to add material on how tagging for sign(ed)
languages to the 3066ter effort being proposed?  If so, could
Peter's message be distilled down to a high-level sentence for
the charter discussion?

Randy

----- Original Message ----- 
From: "Peter Constable" <[email-masked]>
To: "IETF Languages Discussion" <[email-masked]>
Sent: Tuesday, February 28, 2006 12:22 AM
Subject: RE: Language Subtag Registration Form: variant "signed"

I had an hour conversation today with an SIL linguist that has been assisting teams working on sign language projects for a number
of years. We discussed various things, including the phenomenon of "signed-spoken-lang-X" varieties.

In thinking about how to construct tags for these languages, the crucial question in my mind is this (using "signed English" in the
US as an example):

Is signed English

1) basically English expressed in a different modality,
2) basically ASL with some kind of modification or qualification -- e.g. a dialect or register, or
3) a pidgin of English and ASL?

Whichever it is, we should tag it accordingly (and if three, then possibly code as though it were a distinct language).

I was thinking we might use a subtag "-signed" based on the assumption that (1) was applicable. I know understand that these
language varieties typically fall into (2), though perhaps sometimes into (3); generally these are probably best thought of as
registers of the relevant signed language. They typically use phonology and lexica from the sign language and impose elements of the
syntax (possibly including morphology) of the spoken language.

Thus, here's my thoughts on a good approach to tagging signed languages:

- We treat "sgn" as though it were a macrolanguage. (My contact said that really wasn't that much of a stretch.)

- We use ISO 639-3 IDs as extlang subtags together with a primary subtag of "sgn"; e.g., "sgn-ase" for ASL. All signed languages
(SLs proper, not the Signed English cases) use tags constructed this way.

- We generally treat varieties like Signed English as registers of the signed language they are associated with. Thus, the tag is
formed by adding a variant subtag to the tag for the sign language. Because there can be multiple varieties for a given sign
language/spoken language combination, registered variant subtags provide the necessary level of flexibility. E.g. something like
"sgn-ase-enexact" "sng-ase-enexact2" for SEE and SEE2; and "sgn-ase-esbaja" for the signed Spanish spoken in southern Baja
California (which is based on ASL).

- For cases of signed-spoken-lang-X that are pidgins, we treat these based on whatever general principles we adopt for pidgins. (I'm
not sure at the moment what that should be; the problem with pidgins is that they are transitional and not yet stable -- they may
stabilize as a creole or they may continue to mutate or they may disappear.)

This should give generally good results for matching algorithms. Having "sgn" at the start immediately sets apart the modality,
which will generally trump any other distinction in importance to the user. A request for "sgn-ase" will return results that include
(the hypothetical) "sgn-ase-enexact" and "sgn-ase-esbaja", which is likely to be reasonable: an ASL speaker is going to recognize
all or nearly all of the lexical items in either case and so will have about as much problem in comprehension as we'd expect from
dialect or register differences.

This is a preliminary take. I'm know my understanding is still limited, and that are likely to be several parts of what I've
outlined that need work and further discussion.

Peter Constable
_______________________________________________
Ietf-languages mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/ietf-languages

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 6 Jul 2006 13:55:29 -0400

> Peter's message be distilled down to a high-level sentence for

Here's my first try:

	The working group is also expected to design a suitable mechanism
	for the tagging of sign languages and signed spoken languages.

-- 
John Cowan                                [email-masked]
At times of peril or dubitation,          http://www.ccil.org/~cowan
Perform swift circular ambulation,
With loud and high-pitched ululation.

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 6 Jul 2006 11:01:44 -0700

I have several thoughts here:

1. I am hoping that "sgn-ase" (etc. etc.) is dealt with as part of
incorporating ISO 639-3, that is, it is a special case of the more general
treatment of extended language subtags. I suspect that it would be best if
an ISO 639-3 code is either *always* a language subtag or *always* an
extlang (with a specific prefix).

2. I think that tagging of signed languages should be cited as an example of
the problem of incorporating ISO 639-3 in the charter. 

3. It might be a good idea to consider, instead of more wordsmithing within
3066bis, splitting the document yet again. Sections 2 and 3 of the current
document concern the format of tags and the creation and maintenance of the
registry. These are mechanical, non-controversial things, which will require
very little work. Section 4 ("Formation and Processing of Language Tags")
might benefit from being its own, standalone, document incorporating more
(and more accessible) material on choosing and using tags--including "best
practices" in tag formation to address cases such as sign languages. Many of
these recommendations are not normative in the sense of being at the
MUST/MUST NOT level. Expanding on the reasons why one should use
"sgn-ase-foobar" instead of, for example, "ase-US-xyzzy" would help users,
but, pace my suspicion in item #1 above, either might be a valid tag, and
even useful in certain situations.

Addison

Addison Phillips
Internationalization Architect - Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.  

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]] 
> Sent: jeudi 6 juillet 2006 10:30
> To: LTRU Working Group
> Subject: [Ltru] Charter - sign(ed) language tag construction ?
> 
> Hi -
> 
> I had an hour conversation today with an SIL linguist that 
> has been assisting teams working on sign language projects 
> for a number
> of years. We discussed various things, including the 
> phenomenon of "signed-spoken-lang-X" varieties.
> 
> In thinking about how to construct tags for these languages, 
> the crucial question in my mind is this (using "signed English" in the
> US as an example):
> 
> Is signed English
> 
> 2) basically ASL with some kind of modification or 
> qualification -- e.g. a dialect or register, or
> Whichever it is, we should tag it accordingly (and if three, 
> then possibly code as though it were a distinct language).
> 
> I was thinking we might use a subtag "-signed" based on the 
> assumption that (1) was applicable. I know understand that these
> language varieties typically fall into (2), though perhaps 
> sometimes into (3); generally these are probably best thought of as
> registers of the relevant signed language. They typically use 
> phonology and lexica from the sign language and impose elements of the
> - We treat "sgn" as though it were a macrolanguage. (My 
> contact said that really wasn't that much of a stretch.)
> 
> - We use ISO 639-3 IDs as extlang subtags together with a 
> primary subtag of "sgn"; e.g., "sgn-ase" for ASL. All signed languages
> - We generally treat varieties like Signed English as 
> registers of the signed language they are associated with. 
> Thus, the tag is
> formed by adding a variant subtag to the tag for the sign 
> language. Because there can be multiple varieties for a given sign
> language/spoken language combination, registered variant 
> subtags provide the necessary level of flexibility. E.g. 
> something like
> "sgn-ase-enexact" "sng-ase-enexact2" for SEE and SEE2; and 
> "sgn-ase-esbaja" for the signed Spanish spoken in southern Baja
> - For cases of signed-spoken-lang-X that are pidgins, we 
> treat these based on whatever general principles we adopt for 
> pidgins. (I'm
> not sure at the moment what that should be; the problem with 
> pidgins is that they are transitional and not yet stable -- they may
> This should give generally good results for matching 
> algorithms. Having "sgn" at the start immediately sets apart 
> the modality,
> which will generally trump any other distinction in 
> importance to the user. A request for "sgn-ase" will return 
> results that include
> (the hypothetical) "sgn-ase-enexact" and "sgn-ase-esbaja", 
> which is likely to be reasonable: an ASL speaker is going to recognize
> all or nearly all of the lexical items in either case and so 
> will have about as much problem in comprehension as we'd expect from
> This is a preliminary take. I'm know my understanding is 
> still limited, and that are likely to be several parts of what I've