Subject: [Ltru] FW: encoding languages and writing systems

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 12 Jul 2006 08:32:53 -0700

Hi,

Please take a few minutes to look at this link Chris Lilley
cites below - this document proposes an alarming abuse of 
language tags to include charset suffixes!

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Chris Lilley
Sent: Wednesday, July 12, 2006 11:08 AM
To: [email-masked]
Subject: encoding languages and writing systems

Hello www-international,

My attention was recently drawn to this document, by the Center for Hellenic
Studies in Washington:

Developing standards for encoding languages and writing systems in the
editing of Greek and Latin texts
http://chs75.harvard.edu/projects/diginc/techpub/language-script

Its interesting both for the way it reflects current work (eg, use of RFC
3066bis) and the way it seems to diverge from it (either I don't understand
what they mean by a 'mapping', or else they propose character abuse and
don't understand that XML has a single document character set).

-- 
 Chris Lilley                    mailto:[email-masked]
 Interaction Domain Leader
 Co-Chair, W3C SVG Working Group
 W3C Graphics Activity Lead
 Co-Chair, W3C Hypertext CG

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.10/386 - Release Date: 7/12/2006

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 12 Jul 2006 13:21:02 -0700

Hi -

> From: "McDonald, Ira" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, July 12, 2006 8:32 AM
> Subject: [Ltru] FW: encoding languages and writing systems
...
> language tags to include charset suffixes!
...
> Sent: Wednesday, July 12, 2006 11:08 AM
...
> don't understand that XML has a single document character set).
...

As a technical contributor...
I agree with Ira and Chris that including character set identification
in the language tag would be a bad idea.

In particular, it's worth noting that this WG explicitly rejected the
notion of trying to combine character set information with language
tagging.  (Issue #890 at https://rt.psg.com/ user and password "ietf")

Does anyone know how to contact the authors of that paper?

Randy

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 12 Jul 2006 14:58:12 -0700

I firmly agree; this is a settled issue. I find the original paper
ill-thought out. It's worth contacting the authors to find out what they
really had in mind.

Mark

---

From: John Cowan <[email-masked]>
Date: Wed, 12 Jul 2006 18:56:02 -0400

> ill-thought out. It's worth contacting the authors to find out what they

I have!  I have!  Why is nobody listening?

-- 
Híggledy-pìggledy / XML programmers            John Cowan
Try to escape those / I-eighteen-N woes;        http://www.ccil.org/~cowan
Incontrovertibly / What we need more of is      [email-masked]
Unicode weenies and / François Yergeaus.

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 12 Jul 2006 16:46:15 -0700

Hi -

> From: "John Cowan" <[email-masked]>
> To: "Mark Davis" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, July 12, 2006 3:56 PM
> Subject: Re: [Ltru] FW: encoding languages and writing systems
>
> Mark Davis scripsit:
...

We are.  Queueing and propagation delay may be factors.

Randy