Subject: [Ltru] Charter update proposal

From: Martin Duerst <[email-masked]>
Date: Fri, 28 Jul 2006 17:41:01 +0900

Dear LTRU WG,

As you know, we have completed all the goals and milestones
in our current charter
(at http://www.ietf.org/html.charters/ltru-charter.html),
but as recent discussion has shown, we think that we
should do some more work. The IETF closes a WG when it
thinks that its work is done, but if additional work
is identified or the current work plan has to be changed,
a RECHARTER is done (see e.g.
http://www1.ietf.org/mail-archive/web/ietf-announce/current/msg02763.html).

Based on the input on the mailing list, and with some detailled
feedback from Randy, I have prepared a draft for the new charter.
Any comments are welcome, but please note that ultimately, what
goes into a charter and what not is the decision of the ADs and
the IESG.

Also, please note that on purpose, I have kept the draft quite
terse. This reflects the fact that the work on the registry
document is supposed to be minor compared with what we have
done so far. It is also based on the understanding that whether
a particular subject or detail is up for discussion or not is not
determined by whether it is mentioned in the charter or not, but
by whether the reason and the way we deal with it fits within
the limits given by the charter.

So below please find the "Description" and "Milestones" parts
of the charter. The 'front' part of the charter (chairs/ADs/
mailing lists) are assumed to stay as is.

-----------------------------------------------------------------
Description of the Working Group:

The primary language tags allowed by the current IANA language
subtag registry are limited to ISO 639-1 and ISO 639-2 in the
same way as they were limited by RFC 3066. This covers
approximately 400 (??) possible language codes.
ISO 639-3, scheduled for approval towards the end of 2006,
will make available around 6000 (??) more primary language codes
and language variant codes.

The working group will work on an update to the language subtag
registry procedures to allow the use of 3-letter codes from
ISO 639-3 as primary subtags or variant subtags as appropriate.
The working group will also deliver means to update the current
IANA language subtag registry with the newly available codes.

The working group may make adjustments to the registration process
and the form of the registry if this is deemed appropriate based
on ongoing registration and operational experience and such
adjustments are not expected to delay the progress of the work.

Work on the drafts is planned to start before ISO 639-3 is fully
approved and published. However, the WG will not finalize the drafts
before ISO 639-3 is fully approved.

Goals and Milestones:

September 2006   Submit first WG draft of registry procedure update
September 2006   Submit first WG draft of registry data update

January   2007   Submit registry procedure update draft for IETF Last Call
January   2007   Submit registry data update draft for IETF Last Call
------------------------------------------------------------------------

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]     

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 28 Jul 2006 14:12:47 +0200

Martin Duerst wrote:

> The working group will work on an update to the language
> subtag registry procedures to allow the use of 3-letter
> codes from ISO 639-3 as primary subtags or variant subtags
> as appropriate.

Do you mean "variant" here, or should that be "extended" ?
If it's really "variant" I've no clue what you have in mind.

Bye, Frank

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 28 Jul 2006 06:52:10 -0700

One small comment: 639-3 won't make any codes available that would get used as variant subtags. It will make available codes that we expect will get used as extlang subtags.

I'm guessing the number of additional codes that would get added is around 6,800 (I think there was approx 7200 total in the draft code table of which approx 400 are in 639-2).

Peter

> -----Original Message-----
> From: Martin Duerst [mailto:[email-masked]]
> Sent: Friday, July 28, 2006 1:41 AM
> To: LTRU Working Group
> Subject: [Ltru] Charter update proposal
> 
> Dear LTRU WG,
>

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 28 Jul 2006 07:02:51 -0700

Something along these lines looks good. A couple wording items:

=>
on ongoing registration and operational experience. It may also clarify
some of the text. Such

---

From: John Cowan <[email-masked]>
Date: Fri, 28 Jul 2006 10:04:00 -0400

> IANA language subtag registry with the newly available codes.

Proposed replacement:

The working group will work on an update to the language subtag
registry procedures to allow the use of 3-letter codes from
ISO 639-3 as primary subtags or extlang subtags as appropriate.
Special attention will be given to the matter of sign languages.
The working group will also deliver means to update the current
IANA language subtag registry with the newly available codes.

You should also add in Addison's language on 639-6.

-- 
Deshil Holles eamus.  Deshil Holles eamus.  Deshil Holles eamus.
Send us, bright one, light one, Horhorn, quickening, and wombfruit. (3x)
Hoopsa, boyaboy, hoopsa!  Hoopsa, boyaboy, hoopsa!  Hoopsa, boyaboy, hoopsa!
  -- Joyce, Ulysses, "Oxen of the Sun"       [email-masked]

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 28 Jul 2006 08:04:01 -0700

In addition to signed languages, I'd like to see us discussing transliterations and transcriptions.

Peter

> From: John Cowan [mailto:[email-masked]]
> Sent: Friday, July 28, 2006 7:04 AM
> To: Martin Duerst
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Charter update proposal
> 
> Martin Duerst scripsit:
>

---

From: John Cowan <[email-masked]>
Date: Fri, 28 Jul 2006 11:06:15 -0400

> transliterations and transcriptions.

+1

-- 
I don't know half of you half as well           John Cowan
as I should like, and I like less than half     [email-masked]
of you half as well as you deserve.             http://www.ccil.org/~cowan
        --Bilbo

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 28 Jul 2006 16:40:52 +0100

+1 

-----Original Message-----
From: Peter Constable [mailto:[email-masked]] 
Sent: 28 July 2006 16:04
To: LTRU Working Group
Subject: RE: [Ltru] Charter update proposal

In addition to signed languages, I'd like to see us discussing
transliterations and transcriptions.

Peter

> > registry procedures to allow the use of 3-letter codes from ISO 
> > 639-3 as primary subtags or variant subtags as appropriate.
> > The working group will also deliver means to update the current IANA 
> > language subtag registry with the newly available codes.
> 
> Proposed replacement:
> 
> registry procedures to allow the use of 3-letter codes from ISO 639-3 
> as primary subtags or extlang subtags as appropriate.
> The working group will also deliver means to update the current IANA 
> language subtag registry with the newly available codes.
> 
> Send us, bright one, light one, Horhorn, quickening, and wombfruit. 
> (3x) Hoopsa, boyaboy, hoopsa!  Hoopsa, boyaboy, hoopsa!  Hoopsa, 
> boyaboy, hoopsa!

---

From: "Addison Phillips" <[email-masked]>
Date: Fri, 28 Jul 2006 13:44:35 -0700

Hello Martin,

Thank you for doing this. Unless notes, I am "+1" to everything you said in
your message.

Specific comments follow.

Addison

Addison Phillips
Internationalization Architect - Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.  

> Sent: vendredi 28 juillet 2006 01:41

> and language variant codes.

As noted by others, this sentence should say something else. However, I'm
convinced that the comments so far go in the wrong direction. In our jargon,
the term "codes" refers to codes in ISO 639, not to subtags. I would thus
propose we say:

--
ISO 639-3, scheduled for approval towards the end of 2006, will make
available around 7000 additional codes for identifying languages.
--
> The working group will work on an update to the language subtag

(Editorial) I would replace the phrase "work on" with "prepare" or "create".

> ISO 639-3 as primary subtags or variant subtags as appropriate.

As noted by others, replace 'variant' with 'extended language'.

> IANA language subtag registry with the newly available codes.

I would change this to be slightly more expansive:

--
The working group will also deliver a means to update the current
IANA language subtag registry with the newly available codes, as well
as procedures for maintaining the registry as codes are assigned 
or modified in the future.
--

Or you might consider using a separate sentence, such as the one I proposed
yesterday:

--
The working group must decide how ISO 639-3 codes are entered into the
registry, what rules apply to associating a code with the language and/or
extlang subtag types, and any additional rules or guidance on their adoption
and use.
--

> adjustments are not expected to delay the progress of the work.

(Editorial) This is a bit of a run-on sentence. Please break it into two
setences between
'experience' and 'such'.

I wouldn't oppose including some version of (Mark's version of) my ISO 639-6
text here ;-).

> before ISO 639-3 is fully approved.

I'm not sure that's correct. It would be more appropriate to say
"Publication of the draft(s) as an RFC will depend on final approval of ISO
639-3." There is ample space in the RFC Editor process for awaiting specific
external events (as we've already discovered). We might well finalize an
update to draft-registry quite quickly, but not the actual registry update
("draft-initial").

---

From: "Peter Constable" <[email-masked]>
Date: Sat, 29 Jul 2006 09:12:34 -0700

> From: Addison Phillips [mailto:[email-masked]]

> the term "codes" refers to codes in ISO 639, not to subtags. I would thus

If we really wanted to nitpick on terminology... ISO 639-3 will add *one* language code. That language code will include language identifiers for around 7000 additional languages. (That's the correct ISO-speak.)

Peter

---

From: John Cowan <[email-masked]>
Date: Sat, 29 Jul 2006 12:22:00 -0400

Peter Constable scripsit:

> If we really wanted to nitpick on terminology... ISO 639-3 will
> add *one* language code. That language code will include language
> identifiers for around 7000 additional languages. (That's the correct
> ISO-speak.)

But not correct RFC-speak, in which "code" is used to mean the two-
and three-letter items when being treated independently.

We probably should add to the charter an opportunity to reconcile
our terminology for talking about ISO standards with the terminology
used by the standard itself.

-- 
John Cowan   [email-masked]    http://ccil.org/~cowan
[R]eversing the apostolic precept to be all things to all men, I usually [before
Darwin] defended the tenability of the received doctrines, when I had to do
with the [evolution]ists; and stood up for the possibility of [evolution] among
the orthodox -- thereby, no doubt, increasing an already current, but quite
undeserved, reputation for needless combativeness.  --T. H. Huxley

---

From: "Debbie Garside" <[email-masked]>
Date: Sat, 29 Jul 2006 17:28:52 +0100

I think there is some variance in the terminology used within ISO 639-3 and
the RFC.  I would propose:

----

The ISO 639-3 code, due to be published in 2006, will make available
approximately 6,800 additional subtags for identifying linguistic entities. 

----

Best regards

Debbie

> Sent: 29 July 2006 17:13
> > > available around 6000 (??) more primary language codes 
> and language 
> > > variant codes.
> > 
> > As noted by others, this sentence should say something 
> else. However, 
> > I'm convinced that the comments so far go in the wrong 
> direction. In 
> > our jargon, the term "codes" refers to codes in ISO 639, not to 
> > subtags. I would thus propose we say:
> > 
> > --
> will make 
> If we really wanted to nitpick on terminology... ISO 639-3 
> will add *one* language code. That language code will include 
> language identifiers for around 7000 additional languages. 
> (That's the correct ISO-speak.)
> 
> 
> 
> Peter
>

---

From: "Addison Phillips" <[email-masked]>
Date: Sat, 29 Jul 2006 09:51:03 -0700

I am, of course, using the specific terminology of RFC 3066bis :-).

"... language identifiers for identifying languages" strikes me funny.

How about:

  ISO 639-3, scheduled for approval towards the end of 2006, is expected
  to provide identifiers for about 7000 additional languages.

Addison

Addison Phillips

> Sent: samedi 29 juillet 2006 09:13
> To: LTRU Working Group
> else. However, I'm