Subject: [Ltru] RE: Wikimedia language codes

From: "Debbie Garside" <[email-masked]>
Date: Sun, 12 Nov 2006 20:38:37 -0000

Fair comment.  But I think there is a high probability that this need will
increase in the not too distant future. Perhaps IETF-languages and more
importantly the LTRU WG should start at least thinking about how this need
could possibly be met in the future by ISO DIS 639-6 without necessarily
obstructing RFC4646bis.

Now is the time to consider ISO 639-6 in order that any requests for changes
to the data structure can be considered and implemented where necessary, not
in a years time when it will be virtually set in stone.  

Best regards

Debbie Garside
(cross posted to LTRU WG)

> -----Original Message-----
> From: Stephane Bortzmeyer [mailto:[email-masked]] 
> Sent: 12 November 2006 20:21
> To: Debbie Garside
> Cc: [email-masked]; [email-masked]
> Subject: Re: Wikimedia language codes
> 
> On Sun, Nov 12, 2006 at 06:16:35PM -0000,  Debbie Garside 
> <[email-masked]> wrote  a message of 119 lines which said:
> 
> > Your need is for ISO 639-6. This part of the ISO 639 family 
> is due for 
> > publication in January 2008.
> 
> I do not think that the Wikimedia Foundation (which has the problem
> now) can wait and I do not see why RFC 4646 does not solve 
> the technical side of the problem today.
> 
> 
> 
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 12 Nov 2006 19:23:09 -0800

Hi -

> From: "Debbie Garside" <[email-masked]>
> To: <[email-masked]>; "'IETF Languages Discussion'" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Sunday, November 12, 2006 12:38 PM
> Subject: RE: Wikimedia language codes
>
...

Can anyone summarize the syntax of 639-6 identifiers for us?

Randy

---

From: John Cowan <[email-masked]>
Date: Sun, 12 Nov 2006 22:31:05 -0500

> Can anyone summarize the syntax of 639-6 identifiers for us?

Four alphabetic characters; lower case is canonical.

-- 
And through this revolting graveyard of the universe the muffled, maddening
beating of drums, and thin, monotonous whine of blasphemous flutes from
inconceivable, unlighted chambers beyond Time; the detestable pounding
and piping whereunto dance slowly, awkwardly, and absurdly the gigantic
tenebrous ultimate gods -- the blind, voiceless, mindless gargoyles whose soul
is Nyarlathotep. (Lovecraft) John [email-masked]|ccil.org/~cowan

---

From: "Debbie Garside" <[email-masked]>
Date: Mon, 13 Nov 2006 09:35:03 -0000

> Can anyone summarize the syntax of 639-6 identifiers for us?

At the moment it is alpha-4 but discussions are in progress as to whether
there should be an extension coding aspect mapped to ISO 639-6.  

Best regards

Debbie