Subject: [Ltru] HOWTO register a subtag (Was: rejecting proposals based on syntax

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 24 Jan 2007 11:40:36 +0100

On Tue, Jan 23, 2007 at 04:19:41PM -0000,
 Debbie Garside <[email-masked]> wrote 
 a message of 73 lines which said:

> This would create an inclusive, friendly forum as opposed to a forum
> where we have those in the know and those not in the know.  It would
> also encourage more people to request the sub tags that they need
> and perhaps stop people from creating their own.  I believe that is
> what standardization is all about.

OK, better to light a candle than to complain about obscurity. What do
people think of this attempt?

http://ltru.generic-nic.net/register-new-subtag.html

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 24 Jan 2007 09:20:06 -0500

> http://ltru.generic-nic.net/register-new-subtag.html

Bravo!  This list of suggestions may seem long, but is in the direction
of ruthless simplification.

1) Don't even mention language subtags.  Too many people will insist
that his language variety is a separate language and try to register a
language subtag.  Just say they have to go through ISO (which is true,
even if in principle they might end up back here.)

2) Fill in the value of Type for them.

3) Omit altogether the lines Preferred-Value, Deprecated, and
Suppress-Script, which have little or no relevance to variant subtags
and will be productive of nothing but confusion.  Content-free lines
don't end up in the Registry anyhow.

4) Variant subtags beginning with a digit should be 4-8 characters,
not just 4, although currently we have only 4-digit ones.  5) Give an
example of a tag which is too short.

A few minor corrections of idiom:

6) "specially" should be "especially".

7) "People" is treated as a plural noun, so "People in my home town
speak".

8) Use "beforehand" instead of "before" in "subscribe to the mailing
list before", or else say "in advance".

9) Adjectives of nationality are capitalized in English, thus:  "the
French language", "the French Academy".  This makes no sense, and no other
European language does it; but not doing it looks childish in English.

10) "the Middle Ages".

11) "early modern French", without the article.

-- 
John Cowan    http://ccil.org/~cowan    [email-masked]
Mr. Henry James writes fiction as if it were a painful duty.  --Oscar Wilde

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 24 Jan 2007 15:28:26 -0000

Stephane wrote:

> OK, better to light a candle than to complain about 
> obscurity. What do people think of this attempt?
> 
 
I can only reiterate those who have gone before... Bravo! :-)

Best

Debbie

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Stephane Bortzmeyer
> Sent: 24 January 2007 10:41
> To: Debbie Garside; Doug Ewell
> Cc: [email-masked]; [email-masked]
> Subject: HOWTO register a subtag (Was: rejecting proposals 
> based on syntax
> 
> On Tue, Jan 23, 2007 at 04:19:41PM -0000,  Debbie Garside 
> <[email-masked]> wrote  a message of 73 lines which said:
> 
> > also encourage more people to request the sub tags that 
> they need and 
> > perhaps stop people from creating their own.  I believe 
> that is what 
> > standardization is all about.
> 
> OK, better to light a candle than to complain about 
> obscurity. What do people think of this attempt?
> 
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
> 
> 
>

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 24 Jan 2007 23:43:20 +0100

Stephane Bortzmeyer wrote:

> What do people think of this attempt?

Nice.  For the "language" case you could say that folks trying this
need a very good proposal and the evidence that ISO 639 rejected it.

If you want a link to a specific section of RFC 4646 you could use
e.g. <http://tools.ietf.org/html/rfc4646#section-3.5> or later in
your text <http://tools.ietf.org/html/rfc4646#section-2.1>.

The required background information should be something better than
an ordinary Wikipedia link (a Wikipedia permalink is already better).

Would encoding="ISO-8859-1" help with legacy browsers and / or MUAs
for the references in the second example ?

Frank

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 25 Jan 2007 22:02:27 +0100

On Wed, Jan 24, 2007 at 11:43:20PM +0100,
 Frank Ellermann <[email-masked]> wrote 

> your text <http://tools.ietf.org/html/rfc4646#section-2.1>.

Great. I hope that tools.ietf.org is perennial.
 
> an ordinary Wikipedia link (a Wikipedia permalink is already

By "permalink", you mean a link to a specific release of the page? 

Side note: is it better to use a reference to an online page which is
freely and easily readable by anyone, but is only a secondary source
of information or to the paper book which is the primary source but
may be difficult to get?

Case study: shoud I support the registration of variant "valencia"
with:

http://ca.wikipedia.org/wiki/Valenci%C3%A0 (a very good text, very
detailed)

or with (the same, a specific version, to be sure it is stable):

http://ca.wikipedia.org/w/index.php?title=Valenci%C3%A0&oldid=819131

or with:

Sanchis i Guarner, Manuel (1934, 1967). La llengua dels
valencians. Edicions 3i4, València 2005. ISBN 84-7502-082-8.

> for the references in the second example ?

I switched to US-ASCII and Unicode escapes, John Klensin will be happy
:-)

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 26 Jan 2007 16:04:19 +0100

<http://tools.ietf.org/html/rfc4646#section-3.5>
> Great. I hope that tools.ietf.org is perennial.

Among those hoping that are IETF area directors and 
Wikipedia (en, meta, maybe more) admins.  Henrik's
and Bill's IETF tools are cool, and cool URIs never
change... :-)

>> something better than> an ordinary Wikipedia link
>> (a Wikipedia permalink is already better).

> By "permalink", you mean a link to a specific release

Yes, in some of their CSS skins the link is presented 
using that name.     
 
> Side note: is it better to use a reference to an online
> page which is freely and easily readable by anyone, but
> is only a secondary source of information or to the paper
> book which is the primary source but may be difficult to
> get?

How about both ?  If the secondary source is Wikipedia it
is supposed to offer good primary sources.  Online as an
"external link", or offline as "reference".
 
> http://ca.wikipedia.org/w/index.php?title=Valenci%C3%A0&oldid=819131

I'd prefer that, but of course it's important to convince
the subtag review list and especially the expert reviewer.

> valencians. Edicions 3i4, València 2005. ISBN 84-7502-082-8.

Both are fine, aren't they ?  The ISBN style might be soon
obsolete, AFAIK they switched to a "new" scheme this year.

>> Would encoding="ISO-8859-1" help with legacy browsers
>> and / or MUAs for the references in the second example ?
 
> I switched to US-ASCII and Unicode escapes, John Klensin
> will be happy :-)

Maybe you're confusing John with my poor old "mozilla 3" :-)

Whatever you did, the second example (and the whole page)
is still UTF-8, not Latin-1.  If folks use a MUA that does
not support UTF-8 they might be in trouble.  

Frank

---

From: John Cowan <[email-masked]>
Date: Fri, 26 Jan 2007 10:38:11 -0500

> obsolete, AFAIK they switched to a "new" scheme this year.

New ISBNs are basically just old ones with "978" prefixed, but the
checksum (the final character) has to be recomputed using a new algorithm.
ISBN-13s will eventually be assigned with 979 and perhaps other prefixes.
These are the values already used on barcodes, and prevent collisions
with other types of consumer goods.

-- 
There are three kinds of people in the world:   John Cowan
those who can count,                            [email-masked]
and those who can't.