Subject: Re: [Ltru] Re: two identical singleton extension tags issue

From: Nicolas Krebs <[email-masked]>
Date: Tue, 2 Jan 2007 23:22:17 +0100

>Date: Thu, 21 Dec 2006 10:15:43 +0100
>From: Stephane Bortzmeyer <[email-masked]>
>To: John Cowan <[email-masked]>
>Copy: LTRU Working Group <[email-masked]>

>On Wed, Dec 20, 2006 at 12:02:11PM -0500,
> John Cowan <[email-masked]> wrote 
> a message of 24 lines which said:
>
>> What is more, we should publish the regex in 4646bis 
>
>-1
>
>Or even -X with X >> 1 :-)
>
>We publish the ABNF, which is the normative definition of the
>grammar. Publishing the grammar in yet another format is a recipe for
>subtle inconsistencies between them.

Could it be INFORMATIVE, such in rfc 4287 Appendix B ? 

>> so that people can use it in declarative contexts like XML schemas.
>
>May be we could suggest a very simplified regexp such as:
>
>[a-z0-9]+(-[a-z0-9]+)* 
>
>(case-insensitive, /i in Perl, re.IGNORECASE in Python)
>
>It would catch most of the stupid mistakes in XML files and be
>reasonable readable, although more lax than the real grammar. in the
>same way that the XML schema of RFC 4287 suggests the following regexp
>for e-mail addresses (whose grammar is beyond the ability of 99.9 % of
>mortal programmers):
>
>   # Whatever an email address is, it contains at least one @
>   atomEmailAddress = xsd:string { pattern = ".+@.+" }

If a very simplified regexp is added, i would suggest to add the following
simplified ABNF as informative : 

	Language-Tag = 1*8ALPHA *( "-" 1*8alphanum )

(this would solve the issue 
http://www.w3.org/Protocols/HTTP/1.1/rfc2616bis/issues/#i13 
for rfc 2616bis)

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Sat, 6 Jan 2007 18:21:45 +0100

On Tue, Jan 02, 2007 at 11:22:17PM +0100,
 Nicolas Krebs <[email-masked]> wrote 

> 	Language-Tag = 1*8ALPHA *( "-" 1*8alphanum )

I agree.

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 06 Jan 2007 19:26:19 +0100

Stephane Bortzmeyer wrote:
 
>> If a very simplified regexp is added, i would suggest to add the
>> following simplified ABNF as informative :

> I agree.

To some degree we have that already in 4647 2.1.  We also discussed
the issue of the 2616 errata at this time.  And decided that we don't
dare "updates 2616".

For unknown reasons that nit didn't make it yet into the 2616bis I-D,
but apparently there might be a http BOF + WG later to fix this.  

In other words, it's not critical to have a "simplified ABNF" in 
4646bis.  IMHO it's even confusing, let 4647 and 2616bis handle this.
After all it's already an approved 2616 erratum.

Frank