Subject: [Ltru] Re: Well-formed vs. regular (Was: I-D ACTION:draft-ietf-ltru-4646bis-01.txt

From: "Doug Ewell" <[email-masked]>
Date: Wed, 3 Jan 2007 13:32:14 -0800

Addison Phillips <addison at yahoo dash inc dot com> wrote:

>> This is not perfect yet in -02 which says:
>>
>>    grandfathered = langtag   ; well-formed grandfathered tags
>>                  / irregular ; grandfathered that don't match langtag
>>
>> The "well-formed" should be replaced by "regular".
>
> Except that "regular" doesn't really convey any information here. Yes, 
> it is an antonym for 'irregular', but that doesn't really add 
> information. I think we should just omit "well-formed".

I agree.  This would define "langtag" and "regular" circularly, in terms 
of each other, much like writing:

grandfathered = A   ; grandfathered tags that aren't B
              / B   ; grandfathered tags that aren't A

Are the comments really necessary at all, or are the definitions of 
"langtag" and "irregular" sufficient (or even better) on their own?

--
Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
http://users.adelphia.net/~dewell/
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 3 Jan 2007 17:37:39 -0500

> "langtag" and "irregular" sufficient (or even better) on their own?

Lose the comments, I'd say.  See also my earlier posting.

-- 
Even a refrigerator can conform to the XML      John Cowan
Infoset, as long as it has a door sticker       [email-masked]
saying "No information items inside".           http://www.ccil.org/~cowan
        --Eve Maler