Subject: [Ltru] Re: For review: Tagging text with no language

From: "Doug Ewell" <[email-masked]>
Date: Thu, 12 Apr 2007 21:28:26 -0700

I think the one thing we want to *avoid* doing, as a result of this 
thread, is defining the empty string "" as a valid language tag or 
associating it with any particular meaning.  "" is a placeholder, not a 
real language tag.

--
Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
http://users.adelphia.net/~dewell/
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 20 Apr 2007 12:59:49 -0700

Richard, getting back to the topic of XML, it sounds like we have three
cases, illustrated by the following example:

<p xml:lang="en">There are three cases:
  <span>foo</span>,
  <span xml:lang="">foo</span>,
  <span xml:lang="und">foo</span>
</p>

In the first foo construction, we are saying that it inherits the language
"en". The second and third construction are equivalent: we are overriding
the "en" setting, and saying that foo is undetermined with regard to
language. The difference between them is that:

   - the second construction can't be used in XHTML (or any other case
   where a DTD or schema requires a value).
   - the third construction can always be used, but shouldn't be used if
   the second can be.

Mark

On 4/11/07, Richard Ishida <[email-masked]> wrote:
>
>
>
>
> http://www.w3.org/International/questions/qa-no-language
>
> Comments are being sought on this FAQ-based article prior to final
> release. Please send any comments to [email-masked]. We expect
> to publish a final version in one to two weeks.
>
>
>
> ============
> Richard Ishida
> Internationalization Lead
> W3C (World Wide Web Consortium)
>
> http://www.w3.org/People/Ishida/
> http://www.w3.org/International/
> http://people.w3.org/rishida/blog/
> http://www.flickr.com/photos/ishida/
>
>
>
>

-- 
Mark