Subject: [Ltru] RE: New web app: Searching for language subtags

From: Misha Wolf <[email-masked]>
Date: Sun, 01 Apr 2007 15:14:09 +0100

Hi Richard,

Having spent a few minutes playing with this, it seems to 
be both useful and fun.

My one concern is that people who haven't been initiated 
into the arcane mysteries of BCP 47, might misunderstand 
the meaning of a heading like "redundant" in response to 
a search for "Chinese".  It needs to be made clear to 
people that this is a tool for examining the registry, 
*NOT* a tool for finding appropriate language tags.  If 
it is meant to be used for the latter purpose, then some 
changes are very much needed :-)

Regards,
Misha

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Richard Ishida
Sent: 01 April 2007 14:59
To: 'WWW International'
Subject: New web app: Searching for language subtags

You may find this of interest.  It's purely a personal project.

http://people.w3.org/rishida/utils/subtags/

http://people.w3.org/rishida/blog/?p=90 says:

This tool allows you to search for tags that have, say, 'french' in
their description (there are currently 11), or to find out what that
mysterious 'ch' tag stands for (there are 2 possibilities). Or you can
simply list all current language tags, or script tags, or variants, etc.

For months I've been wanting to write a small, Web-based tool for
finding things in the subtag registry without having to work on the (for
many people, intimidating) raw text file on the IANA site.

Tom Gruner created an initial tool for pretty printing the IANA list,
which handled enough of the basics to allow me to use the little time I
have these days to add the search functionality on top.

If you have JavaScript running, you are shown just the tags and
descriptions initially, but by clicking on those you can reveal all
additional information in the registry for a given tag. I also highlight
tags that are deprecated, so you can see that straight away.

(PS: Some final tweaks to the code will come when I have a spare moment
for things like making the expanding list more accessible, etc.)

RI

============
Richard Ishida
Internationalization Lead
W3C (World Wide Web Consortium)
 
http://www.w3.org/People/Ishida/
http://www.w3.org/International/
http://people.w3.org/rishida/blog/
http://www.flickr.com/photos/ishida/

This email was sent to you by Reuters, the global news and information company. 
To find out more about Reuters visit www.about.reuters.com

Any views expressed in this message are those of the individual sender, 
except where the sender specifically states them to be the views of Reuters Limited.

Reuters Limited is part of the Reuters Group of companies, of which Reuters Group PLC is the ultimate parent company.
Reuters Group PLC - Registered office address: The Reuters Building, South Colonnade, Canary Wharf, London E14 5EP, United Kingdom
Registered No: 3296375
Registered in England and Wales

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Addison Phillips <[email-masked]>
Date: Sun, 01 Apr 2007 09:40:54 -0700

+1

This is quite a nice tool.

I note: I think a bit more care should be used with the terms "tag" and 
"subtag". The use of the word "tag" in the tool is misleading, since it 
implies the tools searches for tags. In fact, the tool can only look at 
the grandfathered/redundant tags. It's really a subtag tool.

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 2 Apr 2007 11:48:02 +0200

On Sun, Apr 01, 2007 at 03:14:09PM +0100,
 Misha Wolf <[email-masked]> wrote 
 a message of 88 lines which said:

> My one concern is that people who haven't been initiated into the
> arcane mysteries of BCP 47, might misunderstand

Yes, there are funny things for instance:

"french" gives you three geographic regions, not one of them being
France ("fr")

Knowing the registry, I can understand i, but ordinary users may
deserve more warnings.

Bug report: multiline comments are not properly handled, only the
first line is displayed. See variant "1694acad" or region "gb" for an
example.

---

From: "Richard Ishida" <[email-masked]>
Date: Mon, 2 Apr 2007 14:35:44 +0100

I have just uploaded a new version.  It now allows you to enter a
hyphen-separated string of subtags in the search field and reports what it
finds in the registry.

See also the new notes on the right hand side.

RI

============
Richard Ishida

> From: Najib TOUNSI [mailto:[email-masked]] 
> Sent: 02 April 2007 14:00
> To: Richard Ishida; WWW International; LTRU Working Group
> Subject: RE: New web app: Searching for language subtags
> 
> Hi all,
> 
> --- Misha Wolf <[email-masked]> wrote:
> 
> > 
> > Hi Richard,
> > 
> > Having spent a few minutes playing with this, it seems to be both 
> > useful and fun.
> +1
> > 
> > arcane mysteries of BCP 47, might misunderstand the meaning of a 
> > heading like "redundant" in response to a search for "Chinese".
> 
> "people who haven't been initiated into the arcane mysteries 
> of BCP 47", might even not understand what 'redundant', 
> 'Grandfathered' and other 'variant' mean or what they are for.
> 
> http://en.wikipedia.org/wiki/BCP_47 just refers to 
> http://www.w3.org/International/articles/language-tags/Overview.en.php
> (which defines what variant means, but not all other key 
> vocabularies) http://www.iana.org/assignments/language-subtag-registry
> (which is a list of language subtags.)
> 
> Najib
> 
> > It needs to be made clear
> > to
> > finding things in the subtag registry without having to work on the 
> > (for many people, intimidating) raw text file on the IANA site.
> > 
> > which handled enough of the basics to allow me to use the 
> little time 
> > I have these days to add the search functionality on top.
> > 
> > additional information in the registry for a given tag. I also 
> > highlight tags that are deprecated, so you can see that 
> straight away.
> > 
> > (PS: Some final tweaks to the code will come when I have a spare 
> > moment for things like making the expanding list more accessible, 
> > etc.)
> > 
> > RI
> > 
> > 
> > ============
> > Richard Ishida
> > This email was sent to you by Reuters, the global news and 
> information 
> > company.
> > Any views expressed in this message are those of the individual 
> > sender, except where the sender specifically states them to be the 
> > views of Reuters Limited.
> > 
> > Reuters Limited is part of the Reuters Group of companies, of which 
> > Reuters Group PLC is the ultimate parent company.
> > Reuters Group PLC - Registered office address: The Reuters 
> Building, 
> > South Colonnade, Canary Wharf, London E14 5EP, United Kingdom 
> > Registered No: 3296375 Registered in England and Wales
> > 
> > 
> > 
> > 
> 
> 
> 
>  
> ______________________________________________________________
> ______________________
> Food fight? Enjoy some healthy debate 
> in the Yahoo! Answers Food & Drink Q&A.
> http://answers.yahoo.com/dir/?link=list&sid=396545367
>

---

From: "Richard Ishida" <[email-masked]>
Date: Mon, 2 Apr 2007 14:37:13 +0100

Hi Addison,

I tried to clarify uses of tag and subtag properly, and added the ability to look at tags too.

RI

============
Richard Ishida

> From: Addison Phillips [mailto:[email-masked]] 
> Sent: 01 April 2007 17:41
> To: Misha Wolf
> Cc: Richard Ishida; WWW International; LTRU Working Group
> Subject: Re: [Ltru] RE: New web app: Searching for language subtags
> 
> +1
> 
> I note: I think a bit more care should be used with the terms 
> "tag" and "subtag". The use of the word "tag" in the tool is 
> misleading, since it implies the tools searches for tags. In 
> fact, the tool can only look at the grandfathered/redundant 
> tags. It's really a subtag tool.
> 
> Addison
> 
> Misha Wolf wrote:
> > Hi Richard,
> > 
> > heading like "redundant" in response to a search for "Chinese".  It 
> > needs to be made clear to people that this is a tool for 
> examining the 
> > registry,
> > *NOT* a tool for finding appropriate language tags.  If it 
> is meant to 
> > be used for the latter purpose, then some changes are very 
> much needed 
> > :-)
> > 
> > Regards,
> > Misha
> >  
> > 
> information company. 
> > sender, except where the sender specifically states them to 
> be the views of Reuters Limited.
> > 
> > Reuters Limited is part of the Reuters Group of companies, 
> of which Reuters Group PLC is the ultimate parent company.

---

From: "Richard Ishida" <[email-masked]>
Date: Mon, 2 Apr 2007 14:46:42 +0100

Hi Stephane,

> "french" gives you three geographic regions, not one of them 
> being France ("fr")
> 
> Knowing the registry, I can understand i, but ordinary users 
> may deserve more warnings.

This is an issue for the registry (if it is an issue) since people will look
for things there in the same way as they do using this form.  The only other
way to find FR for France would be to read the registry, and I don't think
people will thank you for suggesting that (especially if they are looking
for say a language that begins with 'w') ;-)

As it happens, I'm not sure it's an issue.  I think that if you are looking
for a country code you'd search on France, not French.

I think that whats happening here is rather that you are getting some
regions when you search for a language - which, for me, is not a big deal
either.  

> Bug report: multiline comments are not properly handled, only 
> the first line is displayed. See variant "1694acad" or region 
> "gb" for an example.

Yes, thanks.  I was aware, but have not had time to fix it yet.  Will do so
asap.

RI

============
Richard Ishida

> From: Stephane Bortzmeyer [mailto:[email-masked]] 
> Sent: 02 April 2007 10:48
> To: WWW International; LTRU Working Group
> Subject: [Ltru] Re: New web app: Searching for language subtags
> 
> On Sun, Apr 01, 2007 at 03:14:09PM +0100,  Misha Wolf 
> <[email-masked]> wrote  a message of 88 lines which said:
> 
> "french" gives you three geographic regions, not one of them 
> being France ("fr")
> 
> Knowing the registry, I can understand i, but ordinary users 
> may deserve more warnings.
> 
> Bug report: multiline comments are not properly handled, only 
> the first line is displayed. See variant "1694acad" or region 
> "gb" for an example.
>

---

From: "Richard Ishida" <[email-masked]>
Date: Mon, 2 Apr 2007 14:54:11 +0100

Hmm. People who haven't been initiated into the arcane mysteries of BCP 47
still have to use the registry to find subtags. If there are things they
need to understand, we'd better help them there.  Note that they no longer
see redundant tags when searching for Chinese with my tool, and that I
included a short explanation of redundant in the side notes.  I hope that
will help.

RI

============
Richard Ishida

> From: Misha Wolf [mailto:[email-masked]] 
> Sent: 01 April 2007 15:14
> Having spent a few minutes playing with this, it seems to be 
> both useful and fun.
> 
> My one concern is that people who haven't been initiated into 
> the arcane mysteries of BCP 47, might misunderstand the 
> meaning of a heading like "redundant" in response to a search 
> for "Chinese".  It needs to be made clear to people that this 
> is a tool for examining the registry,
> *NOT* a tool for finding appropriate language tags.  If it is 
> meant to be used for the latter purpose, then some changes 
> are very much needed :-)
> 
> Regards,
> Misha
>  
> 
> This tool allows you to search for tags that have, say, 
> 'french' in their description (there are currently 11), or to 
> find out what that mysterious 'ch' tag stands for (there are 
> 2 possibilities). Or you can simply list all current language 
> tags, or script tags, or variants, etc.
> 
> For months I've been wanting to write a small, Web-based tool 
> for finding things in the subtag registry without having to 
> work on the (for many people, intimidating) raw text file on 
> the IANA site.
> 
> Tom Gruner created an initial tool for pretty printing the 
> IANA list, which handled enough of the basics to allow me to 
> use the little time I have these days to add the search 
> functionality on top.
> 
> If you have JavaScript running, you are shown just the tags 
> and descriptions initially, but by clicking on those you can 
> reveal all additional information in the registry for a given 
> tag. I also highlight tags that are deprecated, so you can 
> see that straight away.
> 
> (PS: Some final tweaks to the code will come when I have a 
> spare moment for things like making the expanding list more 
> accessible, etc.)
> 
> RI
> 
> 
> ============
> Richard Ishida
> Any views expressed in this message are those of the 
> individual sender, except where the sender specifically 
> states them to be the views of Reuters Limited.
> 
> Reuters Limited is part of the Reuters Group of companies, of 
> which Reuters Group PLC is the ultimate parent company.
> Building, South Colonnade, Canary Wharf, London E14 5EP, 
> United Kingdom Registered No: 3296375 Registered in England and Wales
> 
>

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 2 Apr 2007 11:15:13 -0700

I have a couple of usability suggestions.

Example. Click on Regions, put in "France" in *Search for: *and click *Show
Result*. You get unexpected outcome. It isn't clear that the push button
only affects what the radio button says. And even after you know this, it's
clumsy, since you always have to switch the radio button, then hit the push
button.

Rather than the current interface, it would be faster and less confusing to
have pushbuttons for all of what you have as radio buttons, and remove "Show
Results". And retitle Descriptions and Subtags as "Search Descriptions" and
"Search Subtags".

Subtags isn't quite right either, since I can put in whole language tags
like "ar-Arab". So I'd suggest separating that as a separate button "Search
Tags". You don't test for invalid whole tags right now, so "Arab-en". You
document that, but it would be easy to fix. I have a regex that tests
validity and divides up the language tag into the pieces, so you could use
that if you want.

Mark
**

-- 
Mark

---

From: "CE Whitehead" <[email-masked]>
Date: Mon, 02 Apr 2007 14:55:15 -0400

Hi, thanks it seems you are right Mark one has to put in a code like fr or 
something
and then choose descriptions or subtags
that's the only way to use the text box

The text box does not work for the radio buttons;
it would be nice to search for a language name (if there were consistent 
language names for all languages!) and get language, variant, what have you 
subtags.

>>included a short explanation of redundant in the side notes.  I hope that

_________________________________________________________________
5.5%* 30 year fixed mortgage rate. Good credit refinance. Up to 5 free 
quotes - *Terms 
https://www2.nextag.com/goto.jsp?product=100000035&url=%2fst.jsp&tm=y&search=mortgage_text_links_88_h2a5d&s=4056&p=5117&disc=y&vers=910

---

From: "Richard Ishida" <[email-masked]>
Date: Wed, 4 Apr 2007 10:22:05 +0100

So you're aware.  I'm looking at modifying the UI, but don't have a lot of time to work on it just now.
 
RI
 
============
Richard Ishida

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: 02 April 2007 19:15
To: Richard Ishida
Cc: Misha Wolf; LTRU Working Group; WWW International
Subject: Re: [Ltru] RE: New web app: Searching for language subtags

Example. Click on Regions, put in "France" in Search for: and click Show Result. You get unexpected outcome. It isn't clear that the push button only affects what the radio button says. And even after you know this, it's clumsy, since you always have to switch the radio button, then hit the push button. 

Rather than the current interface, it would be faster and less confusing to have pushbuttons for all of what you have as radio buttons, and remove "Show Results". And retitle Descriptions and Subtags as "Search Descriptions" and "Search Subtags". 

Subtags isn't quite right either, since I can put in whole language tags like "ar-Arab". So I'd suggest separating that as a separate button "Search Tags". You don't test for invalid whole tags right now, so "Arab-en". You document that, but it would be easy to fix. I have a regex that tests validity and divides up the language tag into the pieces, so you could use that if you want. 

Mark

RI

============
Richard Ishida

> From: Misha Wolf [mailto: [email-masked] <mailto:[email-masked]> ]

-- 
Mark

---

From: "Richard Ishida" <[email-masked]>
Date: Mon, 9 Apr 2007 20:50:06 +0100

I carved out some time to change the selection UI.  Hopefully that's now clearer.
 
http://people.w3.org/rishida/utils/subtags/index.php
 
RI

============
Richard Ishida

  _____  

Mark

RI

============
Richard Ishida

-- 
Mark