Subject: [Ltru] Grammar and grandfathered (Was: I-D ACTION:draft-ietf-ltru-4646bis-03.txt

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 4 Apr 2007 12:45:18 +0200

On Thu, Mar 29, 2007 at 10:50:02AM -0400,
 [email-masked] <[email-masked]> wrote 
 a message of 94 lines which said:

> 	Title		: Tags for Identifying Languages
> 	Author(s)	: A. Phillips, M. Davis
> 	Filename	: draft-ietf-ltru-4646bis-03.txt

I approve the new wording of well-formed vs. invalid in section 2.2
"Classes of conformance".

However, it is now at odds with the ABNF (the comment in the
<grandfathered> production). Following a suggestion by John Cowan
(http://www1.ietf.org/mail-archive/web/ltru/current/msg07422.html), I
suggest the following ABNF, where "grandfathered" was completely
removed (it is a semantic concept and does not belong in the grammar):

   Language-Tag  = langtag
                 / privateuse             ; private use tag
                 / irregular              ; some grandfathered registrations

   langtag       = (language
                    ["-" script]
                    ["-" region]
                    *("-" variant)
                    *("-" extension)
                    ["-" privateuse])

   language      = (2*3ALPHA [ extlang ]) ; shortest ISO 639 code
                 / 4ALPHA                 ; reserved for future use
                 / 5*8ALPHA               ; registered language subtag

   extlang       = *3("-" 3ALPHA)         ; specific ISO 639-3 codes

   script        = 4ALPHA                 ; ISO 15924 code

   region        = 2ALPHA                 ; ISO 3166 code
                 / 3DIGIT                 ; UN M.49 code

   variant       = 5*8alphanum            ; registered variants
                 / (DIGIT 3alphanum)

   extension     = singleton 1*("-" (2*8alphanum))

   singleton     = %x41-57 / %x59-5A / %x61-77 / %x79-7A / DIGIT
                 ; "a"-"w" / "y"-"z" / "A"-"W" / "Y"-"Z" / "0"-"9"
                 ; Single alphanumerics
                 ; "x" is reserved for private use

   privateuse    = "x" 1*("-" (1*8alphanum))

   irregular     = "en-GB-oed" / "i-ami" / "i-bnn" / "i-default"
                 / "i-enochian" / "i-hak" / "i-klingon" / "i-lux"
                 / "i-mingo" / "i-navajo" / "i-pwn" / "i-tao"
                 / "i-tay" / "i-tsu" / "sgn-BE-fr" / "sgn-BE-nl"
                 / "sgn-CH-de"

   alphanum      = (ALPHA / DIGIT)       ; letters and numbers

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Addison Phillips <[email-masked]>
Date: Wed, 04 Apr 2007 08:21:34 -0700

Stephane,

John's note came after draft-03 was submitted. I had incorporated this 
already in the editor's copy, which has not yet been submitted. See:

http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-04.html#syntax

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.