Subject: [Ltru] RE: New web app: Searching for language subtags

From: Najib Tounsi <[email-masked]>
Date: Mon, 02 Apr 2007 13:39:51 +0000

Hi all,

--- Misha Wolf <[email-masked]> wrote:

 >
 > Hi Richard,
 >
 > Having spent a few minutes playing with this, it
 > seems to
 > be both useful and fun.

+1

 >
 > My one concern is that people who haven't been
 > initiated
 > into the arcane mysteries of BCP 47, might
 > misunderstand
 > the meaning of a heading like "redundant" in
 > response to
 > a search for "Chinese". 

"people who haven't been initiated into the arcane
mysteries of BCP 47", might even not understand what
'redundant', 'Grandfathered' and other 'variant' mean
or what they are for.

A small definition of the key vocabulary would be welcome.

One can try http://en.wikipedia.org/wiki/BCP_47, but it doesn't give any 
explanation, and just refers to
http://www.w3.org/International/articles/language-tags/Overview.en.php 
(which defines what variant means, but not all the other related 
vocabulary)
and http://www.iana.org/assignments/language-subtag-registry (which is a 
list of language subtags.)

Najib

 > It needs to be made clear
 > to
 > people that this is a tool for examining the
 > registry,
 > *NOT* a tool for finding appropriate language tags.
 > If
 > it is meant to be used for the latter purpose, then
 > some
 > changes are very much needed :-)
 >
 > Regards,
 > Misha
 > 
 >
 > -----Original Message-----
 > From: [email-masked]
 > [mailto:[email-masked]] On Behalf
 > Of Richard Ishida
 > Sent: 01 April 2007 14:59
 > To: 'WWW International'
 > Subject: New web app: Searching for language subtags
 >
 >
 > You may find this of interest.  It's purely a
 > personal project.
 >
 > http://people.w3.org/rishida/utils/subtags/
 >
 >
 > http://people.w3.org/rishida/blog/?p=90 says:
 >
 > This tool allows you to search for tags that have,
 > say, 'french' in
 > their description (there are currently 11), or to
 > find out what that
 > mysterious 'ch' tag stands for (there are 2
 > possibilities). Or you can
 > simply list all current language tags, or script
 > tags, or variants, etc.
 >
 > For months I've been wanting to write a small,
 > Web-based tool for
 > finding things in the subtag registry without having
 > to work on the (for
 > many people, intimidating) raw text file on the IANA
 > site.
 >
 > Tom Gruner created an initial tool for pretty
 > printing the IANA list,
 > which handled enough of the basics to allow me to
 > use the little time I
 > have these days to add the search functionality on
 > top.
 >
 > If you have JavaScript running, you are shown just
 > the tags and
 > descriptions initially, but by clicking on those you
 > can reveal all
 > additional information in the registry for a given
 > tag. I also highlight
 > tags that are deprecated, so you can see that
 > straight away.
 >
 > (PS: Some final tweaks to the code will come when I
 > have a spare moment
 > for things like making the expanding list more
 > accessible, etc.)
 >
 > RI
 >
 >
 > ============
 > Richard Ishida
 > Internationalization Lead
 > W3C (World Wide Web Consortium)
 > 
 > http://www.w3.org/People/Ishida/
 > http://www.w3.org/International/
 > http://people.w3.org/rishida/blog/
 > http://www.flickr.com/photos/ishida/
 > 
 >
 >
 >
 >
 > This email was sent to you by Reuters, the global
 > news and information company.
 > To find out more about Reuters visit
 > www.about.reuters.com
 >
 > Any views expressed in this message are those of the
 > individual sender,
 > except where the sender specifically states them to
 > be the views of Reuters Limited.
 >
 > Reuters Limited is part of the Reuters Group of
 > companies, of which Reuters Group PLC is the
 > ultimate parent company.
 > Reuters Group PLC - Registered office address: The
 > Reuters Building, South Colonnade, Canary Wharf,
 > London E14 5EP, United Kingdom
 > Registered No: 3296375
 > Registered in England and Wales
 >
 >
 >
 >

-- 
Najib TOUNSI (mailto:tounsi @ emi.ac.ma)
Ecole Mohammadia d'Ingenieurs, BP 765 Agdal-RABAT Maroc (Morocco)
Phone : +212 (0) 37 68 71 50 (P1711)  Fax : +212 (0) 37 77 88 53
Mobile: +212 (0) 61 22 00 30 

-- 
Najib TOUNSI (mailto:tounsi @ w3.org)
Bureau W3C au Maroc (http://www.w3c.org.ma/)
Ecole Mohammadia d'Ingenieurs, BP 765 Agdal-RABAT Maroc (Morocco)
Phone : +212 (0) 37 68 71 50 (P1711)  Fax : +212 (0) 37 77 88 53
Mobile: +212 (0) 61 22 00 30 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 4 Apr 2007 10:07:03 +0200

On Mon, Apr 02, 2007 at 01:39:51PM +0000,
 Najib Tounsi <[email-masked]> wrote 
 a message of 168 lines which said:

> One can try http://en.wikipedia.org/wiki/BCP_47, 

Very bad article, which does not even point to the real Wikipedia
article:

http://en.wikipedia.org/wiki/IETF_language_code

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 04 Apr 2007 17:07:35 +0200

Stephane Bortzmeyer wrote:
 
>> One can try http://en.wikipedia.org/wiki/BCP_47
 
> Very bad article, which does not even point to
> the real Wikipedia article:
 
> http://en.wikipedia.org/wiki/IETF_language_code

[[User:Zundark]] redirected the former to the latter.
I've added some categories, fixed a nit about the
supranational UN codes, and tried to add a link to
ltru.generic-nic.net/ (that failed because I've no
account anymore, and the "captchas" don't work with
my browser - one of several severe reasons why I've
killed all my wikimedia accounts).

Frank