Subject: RE: [Ltru] Re: Language Tag Special Cases

From: "Kent Karlsson" <[email-masked]>
Date: Sat, 21 Apr 2007 22:27:47 +0200

Peter Constable wrote:
> From: Kent Karlsson
> 
> > "Miscellaneous" does mean "anything". But it is an "anything"
> > for things not otherwise classified. *coverage* (everything)
> > vs. *recommended use* (not otherwise classified).
> 
> I don't think I'd express things the way you do, but I start
> to think that, in practical terms, our views are similar.
> 
> Using an example, an application of ISO 639 could choose to use
> as its inventory {eng, fra, deu, und, zxx, mis}, in which case
> mis would encompass Swedish and Italian and several thousand other
> languages *in that application context*.

Yes.

> I think you'd agree with that.
> 
> In the context of BCP47, mis would encompass only a very small set of
> languages (once 639-3 is included, a very small set indeed).

Yes, modulo the possibility that 'mis' and other collection codes
maybe (as John Cowan suggested) could be used for a partial information
scenario. E.g.

'smi' - this has been determined (or deemed) to have a Saami language
content, but have not determined (yet) which Saami language;

'mis' - this has been determined (or deemed) to have content in a (one)
natural language, but have not determined (yet) which one;

'und' - no determination made (yet), may be in one or more natural
languages, or may (predominantly) be something else.

But that is not clear from the text of 639-2, nor IIRC from the
much longer and intricate BCP47 text, that collection codes can
be used like that, just that 'und' can be used like that.

		/kent k

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Sat, 21 Apr 2007 14:03:39 -0700

From: Kent Karlsson [mailto:[email-masked]]

> natural language, but have not determined (yet) which one;

This is where we depart. Here, I'd use 'und'. Again, in the context of BCP47, I consider mis to encompass a fairly small set of languages. I don't have a big problem with 'smi' when the confidence level is at the level of "it's a Saami language", but I still maintain that 'mis' is for the exceptions not covered by available IDs, and 'und' is for the general "don't know" case.

Peter