Subject: [Ltru] Transliteration of reference titles

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 25 Apr 2007 20:55:13 -0700

Hi -

Forwarded from [email-masked], and given a new
subject line.  As a technical contributor, I fully agree with the
sentiment.  However, I leave it to others to decide whether
championing sich a change makes sense at this time.

Randy

> From: "Michael Everson" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, April 25, 2007 3:08 PM
> Subject: Re: Re[2]: be-tarask
>

> At 11:06 -0700 2007-04-25, Randy Presuhn wrote:
> 
> >(Even if I would like it better if it were not transliterated.  :-)
> 
> The point of the entry is to enable people to find the book. I did 
> not like Birl&#x4D9;&#x15F;dirilmi&#x15F; and I still don't. If the 
> entries were in proper HTML with charset headers it would be one 
> thing.  They're not, and I'd really rather stick with ASCII since 
> that's how primitive the registry format is.
> 
> Now there's something useful LTRU could chew on.
> -- 
> Michael Everson * http://www.evertype.com

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 26 Apr 2007 00:59:00 -0400

> championing sich a change makes sense at this time.

The only way to make that work would be to re-express the whole
registry as an HTML or XML file; I would be stronly opposed to such a
redesign at this time.

-- 
John Cowan  [email-masked]  http://www.ccil.org/~cowan
Thor Heyerdahl recounts his attempt to prove Rudyard Kipling's theory
that the mongoose first came to India on a raft from Polynesia.
        --blurb for Rikki-Kon-Tiki-Tavi

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 26 Apr 2007 22:03:25 +0200

Randy Presuhn wrote:

> Forwarded from [email-masked]

It got two replies there so far, Archived-At:
<http://permalink.gmane.org/gmane.ietf.languages/4632>
<http://permalink.gmane.org/gmane.ietf.languages/4633>

How about declaring this issue as "closed" unless some
evidence about the worldwide adoption of UTF-8 before
Harald's deadline as specified in RFC 2277 is posted ?

Frank
-- 
Negotiating a charset may be regarded as an interim mechanism that is
to be supported until support for interchange of UTF-8 is prevalent;
however, the timeframe of "interim" may be at least 50 years [BCP 18]

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 26 Apr 2007 13:35:04 -0700

I don't think there is any question that UTF-8 is sufficiently universal
that the vast majority of people can handle it without any problem at all,
and anyone else can handle it with a small amount of effort if they want to.
But the real issue is, which of the following is *more* universal in a
plaintext file:

Option 1. Birl&#x4D9;&#x15F;dirilmi&#x15F;
  or
Option 2. Birlәşdirilmiş

Mark

-- 
Mark

---

From: John Cowan <[email-masked]>
Date: Thu, 26 Apr 2007 16:51:26 -0400

> that the vast majority of people can handle it without any problem at 

On the Web, yes.  In email (and email is an essential part of the
registration process), no.

> Option 2. Birl????dirilmi??

Well, that's what they look like in my email client.  Both are illegible,
but only the first is reconstructible.  If we want to keep things like the
above version of Option 2 out of the registry, we either need to bypass
email entirely, or we need to stick with what we've got.

-- 
What has four pairs of pants, lives             John Cowan
in Philadelphia, and it never rains             http://www.ccil.org/~cowan
but it pours?                                   [email-masked]
        --Rufus T. Firefly

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 26 Apr 2007 23:21:07 +0200

Mark Davis wrote:
 
> Option 2. BirlÓ™ÅŸdirilmiÅŸ

I pick option 1 for obvious reasons... :-)

Frank

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 26 Apr 2007 14:26:52 -0700

True, email is the big holdout, notably hotmail and Eudora. There are two
other possibilities that people mentioned.

   1. Use email, but require any forms with UTF-8 to be attachments, not
   inline.
   2. Use the current format in submission forms, but have the result be
   converted to UTF-8, either before sending to IANA (in an attachment), or by
   IANA before posting.

 I'll cc Michael, since he is involved in this.

Mark

BTW, I'm not pushing strongly for this, since the current situation is
workable, though not not optimal. One example of why it is not optimal is
that Yahoo, Google, etc. don't think that the language subtag registry
contains words like Bokmål. Try a Google or Yahoo search for

  iana language-subtag-registry Bokmål

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 26 Apr 2007 21:15:19 -0700

Hi,
 
Reality check:
 
Email access clients aren't the big problem - email backbone
infrastructure is still fragmented, flaky, and nowhere near
universally UTF-8 safe.
 
Also, not every computer user (or even the vast majority)
happen to be privileged to constantly have the latest hardware
and software.
 
Harold's 50 years 'interim' keeps looking more and more
realistic and less and less like the hyperbole that I originally
read into it.
 
And the IETF process (for ALL IETF working groups) depends
centrally on email and only modestly on web interfaces.
 
Cheers,
- Ira
 
Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked] 
-----Original Message-----
From: Mark Davis [mailto:[email-masked]]
Sent: Thursday, April 26, 2007 4:27 PM
To: John Cowan
Cc: Frank Ellermann; Michael Everson; [email-masked]
Subject: Re: [Ltru] Re: Transliteration of reference titles

True, email is the big holdout, notably hotmail and Eudora. There are two other possibilities that people mentioned.

1.	Use email, but require any forms with UTF-8 to be attachments, not inline. 

2.	Use the current format in submission forms, but have the result be converted to UTF-8, either before sending to IANA (in an attachment), or by IANA before posting. 

Mark

BTW, I'm not pushing strongly for this, since the current situation is workable, though not not optimal. One example of why it is not optimal is that Yahoo, Google, etc. don't think that the language subtag registry contains words like Bokmål. Try a Google or Yahoo search for 

On 4/26/07, John Cowan < HYPERLINK "mailto:[email-masked]"[email-masked]> wrote: 

--
What has four pairs of pants, lives             John Cowan
in Philadelphia, and it never rains             HYPERLINK "http://www.ccil.org/~cowan"http://www.ccil.org/~cowan
but it pours?                                   HYPERLINK "mailto:[email-masked]"[email-masked]
        --Rufus T. Firefly

-- 
Mark 

No virus found in this outgoing message.
Checked by AVG Free Edition. 
Version: 7.5.463 / Virus Database: 269.6.1/776 - Release Date: 4/25/2007 12:19 PM