Subject: [Ltru] RE: "mis" update review request

From: "Kent Karlsson" <[email-masked]>
Date: Sat, 14 Apr 2007 14:38:07 +0200

(I'll dare a crosspost here, since most of this debate is crossposted already...)

Doug Ewell wrote:
> I suspect this whole debate over "mis" is more of a thought-experiment, 

I think so too. But while we're at it...

I'm not too keen on the word "miscellaneous", which seem more appropriate
to what you can find on a shelf of books (these books are in miscellaneous
languages, that no-body here has cared to divide up) than for tagging a
single document, or part of a document. For a single document or portion
of a document, "mis" *seems* to be saying the same as "mul", which I don't
think was the intention.

I would rather see "mis" as saying "linguistic content" (but not specified
which language), opposite to "no linguistic content", but quite close to "und"
(which seems to cover both "no linguistic content" and "linguistic content"
and maybe also 'mul', II understand the debate so far). I don't think that 
ny of the collection codes, 'mis' included, are intended to cover 'mul',
though 'und' could well cover 'mul'.

But I agree that while the current interpretation (as per MARC at least)
would be "other lingustic content", but I agree that the "other" in that
interpretation is problematic (as for many other collection codes).

		/kent k

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Sat, 14 Apr 2007 09:18:41 -0700

From: Kent Karlsson [mailto:[email-masked]]

> I would rather see "mis" as saying "linguistic content"
> (but not specified which language), opposite to "no
> linguistic content", but quite close to "und" (which
> seems to cover both "no linguistic content" and "linguistic
> content" and maybe also 'mul', II understand the debate
> so far).

"" means 'I'm giving no information.'

und means 'I have not determined what the language attribute is of this information object.'

mul means 'I have detected that this information object contains at least one portion X in some language Lx and a different portion Y in some different language Ly.'

mis means 'I have determined that this information object is in a language other than the set of languages covered by the available identifiers.'

zxx means 'I have determined that this information object is not expressed in terms of a human language.'

None of these mean the same thing as any other or IMO is close in meaning to any other.

Peter

---

From: "Jukka K. Korpela" <[email-masked]>
Date: Sat, 14 Apr 2007 19:41:10 +0300 (EEST)

> "" means 'I'm giving no information.'

Does that apply to its use in xml:lang="" too? That's different from 
omitting xml:lang.

If you have an XML document with xml:lang="en" for the root element, then 
any subelement is assumed to be in English by default. The attribute 
xml:lang="" is the recommended way of breaking such inheritance. In 
practical terms, it seems to say 'I'm not telling the language of the 
content is but I'm saying it's not English'. Or should it be interpreted 
as saying 'I'm giving no information except that you should not assume 
that the language of the content is the same as declared for its parent'?

-- 
Jukka "Yucca" Korpela, http://www.cs.tut.fi/~jkorpela/

---

From: Peter Constable <[email-masked]>
Date: Sat, 14 Apr 2007 10:35:26 -0700

It doesn't mean "it's not English"; it means, "I'm not telling you." Probably it's a safe assumption to suppose that the content isn't English, but that's an inference, not an explicit statement or a deduction.

Peter

---

From: John Cowan <[email-masked]>
Date: Sat, 14 Apr 2007 15:40:57 -0400

Peter Constable scripsit:

> mul means 'I have detected that this information object contains at
> least one portion X in some language Lx and a different portion Y in
> some different language Ly.'
> 
> mis means 'I have determined that this information object is in a
> language other than the set of languages covered by the available
> identifiers.'
> 

IMHO this language should go into 4646bis, of course made more formal.

-- 
John Cowan  [email-masked]  http://ccil.org/~cowan
The competent programmer is fully aware of the strictly limited size of his own
skull; therefore he approaches the programming task in full humility, and among
other things he avoids clever tricks like the plague.  --Edsger Dijkstra

---

From: "Kent Karlsson" <[email-masked]>
Date: Sat, 14 Apr 2007 23:49:51 +0200

> "" means 'I'm giving no information.'

Agreed, but if one removes the subjective parts here, then
"" and "und" are then very much the same. The content can
(appropriately) be in any (human) language or languages, or
maybe have no linguistic content. Both would cover all and
any (human) language or languages as well as have no linguistic
content.

> is of this information object.'

I'm not too keen on the subjectiveness ("I") here. It assumes
that the "I" (or "we") is somehow known or knowable for a use
instance.

> mul means 'I have detected that this information object 
> contains at least one portion X in some language Lx and a 
> different portion Y in some different language Ly.'

ok.

> mis means 'I have determined that this information object is 
> in a language other than the set of languages covered by the 
> available identifiers.'

That would be "other (human) language". But you want to remove
the "other" from the collection names, and I guess that means a
semantic change too. "mis" would then include all languages
in-scope, not just the ones without a code (or more specific
collection code) of their own.

If you include the "other" part here, "mis" in a 639-3 setting
is the empty set of languages (at least until a new in-scope
language is discovered/invented).

Assuming instead a "mis" without the "other" part, "mis" would
say "any one (human) language", almost the same as "und" and
"" except that "mis" would not cover "mul" nor "zxx".

But "mis" with and without "other" are quite different: empty
set (w.r.t. 639-3) vs. the set of all individual languages.

> zxx means 'I have determined that this information object is 
> not expressed in terms of a human language.'

Ok (and some subjectiveness must remain...).
 
		/kent k

---

From: Peter Constable <[email-masked]>
Date: Sat, 14 Apr 2007 15:42:06 -0700

> "" and "und" are then very much the same.

The only difference is that with "und" you can infer that the tagger evaluated the content made a conscious choice to use "und", whereas with "" you know nothing about the tagger's decision process. In terms of processing you can do on content so tagged, I don't think there's a difference.

> that the "I" (or "we") is somehow known or knowable for a use

Replace "I" with "whomever/whatever process tagged this content.

> That would be "other (human) language". But you want to remove
the "other" from the collection names

It is a special case, the one case where "other" is OK.

> "" except that "mis" would not cover "mul" nor "zxx".

No good: "mis" without "other" is no long the same "mis".

Peter

---

From: Peter Constable <[email-masked]>
Date: Mon, 16 Apr 2007 08:47:10 -0700

From: Jeremy Carroll [mailto:[email-masked]]

>> omitting xml:lang...

I didn't write all the stuff you quoted as being from me; *you* wrote it.

> I don't think xml:lang="" should be given any semantics other than a
> processing one

My statement was that "" means 'no information'. I think we're saying the same thing.

> On the wider topic, I wonder if there is a compromise comment that can
> be added to the mis definition, that suggests that, when tagging, other
> more specific correct tags should be used in preference, but when
> reading, no such assumption can be made, due to the inherent instability
> of such usage. This would not invalidate any prior use, but would
> suggest that the more conservative approach was preferred.

Users need to understand that mis is inherently unstable wrt semantics.

Peter

---

From: John Cowan <[email-masked]>
Date: Mon, 16 Apr 2007 12:15:01 -0400

Jeremy Carroll scripsit:

> In practice xml:lang="" is most likely to arise when merging information 
> from multiple xml documents. 

Indeed, IIRC it was originally introduced by the XML Core WG (to which
I belong, but which I am *not* speaking for) in connection with the
development of XInclude, which is designed precisely to merge multiple
XML documents into a single one.

-- 
And through this revolting graveyard of the universe the muffled, maddening
beating of drums, and thin, monotonous whine of blasphemous flutes from
inconceivable, unlighted chambers beyond Time; the detestable pounding
and piping whereunto dance slowly, awkwardly, and absurdly the gigantic
tenebrous ultimate gods -- the blind, voiceless, mindless gargoyles whose soul
is Nyarlathotep. (Lovecraft) John [email-masked]|ccil.org/~cowan

---

From: Peter Constable <[email-masked]>
Date: Mon, 16 Apr 2007 10:23:20 -0700

My apologies: Jukka wrote the text Jeremy attributed to me.

Peter

-----Original Message-----
From: Peter Constable [mailto:[email-masked]]
Sent: Monday, April 16, 2007 8:47 AM
To: [email-masked]; 'LTRU Working Group'
Subject: RE: [Ltru] RE: "mis" update review request

Peter