Subject: Re: Suggested language for "mis" (Re: [Ltru] RE: ISO 639-2 decision: "mis")

From: Nicolas Krebs <[email-masked]>
Date: Thu, 21 Jun 2007 23:33:37 +0200

Mark Davis wrote 

>That's going in the right direction, but doesn't not given enough guidance
>as to why to avoid it. My suggested language:
>
>The 'mis' (Uncoded) primary language subtag SHOULD NOT be used. According to
>ISO 639, it is used to identify linguistic content whose language is known
>but which does not *currently* have a corresponding subtag. It is thus
>intrinsically unstable -- the addition of other codes in the future can
>render its application invalid at any point without any warning -- and hence
>incompatible with the stability goals of BCP 47. It is thus always
>preferable to use other subtags: either "und" or -- with prior agreement --
>private use subtags.

What do you plan for 
afa	Afro-Asiatic (Other)
cpe	Creoles and pidgins, English-based (Other)
roa	Romance (Other)
wich are unstable too (but less than mis) ? 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 22 Jun 2007 00:26:59 -0400

> wich are unstable too (but less than mis) ? 

The ISO 639 committee intends (as far as I understand) to remove
"(Other)" from these, widening them.  It will of course
remain best practice not to use them if more specific coding is
available and known to the coder.

-- 
John Cowan  [email-masked]  http://www.ccil.org/~cowan
Thor Heyerdahl recounts his attempt to prove Rudyard Kipling's theory
that the mongoose first came to India on a raft from Polynesia.
        --blurb for Rikki-Kon-Tiki-Tavi