Subject: [Ltru] extlang registration rules... (was Section 2.2.2, etc.)

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 6 Jun 2008 11:49:04 -0700

In my copy (not posted yet), I implemented the changes Randy proposed to remove the very explicit restriction to 'ar', 'zh' and 'sgn'. The text I propose for the "rules" for registration went into the stability section and reads:

--
<t>Codes assigned by ISO 639-3 MAY also be considered for an extended language subtag registration. Note that they MUST be assigned a primary language subtag record of type 'language' even when an 'extlang' record is proposed. When considering extended language subtag assignment, these criteria apply:

<list>

   <t>Languages whose macrolanguage mapping at the time of their creation that maps to a language that has extended language records assigned SHOULD have an 'extlang' record. For example, any language with a macrolanguage of 'zh' or 'ar'.</t>

   <t>'Extlang' records SHOULD NOT be created for languages if other languages enclosed by the macrolanguage do not also include 'extlang' records. For example, if a new Serbo-Croatian ('sh') language were registered, it would not get an extlang record because other languages enclosed such as Serbian ('sr') do not include one in the registry.</t>

   <t>Sign languages SHOULD have an 'extlang' record with a 'Prefix' of 'sgn'.</t>

   <t>'Extlang' records MUST NOT be created for items already in the registry. Extended language subtags will only be considered at the time of initial registration.</t>

   <t>Extended language subtag records MUST include the fields 'Prefix', 'Deprecated', and 'Preferred-Value' with field-values assigned as described in <xref target="extlang"></xref>.</t>

</list>
</t>
--

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 6 Jun 2008 17:55:47 -0400

Phillips, Addison scripsit:

>    <t>Languages whose macrolanguage mapping at the time of their
>    creation that maps to a language that has extended language records
>    assigned SHOULD have an 'extlang' record. For example, any language
>    with a macrolanguage of 'zh' or 'ar'.</t>

Okay, that handles "zh-foo" if a new Chinese language 'foo' is added by
the RA.

>    <t>Sign languages SHOULD have an 'extlang' record with a 'Prefix'
>    of 'sgn'.</t

Why only SHOULD?

>    <t>'Extlang' records MUST NOT be created for items already in the
>    registry. Extended language subtags will only be considered at the
>    time of initial registration.</t>

Okay, that allows Voro to become 'et-vor' or whatever.

It seems to me, then, that we should do some more cherry-picking, and
add the four special cases from draft 14 (Konkani, Malay, Swahili,
and Uzbek) to the list of extlangs.  These are cases where a single
developed variant is highly dominant.

That would give us:

	kok-knn (dominant), kok-gom

	ms-zsm (dominant), mly-btj, mly-bve, mly-bvu, mly-coa, mly-hji,
	ms-jax, mly-meo, mly-mqg, ms-mly (deprecated, no direct
	replacement), ms-zlm, ms-xmm, ms-max, ms-mfa, ms-msi, ms-vkt

	sw-swh (dominant), sw-swc

	uz-uzn (dominant), uz-uzs

Of course all these would be allowed as language subtags as well as
extlang subtags.

-- 
If you have ever wondered if you are in hell,         John Cowan
it has been said, then you are on a well-traveled     http://www.ccil.org/~cowan
road of spiritual inquiry.  If you are absolutely     [email-masked]
sure you are in hell, however, then you must be
on the Cross Bronx Expressway.          --Alan Feuer, NYTimes, 2002-09-20
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 6 Jun 2008 15:10:34 -0700

>
> >    <t>Sign languages SHOULD have an 'extlang' record with a
> > 'Prefix' of 'sgn'.</t
>
> Why only SHOULD?

... because we are leaving it up to the registration process to determine inclusion.

> developed variant is highly dominant.

Randy had the same opinion. I will make these changes: they seem sensible to me and I can easily reach them from my cherry-picker :-o.

Addison

---

From: John Cowan <[email-masked]>
Date: Fri, 6 Jun 2008 18:31:16 -0400

Phillips, Addison scripsit:

> Randy had the same opinion. I will make these changes: they seem
> sensible to me and I can easily reach them from my cherry-picker :-o.

Just make sure we justify it by applying a general principle, or
the Official Doug will <span lang='en-IN'>condemn us very severely
indeed</span>.

-- 
John Cowan    [email-masked]    http://ccil.org/~cowan
This great college [Trinity], of this ancient university [Cambridge],
has seen some strange sights. It has seen Wordsworth drunk and Porson
sober. And here am I, a better poet than Porson, and a better scholar
than Wordsworth, somewhere betwixt and between.  --A.E. Housman
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Mon, 09 Jun 2008 16:15:12 +0900

>developed variant is highly dominant.

[technical hat on] I would strongly favor this.

Regards,    Martin.

>Of course all these would be allowed as language subtags as well as

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]