Subject: [Ltru] 'car' in different ISO 639 parts

From: "Doug Ewell" <[email-masked]>
Date: Sun, 8 Jun 2008 11:37:04 -0600

I'm in the process of building a new 4645bis Registry that takes into 
account the ISO 639-5 data, which I assume I have the rights to use.

Generally, when two different parts of ISO 639 apply different names to 
the same code element, we have a policy of keeping all the names in the 
Registry, because it was considered important for traceability.  So we 
will have things like:

Type: language
Subtag: ms
Description: Malay (macrolanguage)
Description: Malay
Added: 2005-10-16
Suppress-Script: Latn

because ISO 639-2 calls it simply "Malay" while ISO 639-3, which has to 
differentiate macrolanguage codes from individual language codes, calls 
it "Malay (macrolanguage)".  This doesn't pose a problem since the 
different names seem to refer to the same linguistic concept.

Now, ISO 639-5 draws a formal distinction between "language groups" and 
"remainder groups," concepts used in (but not formally defined by) ISO 
639-2.  These are identified primarily by the words "languages" or 
"(Other)" in the ISO 639-2 name.  A code element like 'apa' ("Apache 
languages") is considered to cover all Apache languages, whereas a code 
element like 'gem' ("Germanic (Other)") covers only those Germanic 
languages that do not have an ISO 639-2 code element of their own.  Both 
the LTRU WG and ietf-languages are familiar with this concept and have 
discussed it often.

ISO 639-5 apparently redefines the 639-2 remainder groups to be full 
language groups, meaning that it considers 'gem' to cover all Germanic 
languages under 639-5, including those that have their own code, such as 
German.  I've been under the impression that this was the Way of the 
Future for ISO 639, and so it was safe to replace all "(Other)"-type 
Description fields in the Registry with the 639-5 names.  After all, it 
would be internally inconsistent to have something like:

Type: language
Subtag: gem
Description: Germanic languages
Description: Germanic (Other)
Added: 2005-10-16

For 'car' we have a unique problem.  ISO 639-5 defines this code element 
as "Carib languages" and calls it a group (not remainder) code, but ISO 
639-2 and 639-3 both define it as "Galibi Carib".  This was officially 
changed in 639-2 from plain "Carib" on 2006-11-22.  Indeed, 639-3 
identifies this as an Individual language.  This affects not only the 
Description fields in the Registry, but also the Scope field if it is 
ultimately decided to add one.

We need to decide which Description, and by extension which scope, 
should be reflected in the Registry for 'car'.  I ask for the guidance 
of both the LTRU WG and ietf-languages list, since this is not only a 
draft issue but also a registration issue, and for that reason I have 
cross-posted both lists.

--
Doug Ewell  *  Arvada, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Sun, 8 Jun 2008 13:52:20 -0400

> ultimately decided to add one.

I bugged the Library of Congress (which is both 639-2/RA and 639-5/RA)
about this one; in the end, only they can decide.

-- 
Mark Twain on Cecil Rhodes:                    John Cowan
I admire him, I freely admit it,               http://www.ccil.org/~cowan
and when his time comes I shall                [email-masked]
buy a piece of the rope for a keepsake.
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 8 Jun 2008 12:02:56 -0600

> about this one; in the end, only they can decide.

So there is no way to resolve this in draft-4645bis until the Library of 
Congress reaches a decision?

---

From: John Cowan <[email-masked]>
Date: Sun, 8 Jun 2008 14:34:17 -0400

> Congress reaches a decision?

*shrug*

I assume that the resolution will be to add a new 3-letter code element
for "Carib languages" and retire the old.

If they don't do so in time, clearly the -2/-3 name has to win, simply
because it has priority.  I suspect what happened was that the 639-5
working group simply missed the reassignment.

-- 
Eric Raymond is the Margaret Mead               John Cowan
of the Open Source movement.                    [email-masked]
        --Bruce Perens,                         http://www.ccil.org/~cowan
          some years ago
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 8 Jun 2008 14:34:05 -0700

Hi -

As a technical contributor...

> From: "Doug Ewell" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>; <[email-masked]>
> Sent: Sunday, June 08, 2008 10:37 AM
> Subject: [Ltru] 'car' in different ISO 639 parts
...
> different names seem to refer to the same linguistic concept.

These sound like two different things to me.  I would expect "Malay" to refer
to a subset of the things covered by the "Malay macrolanguage", and would be
very surprised if Malay were the only member of that set.  Do we
know whether they were intended to refer to exactly the same sets of things?

> German.

This sounds to me like progress.  For the applications I'm familiar with,
"Language groups" are more useful (and more stable) than "remainder groups".

...

To the 'car' question itself, at this point I can only respond "ugh," so
I didn't include [email-masked] in my reply.

Randy

---

From: Peter Constable <[email-masked]>
Date: Mon, 9 Jun 2008 10:21:15 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Doug Ewell

> 639-2 and 639-3 both define it as "Galibi Carib".

This is an inconsistency in ISO 639 that the JAC should resolve: 639-5 is giving a very different denotation from -2/-3 -- a collection scope versus individual-language scope -- which is something that should never happen.

Peter

---

From: John Cowan <[email-masked]>
Date: Mon, 9 Jun 2008 13:32:42 -0400

Peter Constable scripsit:

> This is an inconsistency in ISO 639 that the JAC should resolve: 639-5
> is giving a very different denotation from -2/-3 -- a collection scope
> versus individual-language scope -- which is something that should
> never happen.

It would be good if the JAC could expedite this.

Does the provision for "rest groups" in 639-5 and their treatment as
full families mean that the effort to remove "(Other)" in 639-2 is a
dead letter now?

-- 
John Cowan  [email-masked]  http://www.ccil.org/~cowan
Does anybody want any flotsam? / I've gotsam.
Does anybody want any jetsam? / I can getsam.
        --Ogden Nash, No Doctors Today, Thank You
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Mon, 9 Jun 2008 10:37:05 -0700

> Randy Presuhn

> know whether they were intended to refer to exactly the same sets of

The complete details of what is intended are given below. (This comes from a JAC doc that enumerated problem cases in aligning 639-2 with the draft code table for 639-3.) The JAC never processed this particular item explicitly, and so was tacitly adopted. For purposes of LTRU, while they may sound different, we should assume they are not.

----------------------------------------------------

5.32 Malay

PROBLEM: ISO 639 has [ms/msa/may] "Malay". Ethnologue lists "Malay", also known as
"Bahasa Malaysia". It also lists several other languages that use the name "Malay". Most are nonstandard
languages closely related to Bahasa Malaysia:

- Varieties spoken in Sabah: Banjar (Banjar Malay), Cocos Islands Malay, Sabah Malay
(Bazaar Malay),

- Varieties spoken in Indonesia: Banjar (Banjar Malay), Berau Malay, Bukit Malay, Jambi
Malay, Kota Bangun Kutai Malay, Menadonese Malay, North Moluccan Malay,
Tenggarong Kutai Malay

- Varieties spoken in Thailand: Kedah Malay, Pattani Malay

(Additional note on "Sabah Malay": This is a variety used primarily by speakers of Malayic
languages other than Bahasa Malaysia as second language for communication with speakers of
other varieties. It is not fully developed, and usage is diglossic, with speakers shifting to other
languages for lexica in certain domains.)

There are other languages in the same immediate genetic sub-group as Bahasa Malaysia (the
Local Malay sub-group) that are not listed in Ethnologue as being known by the name "Malay".

Ethnologue also lists "Negeri Sembilan Malay" (spoken in Peninsular Malaysia), which is not
from the Local Malay sub-group but rather from a different sub-group at the same level in the
classification taxonomy. Speakers refer to themselves as "Orang Negeri".

Ethnologue also lists several Malay-based Creoles that use the name "Malay":

    Ambonese Malay (Melayu Ambon), Baba Malay (Straits
    Malay, Chinese Malay), Betawi (Betawi Malay, Jakarta
    Malay), Kupang Malay, Malaccan Creole Malay (Chitties
    Creole Malay), Sri Lankan Creole Malay

Of course, Bahasa Indonesia is also closely related to Bahasa Malaysia.

The MARC Language Code List uses [may] for Bahasa Malaysia and other languages from the
Local Malay sub-group: Enim, Kaya Agung, Lembak, Palembang, Semendo and Siladang (Lubu),
all of which are spoken in Sumatra. MARC also uses [may] for Urak Lawoi', a Malayic language
from a different sub-group than Local Malay that is spoken in Thailand. It also uses [may] for the
Malay-based creoles Ambonese Malay and Betawi.

There are existing software implementations that use [ms/msa/may] for "Malay" (Bahasa
Malaysia) of Malaysia and of Brunei.

POSSIBLE SOLUTIONS:

1. Specify denotation of [ms/msa/may] as specifically Bahasa Malaysia; denotation does not
encompass non-standard varieties or Malay-based creoles.

2. Change scope of [ms/msa/may] from I to M; denotation encompasses Bahasa Malaysia
and Sabah Malay (the Local Malay varieties used primarily in Malaysia; would
encompass Bahasa Malaysia as used in Brunei).

3. Change scope of [ms/msa/may] from I to M; denotation encompasses the thirteen
languages from the Local Malay sub-group that use the name "Malay".

4. Change scope of [ms/msa/may] from I to C (ad hoc); denotation encompasses varieties
that are called "Malay", whether Local Malay, other Malayic or Malay-based Creoles,
and whether spoken in Malaysia, Brunei, Indonesia or Thailand.

5. Change scope of [ms/msa/may] from I to C (genetic) and change name to "Malay
languages"; denotation encompasses the thirty-eight languages of the Local Malay subgroup.

PROPOSED SOLUTION: Option 3.

----------------------------------------------------

Peter

---

From: Peter Constable <[email-masked]>
Date: Mon, 9 Jun 2008 10:47:09 -0700

> From: John Cowan [mailto:[email-masked]]

> It would be good if the JAC could expedite this.

I have raised the issue.

> full families mean that the effort to remove "(Other)" in 639-2 is a

I'm guessing it might.

Peter