Subject: Re: [Ltru] draft-16 (editor's copy) posted...

From: "Doug Ewell" <[email-masked]>
Date: Thu, 12 Jun 2008 20:39:05 -0600

Peter Constable <petercon at microsoft dot com> wrote:

> Matching description fields and matching this particular property 
> value are not the same. I think "local" is inappropriate in our 
> context. (I don't like it in ISO 639 either, but the history there 
> precedes me.) We use the term "private use" for this concept elsewhere 
> in our spec, and that's what we should use for that concept here.

and Addison added:

> I agree. In the text we can mention that private use corresponds to 
> the value 'local' in ISO 639.

That's fine with me, as long as the old newspaper editor in me can be 
satisfied by adding the hyphen to the attributive noun phrase 
"private-use," as in "The private-use tag is intended for private use."

Heck, if we can debate the finest points of ABNF again, I can squeeze in 
two sentences about proper English punctuation.

--
Doug Ewell  *  Arvada, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 12 Jun 2008 21:54:42 -0600

John Cowan <cowan at ccil dot org> wrote:

> Hmm.  How about if we deprecate zh-min with a Comment: that says "Use 
> (zh-)nan, (zh-)cdo, (zh-)mnp, (zh-)czo, or (zh-)cpx", where the "zh-" 
> is in or out depending on the resolution of that issue.
>
> Then we could also deprecate cel-gaulish with a Comment: that says 
> "Use xtg or xcg".

That's not a bad idea, and we don't even have to do it here; it can be 
done by ietf-languages at any time.

---

From: John Cowan <[email-masked]>
Date: Thu, 12 Jun 2008 23:58:46 -0400

> done by ietf-languages at any time.

Well, any time after Date C.

-- 
XQuery Blueberry DOM                            John Cowan
Entity parser dot-com                           [email-masked]
    Abstract schemata                           http://www.ccil.org/~cowan
    XPointer errata
Infoset Unicode BOM                                 --Richard Tobin
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Fri, 13 Jun 2008 00:38:32 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Doug Ewell

> "private-use," as in "The private-use tag is intended for private use."

When used attributively, absolutely! (I had written "private-use" at first, but noted the quoted text was not an attributive noun phrase so removed the hyphen.)

Peter

---

From: "Doug Ewell" <[email-masked]>
Date: Fri, 13 Jun 2008 07:00:57 -0600

Peter Constable <petercon at microsoft dot com> wrote:

> When used attributively, absolutely! (I had written "private-use" at 
> first, but noted the quoted text was not an attributive noun phrase so 
> removed the hyphen.)

Some of the proposed Scope values are adjectival ("individual" and 
"special") while others are not ("collection" and "macrolanguage").  We 
can make this one "private use" if the group and editors prefer.

---

From: John Cowan <[email-masked]>
Date: Fri, 13 Jun 2008 09:14:05 -0400

> can make this one "private use" if the group and editors prefer.

I prefer "private-use".

-- 
One art / There is                      John Cowan <[email-masked]>
No less / No more                       http://www.ccil.org/~cowan
All things / To do
With sparks / Galore                     --Douglas Hofstadter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 13 Jun 2008 08:00:08 -0700

> > can make this one "private use" if the group and editors prefer.

+1 for 1 token.

Addison

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 13 Jun 2008 08:20:45 -0700

Hmm...

I was putting the text about the 'private-use' scope into the draft when it occurred to me: should we provide the private use codes as extlang subtags and not just as primary language subtags?

It would complicate processing, so I hesitate to suggest it. However, we do provide the private use codes in most other places.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: Friday, June 13, 2008 6:14 AM
> To: Doug Ewell
> Cc: LTRU Working Group
> Subject: Re: [Ltru] draft-16 (editor's copy) posted...
>
> Doug Ewell scripsit:
>

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 13 Jun 2008 08:48:41 -0700

+1

Mark

---

From: Peter Constable <[email-masked]>
Date: Fri, 13 Jun 2008 09:07:08 -0700

> John Cowan

> > can make this one "private use" if the group and editors prefer.

As a value for the scope *attribute*, I agree.

Peter

---

From: "Doug Ewell" <[email-masked]>
Date: Fri, 13 Jun 2008 18:11:35 -0600

"Phillips, Addison" <addison at amazon dot com> wrote:

> should we provide the private use codes as extlang subtags and not 
> just as primary language subtags?

I don't see a benefit in this.

---

From: Peter Constable <[email-masked]>
Date: Fri, 13 Jun 2008 22:24:57 -0700

> I don't see a benefit in this.

I think I'm inclined to agree: if people want to add some private-use variation for an ISO 639 ID foo, they can always use foo-...x-...

Peter

---

From: "Mark Davis" <[email-masked]>
Date: Sat, 14 Jun 2008 10:06:42 -0700

I agree

Mark

On Fri, Jun 13, 2008 at 10:24 PM, Peter Constable <[email-masked]>
wrote:

> I think I'm inclined to agree: if people want to add some private-use
> variation for an ISO 639 ID foo, they can always use foo-...x-...
>
>
>
> Peter