Subject: [Ltru] Section 2.2.2 exhaustive specification of possible prefixes

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 5 Jun 2008 19:08:16 -0700

Hi -

As a technical contributor...

Some comments on the June 5th version of
http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-15.txt

I think the current text in section 2.2.2 looks pretty good.
However, I'm a little concerned that we may be overspecifying
things slightly, and would suggest deleting two sentences:

   Only
   languages that have an ISO 639-3 "macrolanguage" mapping equivalent
   to 'zh' (Chinese) or 'ar' (Arabic) or which are identified as sign
   languages have extended language subtags defined.

   This prefix MUST be one of these subtags: 'zh', 'ar', or 'sgn'.

I am *not* suggesting that we add any other possible prefixes at this
time, but am wary of baking a limitation into the spec that might
somehow come back to bite us later.  The decision as to whether there
adequate "various historical reasons" to designate a prefix for future
extended language subtags is something that should, in my opinion, be
left to [email-masked] and the Language Subtag Reviewer.

Randy

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 6 Jun 2008 11:07:27 -0700

Hi,

I wrote this version with cherry-picking mode set to maximum. That is, we specifically picked those three languages (see Peter's email and others) for compatibility reasons. I assumed that our reasoning regarding the selection of these three languages would hold in the future, should ISO 639-3 see fit to designate another Chinese, Arabic, or sign language, but that we would "permanently reserve" extlang against other registrations.

If we are not to enshrine the specific prefixes here, then we need to say what the rules are for registering an extlang. I would assume these would be:

- any extlang MUST be registered with an identical language record
- any extlang MUST also be Deprecated in favor of its primary language subtag
- no item that already has a primary language subtag is permitted to have an extlang registered (no backsliding)
- an extlang SHOULD have a macrolanguage that it uses as its prefix (sgn is an exception)
- if a language's macrolanguage has any extlangs, then this language SHOULD also be extlangs; if the shared extlangs are not already present, then the new language SHOULD NOT be an extlang either.
- no language that has an ISO 639-1 code can be an extlang

Some examples:

- If Estonian "splits", then its new encompassed languages would be a candidate according to these rules.
- If Montenegrin were to be registered, then it would NOT be a candidate because Serbian, Bosnian, Croatian, etc. are not extlangs
- Nynorsk cannot be registered as an extlang because it is already not an extlang (and because of the 639-1 rule)
- If 'Foovian' is a new language encompassed by Chinese, it would be considered for an extlang
- If 'Barvian' is a new language encompassed by Cree, it would be considered for an extlang but would probably be rejected (other Cree languages are not extlangs)
- If 'Hanseatic Bazian' and 'Standard German' are new languages encompassed by 'de', they would be considered for extlang

Thoughts?

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: Thursday, June 05, 2008 7:08 PM
> To: LTRU Working Group
> Subject: [Ltru] Section 2.2.2 exhaustive specification of possible
> prefixes
>
> Hi -
>