Subject: Re: [Ltru] More on combination type/scope field

From: "Doug Ewell" <[email-masked]>
Date: Fri, 6 Jun 2008 19:05:49 -0600

Stephane Bortzmeyer <bortzmeyer at nic dot fr> wrote:

>> In that case, I suggest omitting the "Language-Type" field when the
>> value is "living," and omitting the "Scope" field when the value is
>> "individual," since these are the overwhelming majority and can be
>> treated as defaults.
>
> Why not. But why? For limiting the size of the file? For easier
> reading under vi or Notepad?

Sort of.  To avoid stating the obvious for 93% of the language subtags,
perhaps; the "collection" and "macrolanguage" values are exceptions to
the general rule than language subtags represent individual languages.

This is moot in any case, since the "Language-Type" field had almost no
WG support, and the "Scope" field apparently didn't have enough support
to make it into the draft either.

--
Doug Ewell  *  Arvada, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Kent Karlsson" <[email-masked]>
Date: Sat, 7 Jun 2008 11:54:25 +0200

Doug Ewell wrote:
> WG support, and the "Scope" field apparently didn't have 
> enough support to make it into the draft either.

I don't know why it didn't go into the current draft. But I did not see 
any major opposition to noting "individual" (default), "macrolanguage",
"collection", and "special" in a field by one name or another (e.g.
"Scope"). There was opposition to including "living", "extict", etc., but
I think that opposition was NOT also an opposition to including a "Scope"
field. (I don't mind the double-linking re. "macrolanguage".)

	/kent k

---

From: Peter Constable <[email-masked]>
Date: Sat, 7 Jun 2008 08:30:45 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Kent Karlsson

> field. (I don't mind the double-linking re. "macrolanguage".)

I also thought there was some interest in capturing at least "collection" and "special" scope values in an attribute.

Peter

---

From: Leif Halvard Silli <[email-masked]>
Date: Sat, 07 Jun 2008 17:55:15 +0200

Peter Constable 2008-06-07 17.30:

>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Kent Karlsson
> 
>>> This is moot in any case, since the "Language-Type" field
>>> had almost
>> no
>> I don't know why it didn't go into the current draft. But I
>> did not see any major opposition to noting "individual"
>> (default), "macrolanguage", "collection", and "special" in a
>> field by one name or another (e.g. "Scope"). There was
>> opposition to including "living", "extict", etc., but I think
>> that opposition was NOT also an opposition to including a 
>> "Scope" field. (I don't mind the double-linking re.
>> "macrolanguage".)
> 
> I also thought there was some interest in capturing at least
> "collection" and "special" scope values in an attribute.

I have no strong opinon about the field name(s). But for each 
macrolanguage it should be some field which says "macrolanguage".
-- 
leif halvard silli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 9 Jun 2008 10:03:34 -0700

> I don't know why it didn't go into the current draft.

(editor hat ON)

It didn't go into the current version of draft-15 because the editors are still struggling to get the existing set of changes implemented.

(removes editors hat)

Personally, I don't care for mirroring this information. But I'm in the minority on this. I'll attempt to put a 'Scope' field and instructions for its content into draft-15 before I submit it today.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.