Subject: [Ltru] heads up: Estonian

From: Peter Constable <[email-masked]>
Date: Tue, 3 Jun 2008 07:11:00 -0700

Given our current deliberations, it seems appropriate for me to give a heads up that the JAC has been given a request to have a separate identifier for the Võro variety within Estonian, and that a likely way of handling things, if it's decided to code that, would be to change the scope for et/est from individual language to macrolanguage, with Võro and at least one other variety as encompassed languages.

Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Tue, 3 Jun 2008 17:14:44 +0100

Unless the requester specifically requires an alpha3 why not wait for 639-6?
 
Best regards
 
Debbie

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Peter Constable
Sent: 03 June 2008 15:11
To: 'LTRU Working Group'
Subject: [Ltru] heads up: Estonian

Given our current deliberations, it seems appropriate for me to give a heads
up that the JAC has been given a request to have a separate identifier for
the Võro variety within Estonian, and that a likely way of handling things,
if it’s decided to code that, would be to change the scope for et/est from
individual language to macrolanguage, with Võro and at least one other
variety as encompassed languages.

Peter

---

From: "Kent Karlsson" <[email-masked]>
Date: Tue, 3 Jun 2008 19:08:30 +0200

Peter Constable wrote: 

Given our current deliberations, it seems appropriate for me to give a heads up that the JAC has been given a request to have a
separate identifier for the Võro variety within Estonian, and that a likely way of handling things, if it’s decided to code that,
would be to change the scope for et/est from individual language to macrolanguage, with Võro and at least one other variety as
encompassed languages.

Personally, I don't think that would not be helpful to the users of "standard" Estonian nor to the users of Võro, nor to "us" or the
users of LSR.

I think "doing a Frisian" (here clarify that est/et is closer to "standard" Estonian than might have previously been thought, and
just intro a new code for Võro and maybe other new codes for other langauges closely related to Estonian) would be the lesser evil
here.

I note that we have no trouble whatsoever with Frisian languages, but no end of trouble with Norwegian languages and Chinese
languages, in large part due to the macrolanguage codes. I would guess (I don't have a large (or even small) database on current
use) that just about all content tagged as 'et' is in "standard" Estonian, and next to none (or even none) is in Võro. Though not
formally a language tag, Wikipedia, for instance, uses fiu-vro (a collection code augmented extlang style with a home-grown code for
Võro) as the language prefix for Võro Wikipedia, not et-something. Not that I think using a collection code that way is at all good
(or even use macrolanguage codes that way), I'm just noting that they DON'T use et-... .

    /kent k

---

From: Leif Halvard Silli <[email-masked]>
Date: Tue, 03 Jun 2008 20:18:20 +0200

Kent Karlsson 2008-06-03 19.08:

>  
> Peter Constable wrote: 
> 
>     Given our current deliberations, it seems appropriate for me to give
>     a heads up that the JAC has been given a request to have a separate
>     identifier for the Võro variety within Estonian, and that a likely
>     way of handling things, if it’s decided to code that, would be to
>     change the scope for et/est from individual language to
>     macrolanguage, with Võro and at least one other variety as
>     encompassed languages.

I suppose "one other variety" = the dominant langauge? Then the 
qeustion is: does the main language need another name than Estonian?

> Personally, I don't think that would not be helpful to the users of 
> "standard" Estonian nor to the users of Võro, nor to "us" or the users 
> of LSR.
> 
> I think "doing a Frisian" (here clarify that est/et is closer to 
> "standard" Estonian than might have previously been thought, and just 
> intro a new code for Võro and maybe other new codes for other langauges 
> closely related to Estonian) would be the lesser evil here.

If they have  Macrolanguage situation, then I think should do a 
Norwegian instead ;-) Or a Chinese.

> I note that we have no trouble whatsoever with Frisian languages, but no 
> end of trouble with Norwegian languages

I can't really get my self to speak about "Norwegian languages", 
in plural.

Norwegian is both a individual language and a macrolanguage.

Only from the perspective of written norm/literature language is 
Norwegian two.

> and Chinese languages, in large 
> part due to the macrolanguage codes. I would guess (I don't have a large 
> (or even small) database on current use) that just about all content 
> tagged as 'et' is in "standard" Estonian, and next to none (or even 
> none) is in Võro. Though not formally a language tag, Wikipedia, for 
> instance, uses fiu-vro (a collection code augmented extlang style with a 
> home-grown code for Võro) as the language prefix for Võro Wikipedia, not 
> et-something. Not that I think using a collection code that way is at 
> all good (or even use macrolanguage codes that way), I'm just noting 
> that they DON'T use et-... 

That would definitely be a good way to use extlang. I would like 
it much better if Wikipedia used "no-bok" and "no-nyn", rather 
than "nn" for Nynorsk and "no" for Bokmål.

But it defepends a little on those Võro speakers. If they hate to 
define their language as Estoninan etc.
-- 
leif halvard silli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Kent Karlsson" <[email-masked]>
Date: Tue, 3 Jun 2008 21:54:16 +0200

Leif Halvard Silli wrote:

> If they have  Macrolanguage situation,

They don't, almost by definition. See Peter's explanation
of why the notion of "macrolanguage" was invented. It had to
do with matching -2 codes with -3 codes. So far Võro has
not had a language code, so there is no such matching issue.

> then I think should do a Norwegian instead ;-) Or a Chinese.

Why would you want to foist such a language tagging disaster
upon the users of Estonian and Võro? Look at the trouble "we"
are having with macrolanguages. "End users" would surely not
be less confused.

	/kent k

---

From: Leif Halvard Silli <[email-masked]>
Date: Tue, 03 Jun 2008 22:30:38 +0200

> not had a language code, so there is no such matching issue.

I don't know how to literally I should take that - or Peter's claim.

But even if I should take it very literally, that it is all only a 
"coding accident", then we should not fool ourselves into 
believing that that the accident happened because of sloppy ISO 
specifications. The "trouble" is rooted in language reality, no 
matter what. It is not because of ISO that both Nynorsk and Bokmål 
users say that they have Norwegian as mothertongue.

> are having with macrolanguages. "End users" would surely not

I do absoultely want 3 tags for Norwegian. But I have been 
assuming that it would simpler to use correctly under an extlang 
solution. And I still think that this would be simpler for users 
to get.

I read that there were 70.000 Voro speakers. I do not think that 
this little group wants that their "language striving" only 
results in a big "default to English" each time they cannot have 
Voro content/applications/searchresults.
-- 
leif halvard sillli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Peter Constable <[email-masked]>
Date: Tue, 3 Jun 2008 18:22:19 -0700

> Kent Karlsson

> not had a language code, so there is no such matching issue.

I don't quite follow this. The origins of the macrolanguage notion arose in figuring out how to map items in 639-2 with the candidates for 639-3, but the definition of macrolanguage doesn't reference that.

If et/est was only used for Standard Estonian, then it might be possible to say that Võro is simply something new. On the other hand, if there is existing usage of et/est for Võro, and if Võro and Std Estonian are considered distinct languages, then it would be the case that et/est is used (at least in some contexts) for distinct languages -- making it either a collection or macrolanguage. If there are some contexts in which et/est is considered to be a single language, then those options are reduced to macrolanguage.

There are a bunch of "if"s in there. Your suggestion earlier is that we not consider et/est as encompassing Võro. There are, however, known instances of just that, however.

At some point, we face a dilemma: either

- we intentionally narrow denotations to ensure stability and freedom from problems for the majority language; or

- we deprecate the existing category and create new categories for the split, giving us a set of categories free of the macrolanguage problems and stability in the denotation of existing IDs, but a situation in which a deprecated category is what many applications continue to use and consider preferred, and in which there's no formal connection between the old ID and the new ones; or

- we re-scope the existing ID as macrolanguage and add new IDs for encompassed languages, ensuring stability in denotation of the existing ID but taking on potential issues that come with macrolanguages (we probably are hoping that the macrolanguage can continue to be used as in the past, with most actual usage being specifically for the predominant language, the rest not being of significance for most of our applications); or

- we push back on requests to encode the encompassed varieties, possibly ignoring legitimate cases with valid needs.

Peter

---

From: John Cowan <[email-masked]>
Date: Tue, 3 Jun 2008 23:54:18 -0400

Peter Constable scripsit:

> - we push back on requests to encode the encompassed varieties,
> possibly ignoring legitimate cases with valid needs.

Or you urge them to head for ietf-languages.

-- 
Real FORTRAN programmers can program FORTRAN    John Cowan
in any language.  --Allen Brown                 [email-masked]
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Wed, 04 Jun 2008 16:26:02 +0900

[technical hat on]

I'm also leaning towards recommending to not split up et,
the same way others have recommended on this list.

I'd also like to take this to explain my preference for using extlangs.
Over the recent weeks, I have come to the conclusion that part of what
affects my preference for extlangs is what I'd have wanted to happen
in the case German was a Macrolanguage (a case that Mark has brought
up quite a few times).

Assume there was 'de' (well, there actually is), and there was a request
to encode Swiss German, under the assumption that 'de' somehow included
Swiss German, but most resources tagged 'de' were (close to) Standard
German. I think I would be rather surprised and quite annoyed if the
collective outcome was that not only Swiss German had to be tagged as
'gsw' (so far, so good, either 'gsw' or 'de-gsw' would be fine), but
also that while 'de' was still tolerated for any German, good tagging
practice meant that all 'de' tags had to be changed, most of them to
some completely new code 'ge@'. If I lived in Switzerland, a lot of
my content would be in Standard German and therefore affected.

Changing from 'de' to 'ge@' would look and feel silly. Changing from
'de' to 'de-ge@' would be an increase in precision, also implying that
'de' wasn't in principle wrong or outdated. And in my view much less
confusing for the majority of users. Mind you, while I understand
that, and why, linguistically Swiss German is treated as a separate
language, people in Switzerland talk about, and understand Swiss
German as a collection of German dialects. And it's in my view
mostly these end-users that we have to think about, because they
are the biggest group of people who will use these tags.

Given that it is not really fully clear yet what we as a group
will end up with, I'd definitely want to spare the Estonians
the trouble of having two codes for mostly the same thing
just to be correct in terms of coding policy.

I wonder whether a designation for et as follows wouldn't work:

et     Estonian (mostly Standard Estonian)

As just recently discussed on this list, it wouldn't be wrong for
German either, it would actually be more appropriate :-!

At 10:22 08/06/04, Peter Constable wrote:
>> do with matching -2 codes with -3 codes. So far V$B‰S(Bo has
>I don't quite follow this. The origins of the macrolanguage notion arose in 
>figuring out how to map items in 639-2 with the candidates for 639-3, but 
>the definition of macrolanguage doesn't reference that.
>
>If et/est was only used for Standard Estonian, then it might be possible to 
>say that V$B‰S(Bo is simply something new. On the other hand, if there is 
>existing usage of et/est for V$B‰S(Bo, and if V$B‰S(Bo and Std Estonian are 
>considered distinct languages, then it would be the case that et/est is 
>used (at least in some contexts) for distinct languages -- making it either 
>a collection or macrolanguage. If there are some contexts in which et/est 
>is considered to be a single language, then those options are reduced to 
>macrolanguage.
>
>There are a bunch of "if"s in there. Your suggestion earlier is that we not 
>consider et/est as encompassing V$B‰S(Bo. There are, however, known instances 
>of just that, however.
>

The idea that a language code/subtag is completely stable in denotation
is anyway just an ideal. As we know, languages change all the time.
In the limit, there may be books that a librarian tagged as 'et'
because s/he figured out it was published in Estonia, or what,
without really being even close to understanding any Estonian
or Vo"ro. Also, we don't know how many taggers used 'et' because
they knew about Vo"ro, were looking in the list, and said:
"Well, it's not Estonian, but the best code I can find in the
list is Estonian, so I'll go with that for the lack of something
better." None of these in any way imply that 'et' included Vo"ro
in its denotation. Indeed all we have for 'et' in 693-1
(which is the main source for this code in LTRU) is the name
of the language.

Regards,    Martin.

>- we deprecate the existing category and create new categories for the 
>split, giving us a set of categories free of the macrolanguage problems and 
>stability in the denotation of existing IDs, but a situation in which a 
>deprecated category is what many applications continue to use and consider 
>preferred, and in which there's no formal connection between the old ID and 
>the new ones; or
>
>- we re-scope the existing ID as macrolanguage and add new IDs for 
>encompassed languages, ensuring stability in denotation of the existing ID 
>but taking on potential issues that come with macrolanguages (we probably 
>are hoping that the macrolanguage can continue to be used as in the past, 
>with most actual usage being specifically for the predominant language, the 
>rest not being of significance for most of our applications); or
>
>- we push back on requests to encode the encompassed varieties, possibly 
>ignoring legitimate cases with valid needs.
>
>
>
>Peter

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp      mailto:[email-masked]

---

From: Peter Constable <[email-masked]>
Date: Wed, 4 Jun 2008 12:05:19 -0700

> From: Martin Duerst [mailto:[email-masked]]

> the same way others have recommended on this list.

IIUC, you're saying you lean in favour of re-scoping et as a macrolanguage and adding two (or more) new IDs for encompassed varieties, including Võro and (presumably) Standard Estonian -- is that right?

Peter

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 4 Jun 2008 13:02:30 -0700

Hi -

As a technical contributor...

> From: "Peter Constable" <[email-masked]>
> To: "Martin Duerst" <[email-masked]>; "'LTRU Working Group'" <[email-masked]>
> Sent: Wednesday, June 04, 2008 12:05 PM
> Subject: Re: [Ltru] heads up: Estonian
...
> IIUC, you're saying you lean in favour of re-scoping et as a
> macrolanguage and adding two (or more) new IDs for
> encompassed varieties, including Võro and (presumably) Standard Estonian -- is that right?

While not pretending to speak for Martin, I think we should
recognize that a similar needs will exist for most languages -

   1) a need to tag material as being specifically in a "standard"
        form of a language (the utility of such a thing depends on
        a language's situation)
   2) a need to tag material as being in some particular variety of a language
   3) a need to tag material as being in a language, without comment on
        the specific variety, recognizing that the broadness / narrowness
        of what gets counted as being varieties of the same language varies,
        for good historical and sociolinguistic reasons.

(2) and (3) are covered by our existing regime of subtags.
We haven't been as explicit as we should be about (1).
This case also could be handled with subtags, but there
have not been many corresponding registrations.  This could
be because most languages don't need to specifically identify
their "standard" forms, but I think more likely because we've
tended to overload the meaning of a naked language tag to
mean both "any variety of this language" (superset) and
"the standard variety of this language" (exemplary subset).

Randy

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 4 Jun 2008 13:06:43 -0700

I agree. Ideally, we would have a code (where it makes a difference) for
"any variety" and "standard variety". The problem is where we've only had
one in the past -- where some people treat the code one way, and some the
other -- any transition to two codes is very difficult.

-- 
Mark

---

From: John Cowan <[email-masked]>
Date: Wed, 4 Jun 2008 16:39:26 -0400

Mark Davis scripsit:

> "any variety" and "standard variety". 

We could introduce a variant tag "standard" for the purpose, to be added
to unicentric languages like German, Dutch, and French.  (It would be
inappropriate for English, Catalan, or Norwegian.)

-- 
John Cowan  http://ccil.org/~cowan  [email-masked]
All "isms" should be "wasms".   --Abbie
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Gerard Meijssen" <[email-masked]>
Date: Wed, 4 Jun 2008 23:08:17 +0200

Hoi,
How would you deal with Dutch 2006 or 1996 or 1986 ... every ten years there
is a change to the orthography... How would you deal with the "witte boekje"
that is the orthography used by Dutch newspapers in opposition to the
official "groene boekje" ??

There is no such thing as standard Dutch, there is only standard Dutch given
a specific orthography.
Thanks,
     Gerard

On Wed, Jun 4, 2008 at 10:39 PM, John Cowan <[email-masked]> wrote:

> John Cowan  http://ccil.org/~cowan <http://ccil.org/%7Ecowan>
> [email-masked]

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 4 Jun 2008 14:24:07 -0700

All of these are matters of degree, as John explained in an earlier message,
and doesn't go down to that level of specificity.
Mark

On Wed, Jun 4, 2008 at 2:08 PM, Gerard Meijssen <[email-masked]>
wrote:

> Hoi,
> How would you deal with Dutch 2006 or 1996 or 1986 ... every ten years
> there is a change to the orthography... How would you deal with the "witte
> boekje" that is the orthography used by Dutch newspapers in opposition to
> the official "groene boekje" ??
>
> There is no such thing as standard Dutch, there is only standard Dutch
> given a specific orthography.
> Thanks,
>      Gerard
>

---

From: Martin Hosken <[email-masked]>
Date: Thu, 5 Jun 2008 08:26:35 +0700

Dear Peter,

> Given our current deliberations, it seems appropriate for me to give a heads up that the JAC has been given a request to have a separate identifier for the Võro variety within Estonian, and that a…

For discussion I introduce three made up language tags:

ess - standard Estonian
vor - Võro
esf - Esfasian, a made up language that I'll explain in a moment
eso - an even more standard Estonian

In calling out vor from est we are narrowing est and as such need to create two languages to reflect the narrowed est and the vor. Thus est = ess + vor. I think that's what you are saying?

What happens if we later discover a language called Esfasian that needs to be called out from ess? Does ess become a macro language and we have yet another code for standard Estonian? So we would need a eso for the narrowed ess, such that ess = eso + esf and est = ess + vor.

At which point ess becomes an historic anomaly since people really should be just using est, eso, vor, esf.

This could go on indefinitely each time we split a language code. It's a good way to fill up the code space, certainly.

The only alternative I can see is our saying that if we call out esf then we just add it to the est macro language and say that users of ess may need to retag. Is that acceptable?

BTW all this is orthogonal to whether one uses extlang to reflect the hierarchy: est-ess-esf or not: esf, since the hierarchy is in the registry for those who want it.

Yours,
Martin

---

From: John Cowan <[email-masked]>
Date: Wed, 4 Jun 2008 21:36:05 -0400

> official "groene boekje" ??

If you, or anyone else, find it useful to do so, you can register variant subtags
to express these distinction.

-- 
John Cowan  [email-masked]   http://ccil.org/~cowan
Promises become binding when there is a meeting of the minds and consideration
is exchanged. So it was at King's Bench in common law England; so it was
under the common law in the American colonies; so it was through more than
two centuries of jurisprudence in this country; and so it is today.
       --Specht v. Netscape
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 4 Jun 2008 18:46:23 -0700

2008/6/4 Martin Duerst <[email-masked]>:

> 'de' wasn't in principle wrong or outdated.

Actually, I think both 'ge@' and 'de-ge@' would look and feel silly. It
would be a painful change that would break lot's of software for no benefit.
Any code that was looking for an exact match between de-AT and ge@-AT or
de-ge@AT would break; code that matched would match too much or too little
whether the extlang approach were used or not.

I think the best approach would be the current de/gsw model.

   - The code et means standard Estonian, period.
   - Anything that is sufficiently mutually incomprehensible enough to
   warrant a separate language code should just get one.
   - Anything that isn't, and is not roughly distinguished by a region code
   should get a variant code.

> And in my view much less
> >> do with matching -2 codes with -3 codes. So far
> V����葹�松�鈿�葹��赱鈑�艱�竢粤��齒��纈�蜩�鈿�齦竏�轣�蓍鈑�蜩齦絎
> �症�粹逾�髟蜚�肬跛阯��蜩��壽�闥蜃蜴�閹���轣竰闌瘤苺瘍�鈿�闔�癇闢�蜴�
> 丈蜃�蜴�阨�蓖����轣�蜚纃�蜴�恭広������竅鈔蜆癆纉�肬�恭広階�碯�
> 浄蒹�粤肅鉗�闔�閹�轣竰闌瘤苺瘍�粹纉逾�鱚聽鱚釿��癆�
> �症�續�齡���闔踟��繖�肬�囈瘤籬鰾�涛�鉗瘤���緕�蜚�迚艾�矼�竟齠蛯跂���
> 杖癨��癆��ぢ����蜩�皷逅踟�齒辣�蜴�鈬������阡蒹�葹鈔��蜀��纈�蜩�
> 上�齡蜴��瘍�閹�續�齡�肬��ぢ���鍖�瘤�蜀��ぢ����瘤�囈�涛�鉗瘤�癇�
> 障闔皷粤鱚�粡齡蜴笏�赱鈑�艱鵺��緕�蜚����矼���竅黼��癆�續�齡�蜩�
> 状黼���跂癈�蜴�齒辣�竢銓纔���肬�粡齡蜴笏�赱鈑�艱�⑬�轣謇鈑�蜚�繪�纈�
> 鍾�竢跛繝�闔�闥�轣竰闌瘤苺瘍絎�膚��纈�癇�齒辣�竢銓纔��蜴��蜒�續�齡�
> 冗�竢銖蜆纈繖���矼��皷鈑跂�赱鈑�艱���緕��闢�關�闔�癇�鱚糒竇���
> 壌痺鳫赱鈑�艱�
> �菖蒹鱚�癇��碯釿�閹�∫罌�蜴��纈絎�搶��齦艸纉�闔�縺鳰蜈�蜩��癆���鈿�
> 障闔皷粤�續�齡�癈�緕竢逅癈皷鈑��ぢ���鎬�壽纈�癇絳�蓖��鬪�謗阯�蜴齡瘤竇�
> 常�褫齡��癆��蓖��鬯
> �樵�齒辣�竟蜴����聲竇��粡跂迯畉�繪�纈
> �将���蜴�銓蜿釶跛�釶鴪阯�粤鈿��闔���緕齦鱚�齡痰蛹蜚�瘤�胙繞粹�胙闕�
> 情鳫碎纃�肬���轣褊鱸��赱鈑�艱�闥
>
> 壽�蜆縺��癆��赱鈑�艱�竢粤����蜩�竢逅跂�踟�齡痰跂�蜴�粤鈿��闔
> 蜩�瘤嵭癨�褫齡�瘤�蜆縺谺�蒼���謗阯��赱鈑�艱�竏瘤艱�瘡����辣�
> 侮���跚迚���纈�轣�矼�硼闍��癆��跚碣癇蛛��艸繖�癈�у�
> 矼竅��鶩蒹�肅苺鱚�阨�蜚���頤碎蜩蒹�蜴�涛�鉗甃�闥��癆�
> ��阨�鱚瘡踟�矼蜴�纐緕�竚闢����粤鴦�鈔蜴�瘤�涛�鉗瘤
>
> 闥�幔Å鎬�糟齒����粹逾�謗阯�蓖��轣銷��艸纈��繖�у��矼竅���纖�謗纓�痰阨�幔Å鍖��鱚�跫闍蜴�蜴���跚齡��瘤�黶蜆��繻讙�蜚��鈿�涛�鉗瘤��碯���矼齡�竢粤��竅�肅鈔�蜴���跚齡�蜩�涛�鉗瘤��齒�彦跛�苡�����癆�肬���赱站�閹�齒辣�蜴�矼�纈��麗鈬�閹��纉�蜴�瘤���蜊韭��癆�у��蜴竚�繖�幔Å�蜴�蜚�粤鈿��闔��侮粤繖�瘡���葹��肬�у��蜴�狭貝��蓍竏�蜩���轣蜴�齒�竇�肬��蜩�竢粤�蜴�猛簒��蜩���釶辣
> 閹���赱鈑�艱�
>
> 吶艨鰾鵺����浴鶯蜴�
>
>
> 将���粤頏繝癆���纔蜩�鈑�竅�苡鴒�瘤�竰縺��鈬��竅�苡鱸纉�肬���
> 杖韭蜚��芍�鈑����黼�閹�竅�苡鱸纉�胙繞�閹���轣竰闌瘤苺瘍�頏閧跂逑�瘤�
> 杖�砠跚��蜴���粤鈿��闔�閹�纔蜩�鈑�苗鵺�碯��皷�癆蜿�蜴��蜒��
> 鞘辮鱚竅��竅�苡鴒�蜩��癆�轣銷�瘰韭蜒癆蜿銖�竢銓蜴������瘤�竢銖蜆纈�
> 情鱚聽鴪繖��瘤�蜴��蜒��纈紮�鈿�肬鴉瘡�竢銕繝�闔�矼�繞���闌�苗�瘤�
> 浄蒹�鈬��闔纉�闥
> �将���鱚∮竢鞳���纔蜩�鈑�苗�癈�轣竰闌瘤苺瘍�瘤�痲�鈬��苗�肬�
> 上釿闕鞜齠繖�赱鈑�艱鵺�緕齦鱸鈑�齡痰蛹蜚�蜴�粤鈿��闔�閹���纔蜩�鈑�苗�
> 鐘���謇鈑�闔�竟�銓蛛�蜩齦纉��癆�竢辣����轣竰闌瘤苺瘍纉���頏閧痰踟�
> 鍾鱚�蓖韈鈑��癆���轣竰闌瘤苺瘍�竅�竢銓蜴����矼��繖�癈�蜴���鞜齡��
> 穣蜚�迴齡�痺�瘡��瘍�矼蜴�齔繝蜀蜒瘡踟�肬���頏繖闕蜴瘤�赱鈑�艱����
> 条纉�鈿�矼蜴�閹�皷芬蜀蜒瘤竇�肬�迴齡�閹�阨�瘰韭蜒癆蜿銖��闥
> �将���頤鼈�矚站�闔�鱚髟纉����緕竢粤���緕竢逅癈黼��鱸續蜈鵺�竟齠蛯踟�
> 冗芬闥蜴�跂芍�轣��竅黼�����跚�鈬繖鶤
> ���笑續纈
> 醤烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝烝
> 礁���轣蛹蜴�跚齡
> 礁��蜈��鱧
> 乗�頌痕���續罧闥膀轣蛹轣遲跚齡蜴肬���
>
>
> ����浴鶯蜴�噴�汀Å齡��蒼齒祟�會閹纉齒鬪�聡增轣�煤謨蜴�寰蝟纈皷�
> ����蔗�痕����蜚�陌瘢甌痺�������轣蛹�坂�鴦�蜚�陌瘢甌痺�����
>
>

---

From: Leif Halvard Silli <[email-masked]>
Date: Thu, 05 Jun 2008 04:53:20 +0200

> inappropriate for English, Catalan, or Norwegian.)

I guess you could use "en-GB-standard"? And why not "nn-standard"?

For macrolanguages, however, I agree. The "standard" could not be 
applied to them. Or else "standard" would soon end up being 
associated with a particular encompassed language ...

For Estonian this would mean that when encompassed languages were 
registered, then one should not use "et-standard" anymore. (To 
know what "standard" mean then, one needs a timestamp. But that 
perhaps the same for any tag.)

The same for "de", if German is to be considered macrolanguage.

For Mandarin, which discerns between simple and traditional 
script, I begin to wonder how to eventually use it ...
-- 
leif halvard silli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Leif Halvard Silli <[email-masked]>
Date: Thu, 05 Jun 2008 05:53:39 +0200

Martin Hosken 2008-06-05 03.26:

> ess - standard Estonian vor - Võro esf - Esfasian, a made up
> language that I'll explain in a moment eso - an even more
> standard Estonian
> 
> In calling out vor from est we are narrowing est and as such

We're not changing 'est'. Only knowledging that it covers more 
than one language.

> need to create two languages to reflect the narrowed est and
> the vor. Thus est = ess + vor. I think that's what you are
> saying?
> 
> What happens if we later discover a language called Esfasian
> that needs to be called out from ess? Does ess become a macro
> language and we have yet another code for standard Estonian? So
> we would need a eso for the narrowed ess, such that ess = eso +
> esf and est = ess + vor.

How could it happen that Esfasian speakers could accept to be seen 
as a part of micro-Estonian, but would not be associated with 
macro-Estonian? ;-)
-- 
leif halvard silli

---

From: Peter Constable <[email-masked]>
Date: Wed, 4 Jun 2008 20:56:24 -0700

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis

> - Anything that is sufficiently mutually incomprehensible
> enough to warrant a separate language code should just get one.

That probably would seem reasonable -- unless perhaps you're one of the people who have up to now assumed that et encompassed that variety that just got a separate language code. I note just over a week ago (27/5) you said

> It would also have been reasonable for someone to interpret
> 'de' as Any German (and up until 2006-03-08, encompassing
> Swiss German),

I guess you're being consistent in your position -- which appears to be that narrowing the denotation of an ID is OK as long as a predominant variety doesn't change it's ID?

Peter

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 4 Jun 2008 21:10:44 -0700

Hi -

Returning to Martin Hosken's hypothetical example...
> eso - an even more standard Estonian

Assuming for the sake of the example that there are good reasons
to distinguish these in some application domain...
Am I the only one who thinks the tidiest (and easiest to explain) way of
handling this would be to use
et-ess
et-vor
et-esf
et-eso
and, of course, naked et for folks who don't care or can't tell the difference?

Unlike an example like Erzgebirgisch, where there's a question of which
language in a dialect continuum the variety "belongs to", there appears
to be no question that all the cases in this hypothetical example are all
varieties of the same language, Estonian.  (I base this on the Ethnologue
claim that Voro and "standard" Estonian are mutually intelligible.)

Randy

---

From: John Cowan <[email-masked]>
Date: Thu, 5 Jun 2008 00:17:02 -0400

> claim that Voro and "standard" Estonian are mutually intelligible.)

to register as the variant subtag 'werro' (or whatever).

-- 
Possession is said to be nine points of the law,                John Cowan
but that's not saying how many points the law might have.       [email-masked]
        --Thomas A. Cowan (law professor and my father)
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 5 Jun 2008 10:41:19 +0100

Randy wrote:

> Assuming for the sake of the example that there are good
> reasons to distinguish these in some application domain...
> Am I the only one who thinks the tidiest (and easiest to
> explain) way of handling this would be to use et-ess et-vor
> et-esf et-eso and, of course, naked et for folks who don't
> care or can't tell the difference?

No, you are not alone :-)

Debbie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: 05 June 2008 05:11
> To: LTRU Working Group
> > esf - Esfasian, a made up language that I'll explain in a
> moment eso -
> > an even more standard Estonian
>
> Assuming for the sake of the example that there are good
> reasons to distinguish these in some application domain...
> Am I the only one who thinks the tidiest (and easiest to
> explain) way of handling this would be to use et-ess et-vor
> et-esf et-eso and, of course, naked et for folks who don't
> care or can't tell the difference?
>
> Unlike an example like Erzgebirgisch, where there's a
> question of which language in a dialect continuum the variety
> "belongs to", there appears to be no question that all the
> cases in this hypothetical example are all varieties of the
> same language, Estonian.  (I base this on the Ethnologue

---

From: Martin Duerst <[email-masked]>
Date: Thu, 05 Jun 2008 10:08:02 +0900

At 04:05 08/06/05, Peter Constable wrote:
>IIUC, you're saying you lean in favour of re-scoping et as a macrolanguage 
>and adding two (or more) new IDs for encompassed varieties, including V$B‰S(Bo 
>and (presumably) Standard Estonian -- is that right?

No, I'm saying that I'd be okay with this if I were really sure
that we'd end up with extlangs (not only for zh). As I'm not totally
sure about that, I think the damage is smaller if you just introduce
a new code for Vo"ro, and (as you call it) narrow the denomination 'et',
without introducing a macrolanguage.

Regards,    Martin.

---

From: Martin Duerst <[email-masked]>
Date: Thu, 05 Jun 2008 19:42:41 +0900

To some extent, what Martin Hosken describes below may in some
cases come close to a denial-of-service attack, along the lines:
"Hey, you have 'et', but we are included there, so we claim
to be a separate language and force a split." I'm sure that
it's never meant that way, and I definitely don't want to claim
that users of minority lanugages are at fault, but if there
is a policy that whenever the original code even marginally
included a minority language that's splitting off, there is
a code split with two new codes, the result may sometimes
be quite annoying.

Regards,    Martin.

At 10:26 08/06/05, Martin Hosken wrote:
>Dear Peter, > >> Given our current deliberations, it seems appropriate for me 
>to give a heads up that the JAC has been given a request to have a separate 
>identifier for the Vテオro variety within Estonian, and that a likely way of 
>handling things, if it's decided to code that, would be to change the scope 
>for et/est from individual language to macrolanguage, with Vテオro and at 
>least one other variety as encompassed languages. > >For discussion I 
>introduce three made up language tags: > >ess - standard Estonian >vor - 
>Vテオro >esf - Esfasian, a made up language that I'll explain in a moment >eso 
>- an even more standard Estonian > >In calling out vor from est we are 
>narrowing est and as such need to create two languages to reflect the 
>narrowed est and the vor. Thus est = ess + vor. I think that's what you are 
>saying? > >What happens if we later discover a language called Esfasian that 
>needs to be called out from ess? Does ess become a macro language and we 
>have yet another code for standard Estonian? So we would need a eso for the 
>narrowed ess, such that ess = eso + esf and est = ess + vor. > >At which 
>point ess becomes an historic anomaly since people really should be just 
>using est, eso, vor, esf. > >This could go on indefinitely each time we split 
>a language code. It's a good way to fill up the code space, certainly. > >The 
>only alternative I can see is our saying that if we call out esf then we 
>just add it to the est macro language and say that users of ess may need to 
>retag. Is that acceptable? > >BTW all this is orthogonal to whether one uses 
>extlang to reflect the hierarchy: est-ess-esf or not: esf, since the 
>hierarchy is in the registry for those who want 
>it. > >Yours, >Martin >_______________________________________________ >Ltru 
>mailing list >[email-masked] >https://www.ietf.org/mailman/listinfo/ltr

---

From: Peter Constable <[email-masked]>
Date: Thu, 5 Jun 2008 07:47:52 -0700

> Randy Presuhn

> and, of course, naked et for folks who don't care or can't tell the

Perceived merits of (i) using the existing approach of adding subtags to narrow the intension, and also (ii) the ability to associate the new, encompassed category with the older and familiar encompassing  category were significant factors that contributed to the suggesting the extlang idea in the first place.

For a scenario such as this, in which a coded category in established use gets analyzed into discrete, constituent categories each coded as individual languages, I do see those two things as pros of the extlang approach -- all other things being equal.

Of course, I'm sure if everyone agreed that all other things *are* equal, we would have had consensus a long time ago. Mark, for one, just responded to Martin giving reasons he thought other things are *not* equal, and in fact (he considers) are worse with the extlang approach.

Peter

---

From: Peter Constable <[email-masked]>
Date: Thu, 5 Jun 2008 08:04:31 -0700

So, you're saying this: if we go with extlang across the board, re-scoping et would be best; but if we don't go with extlang, then narrowing et by "chipping off" Võro would be best. Is that right?

Peter

> Sent: Wednesday, June 04, 2008 6:08 PM
> To: Peter Constable; 'LTRU Working Group'
> Subject: RE: [Ltru] heads up: Estonian
>
> macrolanguage
> >and adding two (or more) new IDs for encompassed varieties, including
> V$B唄(Bo

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 5 Jun 2008 08:22:51 -0700

Part of the problem, I think we'll all agree, is that it is just not clear
from ISO 639-2 or -1 what "de" / "German" means.
If you think it means "anything that someone might think of as German", then
essentially *every* language code is a macrolanguage, and gsw should be an
encompassed language, and we'd need a separate code for Hochdeutsch. And of
course the same goes for "fr" being a macrolanguage, and "nl", and so on.
Any of the creoles or pidgins would count as encompassed languages, and we'd
need a special code for the "standard" form of every language. By that
interpretation, any time we carve out a code that is *not* an encompassed
language, like "gsw", we are illegitimately narrowing the main code ("de").
And of course we have a huge mass of software and data that needs to be
changed (for no good reason).
The other interpretation is that the codes "de", "fr", "en", "et", and so
on mean the standard form of the language (including variants that is not
mutually incomprehensible). That is, anything that was far enough to be
qualify as a separate language would have a separate code. In that case,
distinguishing "gsw" or any similar code is not a narrowing, and perfectly
legitimate. There are many, many cases where this interpretation has been
followed in 639, as evidenced by the many cases where languages were
distinguished without being made encompassed languages. Look at the
half-dozen German's, the dozen or so French's, the few Dutch's, and so on.

And frankly, I think the second is a far more useful approach, and just a
reasonable an view of how ISO 639 has been interpreted in the past. And when
we are talking about compatibility, it doesn't matter what the framers of a
standard intended -- if they were not specific *in the text*; it matters
instead how the text of the standard was interpreted by users, in millions
of implementations and billions of data records. It is far easier for
backwards compatibility if the existing code is interpreted as applying to
the standard form, and if necessary a new code is given for the
collection/macrolanguage than the reverse.

I'm not arguing that we should change 'zh', but interpreted as 'any form'
rather than 'standard form' where it is not necessary just makes the
situation far more complicated than necessary, and is no more justified by
past practice than the interpretation as the 'standard' form.

Mark

On Wed, Jun 4, 2008 at 8:56 PM, Peter Constable <[email-masked]>
wrote:

> That probably would seem reasonable -- unless perhaps you're one of the
> people who have up to now assumed that et encompassed that variety that just
> got a separate language code. I note just over a week ago (27/5) you said
>
> I guess you're being consistent in your position -- which appears to be
> that narrowing the denotation of an ID is OK as long as a predominant
> variety doesn't change it's ID?
>
>
>
>
> Peter

---

From: Leif Halvard Silli <[email-masked]>
Date: Thu, 05 Jun 2008 17:40:55 +0200

> and, of course, naked et for folks who don't care or can't tell the difference?

No, you are not the only one.
-- 
leif halvard silli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Leif Halvard Silli <[email-masked]>
Date: Thu, 05 Jun 2008 19:09:45 +0200

I asked Doug if going for extlang could impact on whether ISO 
defined macrolanguage situations/tags or not. He answered no. 
However, not everyone seems to agree ... I suspected that ...

Going for extlang means
	a) that you can use the macrolanguage tag for any resource which 
exist in just one of the encompassed variants. That's easy!
	b) You can be spesific -- "et-vor" -- without loosing those that 
only look for "et". Also simple. (The standard Estonian users will 
allready have received a proportional lot of Voro content anyhow - 
provided Estonian defact *is* a macrolanguage, so the fact that 
this could "hurt" standard Estonian users is moot.)
	c) Consumers only need to care about two tags: his encompassed 
language tag and the general tag. They can even survive very well 
with only one tag - the macrolanguage tag.

Without extlang, unless the Voro consumers includes all 3 tags in 
their browser, they risk that standard Estoninan is tagged with 
the new standard-Estonian tag - causing them to loose such 
content, getting e.g. English instead.

Hence I undertand Martin. Without extlang then there can be 
advantages for endusers in avoiding a macrolanguage definition. 
Because then, at the very least, they do not need more than two 
tags in order to be fully covered.

Thus, not having the extlang option can lead ISO to not recognize 
macrolanguage situations.

lhs

Peter Constable 2008-06-05 17.04:

> So, you're saying this: if we go with extlang across the board,
> re-scoping et would be best; but if we don't go with extlang,
> then narrowing et by "chipping off" Võro would be best. Is that
> right?

>> -----Original Message----- From: Martin Duerst

>> No, I'm saying that I'd be okay with this if I were really
>> sure that we'd end up with extlangs (not only for zh). As I'm
>> not totally sure about that, I think the damage is smaller if
>> you just introduce a new code for Vo"ro, and (as you call it)
>> narrow the denomination 'et', without introducing a
>> macrolanguage.

---

From: Martin Duerst <[email-masked]>
Date: Fri, 06 Jun 2008 15:54:47 +0900

At 00:04 08/06/06, Peter Constable wrote:
>So, you're saying this: if we go with extlang across the board, re-scoping 
>et would be best;

Best, or at least not a serious problem.

>but if we don't go with extlang, then narrowing et by 
>"chipping off" Vテオro would be best. Is that right?

Yes, or at least highly preferable to re-scoping.

Mind you, the best thing would be if we could somewhat
magically get a nice hierarchy that pleased everybody,
and we could automatically retag all content whenever
we were forced to change something in the tagging scheme.

But we know that's just dreaming :-(.

Regards,    Martin.

>> V#エo