Subject: [Ltru] ABNF for grandfathered/irregular (was RE: Section 2.2.8 needs overhaul

From: Peter Constable <[email-masked]>
Date: Wed, 18 Jun 2008 09:24:08 -0700

I hope we don't get bogged down too long on Kent's concern...

Here's a summary of substantive changes made related to grandfathered and irregular tags:

Draft 1: divided grandfathered into those that match langtag and those that are irregular

<   grandfathered = 1*3ALPHA 1*2("-" (2*8alphanum))

>   grandfathered = langtag   ; well-formed grandfathered tags
>                 / irregular ; tags that are not well-formed
>
>   irregular     = "en-GB-oed" / "i-ami" / "i-bnn" / "i-default"
>                 / "i-enochian" / "i-hak" / "i-klingon" / "i-lux"
>                 / "i-mingo" / "i-navajo" / "i-pwn" / "i-tao"
>                 / "i-tay" / "i-tsu" / "sgn-BE-fr" / "sgn-BE-nl"
>                 / "sgn-CH-de"

Draft 4: removed grandfathered entirely from the ABNF

<   Language-Tag  = langtag
<                 / privateuse             ; private use tag
<                 / grandfathered          ; grandfathered registrations
...
<   grandfathered = langtag   ; well-formed grandfathered tags
<                 / irregular ; grandfathered that don't match langtag

>   Language-Tag  = langtag
>                 / privateuse             ; private use tag
>                 / irregular              ; tags grandfathered by rule

Draft 12: add items (no-*, zh-*) to irregular production:

<   irregular     = "en-GB-oed" / "i-ami" / "i-bnn" / "i-default"
<                 / "i-enochian" / "i-hak" / "i-klingon" / "i-lux"
<                 / "i-mingo" / "i-navajo" / "i-pwn" / "i-tao"
<                 / "i-tay" / "i-tsu" / "sgn-BE-fr" / "sgn-BE-nl"
<                 / "sgn-CH-de"

>   irregular     = "en-GB-oed" / "i-ami" / "i-bnn" / "i-default"
>                 / "i-enochian" / "i-hak" / "i-klingon" / "i-lux"
>                 / "i-mingo" / "i-navajo" / "i-pwn" / "i-tao"
>                 / "i-tay" / "i-tsu" / "no-bok" / "no-nyn"
>                 / "sgn-BE-fr" / "sgn-BE-nl" / "sgn-CH-de" / "zh-cmn"
>                 / "zh-cmn-Hans" / "zh-cmn-Hant" / "zh-gan"
>                 / "zh-min" / "zh-min-nan" / "zh-wuu" / "zh-yue"

Draft 15: reverted the draft 12 change:

<   irregular     = "en-GB-oed" / "i-ami" / "i-bnn" / "i-default"
<                 / "i-enochian" / "i-hak" / "i-klingon" / "i-lux"
<                 / "i-mingo" / "i-navajo" / "i-pwn" / "i-tao"
<                 / "i-tay" / "i-tsu" / "no-bok" / "no-nyn"
<                 / "sgn-BE-FR" / "sgn-BE-NL" / "sgn-CH-DE" / "zh-cmn"
<                 / "zh-cmn-Hans" / "zh-cmn-Hant" / "zh-gan"
<                 / "zh-min" / "zh-min-nan" / "zh-wuu" / "zh-yue"

>   irregular     = "en-GB-oed" / "i-ami" / "i-bnn" / "i-default"
>                 / "i-enochian" / "i-hak" / "i-klingon" / "i-lux"
>                 / "i-mingo" / "i-navajo" / "i-pwn" / "i-tao"
>                 / "i-tay" / "i-tsu" / "sgn-BE-FR" / "sgn-BE-NL"
>                 / "sgn-CH-DE"

I'm not quite sure what led to the flip-flop changes in 12 and 15, but if we can ignore that then Kent is looking for a change from a state that has existed since draft 4 (as was I). I'm wondering what led to the decision at that time, and whether we really need to be re-opening that decision. (We can't keep re-visiting issues if we want to get done any time soon.)

Peter
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 18 Jun 2008 09:52:52 -0700

The draft-12 => 15 flip-flop occurred because we removed the extlang production. This made some tags irregular. Draft-15 restored extlang, making some of the still-grandfathered tags no longer irregular.

I've been experimenting with adding Kent's request to the ABNF. I have no objection to listing the permanently grandfathered items in the ABNF. It would be best if we could eliminate future migration of grandfathered items to the redundant pile, since that would stabilize the syntax for all time.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Constable
> Sent: Wednesday, June 18, 2008 9:24 AM
> To: LTRU Working Group
> Subject: [Ltru] ABNF for grandfathered/irregular (was RE: Section
> 2.2.8 needs overhaul
>
> I'm not quite sure what led to the flip-flop changes in 12 and 15,
> but if we can ignore that then Kent is looking for a change from a
> state that has existed since draft 4 (as was I). I'm wondering what
> led to the decision at that time, and whether we really need to be
> re-opening that decision. (We can't keep re-visiting issues if we
> want to get done any time soon.)
>
>
>
> Peter

---

From: John Cowan <[email-masked]>
Date: Wed, 18 Jun 2008 13:00:25 -0400

Phillips, Addison scripsit:

> I've been experimenting with adding Kent's request to the ABNF. I
> have no objection to listing the permanently grandfathered items in
> the ABNF.

The trick is to do so without making the grammar ambiguous.

> It would be best if we could eliminate future migration of
> grandfathered items to the redundant pile, since that would stabilize
> the syntax for all time.

I believe we are already in that position.  We are not going to make
"lojban", "gaulish", "guoyu", "hakka", or "xiang" into variant tags
*with the meaning they currently have*, and there is no question of
"bok", "nyn", or "min" becoming extlang tags, nor of "nan" becoming a
second-level extlang tag.

-- 
Unless it was by accident that I had            John Cowan
offended someone, I never apologized.           [email-masked]
        --Quentin Crisp                         http://www.ccil.org/~cowan
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 18 Jun 2008 10:59:52 -0700

I agree. I don't want to change the main grammar; it should just detect all
and only valid tags. If we want a separate production in 2.8.8 for
grandfathered tags, that's fine (completely unnecessary, but not a problem).

Mark

---

From: John Cowan <[email-masked]>
Date: Wed, 18 Jun 2008 14:47:19 -0400

> grandfathered tags, that's fine (completely unnecessary, but not a problem).

s/valid/well-formed/.

-- 
John Cowan    http://ccil.org/~cowan  [email-masked]
The Penguin shall hunt and devour all that is crufty, gnarly and
bogacious; all code which wriggles like spaghetti, or is infested with
blighting creatures, or is bound by grave and perilous Licences shall it
capture.  And in capturing shall it replicate, and in replicating shall
it document, and in documentation shall it bring freedom, serenity and
most cool froodiness to the earth and all who code therein.  --Gospel of Tux
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 18 Jun 2008 12:57:41 -0700

(editor hat ON)

I have just uploaded to inter-locale a new version of draft-16. This contains the grandfathered production. I made the ANBF formatting consistent in the use of = and / options. I have not yet edited section 2.2.8 to be consistent with the ABNF change.

Unless someone objects, I will finish tidying that section and then submit draft-16, since we've accumulated a fairly extensive set of edits related to the Scope field, etc.

Addison

Addison Phillips

> From: John Cowan [mailto:[email-masked]]
> Sent: Wednesday, June 18, 2008 11:47 AM
> To: Mark Davis
> Cc: John Cowan; Phillips, Addison; LTRU Working Group
> Subject: Re: [Ltru] ABNF for grandfathered/irregular (was RE:
> Section 2.2.8 needs overhaul
>
> Mark Davis scripsit:
>

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 18 Jun 2008 13:27:40 -0700

right (whoops!)

Mark

---

From: "Kent Karlsson" <[email-masked]>
Date: Thu, 19 Jun 2008 01:10:55 +0200

Phillips, Addison wrote:

> I have just uploaded to inter-locale a new version of 
> draft-16. This contains the grandfathered production. I made 
> the ANBF formatting consistent in the use of = and / options. 
> I have not yet edited section 2.2.8 to be consistent with the 
> ABNF change.

This ABNF is fine, *enabling* correct (abstract) parse structure.
A very minor point in one of the comments:
              ...                   ; and all of these are deprecated
              / "zh-min"            ; in favor of a more modern 
              / "zh-min-nan"        ; subtag or sequence of subtags

zh-min is deprecated in 4645bis (not in current LSR), but
without a replacement.

Please note that the ambiguity in the grammar is *intentional*,
and to be resolved by ex-grammatical means, exactly which to be
left to the implementor. The descriptive text about that in 2.2.8
is fine as is in this draft (but I don't object to 'tidying').

Those who are not interested in the parse structure need not
worry about the ambiguity at all, and can even use just a
(derived) regular expression (which is possible since there
is no nested/recursive structure).

	/kent k

> Unless someone objects, I will finish tidying that section 
> and then submit draft-16, since we've accumulated a fairly 
> extensive set of edits related to the Scope field, etc.
> 
> Addison
> 
> Addison Phillips