Subject: [Ltru] editor's copy of draft-20 updated...

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 5 Dec 2008 10:10:34 -0800

All,

The latest version of the editor's copy is now posted on inter-locale.

Any comments?

Co-chairs: should and if so when should I prepare to submit this draft?

Addison (for the editors)

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Kent Karlsson <[email-masked]>
Date: Fri, 05 Dec 2008 21:53:14 +0100

See below for suggested changes to recently edited portions.

    /kent k

=================================

--------------------------------

   Variant subtag records in the language subtag registry MAY include
   one or more 'Prefix' (Section 3.1.8) fields.  Each 'Prefix' indicates
   a suitable sequence of subtags (with other subtags, as appropriate)
   for forming a language tag using when the variant.
==>
   Variant subtag records in the language subtag registry MAY include
   one or more 'Prefix' fields (Section 3.1.8). Each 'Prefix' indicates
   a suitable sequence of subtags for forming (with other subtags, as
   appropriate) a language tag when using the variant.

(Minor moving around to make it read better.)
--------------------------------

   Private-use subtags should not be confused with what this document
   refers to as "subtags reserved for private use". These are subtags
   such as 'qaa', 'Qaaa', or 'AA' that are designated as private-use
   codes by the underlying ISO standards. Although their purpose is
   very similar, subtags reserved for private use are each represented
   by a record of the appropriate type in the registry and, thus, are
   syntactically "language", "script", or "region" subtags, rather than
   "private-use" subtags.
==>
   Private-use subtags should not be confused with what this document
   refers to as "subtags reserved for private use". The latter are subtags
   such as 'qaa', 'Qaaa', or 'AA' that are designated as private-use
   codes by the underlying ISO standards. Although their purpose is
   very similar, subtags reserved for private use are represented
   by a record of the appropriate type in the registry and, thus, are
   syntactically "language", "script", or "region" subtags, rather than
   "private-use" subtags.

("These" => "The latter" for clarity; "each" => "" since they haven't got
a record each, instead they have range records (which I don't like...).)
--------------------------------

   Once registered, fields of type 'Prefix' MUST NOT be removed from any
   record. The field-body for this type of field MAY be modified, but
   only if the modification broadens the meaning of the subtag. That
   is, the field-body can be replaced only by a prefix of itself. For
   example, the Prefix "be-Latn" (Belarusian, Latin script) could be
   replaced by the Prefix "be" (Belarusian) but not by the Prefix "ru-
   Latn" (Russian, Latin script).
==>
   If there is no 'Prefix' field in a record, no 'Prefix' field may
   later be registered for the record. Otherwise, only changes to the
   set of 'Prefix' fields for a record that widen the recommended
   prefixes are permitted (including removing all 'Prefix' fields in a
   record). For example, the Prefix "be-Latn" (Belarusian, Latin script)
   could be replaced by the Prefix "be" (Belarusian) but not by the
   Prefix "ru-Latn" (Russian, Latin script).

(Correct the description of what is permissible to do with 'Prefix'
fields by the registration (modification) process.)
--------------------------------

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 5 Dec 2008 13:22:53 -0800

(editor hat ON)

Addison Phillips

> Each 'Prefix' indicates

DONE.

> a record each, instead they have range records (which I don't

Note that we got rid of ranges, I believe.

These are good suggestions. However: I notice a problem now in the first sentence (we avoid 2119 keywords except as 2119 keywords). Resulting paragraph is:

<t hangText="Note:">Do not confuse private-use subtags with what this document refers
to as "subtags reserved for private use".  The latter are subtags such as
'qaa', 'Qaaa', or 'AA' that are designated as codes for private use by one of the underlying ISO standards.  Although their purpose is very similar,
subtags reserved for private use are represented by records of the appropriate type in the registry and, thus, are syntactically "language", "script",
or "region" subtags, rather than "private-use" subtags.</t>

> fields by the registration (modification) process.)

This is a good change, but should use normative language. I made it read:

<t>If a record includes no 'Prefix' field, a 'Prefix' field MUST NOT be added to the record at a later date. Otherwise, changes (additions, deletions, or modifications) to the set of 'Prefix' fields MAY be registered, as long as they strictly widen the range of language tags that are recommended. For example, the Prefix "be-Latn" (Belarusian, Latin script) could be replaced by the Prefix "be" (Belarusian) but not by the Prefix "ru-Latn" (Russian, Latin script) or the Prefix "be-Latn-BY" (Belarusian, Latin script, Belarus), since these latter either change or narrow the range of suggested tags.</t>
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Kent Karlsson <[email-masked]>
Date: Fri, 05 Dec 2008 22:40:24 +0100

> Note that we got rid of ranges, I believe.

They are still in lstreg-4646bis-draft-07.txt (and are still described
in draft-ietf-ltru-4646bis-20.txt).

> These are good suggestions. However: I notice a problem now in the first
> sentence (we avoid 2119 keywords except as 2119 keywords). Resulting paragraph
> is:
> 
> 'qaa', 'Qaaa', or 'AA' that are designated as codes for private use by one of
> the underlying ISO standards.  Although their purpose is very similar,
> subtags reserved for private use are represented by records of the appropriate
> type in the registry and, thus, are syntactically "language", "script",

Seems ok.

> <t>If a record includes no 'Prefix' field, a 'Prefix' field MUST NOT be added
> to the record at a later date. Otherwise, changes (additions, deletions, or
> modifications) to the set of 'Prefix' fields MAY be registered, as long as
> they strictly widen the range of language tags that are recommended. For
> example, the Prefix "be-Latn" (Belarusian, Latin script) could be replaced by
> the Prefix "be" (Belarusian) but not by the Prefix "ru-Latn" (Russian, Latin
> script) or the Prefix "be-Latn-BY" (Belarusian, Latin script, Belarus), since
> these latter either change or narrow the range of suggested tags.</t>

Seems ok.

        /kent k

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 5 Dec 2008 14:49:14 -0800

Hi -

As co-chair...

> From: "Kent Karlsson" <[email-masked]>
> To: "Phillips, Addison" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Friday, December 05, 2008 12:53 PM
> Subject: Re: [Ltru] editor's copy of draft-20 updated...
>

> See below for suggested changes to recently edited portions.
...
> fields by the registration (modification) process.)
...

This appears to be a substantial technical change.  There had better
be a darned good reason for this proposal.

Randy

---

From: John Cowan <[email-masked]>
Date: Fri, 5 Dec 2008 18:13:13 -0500

> be a darned good reason for this proposal.

It's not substantial.  It results from the fact that listing no prefixes
is semantically equivalent to declaring every possible prefix.  So if
some record contains "Prefix: zh; Prefix: ja", meaning that it is usable
with Chinese and Japanese, and both Prefix: lines are removed, the scope
is thereby widened to Chinese, Japanese, and every other language.

-- 
It was impossible to inveigle           John Cowan <[email-masked]>
Georg Wilhelm Friedrich Hegel           http://www.ccil.org/~cowan
Into offering the slightest apology
For his Phenomenology.                      --W. H. Auden, from "People" (1953)
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 5 Dec 2008 15:27:21 -0800

> is thereby widened to Chinese, Japanese, and every other language.

It may be substantial.

There is/was an existing prohibition on registering a prefix for a prefix-free variant.

What is a possibly substantial change is that we allow prefixes to be removed provided the overall set of recommended language tags remains a superset of the original.

With the previous wording, if you had this record:

Subtag: foobar
Prefix: xx-Latn
Prefix: xx-Cyrl

You could "widen" it by modifying one of the ranges or adding another, but you MUST NOT remove an entry. So either of these would be acceptable:

Subtag: foobar
Prefix: xx
Prefix: xx-Cyrl

--

Subtag: foobar
Prefix: xx-Latn
Prefix: xx-Cyrl
Prefix: xx

But the following record (now permitted) was NOT permitted:

Subtag: foobar
Prefix: xx

This in spite of the fact that it is syntactically equivalent.

Probably this change should prohibit removing the last prefix (the ultimate widening)??

Addison

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 5 Dec 2008 16:38:48 -0800

I don't consider it a material change, since the semantics is preserved.
That is, the deletion of a Prefix that imposes no constaint is not semantic
change - it makes no change in the requirements or recommendations of the
specification. And once you have:
Subtag: foobar
Prefix: xx-Latn
Prefix: xx-Cyrl
Prefix: xx

you can freely remove the first two, since they are completely subsumed by
the last condition. So that is completely equivalent to:

Subtag: foobar
Prefix: xx

Mark

On Fri, Dec 5, 2008 at 15:27, Phillips, Addison <[email-masked]> wrote:

> What is a possibly substantial change is that we allow prefixes to be
> removed provided the overall set of recommended language tags remains a
> superset of the original.
>
> You could "widen" it by modifying one of the ranges or adding another, but
> you MUST NOT remove an entry. So either of these would be acceptable:
>
> Subtag: foobar
> Prefix: xx
> Prefix: xx-Cyrl
>
> --
>
> Subtag: foobar
> Prefix: xx-Latn
> Prefix: xx-Cyrl
> Prefix: xx
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 5 Dec 2008 17:13:11 -0800

Hi -

> From: "Mark Davis" <[email-masked]>
> To: "Phillips, Addison" <[email-masked]>
> Cc: "John Cowan" <[email-masked]>; "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Friday, December 05, 2008 4:38 PM
...

As co-chair:

Kent Karlsson's proposal would remove "Once registered, fields of type
Prefix' MUST NOT be removed from any record" and would add to the list
of permitted changes "removing all 'Prefix' fields in a record".

Regardless of whether the semantics are the same, this changes whether
certain specific change requests would or would not be permitted.
For example, any request to remove all Prefixes would be rejected under
the original text (note the "MUST NOT"), but would be permitted under
Kent's proposal. Consequently, I believe we must handle this proposal
as a technical change.

Randy