Subject: Re: [Ltru] Request for clarification (Was: requiring full prefixes) (I made a minor correction to my previous post)

From: CE Whitehead <[email-masked]>
Date: Thu, 11 Dec 2008 13:55:52 -0500

Hi.  I am a bit confused; does Mark mean to say that--at some date in the future--we may or 'SHOULD' reconsider allowing 'partial' language tags?  If so, I too think it a good idea to keep this option open for the future--although I agree now that reconsidering 'partial' language tags for this draft would be too much of a change at this point. (And in any case I completely disagree with 'und' 's acting as a wildcard in the prefix for another subtag, since 'und' is a subtag itself--and if 'und' were part of the prefix, my opinion is that people would use 'und'--rather than any of a number of language subtags--as the prefix for the variant in question; that is 'und' would not be seen as a wildcard. )Alas, however, after reviewing both the current draft and previous discussions, I'm just more confused about the rules for prefixes. --CEWFrom: "Mark Davis" <mark at macchiato.com> Date: Tue, 9 Dec 2008 10:43:24 -0800 > Just to confirm, I'm not insisting on allowing "partial" language tags (or using "und"), given the > timing. My concern was that we might need this in the future, but any subtag that would need > it would just have to added with prefixes, perhaps with a comment about intended usage.We did discusss "partial" prefixes previously. (See the ietf-discussion about "zh-Latn-pinyin":http://www.alvestrand.no/pipermail/ietf-languages/2008-July/007816.html
 
'Peter Constable petercon at microsoft.comThu Jul 31 07:56:58 CEST 2008'
' >I'm inclined to think it a mistake for "fonipa" not to require "Latn".' )As I said above, I am quite confused about 'partial prefixes' now after reviewing this discussion. My questions:  (1). Is it possible to register a subtag like 'Latn' as a prefix for a variant--without specifying language codes (I thought a whole prefix had to be registered & that's my understanding from one of the recent versions of the draft I've read too). (2). Had 'Latn' been registered as a prefix for 'fonipa,' would it's prefix have thus been:*-Latn(3).  Finally, the current draft, section 3.4, paragraph 2, item 7 specifies that "The field 'Prefix' . . . SHOULD be included in the initial registration of any records of type 'variant'"  -- which means, I guess, that prefixes are recommended for but not required for variants. So should we have registered a prefix of 'Latn' for 'fonipa'? Can anyone clarify this? Thanks. --C. E. [email-masked]  

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 11 Dec 2008 20:03:06 -0800

Hi -

> From: "CE Whitehead" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, December 11, 2008 10:55 AM
> Subject: Re: [Ltru] Request for clarification (Was: requiring full prefixes) (I made a minor correction to my previous post)
...
> does Mark mean to say that--at some date in the future--
> we may or 'SHOULD' reconsider allowing 'partial' language tags?

Not speaking for Mark, but as a co-chair...
Our intention is to wrap up this WG as soon as the
current batch of RFCs is published. 

...
> Alas, however, after reviewing both the current draft
> and previous discussions, I'm just more confused about
> the rules for prefixes.
...

I believe we have a rough consensus on how prefixes are
supposed to work, and the text in the draft reflects that
consensus.  We'll be handing the draft to our AD real soon now,
so if you still have a problem with it, I suggest you take up the
issue during IETF last call.

Randy