Subject: Re: [Ltru] Issue #59: replace RECOMMENDED language with MUSTlanguage in 2.2.1 (Apps #12a)

From: CE Whitehead <[email-masked]>
Date: Thu, 11 Jun 2009 19:19:29 -0400

Debbie's proposal makes sense.

--C. E. Whitehead

[email-masked]

From: "Debbie Garside" <debbie at ictmarketing.co.uk> 

Date: Wed, 10 Jun 2009 14:11:00 +0100 
> Not wishing to hold this up... but it would be better to have a MUST and it
> is perfectly simple to enforce. Proposed text:

> --- 

> In order for a primary language subtag request to be considered for
> registration within the Language Subtag Registry, the requester MUST supply
> evidence that they have previously applied to the ISO 639 JAC  {or its successor} to encode the
> entity and that the request has been rejected.

---

From: CE Whitehead <[email-masked]>
Date: Tue, 16 Jun 2009 11:38:44 -0400

Hi! 

+1 for Martin Duerst's decision to close Issue #59--

although I liked both Mark's and Debbie's suggestions.
 
(For your reference, Mark suggested:
"proposals rejected by ISO 639/ RA-
JAC MUST be closely scrutinized by the Language Subtag Reviewer
before they are registered with IANA"
 
Debbie suggested that anyone wishing to register a subtag not registered with ISO 639 supply evidence that he/she attempted first to register the subtag with ISO 639.
 
However I am happy with the current text [which is essentially requiring what Debbie says should be required, although it does not spell out that requestors of language subtags must produce evidence of attempted registration; I assume that that goes unsaid].)
 
I tried to find previous discussion of ISO-639 and its relationship to the registry.
 
There was little--I found one comment by Randy in a 2008 thread; see:
 
http://www.ietf.org/mail-archive/web/ltru/current/msg11861.html
Here is Randy's comment:

"As co-chair:
Generating substantial updates to 639-5 would have gone well beyond the
scope of the ltru working group.
Randy"
 
In general there seems to have been consensus for going to ISO 639 first with a request for a language subtag.
 
Best,
 
C. E. Whitehead
[email-masked]