Subject: Re: [Ltru] Applicability Statement for the IANA registry established by 4646

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 23 Jun 2009 18:31:38 -0700

(as a contributor)

Okay, we've had some edit proposals and comments. I have incorporated them into the text below, editing as appropriate for style, grammar, and flow. Generally I took Mark's comments on Randy's comments. I adapted Peter's suggested (positive) text as an introduction, although it is substantially modified to make it "naïve-user" friendly (per Randy) :-).

So... how about:

--
Section x.x.x Applicability of the Subtag Registry

The Language Subtag Registry is the source of data elements used to construct language tags, following rules described in this document. Language tags are intended for use as metadata that describes the linguistic attributes of "information objects" (content, which, in addition to text, can include most media formats such as video or audio). They also form the basis for language and locale negotiation in various protocols and APIs.

The registry is therefore applicable to many applications that need some form of language identification, with these limitations:

  - It is not designed to be the sole data source in the creation of a language selection user interface. For example, the registry does not contain translations for subtag descriptions or for tags composed from the subtags. Sources for localized data based on the registry are generally available, notably [CLDR]. Nor does the registry indicate which subtag combinations are particularly useful or relevant.

   - It does not provide information indicating relationships between different languages, such as might be used in a user interface to select language tags hierarchically, regionally, or on some other organizational model.

    - It does not supply information about potential overlap between different language tags, as the notion of what constitutes a language is not precise: several different language tags might be reasonable choices for the same given piece of content. 

    - It does not contain information about appropriate fallback choices when performing language negotiation. A good fallback language might be linguistically unrelated to the specified language. The fact that one language is often used as a backup language for another is usually a result of outside factors, such as geography, history, or culture--factors which might not apply in all cases. For example, most people who use Breton (a Celtic language used in the Northwest of France) would probably prefer to be served French (a Romance language) if Breton isn't available.
--

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

---

From: Mark Davis ⌛ <[email-masked]>
Date: Tue, 23 Jun 2009 19:14:04 -0700

Looks good, with one additional suggestion.

Mark

On Tue, Jun 23, 2009 at 18:31, Phillips, Addison <[email-masked]> wrote:

> language tags, following rules described in this document. Language tags
> are intended for use as metadata that describes the linguistic attributes of
> "information objects" (content, which, in addition to text, can include most
> media formats such as video or audio).
>

I suggest a simplification of the middle sentence:

Language tags are designed for indicating linguistic attributes of various
content, including not only text but also most media formats such as video
or audio.

> They also form the basis for language and locale negotiation in various
> protocols and APIs.
>
> The registry is therefore applicable to many applications that need some
> form of language identification, with these limitations:
>
>  - It is not designed to be the sole data source in the creation of a
> language selection user interface. For example, the registry does not
> contain translations for subtag descriptions or for tags composed from the
> subtags. Sources for localized data based on the registry are generally
> available, notably [CLDR]. Nor does the registry indicate which subtag
> combinations are particularly useful or relevant.
>
>   - It does not provide information indicating relationships between
> different languages, such as might be used in a user interface to select
> language tags hierarchically, regionally, or on some other organizational
> model.
>
>    - It does not supply information about potential overlap between
> different language tags, as the notion of what constitutes a language is not
> precise: several different language tags might be reasonable choices for the
> same given piece of content.
>
>    - It does not contain information about appropriate fallback choices
> when performing language negotiation. A good fallback language might be
> linguistically unrelated to the specified language. The fact that one
> language is often used as a backup language for another is usually a result
> of outside factors, such as geography, history, or culture--factors which
> might not apply in all cases. For example, most people who use Breton (a
> Celtic language used in the Northwest of France) would probably prefer to be
> served French (a Romance language) if Breton isn't available.
> --
>

---

From: John Cowan <[email-masked]>
Date: Wed, 24 Jun 2009 00:20:20 -0400

> Section x.x.x Applicability of the Subtag Registry

+1

-- 
Where the wombat has walked,            John Cowan <[email-masked]>
it will inevitably walk again.          http://www.ccil.org/~cowan

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 24 Jun 2009 14:53:13 +0900

Hello Alex,

[shepherd hat on]
I have looked at this mail thread. First, I want to appologise for any 
comments that you got based on text that was originally from me.

Second, I think Addison did a very good job below in getting the wording 
smoothed and integrating the various comments from the WG. Of course, 
it's ultimately your call what you want, but I suggets taking the text 
below as your base. Possible changes might be to remove [CLDR] (as 
suggested by Randy; personally, I feel that this as well can stay in) or 
to simplify one sentence as suggested by Mark:

Language tags are designed for indicating linguistic attributes of 
various content, including not only text but also most media formats 
such as video or audio.
<<<<

The last question then is where to put this section. Given it's focus on 
applicability for one particular purpose (creating user interfaces), I 
definitely think that having it as a major section would be wrong.

As Section 3 is about the registry, I think making this section 3.9 
could be just about right.

Regards,    Martin.

On 2009/06/24 10:31, Phillips, Addison wrote:
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: Peter Constable <[email-masked]>
Date: Wed, 24 Jun 2009 00:16:24 -0700

+1

Peter

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis ?
Sent: Tuesday, June 23, 2009 7:14 PM
To: Phillips, Addison
Cc: [email-masked]
Subject: Re: [Ltru] Applicability Statement for the IANA registry established by 4646

Mark

On Tue, Jun 23, 2009 at 18:31, Phillips, Addison <[email-masked]<mailto:[email-masked]>> wrote:
language tags, following rules described in this document. Language tags are intended for use as metadata that describes the linguistic attributes of "information objects" (content, which, in addition to text, can include most media formats such as video or audio).

I suggest a simplification of the middle sentence:
Language tags are designed for indicating linguistic attributes of various content, including not only text but also most media formats such as video or audio.

They also form the basis for language and locale negotiation in various protocols and APIs.

---

From: Kent Karlsson <[email-masked]>
Date: Wed, 24 Jun 2009 09:39:52 +0200

Den 2009-06-24 03.31, skrev "Phillips, Addison" <[email-masked]>:

>     - It does not contain information about appropriate fallback choices when
> performing language negotiation. A good fallback language might be
> linguistically unrelated to the specified language. The fact that one language
> is often used as a backup language for another is usually a result of outside

This text uses both "fallback language" and "backup language" (apparently
meaning the same thing). Using *two* new terms is not helping here. Note
also that such choices are often personal and need not be general for a
given language.

I would be in favour of dropping that entire bullet point.

    /kent k

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 24 Jun 2009 11:40:47 +0200

On Tue, Jun 23, 2009 at 06:31:38PM -0700,
 Phillips, Addison <[email-masked]> wrote 
 a message of 30 lines which said:

> Breton (a Celtic language used in the Northwest of France) 

West

Otherwise, good example and good text. +1

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 24 Jun 2009 07:44:29 -0700

No. In French you would say "North-West" (nord-ouest), but that's not how it's typically done in English. However, the capital "N" is too formal. It should just say "... in the northwest of France".

Addison Phillips

> -----Original Message-----
> From: Stephane Bortzmeyer [mailto:[email-masked]]
> Sent: Wednesday, June 24, 2009 2:41 AM
> To: Phillips, Addison
> Cc: [email-masked]
> Subject: Re: Applicability Statement for the IANA registry
> established by 4646
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 24 Jun 2009 19:51:05 +0200

On Wed, Jun 24, 2009 at 07:44:29AM -0700,
 Phillips, Addison <[email-masked]> wrote 
 a message of 26 lines which said:

> No. In French you would say "North-West" (nord-ouest), but that's
> not how it's typically done in English. However, the capital "N" is
> too formal. It should just say "... in the northwest of France".

Sorry, I was not clear. I wanted to say that Brittany (the region of
France where people historically spoke Breton) is in the West, not the
Northwest (where Normandy is).

---

From: Mark Davis ⌛ <[email-masked]>
Date: Wed, 24 Jun 2009 11:59:08 -0700

>From the geographic center of of France (
http://fr.wikipedia.org/wiki/Centre_de_la_France) -- while there is some
dispute about exactly where that is because of different calculations --
you'd head about WNW, so "west" would be better.

Mark

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 25 Jun 2009 14:56:07 +0100

Martin J. Dürst wrote:

> Second, I think Addison did a very good job below in getting the 
> wording smoothed and integrating the various comments from the WG. Of 
> course, it's ultimately your call what you want, but I suggets taking 
> the text below as your base. Possible changes might be to remove 
> [CLDR] (as suggested by Randy; personally, I feel that this as well 
> can stay in)

I kept it.

> or to simplify one sentence as suggested by Mark:
>
> >>>>

Done.

> The last question then is where to put this section. Given it's focus 
> on applicability for one particular purpose (creating user 
> interfaces), I definitely think that having it as a major section 
> would be wrong.
>