Subject: Re: [Ltru] par 3 of 2.2, "identification of subtag's type" (was Additional issues with 4646bis raised by an Apps Review Team review)

From: CE Whitehead <[email-masked]>
Date: Sun, 7 Jun 2009 17:13:53 -0400

Hi, I felt the need to comment on par 3 of 2.2, "identification of subtag's type", so am following Doug's example in creating a new heading.

From: Alexey Melnikov <alexey.melnikov at isode.com> 
Date: Sat, 06 Jun 2009 21:14:57 +0100
 
I. 
> 11). Paragraph 3 of Section 2.2 asserts that "...identification of the
> subtag's type [is] possible, even if the content of the subtag itself is
> unrecognized".
> 
> Without a table summarizing the rules a reader needs to infer them from
> ABNF in Section 2.1 and possibly by reading the rest of the document. A
> compact text or table summarizing the rules would improve the document.

Would a cross-reference be enough? (A quick parenthetical list of section numbers)??

I note that this issue is dealt with also in Section 2.1, paragraph 2 of the draft at:

http://tools.ietf.org/html/draft-ietf-ltru-4646bis-22

and

http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-23.html#syntax

:

"There are different types of subtag, each of which is distinguished
   by length, position in the tag, and content: each subtag's type can
   be recognized solely by these features.  This makes it possible to
   extract and assign some semantic information to the subtags, even if
   the specific subtag values are not recognized."

2.1 then provides a list of possible subtag types indicating the order/syntax of each (par 3).  Thus a cross-reference to 2.1 may be the only cross-reference needed:

"(see 2.1 above)"

(Also, I know I've asked this question before, but why is a variant subtag beginning with a digit listed as consisting of exactly one digit plus 3 alphanumerica characters in the list mentioned above?? (par 3):

"variant       = 5*8alphanum         ; registered variants
               / (DIGIT 3alphanum)", 

and then just a paragraph down [par 5?  or 4?] a variant beginning with a digit is described as having a length of 4-8 characters:

"There is a subtlety in the ABNF
   production 'variant': a variant starting with a digit has a minimum
   length of four characters, while those starting with a letter have a
   minimum length of five characters."  ??)

Best,

C. E. Whitehead

[email-masked]

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 08 Jun 2009 22:22:19 +0100

>   Hi, I felt the need to comment on par 3 of 2.2, "identification of 
> subtag's type", so am following Doug's example in creating a new heading. 
>

Yes!

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 11 Jun 2009 13:41:25 +0100

>Kent Karlsson wrote:
>  
>
>     ... Replacing (DIGIT 3alphanum) by (DIGIT 3*7alphanum) would just
>     introduce needless ambiguity in the grammar. 
>
>s/ambiguity/redundancy/
>
>  
>
> That said, Kent's response was spot-on. Everything that needs to be 
> covered in the existing production is covered. If it were really 
> desirable to remove the subtlety/cleverness in the ABNF, and **I DO 
> NOT PROPOSE CHANGING ANYTHING HERE**, the solution CE was thinking of 
> might have looked like this:
>
>variant       = ALPHA 4*7alphanum         ; registered variants
>             / (DIGIT 3*7alphanum)
>  
>
With my individual contributor hat on: IMHO, I think this variant is 
more readable.

---

From: CE Whitehead <[email-masked]>
Date: Thu, 11 Jun 2009 19:24:31 -0400

Hi--the table does get worse the more you try to change it I guess, but I still do not think everything is perfectly clear in the table  (I can make sense of it because I know what everything is meant to mean).

That said, it's still a useful table as far as showing the structure of language subtags!

Best,

C. E. Whitehead

[email-masked]

From: "Doug Ewell" <doug at ewellic.org> 
Date: Wed, 10 Jun 2009 19:46:54 -0600 
 
> Kent Karlsson wrote:

... Replacing (DIGIT 3alphanum) by (DIGIT 3*7alphanum) would just introduce needless ambiguity in the grammar. s/ambiguity/redundancy/
> That said, Kent's response was spot-on. Everything that needs to be covered in the existing production is covered.