Subject: [Ltru] Issue #59: replace RECOMMENDED language with MUSTlanguage in 2.2.1 (Apps #12a)

From: Alexey Melnikov <[email-masked]>
Date: Thu, 11 Jun 2009 20:58:14 +0100

I am not entirely happy with the resolution "wantfix" for this one, as 
this is a typical case of what can bring a DISCUSS from other IESG members.
So let me try to suggest a specific text.

OLD:
At the time this document was created, there were no examples of
this kind of subtag and future registrations of this type are
discouraged: primary languages are strongly RECOMMENDED for
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
registration with ISO 639, and proposals rejected by ISO 639/ RA-
^^^^^^^^^^^^^^^^^^^^^^^^^
JAC will be closely scrutinized by the Language Subtag Reviewer
before they are registered with IANA.

NEW:
At the time this document was created, there were no examples of
this kind of subtag and future registrations of this type are
discouraged: an attempt to register a primary language MUST be
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
made to ISO 639, and proposals rejected by ISO 639/ RA-
^^^^^^^^^^^^^^^
JAC will be closely scrutinized by the Language Subtag Reviewer
before they are registered with IANA.

I.e. the discussion about what the Language Tag Reviewer is going to do 
is not the point of this issue.

---

From: Kent Karlsson <[email-masked]>
Date: Thu, 11 Jun 2009 23:11:11 +0200

Having seen the discussion around this issue, I think "MUST" here
is going overboard. This has not been a problem before, and I
don't foresee that this would be a problem in the future. In practice,
there is no real difference, but a "MUST" here seems to push this
into the absurd ("document e-mail thread", "180 days limit", ...).
So I'm opposed to the suggested change.

Nit: "ISO 639" cannot register anything, nor do anything else, it's
a series of standards, not a registration authority.

Another nit: "will be closely scrutinized by the Language Subtag Reviewer
before they are registered with IANA", seems to imply that registration
is inevitable, despite close scrutiny.

    /kent k

Den 2009-06-11 21.58, skrev "Alexey Melnikov" <[email-masked]>:

> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 11 Jun 2009 14:20:30 -0700

Hi -

> From: "Alexey Melnikov" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, June 11, 2009 12:58 PM
> Subject: [Ltru] Issue #59: replace RECOMMENDED language with MUSTlanguage in 2.2.1 (Apps #12a)
>

As a technical contributor...

As long as the understanding is that we don't need to go back and
wordsmith to cover the cases of indefinite delay, non-response, or
tweaks to the scope of what is covered by the registration in ISO-land,
I'd be OK with Alex's proposed text.

Randy

---

From: Mark Davis <[email-masked]>
Date: Thu, 11 Jun 2009 14:37:42 -0700

Me too. I'd be even happier with

proposals rejected by ISO 639/ RA-
JAC will be closely scrutinized by the Language Subtag Reviewer
before they are registered with IANA.
=>
proposals rejected by ISO 639/ RA-
JAC MUST be closely scrutinized by the Language Subtag Reviewer
before they are registered with IANA.

The proposal should not try to predict what the LSR will do, it should
explicitly tell the LSR what to do, and that means a MUST.

Mark

---

From: Leif Halvard Silli <[email-masked]>
Date: Fri, 12 Jun 2009 01:33:47 +0200

+1

-- 
leif halvard silli

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 11 Jun 2009 16:47:12 -0700

(editor hat OFF)

That would be an inappropriate MUST, though. You “MUST scrutinize”?

The problem here is as I expressed previously… the LSR can reject these requests---it is what having an expert reviewer is *for*. But requiring a rejection of something rejected by ISO 639 is tantamount to saying you can’t register any such subtags. We might was well take the mechanism away altogether.

I would propose a slight alteration of Alexey’s text to ensure we do this right:

--
At the time this document was created, there were no examples of
this kind of subtag. Future registrations of this type are
discouraged: an attempt to register any new proposed primary language MUST be
made with ISO 639. Proposals rejected by ISO 639/ RA-JAC are unlikely to meet the
criteria for primary language subtags and are thus unlikely to be registered.
--

This gets us both the MUST with ISO 639 and avoids “frowning”, “the community”, or the Reviewer “scrutinizing” :-).

(editor hat ON)

If I receive support for the above text shortly, I will incorporate it prior to submission and will indicate that I think I have said support on this list.

Since it is late in the day, I expect instead that I will incorporate Alexey’s text. His text I show as having support from at least five people (Alexey, Mark, Leif, Randy, myself), with none opposed and only CE Whitehead proposing different text.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Davis
Sent: Thursday, June 11, 2009 2:38 PM
To: Randy Presuhn
Cc: [email-masked]
Subject: Re: [Ltru] Issue #59: replace RECOMMENDED language with MUSTlanguage in 2.2.1 (Apps #12a)

The proposal should not try to predict what the LSR will do, it should explicitly tell the LSR what to do, and that means a MUST.

Mark

On Thu, Jun 11, 2009 at 14:20, Randy Presuhn <[email-masked]<mailto:[email-masked]>> wrote:
Hi -

> From: "Alexey Melnikov" <[email-masked]<mailto:[email-masked]>>
> To: <[email-masked]<mailto:[email-masked]>>

Randy

_______________________________________________
Ltru mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis <[email-masked]>
Date: Thu, 11 Jun 2009 16:58:54 -0700

Your reformulation works for me.

Mark

On Thu, Jun 11, 2009 at 16:47, Phillips, Addison <[email-masked]> wrote:

> The problem here is as I expressed previously… the LSR can reject these
> requests---it is what having an expert reviewer is **for**. But requiring
> a rejection of something rejected by ISO 639 is tantamount to saying you
> can’t register any such subtags. We might was well take the mechanism away
> altogether.
>
>
>
> This gets us both the MUST with ISO 639 and avoids “frowning”, “the
> community”, or the Reviewer “scrutinizing” :-).
>
>
>
> (editor hat ON)
>
>
>
> If I receive support for the above text shortly, I will incorporate it
> prior to submission and will indicate that I think I have said support on
> this list.
>
>
>
> Since it is late in the day, I expect instead that I will incorporate
> Alexey’s text. His text I show as having support from at least five people
> (Alexey, Mark, Leif, Randy, myself), with none opposed and only CE Whitehead
> proposing different text.
>
>
>
> Addison
>
>
>
> Addison Phillips
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Mark Davis
> *Sent:* Thursday, June 11, 2009 2:38 PM
> *To:* Randy Presuhn
> *Cc:* [email-masked]
> *Subject:* Re: [Ltru] Issue #59: replace RECOMMENDED language with
> MUSTlanguage in 2.2.1 (Apps #12a)
>
>
>
>  On Thu, Jun 11, 2009 at 14:20, Randy Presuhn <
> [email-masked]> wrote:
>
> Hi -
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 11 Jun 2009 17:18:15 -0700

Hi -

> From: "Phillips, Addison" <[email-masked]>
> To: "Mark Davis" <[email-masked]>; "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, June 11, 2009 4:47 PM
> Subject: RE: [Ltru] Issue #59: replace RECOMMENDED language withMUSTlanguage in 2.2.1 (Apps #12a)
...

I could live with this.  (Though ironically, the same logic that led our
reviewer to object to some "MAY" language would also lead to a rejection
of this "MUST", but let's not worry about that!)

Randy

---

From: Leif Halvard Silli <[email-masked]>
Date: Fri, 12 Jun 2009 04:21:36 +0200

> -- At the time this document was created, there were no
> examples of this kind of subtag. Future registrations of this
> type are discouraged: an attempt to register any new proposed
> primary language MUST be made with ISO 639. Proposals rejected
> by ISO 639/ RA-JAC are unlikely to meet the criteria for
> primary language subtags and are thus unlikely to be
> registered. --

- (minus)

This seems redundant and over-explained. If being registered with 
ISO is close to being a criteria in itself, then saying that those 
that are rejected by ISO are "unlikely to meet the criteria" 
undermines that very point.

> Since it is late in the day, I expect instead that I will
> incorporate Alexey’s text. His text I show as having support
> from at least five people (Alexey, Mark, Leif, Randy, myself),
> with none opposed and only CE Whitehead proposing different
> text.

+
-- 
leif halvard silli

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 11 Jun 2009 21:13:14 -0700

I incorporated the text as:

made to the ISO 639 registration authority. Proposals rejected by the ISO 639 registration authority are unlikely to meet the

Addison

Addison Phillips

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phillips, Addison
Sent: Thursday, June 11, 2009 4:47 PM
To: Mark Davis; Randy Presuhn
Cc: [email-masked]
Subject: Re: [Ltru] Issue #59: replace RECOMMENDED language with MUSTlanguage in 2.2.1 (Apps #12a)

(editor hat OFF)

(editor hat ON)

Addison

Addison Phillips

Mark

Randy