Subject: Re: [Ltru] Registering a primary language subtag (was: Additional issues with 4646bis...)

From: Alexey Melnikov <[email-masked]>
Date: Mon, 08 Jun 2009 21:30:34 +0100

>Sorry, there is no ticket for this yet, but at least this e-mail 
>deals with only one issue.
>
>Alexey Melnikov <alexey dot melnikov at isode dot com> wrote:
>
>>>>>At the time this document was created, there were no
>>>>>examples of this kind of subtag and future
>>>>>registrations of this type are discouraged: primary
>>>>>languages are strongly RECOMMENDED for registration
>>>>>with ISO 639, and proposals rejected by ISO 639/
>>>>>RA-JAC will be closely scrutinized by the Language
>>>>>Subtag Reviewer before they are registered with IANA. 
>>>>>
>>>>This might be a big deal, so this might actually require
>>>>wider review, such as IETF LC. 
>>>
>>>What is a big deal? Why would an IETF LC be appropriate for this?
>>
>>To alert IAB and other interested parties about the situation.
>  
>Huh?
>
>Someone wants to register a language subtag for (say) Loxian and
>submits a proposal form to ietf-languages. The Language
>Subtag Reviewer, or designee, submits a proposal to ISO
>639/RA-JAC. That body consults with Linguist List, and after
>due process decides not to assign a code element. The
>original requester makes a convincing case to ietf-languages
>that the subtag is justified. The Reviewer and group "closely
>scrutinize" the request and decide to assign the subtag.
>
>
>Why would this matter deserve special attention by the Internet Architecture
>Board? Who are the "other interested parties" who need to review
>this?
>The tag "i-enochian" was registered in 2002. If done under
>4646 or 4646bis, it would have been the primary language
>subtag "enochian" instead. As I recall, neither the IAB nor
>"other interested parties" were specially alerted. What
>problems did this cause?

Doug, this suggestion wasn't because of my mistrust to Language Tag 
Reviewers, or anything like this. I am just relaying the sentiment 
expressed by the Apps Team reviewer.

After thinking more about this, I think suggesting that interested 
parties should subscribe to the mailing list where reviews take place 
and closing this part of the issue as "no change" would be just fine.

---

From: Peter Constable <[email-masked]>
Date: Mon, 8 Jun 2009 13:57:09 -0700

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexey Melnikov

> and closing this part of the issue as "no change" would be just fine.

I was waiting for Randy to open a ticket before commenting: the process in this regard is essentially unchanged since RFC 1766, and there's not been any problem so far. So, no change sounds OK with me.

Peter

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 8 Jun 2009 19:43:56 -0600

> expressed by the Apps Team reviewer.

I understand that.  My "Huh's" and "Why's" were not directed at you, but 
at the reviewer behind the curtain who asked the question.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ