Subject: Re: [Ltru] par 3 of 2.2, "identification of subtag's type" (was Additional issues with 4646bis raised by an Apps Review Team review)

From: Alexey Melnikov <[email-masked]>
Date: Mon, 08 Jun 2009 22:23:52 +0100

> (Also, I know I've asked this question before, but why is a variant 
> subtag beginning with a digit listed as consisting of exactly one 
> digit plus 3 alphanumerica characters in the list mentioned above?? 
> (par 3):
> "variant       = 5*8alphanum         ; registered variants
>                / (DIGIT 3alphanum)",
>  
> and then just a paragraph down [par 5?  or 4?] a variant beginning 
> with a digit is described as having a length of 4-8 characters:
> "There is a subtlety in the ABNF
>    production 'variant': a variant starting with a digit has a minimum
>    length of four characters,

While this is true, I think deleting the word "minimum" here would fix 
the problem.

> while those starting with a letter have a
>    minimum length of five characters."  ??)
>

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 8 Jun 2009 14:28:45 -0700

> While this is true, I think deleting the word "minimum" here would

No. It would be wrong. 

A requested variant subtag starting with a digit may be up to eight characters (letters or digits) long. They can be as short as four characters. A request for a subtag starting with a letter must be at least five in length. Removing the word "minimum" would make it mean that a variant starting with a digit could only be four characters long.

Addison

---

From: CE Whitehead <[email-masked]>
Date: Wed, 10 Jun 2009 18:18:14 -0400

Hi!

Yes, I saw that the draft sated that variants were 5*8 and also saw the paragraph below the table which is very clear:

"All subtags have a maximum length of eight characters and whitespace is not permitted in a language tag. There is a subtlety in the ABNF production 'variant': a variant starting with a digit has a minimum length of four characters, while those starting with a letter have a minimum length of five characters."

All that is fine, but I expected something in the table like:

"(DIGIT 3*7 alphanum)

I did not think the table was that clear, but perhaps things are o.k. as they are with the info about the variant just above . . . ???  whatever people like me who have learned to scan a lot in their old age think . . .

Best,

C. E. Whitehead

[email-masked]

(My apologies for taking so long to reply to your replies; have not been able to get to a computer for several days; sorry that I just sent an email out and took off . . . unfortunately I have to get to a library to pick up email and reply

I still feel the table is confusing to people who just glance at the table and then go on, but I will let that rest.)

> Date: Mon, 8 Jun 2009 22:41:53 +0100
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]
> Subject: Re: [Ltru] par 3 of 2.2, "identification of subtag's type" (was Additional issues with 4646bis raised by an Apps Review Team review)
> 
> Phillips, Addison wrote:
> 
> >No. The ABNF has a subtlety in it :-). 
> >
> >Here is the production in question:
> >
> >variant = 5*8alphanum ; registered variants
> > / (DIGIT 3alphanum)
> >
> >This means that any subtag (digit or alpha starting) is permitted with length 5-8 and digit-starting ones can have a length of four.
> > 
> >
> Ah, I've missed that alphanum includes digits :-).
> Never mind then.
>

---

From: Kent Karlsson <[email-masked]>
Date: Thu, 11 Jun 2009 01:21:34 +0200

Den 2009-06-11 00.18, skrev "CE Whitehead" <[email-masked]>:

>> > All that is fine, but I expected something in the table like:

The (DIGIT 3alphanum) part of your suggestion is (obviously) covered by
the (DIGIT 3alphanum) part in ABNF. The (DIGIT 4*7alphanum) part of your
suggestion is covered by   5*8alphanum   in the ABNF. The 5*8alphanum also
covers variants that start with a letter. Replacing (DIGIT 3alphanum) by
(DIGIT 3*7alphanum) would just introduce needless ambiguity in the grammar.

    /kent k

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 10 Jun 2009 19:46:54 -0600

Re: [Ltru] par 3 of 2.2, "identification of subtag's type" (was 
Additional issues with 4646bis raised by an Apps Review Team 
review)(information only; no proposals in this post)

Kent Karlsson wrote:

> ... Replacing (DIGIT 3alphanum) by (DIGIT 3*7alphanum) would just 
> introduce needless ambiguity in the grammar.

s/ambiguity/redundancy/

That said, Kent's response was spot-on.  Everything that needs to be 
covered in the existing production is covered.

If it were really desirable to remove the subtlety/cleverness in the 
ABNF, and **I DO NOT PROPOSE CHANGING ANYTHING HERE**, the solution CE 
was thinking of might have looked like this:

variant       = ALPHA 4*7alphanum         ; registered variants
              / (DIGIT 3*7alphanum)

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ