Subject: Re: [Lurk] draft-erb-lurk-rsalg

From: <[email-masked]>
Date: Wed, 1 Jun 2016 15:07:57 +0000

Hi Rich,

How many flights are there in the following:

   The basic premise of RSALG is that in the TLS_RSA_* handshakes:

   o  The KeyOwner will not decrypt the PMS and provide it back to the

      Server.  Instead, the KeyOwner will full compute the Master Secret

      (via the PRF function) and provide that.

   o  The Server will choose a random ephemeral value, N, and provide a

      cryptographically-hashed value of (such as SHA256(N)) as its

      Server Random value.  The Server sends N to KeyOwner which then

      computes the same hashed value and uses that hash as its input to

      the PRF.

Regards

Emile

-----Original Message-----
From: Salz, Rich [mailto:[email-masked]]
Sent: mercredi 25 mai 2016 19:54
To: STEPHAN Emile IMT/OLN; [email-masked]
Subject: RE: draft-erb-lurk-rsalg

> I was reading section 3.2. do you have more details on the flights ?

Not sure what you mean, sorry.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 1 Jun 2016 17:09:26 +0000

One round-trip per PMS computation.

--
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, June 01, 2016 11:08 AM
To: Salz, Rich
Cc: [email-masked]
Subject: RE: draft-erb-lurk-rsalg

Hi Rich,

      the PRF.

Regards

Emile

-----Original Message-----
From: Salz, Rich [mailto:[email-masked]]
Sent: mercredi 25 mai 2016 19:54
To: STEPHAN Emile IMT/OLN; [email-masked]<mailto:[email-masked]>
Subject: RE: draft-erb-lurk-rsalg

Thank you.