Subject: [Lwip] very lightweight sensor's response without request

From: 고석갑 <[email-masked]>
Date: Wed, 28 Mar 2012 12:57:23 +0200

I assume that there is a very lightweight sensor node. The node wakes up on every 1 min and measures the temperature and broadcasts measured value and sleep again. This node does not have any memory and does not receive any message from other nodes.
I want to bring coap message to this node. I know that OBSERVE draft in coap is one candidate. However, it require that the sensor node (coap server) should have availity to receive coap client's request(register) and the memory to remember token from request and client address. But I do not want to make the lightweight sensor node complex.
For this kind of node, Do we need make a special mechnism?  i.e., we define broadcast or preconfigured response without request. The response may have own uri to describe what data is. 

- Softgear Ko (Mobile)

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 Mar 2012 13:32:02 +0200

> For this kind of node, Do we need make a special mechnism?  i.e., we define broadcast or preconfigured response without request. The response may have own uri to describe what data is. 

This is something that we will discuss in the CoRE meeting on Friday under the "sleepy nodes" discussion.

Just to give one possible direction for your thoughts:
There may be other ways to establish an observation relationship than a GET request with an Observe option.
(If you have no memory, you pretty much would have to compile it in.  
This would work with a multicast destination address given a bit more handwaving about initializing the IPv6 source address on each wakeup.)

Grüße, Carsten