Subject: Re: [Lwip] I-D Action: draft-ietf-lwig-cellular-01.txt

From: ma yc <[email-masked]>
Date: Mon, 3 Mar 2014 05:34:10 +0800

Dear Ari,

I just roughly went through the draft. It is an interesting draft. I think
it is a good

approach to summarize the cellular and power efficiency for CoAP
implementation.

Following are some general comments.

1. There are personal drafts referred in this document. Some are not active
now,

for example, draft-vial-core-mirror-proxy, draft-castellani-core-alive, and

draft-fossati-core-publish-monitor-options. However in this draft the three
drafts

are described as the main candidate solutions in Chapter 8.

I think it better to focus on the delegation model description in this
chapter and

avoid talking about solutions since there is no consensus on solutions.

If necessary, the three personal drafts can be used just as example
approaches.

2. The draft is focusing on power efficiency according to the abstract.

However chapter 5 seems to talk about cellular constraints.

the relation with power efficiency is not clearly identified. There should
be

some words describing the role for discovery and registration in

the power efficiency context. Also it is better to add a few word in

the beginning of chapter 5 to clearly indicate that this draft focuses

on CoAP devices in cellular network.

Thank you.

Regards

Yuanchen

2014-02-13 22:35 GMT+08:00 Ari Keränen <[email-masked]>:

> Folks,
>
> This update aligns the CoAP cellular draft with the updated terminology of
> the latest terminology draft and has a few other editorial fixes.
>
> The authors think the draft is ready to move forward but would appreciate
> a review or two before going for last calls.
>
>
> Thanks,
> Ari
>
>
> On 13/02/14 16:27, [email-masked] wrote:
>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>>   This draft is a work item of the Light-Weight Implementation Guidance
>> Working Group of the IETF.
>>
>>          Title           : Building Power-Efficient CoAP Devices for
>> Cellular Networks
>>          Authors         : Jari Arkko
>>                            Anders Eriksson
>>                            Ari Keranen
>>         Filename        : draft-ietf-lwig-cellular-01.txt
>>         Pages           : 15
>>         Date            : 2014-02-13
>>
>> Abstract:
>>     This memo discusses the use of the Constrained Application Protocol
>>     (CoAP) protocol in building sensors and other devices that employ
>>     cellular networks as a communications medium.  Building communicating
>>     devices that employ these networks is obviously well known, but this
>>     memo focuses specifically on techniques necessary to minimize power
>>     consumption.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-lwig-cellular/
>>
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-ietf-lwig-cellular-01
>>
>> A diff from the previous version is available at:
>> http://www.ietf.org/rfcdiff?url2=draft-ietf-lwig-cellular-01
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> Lwip mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/lwip
>>
>>
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>

---

From: Ari Keränen <[email-masked]>
Date: Tue, 4 Mar 2014 17:47:15 +0000

Dear Yuanchen,

Thanks for the review! See comments inline.

On Mar 2, 2014, at 9:34 PM, ma yc wrote:
> I just roughly went through the draft. It is an interesting draft. I think it is a good 
> approach to summarize the cellular and power efficiency for CoAP implementation. 
> 1. There are personal drafts referred in this document. Some are not active now,
> draft-fossati-core-publish-monitor-options. However in this draft the three drafts
> I think it better to focus on the delegation model description in this chapter and
> If necessary, the three personal drafts can be used just as example approaches.

That was the idea but apparently we need to make the text more clear on. Will fix that.

> the relation with power efficiency is not clearly identified. There should be

The idea is that when the devices are already power-efficient and hence perform in a certain kind of way (e.g., implement certain mechanisms and not others), how to take the constraints of a network, such as cellular, in to account. Will clarify this too. 

Thanks,
Ari