Subject: [Lwip] Comments on draft-hex-lwig-energy-efficient-02

From: Ari Keränen <[email-masked]>
Date: Tue, 4 Mar 2014 18:15:21 +0000

Hi,

Here's some comments on draft-hex-lwig-energy-efficient-02. 

In general I think this is good stuff and looking forward to seeing more especially on how to take L2 & L1 features into account at L3 and above. Are there some standard APIs or such available BTW?

More specific comments on the text:

  As show in
  Figure 1 below, the IETF has developed CoAP as the application layer
  and 6LoWPAN as the adaption layer to run IPv6 over IEEE 802.15.4 and
  Bluetooth Low-Energy,

Considering the current work at 6lo it would be good to mention 15.4 and BTLE are just examples of what 6LoWPAN can and will be used on. That said, focusing only to those two in this draft is probably a good idea.

  Below we list the energy consumption profile of the
  most common atom operations on a prevalent sensor node platform.

What's "atom operations"?

   Traffic Filtering Service (TFS): A service provided by an access

Especially since the IEEE standards are not easily accessible, a bit more details on this would be interesting. Can one e.g., address application layer protocols with the filters?

Cheers,
Ari

---

From: "Cao Zhen \(CZ\)" <[email-masked]>
Date: Wed, 19 Mar 2014 12:05:57 +0800

Hello Ari, 

Thanks a lot for your comments and suggestion. 

Please see my inline reply. 

> In general I think this is good stuff and looking forward to seeing more especially
> on how to take L2 & L1 features into account at L3 and above. Are there some
> standard APIs or such available BTW?

Sadly, not yet standard, and the chipset do provide some APIs for their own chipset. 

> Considering the current work at 6lo it would be good to mention 15.4 and BTLE
> are just examples of what 6LoWPAN can and will be used on. That said, focusing
> only to those two in this draft is probably a good idea.

I discussed with authors, they agree to focus on 15.4 and BTLE. 

> What's "atom operations"?

We meant the basic operations that are not dividable. 

> Especially since the IEEE standards are not easily accessible, a bit more details on
> this would be interesting. Can one e.g., address application layer protocols with
> the filters?

That's an issue. Normally the IEEE specs will be free for 6 months since publication. 

The TFS is a capability provided by 802.11v. e.g. it can be used to filter out ICMP message over the air. The Access Point sends a TFS Request to the node, and the node will ack and then the specified traffic will not passed from the infrastructure to the wireless nodes.

---

From: Ari Keränen <[email-masked]>
Date: Fri, 21 Mar 2014 14:19:12 +0200

On 19/03/14 06:05, Cao Zhen (CZ) wrote:
[...]
>> In general I think this is good stuff and looking forward to seeing
>> more especially on how to take L2 & L1 features into account at L3
>> and above. Are there some standard APIs or such available BTW?
>

Maybe a useful implementation guidance would then be to look for these 
APIs or chipsets that provide these APIs if all don't. I guess their 
existence may not be self-evident.

[...]
>> Below we list the energy consumption profile of the most common
>> atom operations on a prevalent sensor node platform.
>>

Maybe this could be rephrased to be more clear.

>> Especially since the IEEE standards are not easily accessible, a
>> bit more details on this would be interesting. Can one e.g.,
>> address application layer protocols with the filters?
>
> The TFS is a capability provided by 802.11v. e.g. it can be used to
> filter out ICMP message over the air. The Access Point sends a TFS
> Request to the node, and the node will ack and then the specified
> traffic will not passed from the infrastructure to the wireless
> nodes.

How can you specify the traffic? Is it specific protocol fields that are 
applicable or could you throw in e.g., an arbitrary bit mask extending 
through the whole protocol stack that if matches would cause the filters 
to do something? Some details along those lines would be helpful in the 
draft.

Cheers,
Ari