Subject: [Lwip] Call for adoption of draft-aks-lwig-crypto-sensors-01

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 3 Aug 2016 04:31:41 +0000

+1 for adoption as WG document.

-------------------------------------------------------------
Also one comment.  In Section 2 (Related Work) it mentioned:

      DTLS can be applied with group keys, pairwise shared keys, or with certificates.

I am not too familiar with the "group keys" mode of DTLS and could not find exactly what you meant by this mode when I read RFC6347.  Can you expand on this in a future update (especially if you had some implementation experience in using this)?

Best Regards,

Akbar

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Fri, 5 Aug 2016 12:28:14 +0530

+ 1 for WG adoption. It is an useful work.

Regarding the group keys, do the authors intend to mention some thing
similar to what was proposed in:
https://tools.ietf.org/html/draft-keoh-dice-multicast-security-08? But that
is still a non-standard approach.
Agree with Akbar, a bit of explanation on this from the authors will be
useful.

Also, at this point I would also like to mention that we did some CoAP
based end-to-end security solution for some constrained applications
requiring frequent secure channel establishment which used pre-provisioned
ID, standard symmetric keys and standard DTLS channel encryption mechanism.
The draft is available here:
https://tools.ietf.org/html/draft-bhattacharyya-dice-less-on-coap-00.
The draft presents an initial experimental work with several comparative
lab results furnished within the document. Wanted to bringing this to the
authors' notice. Just in case they find it worth having a look as part of
the state-of-the-art study.
Regards,
Abhijan

On Wed, Aug 3, 2016 at 10:01 AM, Rahman, Akbar <
[email-masked]> wrote:

> I am not too familiar with the “group keys” mode of DTLS and could not
> find exactly what you meant by this mode when I read RFC6347.  Can you
> expand on this in a future update (especially if you had some
> implementation experience in using this)?
>
>
>
>
>
>
>
> Best Regards,
>
>
>
>
>
> Akbar
>
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>
>