Subject: [magma] MSF API status

From: Bill Fenner <[email-masked]>
Date: Wed, 5 Feb 2003 17:58:57 -0800

Folks,

  I asked the Austin Group (the group that created POSIX 1003.1-2002 /
Single Unix Specification v3) for an opinion on the use of getsockopt()
vs. ioctl().  The general feeling was that a functional interface like
Erik suggested would be best.  The primary argument was that they discourage
use of type-unsafe APIs like setsockopt()/getsockopt()/ioctl() altogether.

  Dave and I will work on a proposal for a functional interface to the
full-state API, and bring a revised draft to the WG soon.

  Bill
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 6 Feb 2003 10:48:05 -0500

Hello;

Does anyone know of a location to get a Free BSD patch for IGMP v3 ?

The
http://www.kloosterhof.com/~wilbert/igmpv3.html
page is now a 404 not found.

Marshall

T.M. Eubanks
Multicast Technologies, Inc.
10301 Democracy Lane, Suite 410
Fairfax, Virginia 22030
Phone : 703-293-9624       Fax     : 703-293-9609
e-mail : [email-masked]
http://www.multicasttech.com

Test your network for multicast :
http://www.multicasttech.com/mt/
  Status of Multicast on the Web  :
  http://www.multicasttech.com/status/index.html

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 6 Feb 2003 10:48:05 -0500

Hello;

The

Marshall

T.M. Eubanks

---

From: "Konstantin KABASSANOV" <[email-masked]>
Date: Thu, 6 Feb 2003 16:57:45 +0100

Hi,

There is an implementation available in KAME snaps.

Konstantin

_____________________________________________________

Konstantin K. KABASSANOV 
Research and Development Engineer

LIP6 Laboratory
Pierre and Marie Curie University

8, rue du Capitaine Scott,
75015 Paris, France

Phone: +33 (0) 1 44 27 71 26
Fax:   +33 (0) 1 44 27 74 95

E-mail: [email-masked]
Web: http://www.kabassanov.com
______________________________________________________

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Marshall Eubanks
> Sent: jeudi 6 février 2003 16:48
> To: Bill Fenner
> Cc: MAGMA List
> Subject: [magma] Free BSD IGMP v3
> 
> Hello;
>

---

From: "Konstantin KABASSANOV" <[email-masked]>
Date: Thu, 6 Feb 2003 16:57:45 +0100

Hi,

Konstantin

Konstantin K. KABASSANOV 

LIP6 Laboratory

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 6 Feb 2003 11:10:48 -0500

Thanks!

With that hint I found this (for the record) :

To: [email-masked]
*	Subject: ReMIME-Version: 1.0 (generated by SEMI 1.14.3 - "Ushinoya")
*	From: [email-masked]
*	Date: Wed, 24 Jul 2002 02:38:22 -0400 (EDT)

------------------------------------------------------------------------

Just FYI.

 >>>>> On Tue, 9 Jul 2002 05:50:37 -0400 (EDT)
 >>>>> [email-masked] said:

 > > Note that unix IGMPv3 support is currently available for
 > > FreeBSD only. Solaris and Linux don't support IGMPv3.
 >
 > It may be better to announce it here as well.
 >
 > IGMPv3 host-side kernel implementation for NetBSD-current has been
 > available.
 >
 > <http://www-sop.inria.fr/planete/Hitoshi.Asaeda/igmpv3>

The above patch is merged into the KAME snaps (NetBSD and FreeBSD-4)
from this week.

If you'd like to use it, please get the snap from the following URL
and rebuild the kernel with "IGMPV3" config option (it is disabled by
default).
	ftp://ftp.kame.net/pub/kame/snap/kame-20020722-netbsd152-snap.tgz
	ftp://ftp.kame.net/pub/kame/snap/kame-20020722-freebsd46-snap.tgz
		(ported the above NetBSD implementation into FreeBSD)

Thanks,
----
SUZUKI, Shinsuke @ KAME Project

> There is an implementation available in KAME snaps.
                                  Regards
                                  Marshall Eubanks

T.M. Eubanks

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 6 Feb 2003 11:10:48 -0500

Thanks!

Just FYI.

Thanks,
----

                                  Regards
                                  Marshall Eubanks

T.M. Eubanks

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Thu, 06 Feb 2003 18:17:18 +0100

>   http://www.multicasttech.com/status/index.html

i have a copy of patches for FreeBSD 4.2 on my web page:
http://www.loria.fr/~lahmadi/

---

From: Abdelkader Lahmadi <[email-masked]>
Date: Thu, 06 Feb 2003 18:17:18 +0100