Subject: [magma] Re: magma digest, Vol 1 #181 - 1 msg

From: Ronan Kelly <[email-masked]>
Date: Thu, 16 Oct 2003 17:24:18 +0100

Below is an extract from a question I recently asked of another router 
vendor.
I think it details what you are running into.
Hope it helps!

Ronan

At the INEX (Irish Neutral Exchange), all the routers are interconnected 
by a L2 switch.
There are no clients attached to the switch, only routers.
If we do not use IGMP snooping on the switch, the switch will flood all 
the multicast traffic it receives.
This will work, but its not ideal.
If we use IGMP snooping, a problem occurs. The down stream router 
wishing to receive a stream will send a PIM Join to 224.0.0.13.
It wont send an IGMP membership report.
The upstream router will receive the join request and proceed to send 
the stream.
The switch will not have received any IGMP membership reports for that 
stream and will correctly drop it.

To get around this Cisco use RGMP RFC3488.

[email-masked] wrote:

>Send magma mailing list submissions to
>	[email-masked]
>
>To subscribe or unsubscribe via the World Wide Web, visit
>	https://www1.ietf.org/mailman/listinfo/magma
>or, via email, send a message with subject or body 'help' to
>	[email-masked]
>
>You can reach the person managing the list at
>	[email-masked]
>
>When replying, please edit your Subject line so it is more specific
>than "Re: Contents of magma digest..."
>
>
>Today's Topics:
>
>   1. IGMPv2 Snooping and Border routers environment ([email-masked])
>
>--__--__--
>
>Message: 1
>From: [email-masked]
>Date: Thu, 16 Oct 2003 10:31:54 +0200
>To: [email-masked]
>Subject: [magma] IGMPv2 Snooping and Border routers environment
>
>Probably it is a problem already solved or discussed.
>
>Using a HP 2524 switch and configuring IGMP snooping as usual.
>The switch is connected only to routers at the borders of 4 different domain.
>
>Multicast traffic between two domains is forwarded by the switch on every port
>connected. That is broadcast.
>IGMP group is not recorded in the switch memory to let this snoop.
>
>
>
>
>Is there something I am missing or this kind of environment could not be used
>for multicast?
>
>------------------------------------------------
>This mail sent through Caspur Webmail powered by
>IMP (http://horde.org/imp/)
>
>
>
>--__--__--
>
>_______________________________________________
>magma mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/magma
>
>
>End of magma Digest
>
>  
>

-- 
Ronan Kelly,   (CCNP, JNCIA) 
HEAnet Ltd, 
Brooklawn House, 
Shelbourne Rd, 
Dublin 4. 
Email:[email-masked], 
Phone +353 (0)1 6609040, 
FAX +353 (0)1 6603666

---

From: Ronan Kelly <[email-masked]>
Date: Thu, 16 Oct 2003 17:24:18 +0100

Ronan