Subject: [magma] I-D ACTION:draft-ietf-magma-mgmd-mib-01.txt

From: [email-masked]
Date: Tue, 28 Oct 2003 15:42:31 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multicast & Anycast Group Membership Working Group of the IETF.

	Title		: Multicast Group Membership Discovery MIB
	Author(s)	: J. Chesterfield
	Filename	: draft-ietf-magma-mgmd-mib-01.txt
	Pages		: 30
	Date		: 2003-10-28
	
This memo defines a portion of the Management Information Base (MIB) 
for use with network management protocols in the Internet community. 
In particular, it describes objects used for managing the Internet  
Group Management Protocol (IGMP) and the Multicast Listener 
Discovery (MLD) protocol.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-magma-mgmd-mib-01.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-magma-mgmd-mib-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-magma-mgmd-mib-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Samanvitha Rao <[email-masked]>
Date: Thu, 30 Oct 2003 11:41:24 -0800

Hello,

I had some comments/questions:

** mgmdHostInterfaceStatus OBJECT-TYPE
- description is missing in this version.

** mgmdHostInterfaceVersion OBJECT-TYPE
- The version running on the interface is
min(configured_version, querier_version)
- The version running can be inferred as IGMPv1 if
mgmdHostInterfaceVersion1QuerierTimer is non-zero,
- IGMPv2 or MLDv1 if mgmdHostInterfaceVersion2QuerierTimer
is non-zero.
- Else its the same as the configured value.
If this is the case the description can say
"The version of MGMD which is configured on this interface."

** mgmdRouterInterfaceVersion OBJECT-TYPE
    DESCRIPTION
            "The version of MGMD which is running on this interface.
            Value 1 applies to IGMPv1 routers only. Value 2 applies
            To IGMPv2 and MLDv1 routers, and value 3 applies to IGMPv3
            and MLDv2 hosts.
                      ^^^^^^ should be routers.

** mgmdRouterInterfaceQueryMaxResponseTime OBJECT-TYPE
** mgmdRouterInterfaceRobustness OBJECT-TYPE
** mgmdRouterInterfaceLastMembQueryIntvl OBJECT-TYPE
SYNTAX     Unsigned32 (0..255)
- Why are these range of values suggested?

** mgmdHostCacheStatus OBJECT-TYPE
    SYNTAX     RowStatus
    MAX-ACCESS read-create
    STATUS     current
    DESCRIPTION
            "The status of this entry."
    ::= { mgmdHostCacheEntry 5 }
- Not sure what the above means?

** Since we have a mgmdRouterCacheUpTime object
should we also have a mgmdHostCacheUpTime object?

** mgmdRouterCacheExpiryTime OBJECT-TYPE
    DESCRIPTION
            "The minimum amount of time remaining before this entry
            will be aged out.  A value of 0 indicates that the entry is
            only present because mgmdRouterCacheSelf is true and that if the
- I believe mgmdRouterCacheSelf was removed from the spec. So we should
not refer to it.

** mgmdRouterCacheStatus OBJECT-TYPE
    SYNTAX     RowStatus
    MAX-ACCESS read-create
    STATUS     current
    DESCRIPTION
            "The status of this entry."
    ::= { mgmdRouterCacheEntry 7 }
- Not sure what this is?

** mgmdHostSrcListHostAddress OBJECT-TYPE
    SYNTAX     InetAddress
    MAX-ACCESS not-accessible
    STATUS     current
    DESCRIPTION
            "The host address to which this entry
            corresponds. The HostCacheSourceFilterMode value for this Group
- Can change this to mgmdHostCacheSourceFilterMode

** mgmdRouterSrcListHostAddress OBJECT-TYPE
    SYNTAX     InetAddress
    MAX-ACCESS not-accessible
    STATUS     current
    DESCRIPTION
            "The host address to which this entry
            corresponds. The RouterCacheSourceFilterMode value for this 
Group
- Can change to mgmdRouterCacheSourceFilterMode

** mgmdMldV2HostMIBCompliance MODULE-COMPLIANCE
** mgmdMldV2RouterMIBCompliance MODULE-COMPLIANCE
- Typo.. MLDv2 hosts must support the IPv6 address type.

** 5. Security Considerations

   This MIB contains readable objects whose values provide information
   related to multicast sessions.  Some of these objects could contain
   sensitive information.  In particular, the mgmdCacheSelf and
- I believe mgmdCacheSelf Object was removed. So references to
it should also be removed.

Thanks,
Sam

>implementation to automatically retrieve the ASCII version of the

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Samanvitha Rao <[email-masked]>
Date: Thu, 30 Oct 2003 11:41:24 -0800

Hello,

Thanks,
Sam