Subject: [magma] Fw: IGMP V2 (RFC2236) clarification

From: "Theodoros Kallimanis" <[email-masked]>
Date: Tue, 14 Oct 2003 11:50:46 +0300

----- Original Message ----- 
From: Theodoros Kallimanis 
To: [email-masked] 
Sent: Tuesday, October 14, 2003 11:44 AM
Subject: Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis 
To: [email-masked] ; [email-masked] 
Sent: Tuesday, October 14, 2003 11:41 AM
Subject: IGMP V2 (RFC2236) clarification

Hello,

I will appreciate a lot if you can clarify a point in IGMP V2 RFC 2236. In the protocol description (ch. 3) the following phrase is mentioned:

" When a host joins a multicast group, it should immediately transmit an unsolicited Version 2 Membership Report for that group, in case it is the first member of that group on the network"

The phrase refers actually to the original join of the group by a non-memebr host. The undelined part of the phrase is the part where I need a clarification. How the "non-member" host can identify that it is the first member of the group? At the state machine diagram at chapter 6 / page 10, no reception of "join group" is shown at Non-Member state. The text at chapter 3 indicates that the Membership Report is sent immediately, so it is assumed that no response delay exists in the case of the initial membership reports sending. Can you clarify please if this is a valid point on the RFC and if it is how this is supposed to be realized?

Best Regards and thanks in advance for the assistance
================================
    Theodoros Kallimanis
     Systems and SW engineer
     INTRACOM SA
     Dept "Access & Transmission"
     tel : +30-210-6671961
================================

---

From: "Theodoros Kallimanis" <[email-masked]>
Date: Tue, 14 Oct 2003 11:50:46 +0300

----- Original Message ----- 
From: Theodoros Kallimanis 
To: [email-masked] 
Sent: Tuesday, October 14, 2003 11:44 AM
Subject: Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis 
To: [email-masked] ; [email-masked] 
Sent: Tuesday, October 14, 2003 11:41 AM
Subject: IGMP V2 (RFC2236) clarification

Hello,

---

From: "Sellers, Julian P" <[email-masked]>
Date: Tue, 14 Oct 2003 10:00:49 -0500

This is an English language problem.  In common usage (in the U.S., at
least), "in case..." does not mean "if...".  It means "to cover or account
for the case that...".
 
Julian

-----Original Message-----
From: Theodoros Kallimanis [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 3:51 AM
To: [email-masked]
Subject: [magma] Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  
Sent: Tuesday, October 14, 2003 11:44 AM
Subject: Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  
Sent: Tuesday, October 14, 2003 11:41 AM
Subject: IGMP V2 (RFC2236) clarification

Hello,
 
I will appreciate a lot if you can clarify a point in IGMP V2 RFC 2236. In
the protocol description (ch. 3) the following phrase is mentioned:
 
" When a host joins a multicast group, it should immediately transmit an
unsolicited Version 2 Membership Report for that group, in case it is the
first member of that group on the network"
 
The phrase refers actually to the original join of the group by a non-memebr
host. The undelined part of the phrase is the part where I need a
clarification. How the "non-member" host can identify that it is the first
member of the group?

---

From: "Sellers, Julian P" <[email-masked]>
Date: Tue, 14 Oct 2003 10:00:49 -0500

Julian

-----Original Message-----
From: Theodoros Kallimanis [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 3:51 AM
To: [email-masked]
Subject: [magma] Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  
Sent: Tuesday, October 14, 2003 11:44 AM
Subject: Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  ; [email-masked]

Hello,

---

From: [email-masked]
Date: Wed, 15 Oct 2003 12:57:58 +0300

Exactly, so it's not required that the host knows whether or not it is the first host.
 
In a way, it would be useful to be able to detect other members first and decide not to send a report upon the join - in the same way solicited reports, generally, only come from the flag holder. This way massive subnets (10's of thousands - e.g. single cell wireless sports event crowd) don't necessarily throw up a join explosion - especially for many sessions during and event. Of course 'should' allows this, but does anyone see any problems doing it this way? (In addition to extended 'waiting' time if the host is actually the first).
 
Cheers, Rod.

-----Original Message-----
From: ext Sellers, Julian P [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 6:01 PM
To: 'Theodoros Kallimanis'
Cc: [email-masked]'
Subject: RE: [magma] Fw: IGMP V2 (RFC2236) clarification

This is an English language problem.  In common usage (in the U.S., at least), "in case..." does not mean "if...".  It means "to cover or account for the case that...".
 
Julian

-----Original Message-----
From: Theodoros Kallimanis [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 3:51 AM
To: [email-masked]
Subject: [magma] Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] 
Sent: Tuesday, October 14, 2003 11:44 AM
Subject: Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] ; [email-masked] 
Sent: Tuesday, October 14, 2003 11:41 AM
Subject: IGMP V2 (RFC2236) clarification

Hello,

 
The phrase refers actually to the original join of the group by a non-memebr host. The undelined part of the phrase is the part where I need a clarification. How the "non-member" host can identify that it is the first member of the group?

---

From: [email-masked]
Date: Wed, 15 Oct 2003 12:57:58 +0300

Cheers, Rod.

-----Original Message-----
From: ext Sellers, Julian P [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 6:01 PM
To: 'Theodoros Kallimanis'
Cc: [email-masked]'
Subject: RE: [magma] Fw: IGMP V2 (RFC2236) clarification

Julian

-----Original Message-----
From: Theodoros Kallimanis [mailto:[email-masked]]
Sent: Tuesday, October 14, 2003 3:51 AM
To: [email-masked]
Subject: [magma] Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] 
Sent: Tuesday, October 14, 2003 11:44 AM
Subject: Fw: IGMP V2 (RFC2236) clarification

----- Original Message ----- 
From: Theodoros Kallimanis <mailto:[email-masked]>  
To: [email-masked] ; [email-masked] 
Sent: Tuesday, October 14, 2003 11:41 AM
Subject: IGMP V2 (RFC2236) clarification

Hello,