Subject: [magma] Question about snooping switches

From: [email-masked]
Date: Wed, 13 Oct 2004 13:53:23 -0400

Pardon me if this isn't the right place to ask this.  I've just discovered "Considerations for IGMP and MLD Snooping Switches" and I'm looking for someone to help me confirm my understanding of it.

I know it says that "discussions are examples only and there may well be other ways to achieve the same functionality" but I'm trying to get my head around *one* way to "achieve the .. functionality".

That said, after reading the Considerations several times, it appears to me that a snooping switch operates a great deal like a proper IGMP router in many cases and I'm trying to mentally model such a switch by how it differs from an IGMP router.

Looking at the STD on page 16 of RFC 2236, it seems to me that a snooping switch will follow _exactly_ this STD on each port with the following definitions:

   "notify routing +" sends a proxy Report (source IP 0.0.0.0) 
    to all ports on which routers have been detected.

   "notify routing -" sends a proxy Leave to all ports on 
   which routers have been detected IF no hosts for this 
   group are present on any other ports.

Does that sound right or am I way off base?

                               Chris

P.S. If this isn't the place for this question, can you recommend another list or newsgroup?  Thanks.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Wed, 13 Oct 2004 14:27:43 -0400

Sounds about right to me. "Notify routing" becomes more "notify routers," because the snooping switches won't themsleves be running a multicast routing protocol.

Also, the switches can "route" the multicasts to switch ports based on the MAC group address derived from the IP multicast address, optionally, rather than using the IP address.

This topic came up recently in comp.dcom.lans.ethernet, which is a reasoably active news group.

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 13, 2004 12:53 PM
> To: [email-masked]
> Subject: [magma] Question about snooping switches
> 
> 
> Pardon me if this isn't the right place to ask this.  I've 
> just discovered "Considerations for IGMP and MLD Snooping 
> Switches" and I'm looking for someone to help me confirm my 
> understanding of it.
> 
> I know it says that "discussions are examples only and there 
> may well be other ways to achieve the same functionality" but 
> I'm trying to get my head around *one* way to "achieve the .. 
> functionality".
> 
> That said, after reading the Considerations several times, it 
> appears to me that a snooping switch operates a great deal 
> like a proper IGMP router in many cases and I'm trying to 
> mentally model such a switch by how it differs from an IGMP router.
> 
> Looking at the STD on page 16 of RFC 2236, it seems to me 
> that a snooping switch will follow _exactly_ this STD on each 
> port with the following definitions:
> 
> P.S. If this isn't the place for this question, can you 
> recommend another list or newsgroup?  Thanks.