Subject: [magma] Picking a multicast address

From: [email-masked]
Date: Fri, 29 Oct 2004 13:02:31 -0400

I'm sorry if this is a little off topic.  I know folks on this list are knowledgable about multicast and I'm hoping someone can point me to a reference or resource to help me solve my problem.

I'm building a network of fairly stupid devices.  Most if not all communication with them will be via MAC-addressable frames.  They aren't big or smart enough to have an IP stack, complex, heavy-weight discovery protocols, etc.  BUT, I also need 'Windows-based tools to be able to reach these devices and _that_ is facilitated by writing to a multicast _IP_ address and letting the stack just do the normal thing of mapping that IP into a multicast MAC address.  

The problem I have is picking the multicast IP address.  I know some are reseerved (all hosts, all routers, etc.) and I know there are protocols for having one assigned dynamically on a network at run time.  But, as I said, these devices are too stupid to negotiate for that assignment.  Is there one or more multicast IP addresses that are intended to be used like network 10 (10.192.x.x, 10.168.x.x, etc.) for local, private communication?

Thanks for any pointers.

                             Chris

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Miguel Angel Rodríguez Jódar <[email-masked]>
Date: Fri, 29 Oct 2004 19:49:46 +0200

> too stupid to negotiate for that assignment.  Is there one or 
> more multicast IP addresses that are intended to be used like 
> network 10 (10.192.x.x, 10.168.x.x, etc.) for local, private 
> communication?

According to IANA, the range from 239.128.0.0 through 239.255.255.255 can be
used to local mcast communications. However, it's possible to use any
class-D address if you take care of setting the TTL field of your packets to
no more than 2.

--
Miguel Angel Rodriguez Jodar | http://icaro.eii.us.es
Departamento de Arquitectura y Tecnologia de Computadores
Universidad de Sevilla
Spain

---

From: Miguel Angel Rodríguez Jódar <[email-masked]>
Date: Fri, 29 Oct 2004 19:50:47 +0200

BTW, this white paper may help you:
http://www.enterasys.com/products/whitepapers/deploy-ip/

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 29 Oct 2004 14:39:04 -0400

Hello;

You have three basic options :

Use your  GLOP address space, if you want them to be globally accessible.

Use SSM and use the 232.0.0.0/8 address space, and ignore what others are doing.
But, in this case, you will need to send each source's IP address to
every receiver.

Use the 239.0.0.0/8 address space. This is the multicast analogue of
the 10.0.0.0 / 8 address space,
and you can do what you want - subject to policy in your AS.

RFC 3171 gives a complete overview
http://www.apps.ietf.org/rfc/rfc3171.html

BTW, you might want to limit the TTL's of your multicasts if you
really intend this to be limited to
the LAN. A TTL of 1 ot 2 would help keep things limited if the
filtering is messed up.

Regards
Marshall Eubanks

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 29 Oct 2004 14:50:24 -0400

One more thing - if your app will have high bandwidth, you should pay
attention to the
"unusable" addresses, where your data could interfer with various
control traffic.

Look at 
http://www.ietf.org/proceedings/03nov/I-D/draft-ietf-mboned-ipv4-mcast-unusable-00.txt
for more details.

Regards
Marshall