Subject: RE: [magma] Multipoint-to-multipoint PIM-SM

From: "Tiago Duarte (Ext_PDM&FC LDA)" <[email-masked]>
Date: Thu, 18 Nov 2004 16:41:56 -0000

> 
> 1) You could have continuous presence for all speakers - that 
> is everyone
> sees everyone else all of the time.
> 
> In PIM_SM (ASM), all you need is one group address (*,G), and 
> each site
> simply sends their video bit stream to their upstream router with the
> address of the Group and Join the Group to receive. Receivers 
> join to the
> Group, and then as the network discovers the sources for each 
> group, joins
> each in turn (Sn,G).
	
	The point is, if the receivers starts to use source trees, how
they discover new senders? If they just prune (*,G) and join all (Sn,G).

> 2) You could have a single video stream which combines the 
> video from all
> speakers - that is everyone sends to a specific address in the network
> (could be unicast) and at this address a 
> multipoint-control-unit merges the
> bit-streams in some sensible fashion. It could select a 
> source, e.g. Based
> on who is speaking, on a floor-control protocol, or insert 
> one video stream
> into a window in another using transcoding  - this is an 
> application, you
> may also wish to do this to mute the mike of other participants, do
> echo-cancellation, etc. This would be much more attractive 
> for large groups.

	This is a good point, but is not suitable for large groups (I
would like to know how many people is a large group! 50? 200? How many
person have one United Nations meeting).

Tiago Duarte
........................................................................
.
SIEMENS

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 18 Nov 2004 12:23:36 -0500

> they discover new senders? If they just prune (*,G) and join all (Sn,G).

Read the PIM spec. That is the network's job. (Although RTP or some other
higher level protocol is needed to keep things sorted out.

> person have one United Nations meeting).

A few hundred locations is a large conference. 

Marshall