Subject: RE: NTDR multicast

From: Chip Elliott <[email-masked]>
Date: Thu, 18 Jun 1998 19:33:20 -0400

Hi Bill,

Aha. The answer to your question is a resounding "I don't know".
I'm travelling right now, but will send email to the relevant
gurus and see if I can dig up the answer.

Our general approach is "the NTDR net looks like an Ethernet"
(although a very big one). What do the standard IP protocols
do in this case -- do they suppress redundant datagrams, or no?
I don't recall any IP protocol that would trim away that
redundancy, but my knowledge in this area is very imperfect.

Rest of folks on list -- should we take this offline? It has
some relation to general "ad hoc" questions, but it's getting
kind of tenuous. If you prefer silence, please tell me (and not
the list) and we'll go offline.

Cheers,

-- Chip

At 08:39 AM 6/18/98 -0400, Wollman, William wrote:
>Sorry.  I was in a bit of rush when I saw your e-mail and decided to ask
>the question.
>
>Basically, imagine four NTDRs on one common RF network.  Assume the
>interface to the NTDR is Ethernet.  Two NTDRs are attached
>to the same Ethernet segment -- common subnet X.  The other two are
>attached
>to a separate common Ethernet segment  -- subnet Y.  A host on subnet Y
>joins multicast group D.  The two NTDRs on subnet Y forward the join
>information
>to the NTDRs on subnet X.  (I am under impression this happens today
>with the NTDR).
>A host on subnet X generates a multicast datagram for group D.  The two
>NTDRs on subnet X receive the multicast datagram.
>They both forward the datagram  (2 copies sent across the RF media)
>toward
>the NTDRs attached to subnet Y.  The NTDRs on subnet X should recognize
>the duplicate data 
>possibly by performing reverse path forwarding check on the source IP
>address -- and then one of them will broadcast on the RF media to the
>other that it will forward the data for group D and  that specific
>source.  One NTDR asserts itself as the forwarder for that source on
>group D.  
>
>My question is will the NTDR do this or something similar to suppress
>the forwarding
>of duplicate multicast datagrams?
>
>Thanks for any info,
>  Bill Wollman
>
>> ----------
>> From: 	[email-masked][SMTP:[email-masked]]
>> Sent: 	Tuesday, June 16, 1998 5:48 PM
>> To: 	[email-masked]
>> Cc: 	[email-masked]; [email-masked]
>> Subject: 	NTDR multicast
>> 
>> Hi Bill,
>> 
>> I'm embarassed to say that I don't understand the question.
>> 
>> What does "Multicast source,group asserts" mean? Maybe I'd
>> understand better if you rephrased the whole question, spelling
>> things out more fully.
>> 
>> I'll answer to the best of my ability, but it would
>> probably be wiser to understand the question first!
>> 
>> Cheers,
>> 
>> Chip
>> 
>> At 04:58 PM 6/16/98 -0400, you wrote:
>> >We were having some discussion about NTDR and IP multicasting.  Does
>> the
>> >NTDR support Multicast source,group asserts on the common broadcast
>> >media when more than one NTDR forwards the same multicast datagram
>> >into the NTDR RF media??  Our current guess is no.
>> >
>> >Thanks for any info,
>> >  Bill Wollman
>> >
>> 
>> 
>

---

From: Jacob Sharony <[email-masked]>
Date: Thu, 18 Jun 1998 22:18:25 -0400

Chip, Bill,

Assuming the NTDR supports Multicast IP (almost every new router today has a multicast IP capability), there may be no problem. Referring to Bill's scenario, when a host R on subnet Y desires to join multicast group D it transmits Internet Group Management Protocol (IGMP) packets which are captured by the routers (NTDR's in our case). Accordingly, the routers will form a multicast TREE with the source host S on subnet X being the root and one of the leaves is the receiver host R on subnet Y, therefore, no duplication of packets. *Note* that since the routers (NTDR's) may be within hearing distance from one another (full connectivity) some form of link activation may be required (superimposing a logical connectivity over the physical connectivity) so that not every router that receives (physically) a datagram will forward it. 
I think the subject discussion belongs to this group since multicast routing/services over ad hoc nets is a practical case.

Regards,

Jacob

>> Chip Elliott <[email-masked]> 06/18 7:33 PM >>>

Hi Bill,

Cheers,

-- Chip

>of duplicate multicast datagrams?
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                          !
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                          !