Subject: Re: I-D ACTION:draft-ietf-manet-aodv-02

From: "Crazy Fingers" <[email-masked]>
Date: Tue, 24 Nov 1998 14:05:01 -0500 (EST)

Could someone please summarize the additions/deletions in this new version of
the AODV ? 
Thank you, 
Arvind 

===============================================================================
Commit random acts of kindness and senseless beauty -- seen on a VW van. 
===============================================================================
Arvind R Raghavan                                     [email-masked]
Wireless Communications                               (864) 653 9498 (Res) 
Electrical & Computer Engineering                     (864) 656 5903 (Off) 
Clemson University									  (864) 656 7856 (Lab)
_______________________________________________________________________________

---

From: Charles Perkins <[email-masked]>
Date: Tue, 24 Nov 1998 12:23:09 -0800 (PST)

Arvind,

I'll take a stab at it.

1) New extensions for some QoS (bandwidth, delay)

2) Reducing or eliminating use of "hello" messages.

3) Specifying a "prefix length" field for RREQs, to allow
   mobile subnets, and ...

4) ... thus, a way to insert an ad hoc network as a transit
   network between two other routing domains.

5) Multicast improvements

6) Updates to parameter values to reflect recent simulation
   experience.

7) Rename MINV to MACT (multicast activation) to more correctly
   reflect the function of the protocol message.

AODV isn't quite done yet, but the last draft does represent
a significant step forward.  There is one thing that needs to
be changed, regarding the frequency at which a node is required
to listen for retransmission from its neighbor.  I'll try to
make that clear during our presentation at the IETF meeting
in Orlando.

Regards,
Charlie P.

PS. As always, comments are most welcome.

---

From: Charles Perkins <[email-masked]>
Date: Tue, 24 Nov 1998 12:30:03 -0800 (PST)

Arvind,

Unfortunately, I made a typo in my response.

>    mobile subnets, and ...                ^^^^

This should have been "RREPs".

Regards,
Charlie P.