Subject: ad hoc routing,and Bluetooth

From: Dmitri Deshun Perkins <[email-masked]>
Date: Mon, 24 Apr 2000 12:29:23 -0400 (EDT)

Hello,

I a PhD student in the initial stages (literature review, etc) of my work
and have read much of the work(routing protocols) in the MANET WG. I am
very interested in pursuing this area as a research focus.

I have also read many of the articles concerning the Bluetooth technology.

Although I am fairly new to this area, it seems to me (I could be 
mistaken) that the MANET work and the Bluetooth work are somehow
complimentary (at least conceptually). Is there anyone who can comment on
(or point me to arcticles that discuss) how/if ad hoc routing is related
to or can be used in a "Bluetooth environment"?

Please excuse and inform me if these questions are inappropriate for
this forum.

Thanks for your time and patience,
D. Perkins

---

From: Hongyi Wu <[email-masked]>
Date: Mon, 24 Apr 2000 14:13:31 -0400 (EDT)

Hi, Dmitri :

I am a Ph.D student too. Based on my understanding, Bluetooth is a special
Ad-Hoc network, which has very low mobility and normally short 
transmission range. You may find a lot of interesting information on
http://www.bluetooth.com/.

> Thanks for your time and patience,

------------------------------------------------------------------------
Hongyi Wu
Phone: (716) 832-4572 
E-mail: [email-masked] 
URL: http://www.cse.buffalo.edu/~hongyiwu
------------------------------------------------------------------------

---

From: Miguel Sanchez <[email-masked]>
Date: Mon, 24 Apr 2000 20:55:21 +0200

Hi Dmitri,

Just as a personal opinion, I do not think MANET and Bluetooth are very much
complementary although other people can think  the opossite. From the initial
statement of each technology:
1) Manet: networks made of set of nodes that act as routers too and use IP
protocol stack(we are at IETF after all).
2) Bluetooth: Radio technology to "cut the cord" intended for PDAs,
cellphones and the like.

Ok, you can, theoretically build something resemling a MANET with physical
and MAC layers of Bluetooth networks. In fact what can make Bluetooth
attractive is the expected very low cost of radio transceivers. But remember,
Bluetooth is intended to 10 meters of coverage (and up to 100 meters with
some power extended mode ...?). However, I think that 10 meters of
transmission range is  too low for most of the MANET applications and the
Bluetooth MAC level can imposse some limitations too.

Some weeks ago it was discussed on the list this same topic. If you cannot
access to previous postings I think that authors can send you a copy.
Best wishes,

Miguel Sanchez
Universidad Politecnica de Valencia (Spain)

PS: Sorry, I see I'm not answering your question, however I thought you also
wanted some comments and this is my two cents one.

---

From: Phil Neumiller <[email-masked]>
Date: Mon, 24 Apr 2000 14:17:35 -0500

Perhaps, by low mobility you really mean low velocity of the personal terminal devices.
(Although this may not be the case for a network flying around in an airplane).  In the
case of the Internet world, inter-domain mobility is usually referred to as macro-mobility
and this would map more or less macro-cellular wireless systems.  Micro-mobility (or maybe
its called Edge-mobility these days) refers to intra-domain mobility which allows host
based forwarding.

You might also be interested in:

http://search.ietf.org/internet-drafts/draft-oneill-ema-01.txt

Which discusses: Mobile IP, Cellular IP, and HAWAII

Personal area networking (PAN) equipment may indeed have many more re-associations or
"handovers" than classic cell phones due to the tiny physical size of the networks so
its a matter of perspective of whether its highly mobile or not.  We could call this
pico-mobility but I'll probably get yelled at by somebody who uses this term for
something else.  

I think the MANET work has an incredible amount to offer Bluetooth and Bluetooth can
can act as a MANET testbed.  However, I would hate to see MANET be developed just for
Bluetooth though, and MANET must strive to be air interface agnostic as much as possible.

---

From: kyrah <[email-masked]>
Date: Tue, 25 Apr 2000 01:03:41 +0200 (CEST)

hello,

	one other thing comes to my mind when we are discussing bluetooth and manet.... how does Jini fit in here? i mean, i am currently working on a project where we develop a prototype of a bluetooth based ad-hoc network where the network nodes communicate using Jini. has anybody had any experience in combining these technologies?! 

best regards,

	kyrah / karin kosina

+----------------------------------------------------------------------
 "Calm down. It's only ones and zeros." -- Sam Kass

 karin kosina (kyrah) 
 http://the.system.at
                                             +-------------------+
                                             | .*n[ui]x rulez!   |
                                             +-------------------+

---

From: Joe Macker <[email-masked]>
Date: Tue, 25 Apr 2000 10:29:06 -0400

>Bluetooth MAC level can imposse some limitations too.

Miguel:

I believe short range and low cost opens up more possibilities for manet 
solutions not the other way around.  There is a more economic possibility 
of having a mesh of devices with associated dynamics (not just from 
motion).  If you envision interconnecting a set of heterogeneous wireless 
devices things get even more interesting.  The proliferation of 
Bluetooth-like technology will certainly occur and continue to evolve.