Subject: RE: Source sequence number

From: "ck Toh" <[email-masked]>
Date: Wed, 05 Jul 2000 14:45:55 GMT

Charlie:

Perhaps you should just confirm this:

Source sequence no. is used by the source during
transmission of route request message. This signifies
the "freshness" of the request associated with this
particular desired route.

Destination sequence number is created by the
receiver to confirm the "validity and freshness"
of the selected route.

How does that sound?

C.K.

>From: "Samir R. Das" <[email-masked]>
>To: "SSDP143" <[email-masked]>,        "mobile adhoc group" 
><[email-masked]>
>Subject: RE: Source sequence number
>Date: Tue, 4 Jul 2000 09:02:57 -0400
>
>Hi,
>
>I assume that your question relates to AODV.
>
>Source sequence number is the sequence number of the source node. Each node
>X maintains a sequence number for itself. See Charlie's last email about 
>the
>details how sequence numbers are maintained. Sequence numbers serve 
>somewhat
>similar purpose as logical clocks, if you are familiar with the latter
>concept.
>
>The terms "destination sequence number" or "source sequence number" are
>contextual. For example, if a node Y sends out an RREQ for a route to X, it
>includes its own current sequence number in the RREQ message as well as the
>last known sequence number of node X. Since node Y is the source and node X
>is the destination, Y's sequence number is called the source sequence 
>number
>and X's sequence number is called the destination sequence number.
>
>Hope this helps,
>
>Samir
>
>
> >-----Original Message-----
> >From: [email-masked]
> >[mailto:[email-masked]]On Behalf Of SSDP143
> >Sent: Tuesday, July 04, 2000 5:36 AM
> >To: mobile adhoc group
> >Subject: Source sequence number
> >
> >
> >Hi
> >what is the main goal of using the source sequence number, and is it a
> >fixed number for each node? and if so, what is the basis on which a  node
> >decides it's source seq number?
> >thanks
> >
>

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 05 Jul 2000 09:48:53 -0700

Hello C-K.,

> particular desired route.

The source sequence number causes reverse routes back
to the source to be tagged appropriately at each
intermediate node, for purposes (at least!) of delivering
the RREP back to the source of the RREQ.

The destination sequence number causes prevents an
intermediate node from responding unless it has "fresher"
information about a route to the destination (i.e.,
a route tagged with a bigger sequence number).

The two sequence numbers are associated with route
table entries for two different nodes, and actually
are used somewhat differently (one _enabling_ the
insertion of a new route table entry for the source,
the other _disabling_ the reporting of old route table
information for the destination).

Regards,
Charlie P.