Subject: Please help with ad hoc network simulation with NS

From: Manish Kochhal <[email-masked]>
Date: Thu, 20 Jul 2000 17:33:25 -0400 (EDT)

hi!

I am Manish Kochhal pursuing my MS + PHD in Wayne State University .....I am 
stuck with the simulation of Mobile Ad hoc Networks Routing Protocols....

I have some questions:

1. Does the current version of ns ie ns-2.1b6 supports mobile ad hoc network 
routing protocol simulation.....Does it have CBT ( core based tree ) as its 
routing protocol, if not then which routing protocol does it  support...

2. Are u aware of any Reference material which would serve as a guidance for me 
in order to simulate Ad hoc networks.....Is Marc Greis Tutorial Sufficient 
enough, particularly the CMU Monarch Wireless extensions to NS

3. If current version of NS doesnt support any Mobile Ad hoc Network Simulation 
this implies that I have to virtually create the Test Bed for my simulation from 
the scratch.....Are u aware of any software which has implemented NS for MANET 
and can u send me the link of that Software for NS.....

Awaiting for ur suggestions

Thanks in advance

Sincerely
Manish

*******************************************************
*                                                     *
* Name         : Manish M Kochhal                     *
*                                                     *
* Address      : 5200 Anthony Wayne Drive             *
*                Apt #1312, De Roy Apartments         *
*                Detroit , MI 48202                   *
*                USA.                                 *
*                                                     *
* Phone Number : 313 832 1724 (Home)                  *
*                313 577 5802 (Work)                  *
*                                                     *
* email        : [email-masked]    *
*                [email-masked]                *
*                [email-masked]           *
*                                                     *
+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=*
*   We receive three educations:                      *
*   one from our parents, one from our schoolmaster,  *
*   and one from the world.                           *
*                                                     *
*   The third contradicts all that the first two teach*
*   us                                                *
*                      - Baron de Montesquieu         *
*                                                     *
*******************************************************

---

From: Shiyi Wus <[email-masked]>
Date: Fri, 21 Jul 2000 09:51:26 +0200

We can find four routing protocol are implemented in ns-2.1b6, they are DSDV, 
DSR, TORA, AODV. Of course you can realise your routing protocol in ns. The 
extensions has been added to cmu model in order to  simulate both wired and 
wireless nodes. You can find this information in the NS's document: ns Notes 
and Documentation.

Best Regards
Shiyi

---

From: Zygmunt Haas <[email-masked]>
Date: Fri, 21 Jul 2000 07:09:30 -0400 (EDT)

Hi Shiyi,

The ZRP protocol is being currently implemented in ns as well. We expect
the implementation to be completed within the next month or so.

Zygmunt.
==---==-===
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    tel: +1-607-255-3454
Wireless Networks Laboratory		                  
School of Electrical Engineering         fax: +1-607-255-9072 
Cornell University
323 Frank Rhodes Hall			 e-mail: [email-masked]
Ithaca, NY 14853			 
U.S.A                             http://www.ee.cornell.edu/~haas/wnl.html
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-