Subject: Local repair in AODV

From: Kubinszky Ferenc <[email-masked]>
Date: Fri, 1 Dec 2000 22:49:12 +0100 (CET)

Hi,

We tried to use the local repair in aodv, built in ns2.1b7.
But we found that the local repair technique doesn't fits with the AODV's
phylosophy.
The problem arises when a node answers to the local RREQ, knowing a route
to the destination through an upstream node of the repairing node. In this
case a routing loop will be created.

Is it true?
Any comments are welcomed.

Regards: 
Ferenc Kubinszky
Attila Torok

---

From: "Samir R. Das" <[email-masked]>
Date: Sat, 2 Dec 2000 02:06:08 -0500

Why do you think that an upstream node will reply? The destination sequence
number in the RREQ will always be greater than that in any upstream node.

Samir

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Kubinszky Ferenc
>Sent: Friday, December 01, 2000 4:49 PM
>To: IETF MANET
>Subject: Local repair in AODV
>
>
>Hi,
>

---

From: [email-masked]
Date: Sun, 3 Dec 2000 22:34:26 +0530 (IST)

Hi,
	Please let me know, in AMRIS all the nodes, which are even not in
any multicast group  do maintain its neighbour information by broadcasting
(with TTL 1) beacon to its neighbours or only those nodes which are in
some multicast group, they maintain neighbour information? 
das