Subject: Re: Fwd: Re: I-D ACTION:draft-ietf-manet-lanmar-00.txt (fwd)

From: Mario Gerla <[email-masked]>
Date: Sun, 10 Dec 2000 00:50:25 -0800

Richard:

good to hear from you and thank you for your interest. See our answers below:

--------------------------------------------

Your first question:  
I have a question about the new draft on Landmark Routing (LANMAR). 
Regarding the computation of a shortest path between a landmark and 
a drifter, Section 5.4.2 states: 
"If an entry of incoming DFDV indicates that the current 
node is its next hop to the landmark, i.e., the current node is on 
the drifter's shortest path to the landmark, the current node will 
insert or update its drifter list." 
Section 4.3 explains this further, where l is the drifter and L 
is the landmark: 
"When i transmits its distance vector to neighbor, say j, 
then j will retain the entry to member l only if d(j,l) 
is smaller than the scope or d(j,L) is smaller than d(i,L). 
The latter condition occurs if j is on the shortest path from i 
(and therefore from l) to L." 
Actually, the latter condition occurs if j is on *any* shortest 
path from i to L, and there could be several such shortest paths. 
Does LANMAR somehow ensure that only nodes along a *single* 
shortest path between the landmark and drifter need to 
maintain the distance information to the drifter?

Actually, every node keeps the shortest path to the Landmark. Packets from
drifters
are routed along the shortest path to the Landmark. Usually, each node has a
pointer to
only one parent (one of the many which advertise the min hop path) up the tree.
So, the 
packet follows a single shortest path. For added redundancy, at additional O/H
cost, 
one can forward the packet
on all shortest paths. But this is not a strict requirement in Lanmar

---------------------------------------------------------

Second question:

>
>In my earlier message, I mentioned that LANMAR may have
>a problem with triangle routing, i.e., to route a packet
>to a drifter, the packet must first be routed on the shortest
>path from the source to the landmark associated with the drifter, 
>and then on the shortest path from the landmark to the drifter.
>Another potential problem is traffic concentration at the
>landmarks, since unless the drifter is drifting toward the
>source of the packet, the packet to a drifter will have to 
>be routed through the landmark.  (If the number of drifters
>is small then this is not a significant problem.)

Indeed, we assume that groups travel in a compact formation. Drifters are
stranded nodes
(eg, disabled trucks etc) and there should be very few of them. 
Nevertheless, your question has merit.  In  fact, we have been giving thoughts
to it.

>I think that both of these potential problems can be alleviated 
>using the approach I mentioned in my earlier message, i.e., 
>applying the concept of mobile IPv6 to landmark routing.
>In this approach, the drifter reports its new "foreign" landmark 
>(or care-of address) to its "home" landmark (analogous to a home 
>agent in mobile IP). The first packet to the drifter is then 
>rerouted by the "home" landmark toward the "foreign" landmark.  
>Then the drifter can inform the source (correspondent node) of 
>its new "foreign" landmark so that subsequent packets can be 
>routed directly toward the new landmark (thus alleviating
>triangle routing and traffic concentration).

Your proposed solution will work if there is a landmark of another logical
group
within scope, and drifter and "foreign Landmark" are not moving rapidely in
opposite directions
(actually, the drifter may be smart enough to select a congenial landmark).
Another solution is to assume that there are a number of static, "public"
landmark nodes (like
beacons) which provide shelter to drifters (ie, act as "care of" address) . 
The distance between beacons is in the order of the scope.
A third solution (valid if nodes are outdoor and are equipped with GPS) is for
drift nodes to advertise
geographic coordinates to their Landmarks. Georouting is used until the packet
is within the drifter's scope.
We are investigating these options, and appreciate your inputs

Thanks, 

Mario and Xiao Yan

>
>I am probably not the first person to think of this, since
>it seems to be a straightforward application of mobile IP to 
>landmark routing. Have you or anyone considered this approach? 

>Richard
>-----------------------
>Richard Ogier
>Sr. Research Engineer
>SRI International
>333 Ravenswood Ave.
>Menlo Park, CA 94025
>Tel: 650-859-4216
>Fax: 650-859-4812
>Email: [email-masked]
>------------------------

---

From: Richard <[email-masked]>
Date: Wed, 13 Dec 2000 11:45:49 -0800

Mario:

Thanks for you answer.  See my clarification below.

> --=====================_67880382==_.ALT
> Content-Type: text/plain; charset="us-ascii"
> 
> 
> Richard:
> 

Actually I was asking about maintaining the path *from* the 
Landmark *to* the the drifter, not the opposite direction.
If you read my question again in that context, then it will
make more sense.  Your draft does not say how LANMAR ensures
that only nodes along a *single* shortest path from the 
landmark to the drifter need to maintain the distance 
information to the drifter.  However, I can see how this
might be done by having each node along such a path overhear
messages from other nodes that have the same next hop to the 
drifter and the same distance to the landmark, and breaking 
ties according to router ID.

Richard