Subject: Re: MAC, HL/2 Handover

From: [email-masked]
Date: Mon, 14 May 2001 14:16:01 +0200

Dear Matthias,

in HL/2, if a CC runs out of power, a CC Handover should be initiated. However, this is up to the implementer and not standardized. If the CC crashes or if no other CC-candidate is available, the remaining terminals try to associate with other CCs. If no 
other CC is detected a terminal starts to transmit a broadcast beacon itself in order to start a new CC selection phase.
The main principle of the CC selection process is, that each terminal withdraws from the selection and stops its beacon transmission, if another beacon is detected. Finally, there will be only one station left that becomes the new CC. You can find the 
specification of "CC selection" (as well as "CC Handover") in the HL/2 standard "ETSI TS 101 761-4 V1.2.1" ("Data Link Control Layer - Extension for Home Environment"), of which I have been the editor. So, if you have any questions, please don't hesitate 
to contact me.

Regards,
Joerg 

<Jvrg,
<
<What I did not understand yet: What happens if all of a sudden the CC cannot transmit anymore (out of <range, no more power ??) and no cc-handover was possible. What would the remaining stations do and can I <find that in the spec somewhere?
<
<In IEEE 802.11 this is neatly solved with the distributed Beacon transmission, how would HL/2 cope with <that ?
<
<Cheers
<Matthias

---

From: Ferenc Kubinszky <[email-masked]>
Date: Mon, 14 May 2001 16:36:23 +0200

Hello !

I did not follow the HL/2 discussion, but my collegue Csaba Keszei wrote
his MSC thesis about HL/2.
If you are intrested in it ,you can donload from

http://wit.mht.bme.hu/~kecsa

Best regards,
Ferenc Kubinszky

---

From: [email-masked]
Date: Tue, 15 May 2001 13:28:48 +0200

Dear Joerg,

But how the system behaves if there are no HL/2 node which can play the CC
role? This can happen if no HL/2 node is in direct view of all other HL/2
nodes. Will be several CC elected or none?

Philippe 

A 14:16 14/05/01 +0200, [email-masked] a écrit :
>Dear Matthias,
>
>in HL/2, if a CC runs out of power, a CC Handover should be initiated.
However, this is up to the implementer and not standardized. If the CC
crashes or if no other CC-candidate is available, the remaining terminals
try to associate with other CCs. If no 
>other CC is detected a terminal starts to transmit a broadcast beacon
itself in order to start a new CC selection phase.
>The main principle of the CC selection process is, that each terminal
withdraws from the selection and stops its beacon transmission, if another
beacon is detected. Finally, there will be only one station left that
becomes the new CC. You can find the 
>specification of "CC selection" (as well as "CC Handover") in the HL/2
standard "ETSI TS 101 761-4 V1.2.1" ("Data Link Control Layer - Extension
for Home Environment"), of which I have been the editor. So, if you have
any questions, please don't hesitate