Subject: Re: MAC ?

From: [email-masked]
Date: Wed, 9 May 2001 16:36:43 +0200

Hi,

in HIPERLAN/2 "Centralized Mode" all data come from or go to the Central Controller, but in "Direct Mode" all data can be directly transmitted from one terminal to another on a Direct Link. Only the control path is still directed towards the Central 
Controller.

In the HL/2 Home Environment Extension the Central Controller is not connected to a wired core network. The control function can be taken over by any device within a cluster and it can also be handed over from one station to another during operation. So, 
this is truely and ad hoc network - not a decentralised but a centralised one!

Yes, you are right that two Central Controllers operate on different frequencies, which might limit the ad hoc network to a single cluster network. This is also the scope of the first phase of the Home Environment Extension (to cover, with a single 
cluster, areas in the size of a flat).

However, it is possible to build a multihop ad hoc network based on Hiperlan/2. I have proposed a solution in an article called "Concept of a Wireless Centralized Multihop Ad Hoc Network" at the "European Wireless" conference 2000. The article will also 
be published in a similar form in "Computer Networks" this year.
The clusters are inter-connected by so-called Forwarding Terminals which are members of both clusters and that switch from one frequency to another. Of course, such a network requires clustering of terminals (see also the work of Gerla and others).

Regards,
Jörg

>Does it not imply that, in "direct mode" HL/2, it is impossible to build an
>ad hoc network with more than two hops and the first hop *must* go through
>the elected centralizer?

>HL/2 experts told me that HL/2 centralizers cannot interoperate on the same
>frequency. Is it true?

>Philippe

>A 21:50 08/05/01 +0100, Matthias Gerlach a écrit :
>Marc Pearlman wrote:
>
>> I was under the impression that HiperLan/2 is solely a wireless
>> infrastructure network.  HiperLan/1, on the other hand, would support both
>> infrastructure and ad hoc deployment.
>>
>
>Marc,
>
>Hiperlan/2 actually got an "Extension for Home Environment", which
>descripes HL/2 devices in an ad-hoc network environment. In that case,
>the HL/2
>devices use the so-called direct mode (DM) to communicate, whereas in
>the
>infrastructure mode all traffic goes to, and comes fom, the central
>controller (in
>that case called access point).
>
>The main difference between HL/2 and IEEE 802.11 ad hoc networks is that
>in
>IEEE 802.11 all devices are the same, whereas (due to the TDMA scheme in
>HL/2) there has to be a central controller scheduling the traffic in
>HL/2.
>The central controller is (dynamically) elected among the HL/2 ("CC
>-capable")
>devices.
>
>All Hiperlan Standards are accessible free of charge at
>www.etsi.org/bran/ .
>
>hope that helps
>Matthias
>
>PS: I am currently writing on my study thesis looking at the different
>architectures. If anybody is interested in architecture overviews of
>those
>standards, just send me an email.
>
>PPS: The main differences in a nutshell:
>IEEE:
>- 5 different PHYs (DSSS, HR/DSSS (802.11b), FHSS, IR, OFDM (802.11a))
>- CSMA/CA scheme distributed MAC (Distributed Coordination Function)
>
>
>HL/2:
>- 1 PHY: OFDM
>- TDMA / TDD scheme, centralized (see above)
>- QoS inherently supported.

---

From: Matthias Gerlach <[email-masked]>
Date: Thu, 10 May 2001 02:27:10 +0100

Jvrg,

What I did not understand yet: What happens if all of a sudden the CC cannot transmit anymore (out of range, no more power ??) and no cc-handover was possible. What would the remaining stations do and can I find that in the spec somewhere?

In IEEE 802.11 this is neatly solved with the distributed Beacon transmission, how would HL/2 cope with that ?

Cheers
Matthias

[email-masked] wrote:

> Jvrg
> >A 21:50 08/05/01 +0100, Matthias Gerlach a icrit :
> >Marc Pearlman wrote:
> >