Subject: [manet] Re: WG Feedback requested

From: "Pete Sholander" <[email-masked]>
Date: Wed, 27 Feb 2002 18:01:08 -0500

This is a belated reply to one of Scott Corson's postings from way back in January ...

Scientific Research Corporation (SRC) has implemented a hybrid-routing protocol that is based on Cornell's ZRP, but has some differences.  It currently runs on Red Hat (2.2 and 2.4 kernels) and Debian Linux (2.4 kernel).  Supported hardware platforms are x86 and StrongARM.  Other OS's and platforms are planned during 2002.  That software has had two beta-testers to date.

SRC may bring that protocol into the IETF after we finish coordinating with Dr. Haas and our various DoD sponsors (AFRL/IF, AFRL/MN and DARPA ATO mainly).  The main goal might be standardizing the *framework* within which the reactive and proactive components communicate --- rather than the components themselves.  As such, SRC is also interested in integrating with other vendors' (and/or colleges') proactive and reactive protocols.  (We're currently also running the INRIA code for OLSR in our lab, but not as the proactive portion of our hybrid protocol.)

In general, hybrid protocols do seem to interest SRC's U.S. DoD customers.  So, IMHO the IETF should continue work on them. Your opinion/mileage may vary, of course :)

Kind Regards,
Pete Sholander

Principal Engineer
Scientific Research Corporation 
2300 Windy Ridge Parkway, Suite 400S
Atlanta, GA  30339

E: [email-masked]
V: 770-989-9551
F: 770-859-9315

>>> Scott Corson <[email-masked]> 01/04/02 02:30PM >>>
Folks,

First off, welcome back from the holidays for those who took time off.

The issue I'm raising was discussed at the SLC meeting and I want to raise
it on the list.  

We are in the process of milestone revamping in the WG charter, and are
looking to clarify the current scope of work.

As mentioned at the meeting, a number of proposals seem best suited for
highly scaled manet networks. The chairs suggest that the manet WG scope
down the areas of near term work until reasonable progress is achieved. The
rough idea is to concentrate on several items for near term work and
progress.

(1) reactive unicast protocol
(2) proactive unicast protocol
(3) flooding protocol work

----------------
The concerns regarding a number of the proposal(s) are:

(1) primarily useful for scaling manets ..longer term scope issue
(2) perceived lack of broad interest .. independent of WG scope

Would anyone interested in *implementing* TORA, ZRP-related drafts and/or
LANMAR please let me know?  And I do not mean simulation.  I would prefer
that you respond to the list.  I do not want to hear from document authors
or parties working directly with authors.  

I am trying to gauge interest in these drafts as WG work items. 

Thanks,

-Scott

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Pete Sholander" <[email-masked]>
Date: Wed, 27 Feb 2002 18:01:08 -0500

Kind Regards,
Pete Sholander

Principal Engineer

E: [email-masked]
V: 770-989-9551
F: 770-859-9315

Folks,

----------------

Thanks,

-Scott