Subject: Re: Some follow-up OLSR/AODV results

From: Joe Macker <[email-masked]>
Date: Fri, 01 Feb 2002 15:45:46 -0500

At 12:10 PM 2/1/2002 -0800, [email-masked] wrote:

>Joe,
>
>> >
>> >in the sendPacket() function, which explained the bug. I changed the line to
>> >
>> >    ch->size() = IP_HDR_LEN + p->datalen();
>> >
>> >which seemed to fix the bug.  Am I missing something?
>> 
>> Richard:
>> Good catch, I also believe this a bug.  I checked prototype olsrv4 ns2 code we developed 
>> here and it does not have th is bug (it was independently developed from the INRIA code).
>
>> I will add your fix and doublecheck my previous snapshot scenarios with both pieces of code.  
>
>I guess the Aalborg study posted a few days ago also needs to be redone.

Yes, I just redid points for 100 nodes, 20 sources, 0 motion with your fix.
Early results (with your fix) still show close to 100% delivery for 2, 4, 6 packets/sec loads.

Perhaps that ported Linux code version your are using is breaking down at 100 nodes. 
The 2 other pieces of source code I am using seem not to have the same effect of 65% delivery bounding.

We can take more of this discussion off-line, but some of it has been useful because the results were presented at the WG meeting. Just the scientific process in action.
-joe

>We are also running simulations for OLSR and TBRPF in ns-2.1b8.
>Now that we have ns-2 code for OLSR from INRIA, I am perfectly
>happy using this code and disregarding the results from our
>port of the OLSR implementation code to ns-2.
>Even though I believe those results are valid (and that we ported
>the code correctly), INRIA stated that the implementation code was
>not intended for simulations (after I presented our results in SLC).
>It is understandable that the code may not have been optimized
>(or even tested) for networks of 100 nodes.

---

From: [email-masked]
Date: Fri, 01 Feb 2002 12:10:41 -0800

Joe,

-----------------------
Richard Ogier
Sr. Research Engineer
SRI International
333 Ravenswood Ave.
Menlo Park, CA 94025
Tel: 650-859-4216
Fax: 650-859-4812
Email: [email-masked]
------------------------