Subject: [manet] DSR and Dijkstra's algorithm

From: [email-masked] (Noah H. Miller)
Date: 24 Jun 2002 15:42:07 EDT

Hello,

I am porting the DSR protocol to Dartmouth College's wireless ad-hoc network simulation (SWAN).  I would like to write the Route Cache using Dijkstra's shortest-path algorithm (per Link-MaxLife specification in Appendix A of the draft).  Does anyone know 
of open source code out there using this algorithm that I could use as reference?  Either code for a DSR simulation or another similar routing protocol.

Thank you,
Noah Miller

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked] (Noah H. Miller)
Date: 25 Jun 2002 09:57:45 EDT

Hello,

According to DSR Internet Draft 7, there is a maximum number of retransmissions of a Request (suggested: 16) and a maximum period for those retransmissions (10 seconds) (see pages 47 and 67).  DSR has similar variables for source routed packets.

A similar problem to the one you raised is the lack of a blacklist for Requests to destinations that cannot be reached (for instance, destinations on the other side of a partition).  A node is allowed to restart Route Discovery as soon as the maximum peri
od for a Request is up, with the time between Requests reset to the initial, small period.

Noah Miller

--- sameer tilak <[email-masked]> wrote: ---
Hi All,I have another doubt regarding DSR. I read from thelatest 
draft that for retransmission of route requestit uses binary backoff 
algorithm. However is there anylimit on the numbre of retries ? I am 
not sure evenwhether Network layer should handle max retries 
orapplicaiton layer should handle this ?Thanks and Regards,--Sameer 
Tilak.
--- end of quote ---

---

From: [email-masked] (Noah H. Miller)
Date: 25 Jun 2002 09:57:45 EDT

Hello,

Noah Miller

--- end of quote ---