Subject: [manet] DSR and Dijkstra's algorithm

From: [email-masked] (Noah H. Miller)
Date: 24 Jun 2002 15:42:07 EDT

Hello,

I am porting the DSR protocol to Dartmouth College's wireless ad-hoc network simulation (SWAN).  I would like to write the Route Cache using Dijkstra's shortest-path algorithm (per Link-MaxLife specification in Appendix A of the draft).  Does anyone know 
of open source code out there using this algorithm that I could use as reference?  Either code for a DSR simulation or another similar routing protocol.

Thank you,
Noah Miller

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jonas Nielsen <[email-masked]>
Date: 24 Jun 2002 22:18:37 +0200

> of open source code out there using this algorithm that I could use as reference?  Either code for a DSR simulation or another similar routing protocol.

It's implemented in the file linkcache.cc in ns2.1b9. (but please note
that the rest of dsr code in this version has a bug that make it
unusable for performance tests).

---

From: Jonas Nielsen <[email-masked]>
Date: 24 Jun 2002 22:18:37 +0200

---

From: sameer tilak <[email-masked]>
Date: Mon, 24 Jun 2002 15:36:43 -0700 (PDT)

Hi All,
I have another doubt regarding DSR. I read from the
latest draft that for retransmission of route request
it uses binary backoff algorithm. However is there any
limit on the numbre of retries ? I am not sure even
whether Network layer should  handle max retries or
applicaiton layer should handle this ? 

Thanks and Regards,
--Sameer Tilak.

--- "Noah H. Miller" <[email-masked]>
wrote:
> Hello,
> 
> I am porting the DSR protocol to Dartmouth College's
> wireless ad-hoc network simulation (SWAN).  I would
> like to write the Route Cache using Dijkstra's
> shortest-path algorithm (per Link-MaxLife
> specification in Appendix A of the draft).  Does
> anyone know 
> of open source code out there using this algorithm
> that I could use as reference?  Either code for a
> DSR simulation or another similar routing protocol.
> 
> Thank you,
> Noah Miller
> 

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

---

From: sameer tilak <[email-masked]>
Date: Mon, 24 Jun 2002 15:36:43 -0700 (PDT)

Hi All,

Thanks and Regards,
--Sameer Tilak.

---

From: Dario Bottazzi <[email-masked]>
Date: Tue, 25 Jun 2002 14:44:54 +0200

Has anybody investigated the opportunity to use Virtual IP addresses for 
MANETs?

regards 
      Dario

---

From: Dario Bottazzi <[email-masked]>
Date: Tue, 25 Jun 2002 14:44:54 +0200

regards 
      Dario