Subject: [manet] QoS over a wireless Ad Hoc network

From: John Peter Tapsell <[email-masked]>
Date: Thu, 27 Jun 2002 13:53:53 +0100

<nl>  I'm trying to find any information on whether I could get QoS
over an Ad-Hoc network.  I have been looking into the various routing
protocols, but not sure which would be suitable for trying to get QoS vver.
<nl><nl>

<nl>  I have looked at RSVP, but as it stands, it doesn't support mobile networks
let alone ad-hoc networks.  There is MRSVP for using RSVP over Mobile IP,
but I need an Ad-Hoc network.
<nl><nl>

<nl>  Unfortunately most information about RSVP is at least 4-5 years old -
what happened?  The mailing lists seem to just die over night.
<nl><nl>

<nl>  I would be looking for a linux implementation, or implementing it myself in ln
^H^HLinux
<nl><nl>

<nl>  Any comments at all are welcome,
sorry if this is the wrong place.         
<nl><nl>

Thanks,
John Tapsell

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: John Peter Tapsell <[email-masked]>
Date: Fri, 28 Jun 2002 13:08:21 +0100

Thank you all very much :)

The trouble is, I have a network with many many nodes, all wanting
to use up as much bandwidth as they can.  I need a way to

*) Prioritise certain nodes.
*) Try hard to guarantee a certain bandwidth to nodes
*) Try hard to guarantee a certain latency to nodes
*) Minimise traffic on certain nodes so it's only used for priority packets
that have no other sensible way.  (For minimal bandwidth etc)
*) Set up routes that take into consideration somehow the quality of the link
e.g. two nodes that are far apart may drop a lot of packets, so a preferable
route would be going through several nodes, etc.

Basically I want the world :)  I'm currently trying to just see what's out there.

I've only looked at SWAN for a few hours, but so far I'm not sure how it
would cope when the needed bandwidth far exceeds actual. :)

I'm new to this field, so have patience with me :)  Thanks.

JohnFlux

---

From: John Peter Tapsell <[email-masked]>
Date: Fri, 28 Jun 2002 13:08:21 +0100

JohnFlux

---

From: "MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN" <[email-masked]>
Date: Fri, 28 Jun 2002 14:28:48 +0200

guarantee a correct QoS in manet is an NP-Complet problem. with the
actuel configuration of materail I think that software solution like
Swan and Insignia car treat all QoS pb in Manet in all situations.

-----Message d'origine-----
De : John Peter Tapsell [mailto:[email-masked]]
Envoye : vendredi 28 juin 2002 14:08
A : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : Re: [manet] QoS over a wireless Ad Hoc network

*) Prioritise certain nodes.
*) Try hard to guarantee a certain bandwidth to nodes
*) Try hard to guarantee a certain latency to nodes
*) Minimise traffic on certain nodes so it's only used for priority
packets
that have no other sensible way.  (For minimal bandwidth etc)
*) Set up routes that take into consideration somehow the quality of the
link
e.g. two nodes that are far apart may drop a lot of packets, so a
preferable
route would be going through several nodes, etc.

Basically I want the world :)  I'm currently trying to just see what's
out there.

JohnFlux

---

From: "MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN" <[email-masked]>
Date: Fri, 28 Jun 2002 14:28:48 +0200

-----Message d'origine-----
De : John Peter Tapsell [mailto:[email-masked]]
Envoye : vendredi 28 juin 2002 14:08
A : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : Re: [manet] QoS over a wireless Ad Hoc network

JohnFlux