Subject: RE: [manet] Data flow in nam for wireless scenarios

From: "Marwaha Shivanajay" <[email-masked]>
Date: Sat, 22 Jun 2002 22:28:23 +0800

Hi,
As far as I know NAM can't show packets flying in wireless simulations. 
I use ns-2.1b8a and in that also it does not show packets flying in the
air.
It just shows node movement. But for wired simulations it does show
packet transfer.

Regards,
Shivanajay

-----Original Message-----
From: Jonas Nielsen [mailto:[email-masked]] 
Sent: Saturday, June 22, 2002 10:19 PM
To: [email-masked]
Subject: [manet] Data flow in nam for wireless scenarios

I'm using ns for simulation of dsr and nam as a visualizer.  For
different reasons I have reinstalled ns-allinone from scratch. I now try
to see data flow in nam. It shows the nodes moving but it shows no
communication (normally visualized as rippling circles and small
rectangles), though you can see that the nodes communicate in the .tr
file. I've tried to install ns-allinone-b9 and ns-allinone-b8. For
ns-allinone-b8 I've tried to use the binary version of nam v1.0a9 a10
and a11. I know there were problems with nam in b8, but I've earlier
bypassed this problem by replacing the binary with another version.

Any suggestions ? I really can't remmember if I dead anything else to
get nam working, so any suggestions would be appreciated.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Miguel Sanchez <[email-masked]>
Date: Sat, 22 Jun 2002 23:22:35 +0200

Hi,

Nam *does* show packets flying from node to node in a wireless 
simulation. It depends on your scenario setup, but it can be done and it 
works in both 2.1b8a and 2.1b9.

You may want to  check the ns2 userlist archives for extra information.

Good luck,

Miguel Sanchez
Universidad Politecnica de Valencia, Spain

---

From: Miguel Sanchez <[email-masked]>
Date: Sat, 22 Jun 2002 23:22:35 +0200

Hi,

Good luck,

Miguel Sanchez

---

From: Alex Hamidian <[email-masked]>
Date: Sun, 23 Jun 2002 18:16:48 +0200

Hi!

To see the packet flow between wireless nodes in a wireless simulation 
you have to
* use namtrace-all-wireless
* set -routerTrace ON

If you want to see the packet flow between wireless nodes in nam-1.0a10 
you have to use several setdest commands in a row:

For example something like this...

$ns at 2.0 "$mobile1 setdest  100.0 150.0 15.0"
$ns at 2.3 "$mobile1 setdest  100.0 150.0 15.0"
$ns at 2.7 "$mobile1 setdest  100.0 150.0 15.0"
...

...or this:

set startTime 2.0
set endTime 50.0 (u can compute this value)
set posx 100.0
set posy 150.0
set velocity 15.0

for {set i $startTime} {$i < $endTime } {incr i} {
            $ns at $i.0 "$mobile1 setdest $posx.0 $posy.0 $velocity.0"
            $ns at $i.3 "$mobile1 setdest $posx.0 $posy.0 $velocity.0"
            $ns at $i.7 "$mobile1 setdest $posx.0 $posy.0 $velocity.0"
}

I hope this helps!
Ali Hamidian

Miguel Sanchez wrote:

> simulation. It depends on your scenario setup, but it can be done and 
> it works in both 2.1b8a and 2.1b9.
>
>> As far as I know NAM can't show packets flying in wireless 
>> simulations. I use ns-2.1b8a and in that also it does not show 
>> packets flying in the
>> air.
>> From: Jonas Nielsen [mailto:[email-masked]] Sent: Saturday, June 22, 
>> 2002 10:19 PM
>> To: [email-masked]

---

From: Alex Hamidian <[email-masked]>
Date: Sun, 23 Jun 2002 18:16:48 +0200

Hi!

...or this:

set startTime 2.0

I hope this helps!
Ali Hamidian

---

From: Jonas Nielsen <[email-masked]>
Date: 24 Jun 2002 10:54:26 +0200

Alex Hamidian <[email-masked]> writes:

> Hi!
> To see the packet flow between wireless nodes in a wireless simulation you have to

It did, thanks.

---

From: Jonas Nielsen <[email-masked]>
Date: 24 Jun 2002 10:54:26 +0200

It did, thanks.

---

From: "Michael Sessinghaus" <[email-masked]>
Date: Mon, 24 Jun 2002 11:24:48 +0200

Hi,

What you think about ad-hockey to use for wireless visualization? Is it
better than Nam.
In Nam, i think, the packet flow is very small from one node to the other. I
prefer the new ad-hockey version from CMU.
But the problem is that the packet flow and the connections (lines) are
build out from the left corner in the main window. This view is wrong or
not? Is there a bug in ad-hockey or i must change some parameter?

Regards, Michael.

----- Original Message -----
From: "Jonas Nielsen" <[email-masked]>
To: "Alex Hamidian" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, June 24, 2002 10:54 AM
Subject: Re: [manet] Data flow in nam for wireless scenarios

you have to

---

From: "Michael Sessinghaus" <[email-masked]>
Date: Mon, 24 Jun 2002 11:24:48 +0200

Hi,

Regards, Michael.

----- Original Message -----
From: "Jonas Nielsen" <[email-masked]>
To: "Alex Hamidian" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, June 24, 2002 10:54 AM
Subject: Re: [manet] Data flow in nam for wireless scenarios

you have to