Subject: [manet] IP addresses in MANET

From: Dario Bottazzi <[email-masked]>
Date: Tue, 25 Jun 2002 19:27:54 +0200

> 1. If the MANET becomes connected to the Internet, how will that work?

In my opinion we might use a gateway with a fixed address.  I think it would 
be accetable because we need an infrastructure in order to see the network 
outside the manet....

> 2. This appears to be a flat address space in effect, just like creating a
> Layer 2 catenet. Not sure how this differs from IEEE 802.11 in ad-hoc mode,
> for example.

I have little experience with 802.11 so I can't answer you now. The 
addressing schema in my mind is this :

- When a node connects to a cluster it is assigned an IP. 
- The name of the host (the Virtual IP) never changes.

PROS. Inter-cluster routing get simpler (tables change with low frequency)
          Intra-cluster routing can be simplified because addresses are    	
assigned by the network (the cluster) itself. The addresses are valid only 
within the cluster. This would also solve a problem: you can't have two 
different nodes with the same IP address.  

Also, if node A is using a service shown by node B and B migrates it is 
simple to manage the reconnection between A and B.
- A searches for a route to B using its "Virtual IP"
- A reconnects B
 
>
> Bert
>
> > -----Original Message-----
> > From: Dario Bottazzi [mailto:[email-masked]]
> > Sent: Tuesday, June 25, 2002 12:24 PM
> > To: [email-masked]
> > Subject: [manet] IP addresses in MANET
> >
> >
> > In my opinion some addressing scheme inspired from Virtual IP
> > would be really
> > useful in MANET framework: we might think to bind real IP
> > addresses to the
> > locality (or to a cluster) and this could reduce most of the
> > network traffic
> > related to routing management. (Routing tables would change
> > with a lower
> > frequency)
> > If the Virtual IP (the name of the node) doesn't change even
> > iin the case of
> > a migration it is possible for the others to track its
> > movement and to use
> > the services it shows as soon as it reconnects somewhere into
> > the MANET.
> > Is it meaningfull? I'd like to have your opinion...
> > regards
> >      Dario
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Dario Bottazzi <[email-masked]>
Date: Tue, 25 Jun 2002 19:27:54 +0200

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 25 Jun 2002 12:43:28 -0400

I've heard this concept before, to use unrelated IP addresses in a MANET.

Two problems come to mind, unless I'm missing something.

2. This appears to be a flat address space in effect, just like creating a Layer 2 catenet. Not sure how this differs from IEEE 802.11 in ad-hoc mode, for example.

Bert