Subject: RE: [manet] IP addresses in MANET

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 27 Jun 2002 17:49:48 -0400

Fred L. Templin wrote:
>
> Hi Bert,
> 
> Manfredi, Albert E wrote:
> > But these are just words. Exactly how one keeps multiple
> > gateways from sending duplicate packets to the Internet,
> 
> I'm not sure I'm interpreting your concern correctly, but
> I don't think there should be any such issue when multiple
> IPv6 gateways within the MANET peer with the Internet. Nodes
> that send packets (and/or intermediate forwarding hops) will
> eventually pick one such gateway as the final next hop before
> the packet leaves the MANET. The unicast MAC address of the
> gateway is then placed as the destination MAC address in the
> forwarded packet, so only one border gateway will do the
> forwarding and duplicates should not arise.

Hmmm. I was thinking that the IP DA of the packet destined to the Internet would be the IP DA of that host out there, in the Internet. And that there would be a good likelihood that several gateways to the Internet could see that packet, and add their own prefix to the IP SA, before sending it on. So the packets would seem different out there, within the wired Internet.

Are you saying that the packet transmitted by the MANET host is encapsulated in another packet, with the gateway's MANET address on it? I suppose you could establish that sort of initial transaction, before transmitting to the outside world. As the MANET host moves, it would have to be aware of changes to the gateway to the Internet.

Bert

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Fred L. Templin" <[email-masked]>
Date: Thu, 27 Jun 2002 15:12:46 -0700

Manfredi, Albert E wrote:
> Hmmm. I was thinking that the IP DA of the packet destined to the Internet
> would be the IP DA of that host out there, in the Internet. And that there
> would be a good likelihood that several gateways to the Internet could see
> that packet, and add their own prefix to the IP SA, before sending it on.
> So the packets would seem different out there, within the wired Internet.

Several gateways might "see" the packet in the RF sense, but only
the one whose MAC address appears in the L2 header's destination
address field will act on it. (Also, the gateways don't add their
own prefix; hosts configure their own prefixes via stateless or
statefull address autoconfiguration.)

> Are you saying that the packet transmitted by the MANET host is
> encapsulated  in another packet, with the gateway's MANET address
> on it? I suppose you could establish that sort of initial transaction,
> before transmitting to the outside world. As the MANET host moves, it
> would have to be aware of changes to the gateway to the Internet.

I'm just talking about vanilla IPv6 forwarding and what happens with
the addresses in the L2 and L3 headers during the process. How MANET
hosts discover gateways to the Internet is a higher-level question
and may/may not entail encapsulation. Perhaps I missed some of the 
earlier context for this discussion?

Fred
[email-masked]

---

From: "Fred L. Templin" <[email-masked]>
Date: Thu, 27 Jun 2002 15:12:46 -0700

Fred
[email-masked]