Subject: Re: [manet] IP addresses in MANET

From: "Yasser A. Lotfy" <[email-masked]>
Date: Thu, 27 Jun 2002 16:54:38 -0400

Good day everybody,

I've been following on the IP addressing proplem, and want to contribute some thoughts
1) I believe ad hoc will adopt IPv6. Since no comercial solution is available for ad-hoc, it makes absolute sense to use IPv6 for addressing. This solve the problem of "Internet running out of space" and introduce the problem of "Personal IP" which is global vs local IP

2) Assigning "pool of addresses" for an ad-hoc network is so difficult in the absense of central authority. This means that nodes will have to announce an IP address when joining the network, get authenticated (how the authentication could be done is a different issue), then the nodes can move within the same ad-hoc freely by keeping their IP.

3) Local traffic (within the same ad-hoc) can be routed easly. Internet traffic will be subject to (gateway address resolution). Since many gateways may work for the same ad-hoc, we need to guarantee consistency between all gateways.

This way no central authority is needed which is very consistent with the MANET charter. Also, if an individual nodes has a static IP it should be able to use it. The authentication process can elementate the possibility of IP address conflict.

Hope I made my point clear, any input?

Yasser

Carleton U
Ottawa Canada

____________________________________________________________
Win a first-class trip to New Orleans and vacation Elvis Style!.
Enter NOW!
http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Kuldip Singh Pabla <[email-masked]>
Date: Thu, 27 Jun 2002 22:03:23 -0700

Hi Yasser,

> 1) I believe ad hoc will adopt IPv6. Since no comercial solution is available for ad-hoc, it makes absolute sense to use IPv6 for addressing. This solve the problem of "Internet running out of spac…

This pretty much matches with my view of ad-hoc network. It could be
IPv6 or something close to it, like UUIDs.
As I had mentioned, IPv6 or IP or any other ID will serve as an identity
of a node and not its location in the hierarchy.
And hence, it would be tough to have a unique identity in the adhoc
network.

> 2) Assigning "pool of addresses" for an ad-hoc network is so difficult in the absense of central authority. This means that nodes will have to announce an IP address when joining the network, get a…

At the same time, the authentication will be very difficult. The adhoc
network created by a bunch nodes may just be a private network not
connected to the Internet - so, no question of authentication and
authorization, unless there is a central authority - which is not
consistent with MANET charter.

> 3) Local traffic (within the same ad-hoc) can be routed easly. Internet traffic will be subject to (gateway address resolution). Since many gateways may work for the same ad-hoc, we need to guarant…

Exactly!

> This way no central authority is needed which is very consistent with the MANET charter. Also, if an individual nodes has a static IP it should be able to use it. The authentication process can ele…

I am still not convinced on address conflict resolution.

-Kuldip

-- 
Kuldip Singh Pabla
Peer-2-Peer Networking

---

From: Kuldip Singh Pabla <[email-masked]>
Date: Thu, 27 Jun 2002 22:03:23 -0700

Hi Yasser,

Exactly!

-Kuldip

-- 
Kuldip Singh Pabla
Peer-2-Peer Networking

---

From: Dario Bottazzi <[email-masked]>
Date: Fri, 28 Jun 2002 13:49:52 +0200

Dr. Pabla
    I am not convinced at all that authentication should be solved at this 
level. I agree that security issues in manet involve any level of protocol 
stack expecially in wireless hightly dynamic networks as MANETs.
The threat of a "false IP" exist even into the internet but it is solved at 
higher level throught certificates and cryptography.
Many research effort have been spend over this field into the context of MANET
i.e. threshold cryptography

regards 
      dario

---

From: Dario Bottazzi <[email-masked]>
Date: Fri, 28 Jun 2002 13:49:52 +0200

Dr. Pabla

regards 
      dario

---

From: Rex Buddenberg <[email-masked]>
Date: Fri, 28 Jun 2002 08:45:52 -0700

At 4:54 PM -0400 6/27/02, Yasser A. Lotfy wrote:
>1) I believe ad hoc will adopt IPv6. Since no comercial solution is 
>available for ad-hoc, it makes absolute sense to use IPv6 for 
>addressing. This solve the problem of "Internet running out of 
>space" and introduce the problem of "Personal IP" which is global vs 
>local IP

This strikes as sensible. 

>
>2) Assigning "pool of addresses" for an ad-hoc network is so 
>difficult in the absense of central authority. This means that nodes 
>will have to announce an IP address when joining the network, get 
>authenticated (how the authentication could be done is a different 
>issue), then the nodes can move within the same ad-hoc freely by 
>keeping their IP.

Litmus test: does this allow full normalization of the addressing field?

(When I mentioned Mobile IP yesterday, I should have also mentioned 
multicast class D addresses which is also an approach to the problem 
and sounds like where you're thinking here.)

>
>3) Local traffic (within the same ad-hoc) can be routed easly. 
>Internet traffic will be subject to (gateway address resolution). 
>Since many gateways may work for the same ad-hoc, we need to 
>guarantee consistency between all gateways.

Agreed.  It's probably reasonable to conjecture that 'backside' comms 
between gateways, because their attached to the Internet, would be 
somewhat more stable than on the MANET side.  This allows cheating -- 
the gateways could sync tables that way and probably maintain 
convergence faster than the rest of the nodes within the MANET.

>
>This way no central authority is needed which is very consistent 
>with the MANET charter. Also, if an individual nodes has a static IP 
>it should be able to use it. The authentication process can 
>elementate the possibility of IP address conflict.

Military systems always need to be designed with distribution in mind 
because Bad Guys are in the business of putting craters in it.  If 
the crater coincides with a single point of failure, we have a 
problem.
-- 
b

---

From: Rex Buddenberg <[email-masked]>
Date: Fri, 28 Jun 2002 08:45:52 -0700