Subject: [manet] Gateway address resolution

From: "Yasser A. Lotfy" <[email-masked]>
Date: Fri, 28 Jun 2002 17:40:04 -0400

Hi,

Seems like many have agreed on the general ideas in my original e-mail. However, one point yet need further discussion:

Gateway address resolution; 
Since ad-hoc IP addresses don't represent a pool of addresses, the idea of subnet mask can not be used. Hince, distinguishing intranet traffic from internet traaffic becomes a critical challenge.

For example ad-hoc gateways can read distination address and check againest table of all ad-hoc IP addresses. This can raise scalability issues. Can IPv6 provide a way to distinguish local ad-hoc nodes from fixed structure nodes? Any other ideas?

Yasser 
Carleton U
Ottawa, Canada

____________________________________________________________
Win a first-class trip to New Orleans and vacation Elvis Style!.
Enter NOW!
http://r.lycos.com/r/sagel_mail/http://www.elvis.lycos.com/sweepstakes/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 28 Jun 2002 18:06:57 -0400

Yasser A. Lotfy wrote:

> Seems like many have agreed on the general ideas in my 
> original e-mail. However, one point yet need further discussion:
> 
> Since ad-hoc IP addresses don't represent a pool of 
> addresses, the idea of subnet mask can not be used. Hince, 
> distinguishing intranet traffic from internet traaffic 
> becomes a critical challenge.
> 
> For example ad-hoc gateways can read distination address and 
> check againest table of all ad-hoc IP addresses. This can 
> raise scalability issues. Can IPv6 provide a way to 
> distinguish local ad-hoc nodes from fixed structure nodes? 
> Any other ideas?

There are many possible variations to how addressing inside the MANET is handled, which makes brief replies difficult or incomprehensible. But I'll give this suggestion.

Assume that MANET hosts use their own IP address, as if it were a flat address. That seems to be the most general case. Have all these random IP addresses intercommunicating in the MANET.

For that to work, with IPv4 addressing especially, I don't see any good solution except one in which the MANET-Internet gateways keep a table of all IP SAs they see arriving from the MANET. If they see packets with IP DAs that they have seen operating in that MANET, they do not forward the packets through to the Internet.

To build up this exhaustive table, ICMP router discovery (RFC 1256), or a derivative, might be useful, and all MANET hosts must participate. In other words, all hosts must transmit router solicitations, in order to be seen by the gateway(s).

If the gateways see an IP DA that they have not seen in the MANET, the gateways must assume these packets are meant for the fixed Internet.

In this last instance, the gateway maps the IP SA of the incoming packet to a fixed-internet address from their fixed Internet subnet, then forwards the packet on to the wired Internet.

Any packet returning with that IP DA is then mapped to the actual IP address of that MANET host, as they had been tabulated by the gateway previously.

This table must be aged, of course.

With IPv6, I would think one could use a simpler scheme, where each MANET host can use its MAC address embedded in the IPv6 address, with some bogus MANET prefix, and let the gateway take care of the prefix for stuff going outside the MANET.

Bert

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 28 Jun 2002 18:06:57 -0400

Bert