Subject: [manet] QoS over a wireless Ad Hoc network

From: John Peter Tapsell <[email-masked]>
Date: Thu, 27 Jun 2002 13:53:53 +0100

<nl>  I'm trying to find any information on whether I could get QoS
over an Ad-Hoc network.  I have been looking into the various routing
protocols, but not sure which would be suitable for trying to get QoS vver.
<nl><nl>

<nl>  I have looked at RSVP, but as it stands, it doesn't support mobile networks
let alone ad-hoc networks.  There is MRSVP for using RSVP over Mobile IP,
but I need an Ad-Hoc network.
<nl><nl>

<nl>  Unfortunately most information about RSVP is at least 4-5 years old -
what happened?  The mailing lists seem to just die over night.
<nl><nl>

<nl>  I would be looking for a linux implementation, or implementing it myself in ln
^H^HLinux
<nl><nl>

<nl>  Any comments at all are welcome,
sorry if this is the wrong place.         
<nl><nl>

Thanks,
John Tapsell

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Liangping Ma <[email-masked]>
Date: Thu, 27 Jun 2002 09:12:40 -0400 (EDT)

Hi, John,

    There are some QoS schemes over Ad-Hoc networks. For example,
INSIGNIA, and SWAN. They were developed by the comet group in Columbia
University. You can go to the university's webpage and find them.

Sincerely yours,
Liangping Ma

On Thu, 27 Jun 2002, John Peter Tapsell wrote:

>
>   I'm trying to find any information on whether I could get QoS over an Ad-Hoc network.  I have been looking into the various routing protocols, but not sure which would be suitable for trying to get QoS vver.
>
>
>   I have looked at RSVP, but as it stands, it doesn't support mobile networks let alone ad-hoc networks.  There is MRSVP for using RSVP over Mobile IP, but I need an Ad-Hoc network.
>
>
>   Unfortunately most information about RSVP is at least 4-5 years old - what happened?  The mailing lists seem to just die over night.
>
>
>   I would be looking for a linux implementation, or implementing it myself in ln ^H^HLinux
>
>
>   Any comments at all are welcome, sorry if this is the wrong place.
>
>   Thanks, John Tapsell  _______________________________________________ manet mailing list [email-masked] https://www1.ietf.org/mailman/listinfo/manet

---

From: Liangping Ma <[email-masked]>
Date: Thu, 27 Jun 2002 09:12:40 -0400 (EDT)

Hi, John,

Sincerely yours,
Liangping Ma

---

From: Rex Buddenberg <[email-masked]>
Date: Thu, 27 Jun 2002 10:27:41 -0700

>protocols, but not sure which would be suitable for trying to get QoS vver.

do you want QoS or QoS control?

>but I need an Ad-Hoc network.

RSVP is per flow; diff-serv is per hop.  What are your requirements?

>what happened?  The mailing lists seem to just die over night.

RSVP sets up reservations across a series of routers.  It therefore 
freezes the topology ... or in language I prefer, it reintroduces 
state into the network layer where the genius of IP was to get it 
out.  In marketing terms, 'RSVP doesn't scale'.    Once this 
realization sank in, RSVP quickly lost popularity.

In a MANET context, RSVP (aka integrated services) runs directly 
counter to the highly volatile topology expected in MANETs -- it 
requires a fixed path through the routing fabric for the duration of 
an RSVP-endowed connection.

><nl>  I would be looking for a linux implementation, or implementing 

Priority queueing, which is what diff-serv does, is much more 
scaleable.  It doesn't reintroduce state in routers.  There's no 
reason I can think of that diff-serv wouldn't work just as well in 
MANETs.  Just don't expect determinism.

The Linux diffserv list has this in the address block, help yourself:

List-Help: <mailto:[email-masked]?subject=help>
List-Post: <mailto:[email-masked]>
List-Subscribe: 
<https://lists.sourceforge.net/lists/listinfo/diffserv-general>,
	<mailto:[email-masked]?subject=subscribe>
List-Id: General discussion of Differentiated Services on Linux 
<diffserv-general.lists.sourceforge.net>
List-Unsubscribe: 
<https://lists.sourceforge.net/lists/listinfo/diffserv-general>,
	<mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://www.geocrawler.com/redir-sf.php3?list=diffserv-general>

-- 
b

---

From: Rex Buddenberg <[email-masked]>
Date: Thu, 27 Jun 2002 10:27:41 -0700

-- 
b