Subject: RE: [manet] IP addresses in MANET

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 27 Jun 2002 17:06:42 -0400

I agree with the thrust of what Yasser says below, which is why I initially offered that MANET addressing would in effect be a flat address space, at least as long as the packets remain within the MANET.

IPv6 would be nice because it supports autoconfiguration. Perhaps, for example, an IP address prefix could be added to the IP addresses used in the MANET by whatever gateway(s) might connect the MANET to the Internet. Meanwhile, a unique MAC address embedded in the IPv6 address would guarantee address uniqueness within the MANET, and then in the Internet.

But these are just words. Exactly how one keeps multiple gateways from sending duplicate packets to the Internet, for instance, is not clear to me. As well as a host of other issues.

Bert

> -----Original Message-----
> From: Yasser A. Lotfy [mailto:[email-masked]]
> Sent: Thursday, June 27, 2002 4:55 PM
> To: Rex Buddenberg; Kuldip Singh Pabla; Charles E. Perkins
> Cc: [email-masked]
> Subject: Re: [manet] IP addresses in MANET
> 
> 
> Good day everybody,
> 
> I've been following on the IP addressing proplem, and want to 
> contribute some thoughts
> 1) I believe ad hoc will adopt IPv6. Since no comercial 
> solution is available for ad-hoc, it makes absolute sense to 
> use IPv6 for addressing. This solve the problem of "Internet 
> running out of space" and introduce the problem of "Personal 
> IP" which is global vs local IP
> 
> 2) Assigning "pool of addresses" for an ad-hoc network is so 
> difficult in the absense of central authority. This means 
> that nodes will have to announce an IP address when joining 
> the network, get authenticated (how the authentication could 
> be done is a different issue), then the nodes can move within 
> the same ad-hoc freely by keeping their IP.
> 
> 3) Local traffic (within the same ad-hoc) can be routed 
> easly. Internet traffic will be subject to (gateway address 
> resolution). Since many gateways may work for the same 
> ad-hoc, we need to guarantee consistency between all gateways.
> 
> This way no central authority is needed which is very 
> consistent with the MANET charter. Also, if an individual 
> nodes has a static IP it should be able to use it. The 
> authentication process can elementate the possibility of IP 
> address conflict.
> 
> Hope I made my point clear, any input?
> 
> Yasser
> 
> Carleton U
> Ottawa Canada

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Fred L. Templin" <[email-masked]>
Date: Thu, 27 Jun 2002 14:32:26 -0700

Hi Bert,

Manfredi, Albert E wrote:
> But these are just words. Exactly how one keeps multiple
> gateways from sending duplicate packets to the Internet,

I'm not sure I'm interpreting your concern correctly, but
I don't think there should be any such issue when multiple
IPv6 gateways within the MANET peer with the Internet. Nodes
that send packets (and/or intermediate forwarding hops) will
eventually pick one such gateway as the final next hop before
the packet leaves the MANET. The unicast MAC address of the
gateway is then placed as the destination MAC address in the
forwarded packet, so only one border gateway will do the
forwarding and duplicates should not arise.

Did I miss your point?

Fred
[email-masked]

---

From: "Fred L. Templin" <[email-masked]>
Date: Thu, 27 Jun 2002 14:32:26 -0700

Hi Bert,

Did I miss your point?

Fred
[email-masked]