Subject: [manet] Any ns implementation for hierarchical routing?

From: "Chiang.Tan" <[email-masked]>
Date: Tue, 17 Sep 2002 10:27:31 +0100

Hi all,
    I wonder if there is any work has been done using hierarchical routing protocols in ns. I tried to search the Internet but was quite surprised that there isn't anything about hierarchical routing implemented in ns. Does anyone know anything about why this is so? Any help will be very much appreciated.

p/s: Is ZRP categorised under "hierarchical routing"?

cheers,
Chiang   

*******************************************************************************
This email and any files transmitted with it are intended solely for the use of
the individual or entity to whom they are addressed and may not be divulged to
any third party without the express permission of the originator.  Any views
expressed in this message are those of the individual sender, except where the
sender specifically states them to be the views of Thales Research Ltd.
*******************************************************************************
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Prince Samar <[email-masked]>
Date: Sun, 22 Sep 2002 00:57:49 -0400 (EDT)

Hi Chiang,

> p/s: Is ZRP categorised under "hierarchical routing"?

ZRP is not a hierarchical routing protocol, but rather a flat protocol.
There is no hierarchical structure in ZRP - each node maintains its own 
routing zone. Consequently a single node may belong to the routing zones 
of a number of nodes, depending on the zone radii of the nodes in its 
neighborhood.

Regards,
Prince.

On Tue, 17 Sep 2002, Chiang.Tan wrote:

> Hi all,
>    I wonder if there is any work has been done using hierarchical
> routing protocols in ns. I tried to search the Internet but was quite
> surprised that there isn't anything about hierarchical routing
> implemented in ns. Does anyone know anything about why this is so? Any
> help will be very much appreciated.
>

---

From: Prince Samar <[email-masked]>
Date: Sun, 22 Sep 2002 00:57:49 -0400 (EDT)

Hi Chiang,

Regards,
Prince.