Subject: [manet] a problem in aodv draft

From: "WangYong" <[email-masked]>
Date: Tue, 17 Sep 2002 22:48:47 +0800

Hello all:

When I read "draft-ietf-manet-aodv-11.txt", I was confused by the sentence below:

5.6.1. Route Reply Generation by the Destination

   If the generating node is the destination itself, it MUST increment
   its own sequence number by one if the sequence number in the
   RREQ packet is equal to that incremented value.

What "that incremented value" refers to ? 

Best Regards

Wangyong
2002.9.17

---

From: "WangYong" <[email-masked]>
Date: Fri, 20 Sep 2002 10:53:07 +0800

destination's sequence number = max( destination's sequence number , sequence number in RREQ) +1

Do you think this works ?

Wang Yong
 
 ----- Original Message ----- 
 From: "Ian Chakeres" <[email-masked]>
 To: "'WangYong'" <[email-masked]>
 Cc: "'MANET mailing list'" <[email-masked]>; <[email-masked]>
 Sent: Thursday, September 19, 2002 11:43 AM
 Subject: RE: [Aodvimpl] Re: [manet] a problem in aodv draft

 > When the destination is responding to a RREQ the destination MUST
> increment it's destination sequence number.  This is to make sure
> routing loops don't occur.
> 
> Ian Chakeres
> 
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "WangYong" <[email-masked]>
Date: Fri, 20 Sep 2002 10:53:07 +0800

Wang Yong