Subject: RE: [manet] RE: [Aodvimpl] Reaction of AODV by receiving more route replies!!

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 18 Sep 2002 06:45:33 -0700

The AODV implementation in all ns-2 packages does not conform to any
AODV draft, there are many differences.  My recommendation is to use the
AODV-UU implementation; it works great in ns-2 and is well written.  You
can find a link from the AODV webpage at
http://moment.cs.ucsb.edu/AODV/aodv.html.

Ian Chakeres

> -----Original Message-----
> From: [email-masked]
[mailto:aodvimpl-public-
> [email-masked]] On Behalf Of Riadh Marrakchi
> Sent: Wednesday, September 18, 2002 2:00 AM
> To: Ian Chakeres; [email-masked]
> Cc: 'MANET mailing list'; [email-masked]
> Subject: Re: [manet] RE: [Aodvimpl] Reaction of AODV by receiving more
> route replies!!
> 
> Hi,
> Ian Chakeres wrote:
> 
> > A higher destination sequence number is always preferred, since it
is an
> > indicator of the freshness of the information contained.
> >
> > Because there can be delay in the network, when you receive a
message
> > does not indicate its freshness.  For example two messages are sent
from
> > node A (1,2 in that order) and they are received by node B in the
order
> > 2,1.  So which message should node B assume has more accurate
> > information?  Message 1, which was sent first but received later
than
> > message 2?  Or message 2 which was sent later?  Message 2 will
contain
> > more up to date information about node A.
> >
> > In the draft it says that you will not update a route under many
> > conditions.  One of those conditions is if a nodes sequence number
(as
> > indicated in the control message) is lower than the sequence number
> > stored in the routing table.
> 
> so far so good. can someone tell me if this feature is also
implemented in
> ns-2??
> That means, if a node gets a second route reply, which is better (Sep.
> num.
> is greater) while it's sending some data packets along the old route
> (given
> by the first route reply), does it immediatly begin to send along the
new
> route or does it first send out all old packets in the queue and then
> update its routing table for further sessions??
> Thanks in advance for any comment...
> 
> 
> >
> >
> > Ian Chakeres
> > > -----Original Message-----
> > > From: Sourabh Sharma [mailto:[email-masked]]
> > > Sent: Tuesday, September 17, 2002 8:27 AM
> > > To: Ian Chakeres
> > > Subject: Re: [manet] RE: [Aodvimpl] Reaction of AODV by receiving
more
> > > route replies!!
> > >
> > > On Tue, 17 Sep 2002, Ian Chakeres wrote:
> > >
> > > > When a node creates a valid route it can send any queued
packets.
> > If it
> > > > receives a RREP with a higher destination sequence number it
will
> > update
> > > > the route and use that route from that point on.
> > >
> > >    Does higher destination sequence number always means a better
route
> > ??
> > >  If yes, then how?
> > >
> > >  if not, then why does a node update its route with the new RREP.?
> > >
> > >  Thanks in Advance.
> > >  Regards,
> > >  Sourabh Sharma
> > >  Centre for Internet Research
> > >  Singapore.
> > >                             *  * * * * * *
> > >                             * The World  *
> > >                             *  Is NoT    *
> > >                             *    EnouGh  *
> > >                             * * * *  * * *
> > > There is an answer to everything in this world.
> > >    The only question which remains to be answered
> > >      IS whether we know the answers or not.
> > >
> >
> > -------------------------------------------------------
> > Sponsored by: AMD - Your access to the experts on Hammer Technology!
> > Open Source & Linux Developers, register now for the AMD Developer
> > Symposium. Code: EX8664 http://www.developwithamd.com/developerlab
> > _______________________________________________
> > Aodvimpl-public mailing list
> > [email-masked]
> > https://lists.sourceforge.net/lists/listinfo/aodvimpl-public
> 
> 
> 
> -------------------------------------------------------
> This SF.NET email is sponsored by: AMD - Your access to the experts
> on Hammer Technology! Open Source & Linux Developers, register now
> for the AMD Developer Symposium. Code: EX8664
> http://www.developwithamd.com/developerlab
> _______________________________________________
> Aodvimpl-public mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/aodvimpl-public

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 18 Sep 2002 06:45:33 -0700

Ian Chakeres

[mailto:aodvimpl-public-
is an
message
from
order
than
contain
(as
implemented in
new
more
packets.
will
route