Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

From: "Martin Layley" <[email-masked]>
Date: Tue, 24 Sep 2002 16:16:14 +0100

But the MASER has a real beam width.  If it doesn't, then you can reduce the problem to a single dimension.  If there are several nodes along a line, as shown in the original e-mail question & answer, then the hidden node problem still exists.  If you expand the problem to a 2D plane, then the probability, even with a physical beam width of a degree or two, is greatly reduced and reduces still further when you expand to a 3D volume.  (note that I'm still considering free space.  Obstructions can cause entertainment).

The hidden node problem was demonstrated with a simple chain.  It won't go away with more complex arrangements.  The chain can happen in real life too.

		Martin
		SERI

-----Original Message-----
From: Phillip Neumiller [mailto:[email-masked]]
Sent: 24 September 2002 16:09
To: Martin Layley; Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

Lets say I have a maser tracking you line of site.  Then there
is no self interference at all right?

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

Wrong.  The probability is merely reduced.

		Martin

-----Original Message-----
From: Phillip Neumiller [mailto:[email-masked]]
Sent: 24 September 2002 16:02
To: Martin Layley
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

There is probably some materials science problems in there, but
if these platonic antennas could exist, then the self-interference
problems of exposed and hidden nodes would not longer exist right?

****************************************************************************
This e-mail is intended only for the addressee named above and may contain
confidential, proprietary or privileged information. If you are not the
named addressee or the person responsible for delivering the message to the
named addressee, please inform us promptly by reply e-mail, then delete the
e-mail and destroy any printed copy. The contents should not be disclosed to
anyone and no copies should be made. We take reasonable precautions to
ensure that our emails are virus free. However we accept no responsibility
for any virus transmitted by us and recommend that you subject any incoming
e-mail to your own virus checking procedures. 

The mail message has been scanned by MAILsweeper
for content analysis.
****************************************************************************
This e-mail is intended only for the addressee named above and may contain
confidential, proprietary or privileged information. If you are not the
named addressee or the person responsible for delivering the message to the
named addressee, please inform us promptly by reply e-mail, then delete the
e-mail and destroy any printed copy. The contents should not be disclosed to
anyone and no copies should be made. We take reasonable precautions to
ensure that our emails are virus free. However we accept no responsibility
for any virus transmitted by us and recommend that you subject any incoming
e-mail to your own virus checking procedures. 
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Phillip Neumiller <[email-masked]>
Date: Tue, 24 Sep 2002 11:27:51 -0400

...and power control that is precisely controlled can help mitigate
this problem.  The S will become N for the node down the line, but
presumably, if these platonic antennas exist the node down the line
can stear antenna nulls as well as antenna beams...

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

But the MASER has a real beam width.  If it doesn't, then you can reduce the
problem to a single dimension.  If there are several nodes along a line, as
shown in the original e-mail question & answer, then the hidden node problem
still exists.  If you expand the problem to a 2D plane, then the
probability, even with a physical beam width of a degree or two, is greatly
reduced and reduces still further when you expand to a 3D volume.  (note
that I'm still considering free space.  Obstructions can cause
entertainment).

The hidden node problem was demonstrated with a simple chain.  It won't go
away with more complex arrangements.  The chain can happen in real life too.

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Martin Layley" <[email-masked]>
Date: Tue, 24 Sep 2002 16:16:14 +0100

Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Tue, 24 Sep 2002 09:33:43 -0600

Hi Martin,

Thinking about it.  The MASER will reduce the exposed terminal problem, but
would probably increase the hidden terminal problem.  

    A
                   C
    B

If A  is sending to C and B wants to send a packet to C, it would be unable
to detect Node A's MASER transmission.  However, if they were omnicasting,
Node B would hear A's carrier and wait.

John Mullen

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 9:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Martin Layley" <[email-masked]>
Date: Tue, 24 Sep 2002 16:31:37 +0100

The probability reduces but never goes away - steering the null may increase interference from some other source.  Any technique which improves the situation with omni antennas will also work with directional ones.  There may also be some directional specific solutions.  The questions are simply 'What is an acceptable level of risk' and 'How can I produce a system with an acceptable level of risk'.

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Tue, 24 Sep 2002 09:33:43 -0600

Hi Martin,

    A
                   C
    B

John Mullen

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 9:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Martin Layley" <[email-masked]>
Date: Tue, 24 Sep 2002 16:38:05 +0100

Engineering trade-offs are soooo wonderful.

		Martin

-----Original Message-----
From: Mullen, John P. (Contractor)
[mailto:[email-masked]]
Sent: 24 September 2002 16:34
To: Martin Layley
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

Hi Martin,

    A
                   C
    B

John Mullen

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 9:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Martin Layley" <[email-masked]>
Date: Tue, 24 Sep 2002 16:38:05 +0100

Martin

-----Original Message-----

Hi Martin,

    A
                   C
    B

John Mullen

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 9:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: "Martin Layley" <[email-masked]>
Date: Tue, 24 Sep 2002 16:31:37 +0100

Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: Phillip Neumiller <[email-masked]>
Date: Tue, 24 Sep 2002 11:27:51 -0400

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:16 AM
To: Phillip Neumiller
Cc: [email-masked]
Subject: RE: [manet] Hidden- & exposed terminal problem in MANET

		Martin
		SERI

-----Original Message-----
From: Martin Layley [mailto:[email-masked]]
Sent: Tuesday, September 24, 2002 11:05 AM
To: Phillip Neumiller
Subject: RE: [manet] Hiden- & exposed terminal problem in MANET

		Martin

---

From: Jorge Nuevo <[email-masked]>
Date: Tue, 24 Sep 2002 15:55:03 -0400 (EDT)

Hi Cesar,

It is interesting the relation you point between the sensing range and the
hidden/exposed problems. If I understand well,

1)the lower the carrier sensing threshold (the larger the sensing range)
-> results in a reduced hidden terminal problem, but in an increased
exposed terminal problem (and less spatial reuse).

2)Increasing the carrier sensing threshold (shortening the sensing range)
-> results in an increased hidden terminal problem (but a better spatial
reuse).

am I right?. What it is needed then is a compromise between these two
points, any document or site where we can see some results, simulations
about this?

regards

Jorge

On Tuesday 24 September 2002 09:46 am, Cesar Santivanez wrote:

> Brahim BENSAOU wrote:

> > This was an interesting example, except that it does not take
> > account of the different time scales under consideration and
> > most importantly it ignored the double dimension of the
> > carrier sensing mechanism of 802.11.

> Actually, I tried to make the example related to the general RTS/CTS
> handshake and somewhat independent of any particular protocol.
>

> Regarding your comments I agree that generally the sensing range is
greater
> than the transmission  range (distance -- or patloss -- needed to
> successfully decode packets). However, this is not necessaryly an
> advantage, since the greater the sensing range, the worse the `exposed
> terminal' problem become. I have no doubt that small carrier sensing
> threshold in a 802.11-like protocol will tend to reduce the hidden
terminal
> problem, but at the cost of reducing spatial reuse due to the exposed
> terminal problem.  So, obviously you do not want to make this value too
> small nor to have a large `sensing range'. In the other hand, being more
> `aggressive' -- i.e. increasing the carrier sensing threshold to better
> exploit spatial reuse --  may initially increase throughput but after a
> point it will induce to many collisions due to the hidden terminal
problem.

> Besides that, you can not guarantee that in 802.11 the sensing range
will
> be twice the transmission range. Obviously this depends on the
propagation
> model you are using. With obstacles, etc., pathloss may decay way faster
> than you expected. In the scenarios I play with, this is usually the
case
> and that is why I picked the example below. But you can easily think of
> other examples of situation when you loss `state' information.  IMHO,
the
> true of the matter is: losing state information is not the exception but
> the norm in 802.11-like protocols, at least in scenaros where pathloss
> decay is dominated by obstructions instead of distance.
>

> BTW, I am interested at looking at your sim results, specially if you
> played around with the carrier sensing threshold.  Is there a place
where
> I can look at them??

> Thanks

> Cesar

---

From: Jorge Nuevo <[email-masked]>
Date: Tue, 24 Sep 2002 15:55:03 -0400 (EDT)

Hi Cesar,

regards

Jorge

greater
terminal
problem.

will
propagation
case
the

where