Subject: [manet] Re: Routing support in MobieEmu

From: Sourabh Sharma <[email-masked]>
Date: Sat, 21 Sep 2002 18:57:25 +0800 (GMT-8)

On Sat, 21 Sep 2002, Yongguang Zhang wrote:

> MobiEmu has no "underlying" routing protocol and
> doesn't emulate any (except perhaps one fictitious
> shortest path routing).   It only gives you an
> environment as if hosts were in an ad-hoc network.
> You ought to have your own routing code (or download
> and install some of the available implementations)
> running on each host.

   Dun u think, the socket extension ( for users
  NOT having root access to clusters) is not of any use
  since we need to install the routing code*  on all the 
  hosts.I mean if we dun have root access, we can't probably
  have the access to install/load AODV/DSR in to each of the
  hosts since it requires recompiling of kernel, enabling some
  options etc etc.

 * Not To Mention that requiring "real code" is itself a draw back
   since we cannot test the most recent protocols, since ppl
   ppl always develop NS simulations before implemeting the
   real protocol.

    ( I am seriously thinking of using MobiEmu, but due to the
  above drawbacks I am kind of stalled and rethinking to 
  work on the good-ol NS only. :-)

      Any solutions Dr. yg zhang?
> 
> Yongguang
> 
> 
> 
> At 09:02 AM 9/19/02 +0800, Sourabh Sharma wrote:
> 
> >  Hello Sir,
> >            I am doing a study of the different routing protocols
> >  in Manet and would like to use the MobiEmu for my experiments.
> >   I wanted to know how do we keep changing the underlying routing
> >  protocols in MobiEmu? Specifically if I've 2-3 routing protocols
> >  installed (AODV,DSR etc) how does the Emulator choose which protocol
> >  to emulate?
> >
> >           Also,are the normal implementations of the protocols in Linux
> >  enough for MobiEmu to use them or do we have to change something the
> >  protocol so tht the emulator can use it?
> >
> >  Waiting for your reply.
> >
> >  Reagrds,
> >  Sourabh Sharma.
> >  Centre for Internet Research
> >  National University of Singapore
> >
> >                             *  * * * * * *
> >                             * The World  *
> >                             *  Is NoT    *
> >                             *    EnouGh  *
> >                             * * * *  * * *
> >There is an answer to everything in this world.
> >    The only question which remains to be answered
> >      IS whether we know the answers or not.
> 
> 

                            *  * * * * * *
                            * The World  *
                            *  Is NoT    * 
                            *    EnouGh  *
                            * * * *  * * *
There is an answer to everything in this world.
   The only question which remains to be answered
     IS whether we know the answers or not.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sourabh Sharma <[email-masked]>
Date: Sat, 21 Sep 2002 18:57:25 +0800 (GMT-8)

*  * * * * * *
                            * The World  *
                            *  Is NoT    * 
                            *    EnouGh  *
                            * * * *  * * *

---

From: Yongguang Zhang <[email-masked]>
Date: Mon, 23 Sep 2002 18:53:25 -0500

Sourabh,

If you want to study the abstract protocol behavior only, it is
perhaps better to use a simulator like ns2.

But if you wish to study a MANET implementation, software, or real
applications in ad-hoc environment, MobiEmu can help.

As for MobiEmu socket extension, it is great for studying ad-hoc
routing in user-space.  Just like the class projects in many advanced
networking courses, routing protocols are often tried out with pure
UDP socket programming.  You can study the routing protocol logics
this way.  I have students who use this tool to implement routing
protocols, to study applications (e.g., service discovery), etc.

Regards,

Yongguang

---

From: Yongguang Zhang <[email-masked]>
Date: Mon, 23 Sep 2002 18:53:25 -0500

Sourabh,

Regards,

Yongguang

---

From: "Roberto Aldunate" <[email-masked]>
Date: Mon, 23 Sep 2002 21:18:52 -0400 (Eastern Daylight Time)

I'm working in developing a MANET as part of my PhD thesis, and I'm forced
to use windows CE.
Does anybody know if there is source code of DSR available, for this
operating system?. It's hard to find a version for such system, and to
develop one from the scratch is something I would like to overpass (if it is
possible). By the way, the one mentioned in the IETFL web page (Dublin
University) is only available in binary.

thanking in advance,

roberto.

---

From: "Roberto Aldunate" <[email-masked]>
Date: Mon, 23 Sep 2002 21:18:52 -0400 (Eastern Daylight Time)

thanking in advance,

roberto.

---

From: "Sudarshan N Raghavan" <[email-masked]>
Date: Mon, 23 Sep 2002 21:44:00 -0400

Hi,
I am analyzing the performance of ad hoc routing protocols in the presence of unidirectional links. I am interested in the performance of DSR in ad hoc networks with unidirectional links. I have not been able to find simulations that have been done over non-802.11 MACs. Could somebody provide me relevant links if some work has been done in this field ??

Regards,
Sudarshan N Raghavan
MS, Computer Sc.,
NC State University

---

From: "Sudarshan N Raghavan" <[email-masked]>
Date: Mon, 23 Sep 2002 21:44:00 -0400

Hi,

Regards,
Sudarshan N Raghavan
MS, Computer Sc.,
NC State University

---

From: Shweta Bhandare <[email-masked]>
Date: Mon, 23 Sep 2002 19:52:23 -0600

I am interested in energy efficient non-802.11 MAC layer. Can anyone 
give me some suggestions?

Thanks!
Shweta.

Sudarshan N Raghavan wrote:
> 
> Hi,
> I am analyzing the performance of ad hoc routing protocols in the 
> presence of unidirectional links. I am interested in the performance of 
> DSR in ad hoc networks with unidirectional links. I have not been able 
> to find simulations that have been done over non-802.11 MACs. Could 
> somebody provide me relevant links if some work has been done in this 
> field ??
>  
> Regards,
> Sudarshan N Raghavan
> MS, Computer Sc.,
> NC State University

---

From: Shweta Bhandare <[email-masked]>
Date: Mon, 23 Sep 2002 19:52:23 -0600

Thanks!
Shweta.

---

From: Sourabh Sharma <[email-masked]>
Date: Tue, 24 Sep 2002 18:10:47 +0800 (GMT-8)

> give me some suggestions?

        I would suggest Bluetooth.

 Also I would like to know what is the current  status of bluetooth
 implementation/research in Manets.
      If there is any one of you in this mailing list who is looking in
 to formation of scatternets over an ad-hoc network.

  Pravin, you were doing some research on routing vector methods for
 BT scatternets. Could you please let all of us know whether there is
 any routing protocol out ( design/implementation) specifically for
 BT scatternets.If its within IPR!:-)

     Also, the last time I heard tht there is still no hardware available
 for formation of BT scatternets. Is this true?
 Does this mean that even if we run AODV, DSR etc in BT devices. WE can
only run it inside a single piconet??

 Thanks,
 Sourabh.

                            *  * * * * * *
                            * The World  *
                            *  Is NoT    * 
                            *    EnouGh  *
                            * * * *  * * *

---

From: Sourabh Sharma <[email-masked]>
Date: Tue, 24 Sep 2002 18:10:47 +0800 (GMT-8)

Thanks,
 Sourabh.

                            *  * * * * * *
                            * The World  *
                            *  Is NoT    * 
                            *    EnouGh  *
                            * * * *  * * *

---

From: Uriel Roque <[email-masked]>
Date: Wed, 25 Sep 2002 09:30:41 +0200 (MEST)

Hi everybody,
I have a question for the people working on AODV. I want to know what is the
effect on the performance of the AODV routing algorithm if the link layer
notifications are ignored. I just want to use Hello AODV messages to maintain
the local connectivity. Does anybody have any idea or some results comparing
AODV with only Hello messages and AODV with Hello messages and link layer
notifications?
Thanks in advance
Uriel

-- 
Werden Sie mit uns zum "OnlineStar 2002"! Jetzt GMX wählen -
und tolle Preise absahnen! http://www.onlinestar.de

---

From: Uriel Roque <[email-masked]>
Date: Wed, 25 Sep 2002 09:30:41 +0200 (MEST)

Hi everybody,

---

From: Erik Nordström <[email-masked]>
Date: 25 Sep 2002 09:42:08 +0200

My experience running the AODV-UU implementation in ns-2 is that the
difference between using Hellos and link layer is typically in the range
of 2-10%, with link layer being the better one... Then there can of
course be differences depending on the scenario, network load and so
forth.

Erik Nordström

Uppsala University, Sweden.

-- 
Erik Nordström <[email-masked]>

---

From: Erik Nordström <[email-masked]>
Date: 25 Sep 2002 09:42:08 +0200

Erik Nordström