Subject: RE: [manet] a problem in aodv draft

From: "Ian Chakeres" <[email-masked]>
Date: Tue, 17 Sep 2002 19:16:48 -0700

When a RRER is received for an active route, the routes destination
sequence number is incremented (and the route invalidated).  If that
node initiates a new RREQ, the destination sequence number in the RREQ
will be larger than the actual destination sequence number stored by the
destination.  When the destination receives the RREQ it must increase
its sequence number, to be greater than (or equal to, I think) the
destination sequence number in the RREQ.

Ian Chakeres

> -----Original Message-----
> From: WangYong [mailto:[email-masked]]
> Sent: Tuesday, September 17, 2002 6:54 PM
> To: Ian Chakeres
> Subject: Re: [manet] a problem in aodv draft
> 
> Hello Ian,
> 
> Thank you for your replying.
> From your description, as I understood, it is possible that a RREQ
packet
> contains
> a sequence number greater than the destination's sequence number. But
when
> does
> this happen? Can you give me an example? And if  it happens, the
RREQ's
> sequence
> number is under any circumstance greater than the destinations' JUST
BY
> ONE??
> 
> Best Regards
> Wang Yong
> 
> ----- Original Message -----
> From: "Ian Chakeres" <[email-masked]>
> To: "'WangYong'" <[email-masked]>; <[email-masked]>
> Sent: Tuesday, September 17, 2002 11:27 PM
> Subject: RE: [manet] a problem in aodv draft
> 
> 
> > Before generating a RREP the destination's internal sequence number
must
> > be greater than or equal to the destination sequence number in the
RREQ
> > packet.
> >
> > If a RREQ packet comes in (to the destination) with a destination
> > sequence number greater the node's internal sequence number, the
node
> > must increase its internal sequence number to be equal to the
> > destination sequence number in the RREQ.
> >
> > I agree the wording in this section is hard to understand.
> > Ian Chakeres
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> > WangYong
> > Sent: Tuesday, September 17, 2002 7:49 AM
> > To: [email-masked]
> > Subject: [manet] a problem in aodv draft
> >
> > Hello all:
> >
> > When I read "draft-ietf-manet-aodv-11.txt", I was confused by the
> > sentence below:
> >
> > 5.6.1. Route Reply Generation by the Destination
> >
> > If the generating node is the destination itself, it MUST increment
> > its own sequence number by one if the sequence number in the
> > RREQ packet is equal to that incremented value.
> >
> > What "that incremented value" refers to ?
> >
> > Best Regards
> >
> > Wangyong
> > 2002.9.17
> >
> >

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Ian Chakeres" <[email-masked]>
Date: Tue, 17 Sep 2002 19:16:48 -0700

Ian Chakeres

packet
when
RREQ's
BY
must
RREQ
node
Of