Subject: [Fwd: Re: [manet] RE: [Aodvimpl] Reaction of AODV by receiving more routereplies!!]

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 17 Sep 2002 11:52:54 -0700

Hello folks,

The original mail had an addressing error for this
mailing list, so I'm forwarding it directly.

Regards,
Charlie P.

-------- Original Message --------
From: "Charles E. Perkins" <[email-masked]>
Subject: Re: [manet] RE: [Aodvimpl] Reaction of AODV by receiving more
routereplies!!
To: Sourabh Sharma <[email-masked]>
CC: Ian Chakeres <[email-masked]>,
[email-masked],[email-masked]

Hello Sourabh,

Under all circumstances, a valid route with a more recent
destination sequence number MUST be preferred to a previous
route, even if there are more hops.  Otherwise the loop-freedom
criterion can be violated.

Regards,
Charlie P.

Sourabh Sharma wrote:
> 
> On Tue, 17 Sep 2002, Ian Chakeres wrote:
> 
> > A higher destination sequence number is always preferred, since it is an
> > indicator of the freshness of the information contained.
> 
>          should a node update its  route just because its  getting a fresher
>   route now? What if this newer route actually has more no. of hops
>   or it already has lot of traffic on it, or is unidirectional?
> 
> >
> > In the draft it says that you will not update a route under many
> > conditions.  One of those conditions is if a nodes sequence number (as
> > indicated in the control message) is lower than the sequence number
> > stored in the routing table.
> 
>   I think there should be a few more factors ( hop count,bandwidth
> available, etc ) which a node should take in to consideration
>  before updating its routing table.
> 
>   I am sure AODV-implementors must've give this a thought.
>  If not, let me know, I'll study in to this matter then.
>  Reagrds,
>  Sourabh Sharma
>  Centre for Internet Research
>  National University of Singapore
> >
> > Ian Chakeres
> > > -----Original Message-----
> > > From: Sourabh Sharma [mailto:[email-masked]]
> > > Sent: Tuesday, September 17, 2002 8:27 AM
> > > To: Ian Chakeres
> > > Subject: Re: [manet] RE: [Aodvimpl] Reaction of AODV by receiving more
> > > route replies!!
> > >
> > > On Tue, 17 Sep 2002, Ian Chakeres wrote:
> > >
> > > > When a node creates a valid route it can send any queued packets.
> > If it
> > > > receives a RREP with a higher destination sequence number it will
> > update
> > > > the route and use that route from that point on.
> > >
> > >    Does higher destination sequence number always means a better route
> > ??
> > >  If yes, then how?
> > >
> > >  if not, then why does a node update its route with the new RREP.?
> > >
> > >  Thanks in Advance.
> > >  Regards,
> > >  Sourabh Sharma
> > >  Centre for Internet Research
> > >  Singapore.
> > >                             *  * * * * * *
> > >                             * The World  *
> > >                             *  Is NoT    *
> > >                             *    EnouGh  *
> > >                             * * * *  * * *
> > > There is an answer to everything in this world.
> > >    The only question which remains to be answered
> > >      IS whether we know the answers or not.
> > >
> >
> >
> >
> 
>                             *  * * * * * *
>                             * The World  *
>                             *  Is NoT    *
>                             *    EnouGh  *
>                             * * * *  * * *
> There is an answer to everything in this world.
>    The only question which remains to be answered
>      IS whether we know the answers or not.
> 
> -------------------------------------------------------
> This SF.NET email is sponsored by: AMD - Your access to the experts
> on Hammer Technology! Open Source & Linux Developers, register now
> for the AMD Developer Symposium. Code: EX8664
> http://www.developwithamd.com/developerlab
> _______________________________________________
> Aodvimpl-public mailing list
> [email-masked]
> https://lists.sourceforge.net/lists/listinfo/aodvimpl-public

-------------------------------------------------------
This SF.NET email is sponsored by: AMD - Your access to the experts
on Hammer Technology! Open Source & Linux Developers, register now
for the AMD Developer Symposium. Code: EX8664
http://www.developwithamd.com/developerlab
_______________________________________________
Aodvimpl-public mailing list
[email-masked]
https://lists.sourceforge.net/lists/listinfo/aodvimpl-public
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 17 Sep 2002 11:52:54 -0700

Hello folks,

Regards,
Charlie P.

-------- Original Message --------
From: "Charles E. Perkins" <[email-masked]>
Subject: Re: [manet] RE: [Aodvimpl] Reaction of AODV by receiving more
routereplies!!

Hello Sourabh,

Regards,
Charlie P.