Subject: [manet] Performance problems in aodv through nb_purge?

From: Riadh Marrakchi <[email-masked]>
Date: Mon, 23 Sep 2002 11:40:59 +0200

Hi everybody,
i already sent this message couple of days ago but i got no answer. I'm
sending it again because i think this issue could be a serious problem
for the evaluation of the performance of AODV in ns-2. I' m talking
about the version ns2.1b9.
The function nb_purge() of AODV (in aodv.cc) should delete the
neighbors, that are timed out in order to eliminate any stale
information in the current node. Normally the nb_delete() function
should be called to delete the neighbor, that is timed out. But the line
including this call (nb_delete(nb->nb_addr)) is commented out, so that
the nb_purge() function is practically without any effect.
I would appreciate any help or comment...
Regards
Riadh

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Mon, 23 Sep 2002 11:10:23 -0700

Riadh,

You are correct that the line you refer to should not
be commented out.  Mahesh Marina informed me of this
last February. However, this will affect simulation results 
only if link-layer detection is not used (so that HELLOs are 
used to detect link failures).

Richard

---

From: [email-masked]
Date: Mon, 23 Sep 2002 11:10:23 -0700

Riadh,

Richard