Subject: RE: [manet] a problem in aodv draft

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 18 Sep 2002 06:45:33 -0700

I'd follow the weird wording.  That is increment the sequence number,
then compare.  If the "incremented sequence number" is still less than
the sequence number in the RREQ then it must be increased.

Ian Chakeres

> -----Original Message-----
> From: WangYong [mailto:[email-masked]]
> Sent: Tuesday, September 17, 2002 9:29 PM
> To: Ian Chakeres
> Subject: Re: [manet] a problem in aodv draft
> 
> Thanks for your help.
> But I DO think this part's wording  is so weird.
> If I want to code this part, should I first compare the two sequence
> numbers or frist increase the
> sequence number of the destination?
> 
> Wang Yong
> 
> ----- Original Message -----
> From: "Ian Chakeres" <[email-masked]>
> To: "'WangYong'" <[email-masked]>
> Cc: "'MANET mailing list'" <[email-masked]>
> Sent: Wednesday, September 18, 2002 10:16 AM
> Subject: RE: [manet] a problem in aodv draft
> 
> 
> > When a RRER is received for an active route, the routes destination
> > sequence number is incremented (and the route invalidated).  If that
> > node initiates a new RREQ, the destination sequence number in the
RREQ
> > will be larger than the actual destination sequence number stored by
the
> > destination.  When the destination receives the RREQ it must
increase
> > its sequence number, to be greater than (or equal to, I think) the
> > destination sequence number in the RREQ.
> >
> > Ian Chakeres
> >
> > > -----Original Message-----
> > > From: WangYong [mailto:[email-masked]]
> > > Sent: Tuesday, September 17, 2002 6:54 PM
> > > To: Ian Chakeres
> > > Subject: Re: [manet] a problem in aodv draft
> > >
> > > Hello Ian,
> > >
> > > Thank you for your replying.
> > > From your description, as I understood, it is possible that a RREQ
> > packet
> > > contains
> > > a sequence number greater than the destination's sequence number.
But
> > when
> > > does
> > > this happen? Can you give me an example? And if  it happens, the
> > RREQ's
> > > sequence
> > > number is under any circumstance greater than the destinations'
JUST
> > BY
> > > ONE??
> > > Best Regards
> > > Wang Yong

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 18 Sep 2002 06:45:33 -0700

Ian Chakeres

RREQ
the
increase
But
JUST

---

From: "WangYong" <[email-masked]>
Date: Thu, 19 Sep 2002 10:07:55 +0800

Why not just compare the two sequence number, if the sequence number in RREQ is greater than 
destination's sequence number ,then set  the destination's equal to that in RREQ ?

I think that would be easier and make more sense.

Wang Yong

---

From: "WangYong" <[email-masked]>
Date: Thu, 19 Sep 2002 10:07:55 +0800

Wang Yong

---

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 18 Sep 2002 20:43:11 -0700

When the destination is responding to a RREQ the destination MUST
increment it's destination sequence number.  This is to make sure
routing loops don't occur.

Ian Chakeres

> From: [email-masked]
[mailto:aodvimpl-public-
> [email-masked]] On Behalf Of WangYong
> Sent: Wednesday, September 18, 2002 7:08 PM
> To: Ian Chakeres
> Cc: MANET mailing list; [email-masked]
> Subject: [Aodvimpl] Re: [manet] a problem in aodv draft
> 
> Why not just compare the two sequence number, if the sequence number
in
> RREQ is greater than
> destination's sequence number ,then set  the destination's equal to
that
> in RREQ ?

---

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 18 Sep 2002 20:43:11 -0700

Ian Chakeres

[mailto:aodvimpl-public-
in
that

---

From: Christian de Waal <[email-masked]>
Date: Thu, 19 Sep 2002 12:04:30 +0200

Hello Ian, hello all,

I am not sure if I understand you correctly.
- The destination MUST (unconditionally) increase its sequence number 
upon RREQ reception?
- Your interpretation of the draft section 5.6.1 is that the destination 
increases its sequence number, then compares it to the RREQs destination 
sequence number, then maybe increases it again?

After some AODV draft exegesis, I personally come to the conclusion that 
the destination must increment its own sequence number if and only if it 
is equal to the RREQs destination sequence number - 1. "Otherwise, the 
destination does not change its sequence number..." This is actually 
what I also read from a previous message of yours.

To clarify this, I think it would be interesting for me and probably the 
other people who raised questions about this AODV design issue to 
discuss its reasons. Here are my thoughts on this:

1) Not requiring the destination to unconditionally increase its 
sequence number should be workable (and not result in loops) because in 
the face of a link break, the source (or locally repairing) node must 
increase its destination sequence number. Now there are two possibilities:

a) If this was the most current destination sequence number, the 
destination must also increase its own sequence number anyway.

b) If this was not the most current destination sequence number, the 
reply of an intermediate node with the most current destination sequence 
number is just as fine as the destination's reply itself, and there is 
no reason why this might cause a loop.

Letting the destination increase its sequence number as seldom as 
possible aims at reducing control traffic, I guess.

2) I believe this curious condition for the destination to increase its 
sequence number is justified by the fact that it is not possible for the 
RREQs destination sequence number to be more than 1 higher, although I 
wonder why it is not simply specified as Wang suggested (the destination 
generally adjusts its own sequence number to that given in a RREQ if it 
is lower) in order to make the protocol specification a little more 
resilient.

What are other people's thoughts on this?

Regards,
Christian de Waal

Ian Chakeres wrote:
>>>I'd follow the weird wording.  That is increment the sequence
>>
> number,
> 
>>>then compare.  If the "incremented sequence number" is still less
>>
> than
> 
>>>>If I want to code this part, should I first compare the two
>>>
> sequence
> 

-- 
_____________________________________________________________________
Christian de Waal

University of Bonn                     Tel.:   +49-228-73-4548
Institute of Computer Science IV       Fax:    +49-228-73-4571
Roemerstr. 164                         E-mail: [email-masked]
D-53117 Bonn, Germany                  http:   www.cs.uni-bonn.de/IV/

---

From: Christian de Waal <[email-masked]>
Date: Thu, 19 Sep 2002 12:04:30 +0200

Hello Ian, hello all,

Regards,
Christian de Waal