Subject: [manet] ip address allocation

From: "John Paul O'Grady" <[email-masked]>
Date: Wed, 2 Oct 2002 15:05:53 +0100

Hello

I have a question in regards to ip address allocation in an ad hoc
environment. In an ad hoc environment presumely ip addresses will be
allocated dynamically to new nodes as they attach themselves to the
network.

Is there much research out there into how exactly this will be done. 
I know in a normal network it can be done through a dhcp server, but
in an ad hoc environment you cant really assume a dhcp server will be
available.

john paul o grady
cit 
ireland

-------------------Legal  Disclaimer---------------------------------------

The above electronic mail transmission is confidential and intended only for the person to whom it is addressed. Its contents may be protected by legal and/or professional privilege. Should it be received by you in error please contact the sender at the above quoted email address. Any unauthorised form of reproduction of this message is strictly prohibited. The Institute does not guarantee the security of any information electronically transmitted and is not liable if the information contained in this communication is not a proper and complete record of the message as transmitted by the sender nor for any delay in its receipt.

----------------------------------------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Mesut Günes" <[email-masked]>
Date: Wed, 2 Oct 2002 17:29:36 +0200

Hi,

###I have a question in regards to ip address allocation in an 
###ad hoc environment. In an ad hoc environment presumely ip 
###addresses will be allocated dynamically to new nodes as they 
###attach themselves to the network.
###
###Is there much research out there into how exactly this will be done. 
###I know in a normal network it can be done through a dhcp 
###server, but in an ad hoc environment you cant really assume 
###a dhcp server will be available.

We have proposed a distributed dynamic configuration algorithm for
mobile 
multi-hop ad-hoc networks which do not require human interaction. Our
aim 
was to introduce a mechanism which is also able to recognize the
splitting 
and merging of several ad-hoc networks.

In our paper we have tried to give an overview about existing dynamic 
addressing approaches (DHCP, Zero Configuration, Auto-Configuration,
...). 
Additionally, you'll find a performance comparison of our own approach
and  DHCP and Auto-Configuration. All results are obtained over ns-2.

Paper:
------
Mesut Günes and Jörg Reibel. 
An ip address configuration algorithm for zeroconf. mobile multi-hop
ad-hoc networks. 
In Proceedings of the International Workshop on Broadband Wireless
Ad-Hoc Networks and Services, Sophia Antipolis, France, September 2002.
ETSI.

The paper is also electronically available via:
http://www.projectmesa.org/workshop2002/agenda.htm

Regards
Mesut Günes

PS: Further information aobut our work you'll find via:
http://www.adhoc-nets.de

---

From: "Mesut Günes" <[email-masked]>
Date: Wed, 2 Oct 2002 17:29:36 +0200

Hi,

Paper:
------

Regards
Mesut Günes

---

From: Nitin H Vaidya <[email-masked]>
Date: Wed, 2 Oct 2002 10:39:03 -0500 (CDT)

On Wed, 2 Oct 2002, John Paul O'Grady wrote:

.  >>Hello
.  >>
.  >>I have a question in regards to ip address allocation in an ad hoc
.  >>environment. In an ad hoc environment presumely ip addresses will be
.  >>allocated dynamically to new nodes as they attach themselves to the
.  >>network.
.  >>
.  >>Is there much research out there into how exactly this will be done. 

You might find the paper on Weak Duplicate Address Detection
from MobiHoc'02 interesting (download from www.crhc.uiuc.edu/~nhv/).

- nitin

---

From: Nitin H Vaidya <[email-masked]>
Date: Wed, 2 Oct 2002 10:39:03 -0500 (CDT)

.  >>Hello
.  >>

- nitin

---

From: Joe Macker <[email-masked]>
Date: Wed, 02 Oct 2002 12:45:29 -0400

>in an ad hoc environment you cant really assume a dhcp server will be

In general, we need more work here on autoconfiguration but there is existing work that is related (duplicate address detection, flooding/broadcast algorithms, multi-hop stateless autoconfiguration, service discovery enhancements)...

...BUT if you just want to get something working quickly, we have demonstrated multi-hop stub network autoconfiguration using manet and dhcprelay for IPv4.  The assumption is you care about connectivity to a greater network and that there is a default gateway. Useful for a home network extension,etc.

---

From: Joe Macker <[email-masked]>
Date: Wed, 02 Oct 2002 12:45:29 -0400

---

From: "Ankur Jain" <[email-masked]>
Date: Thu, 3 Oct 2002 22:38:53 +0800

Hi

Your paper is not available on your website. I could only find the
presentation.

Could you please provide the actual paper also?

Regards
Ankur

---

From: "Ankur Jain" <[email-masked]>
Date: Thu, 3 Oct 2002 22:38:53 +0800

Hi

Regards
Ankur

---

From: "Mansoor Mohsin" <[email-masked]>
Date: Thu, 3 Oct 2002 10:37:51 -0500

Hi,

Ravi Prakash and I have a paper titled "IP Address Assignment in a Mobile Ad Hoc Network". It will appear in the MILCOM 2002 conference next week. The solution is based on the idea of "buddy list" data structure used for memory management.

There is another paper by Sanket Nasergi and Ravi Prakash titled "MANETconf: Configuration of Hosts in a Mobile Ad Hoc Network". It appeared in INFOCOM 2002. You can download this paper from http://www.utdallas.edu/~ravip/.

--------------------------------------------------------------------------------
Mansoor Mohsin

---

From: "Mansoor Mohsin" <[email-masked]>
Date: Thu, 3 Oct 2002 10:37:51 -0500

Hi,

---

From: "Mesut Günes" <[email-masked]>
Date: Fri, 4 Oct 2002 10:24:25 +0200

Hi,

you can download the PDF document via the following URL:

http://www.adhoc-nets.de/paper/2002_Addressing.pdf

Regards
Mesut Günes

###Hi
###
###Your paper is not available on your website. I could only 
###find the presentation.
###
###Could you please provide the actual paper also?
###
###Regards
###Ankur
###
###
###
###
###
###----- Original Message -----
###From: Mesut Günes <[email-masked]>
###To: <[email-masked]>
###Sent: Wednesday, October 02, 2002 11:29 PM
###Subject: AW: [manet] ip address allocation
###
###
###> Hi,
###>
###> ###I have a question in regards to ip address allocation 
###in an ###ad 
###> hoc environment. In an ad hoc environment presumely ip 
######addresses 
###> will be allocated dynamically to new nodes as they ###attach 
###> themselves to the network. ###
###> ###Is there much research out there into how exactly this 
###will be done.
###> ###I know in a normal network it can be done through a dhcp
###> ###server, but in an ad hoc environment you cant really assume
###> ###a dhcp server will be available.
###>
###> We have proposed a distributed dynamic configuration algorithm for 
###> mobile multi-hop ad-hoc networks which do not require human 
###> interaction. Our aim
###> was to introduce a mechanism which is also able to recognize the
###> splitting
###> and merging of several ad-hoc networks.
###>
###> In our paper we have tried to give an overview about 
###existing dynamic 
###> addressing approaches (DHCP, Zero Configuration, 
###Auto-Configuration, 
###> ...). Additionally, you'll find a performance comparison 
###of our own 
###> approach and  DHCP and Auto-Configuration. All results are 
###obtained 
###> over ns-2.
###>
###> Paper:
###> ------
###> Mesut Günes and Jörg Reibel.
###> An ip address configuration algorithm for zeroconf. mobile 
###multi-hop 
###> ad-hoc networks. In Proceedings of the International Workshop on 
###> Broadband Wireless Ad-Hoc Networks and Services, Sophia Antipolis, 
###> France, September 2002. ETSI.
###>
###>
###> The paper is also electronically available via: 
###> http://www.projectmesa.org/workshop2002/agenda.htm
###>
###>
###>
###> Regards
###> Mesut Günes
###>
###> PS: Further information aobut our work you'll find via: 
###> http://www.adhoc-nets.de
###>
###> _______________________________________________
###> manet mailing list
###> [email-masked]
###> https://www1.ietf.org/mailman/listinfo/manet
###
###_______________________________________________
###manet mailing list
[email-masked]
###https://www1.ietf.org/mailman/listinfo/manet
###

---

From: "Mesut Günes" <[email-masked]>
Date: Fri, 4 Oct 2002 10:24:25 +0200

Hi,

Regards
Mesut Günes

###Hi
###