Subject: [manet] IPV6 and Ad Hoc Network

From: "MEDDOUR Djamal Eddine thesard FTRD/DAC/LAN" <[email-masked]>
Date: Wed, 9 Oct 2002 14:55:58 +0200

Hi,
I have a question about the attribution of IP address within MANET with
IPV6. Is it possible to assume that a client can acquire a public IP @
from any network operator, after this, the client can use this address
any-where.

Any comments?

Sincerely 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 09 Oct 2002 08:04:13 -0700

Hello,

I believe most manet protocols intend to allow arbitrary
addresses within the ad hoc network, so that would
include a "public" IP address.  Since IPv6 addresses
are typically global, I'm not quite sure what "public"
means in that connection.

With Mobile IP, one can migrate smoothly back and
forth between the Internet and an ad hoc network that
has a point of connection to the Internet.

Even without Mobile IP, one could presumably migrate,
just not as smoothly.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 09 Oct 2002 08:04:13 -0700

Hello,

Regards,
Charlie P.