Subject: Re: [manet] About ifqueue length

From: tcp <[email-masked]>
Date: Mon, 28 Oct 2002 14:44:07 -0500 (EST)

Hi, Weihua,

"agent->ifqueue" is defined but not used.
The actual interface queue being used is:
"agent->target_->downtarget_" 
(if trace between "Agent" and "LL" is disabled), or 
"agent->target_->downtarget_->downtarget_".

You can find these details in ns-mobilenode.tcl.
Hope it helps!

Alan

> Date: Sat, 26 Oct 2002 17:48:25 +0800
> From: "yang weihua" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [manet] About ifqueue length
> 
> everyone£¬
> 	Does anybody know how to get the ifqueue(between MAC and LL) 
> length from the route agent? I have attempted to get the value 
> by doing this in the AODV C++ source code:
>    queue_len=agent->ifqueue->getLen();
> where agent is the aodv route agent. But to my disappointment, 
> the result always remained to be zero! what's the problem?
>    Appreciate your any help!
> 
> 
> 
> Best regards! 				
> 
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡yang weihua
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡[email-masked]
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡2002-10-26
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: tcp <[email-masked]>
Date: Mon, 28 Oct 2002 14:44:07 -0500 (EST)

Hi, Weihua,

Alan

---

From: Riadh Marrakchi <[email-masked]>
Date: Wed, 30 Oct 2002 11:25:02 +0100

tcp wrote:

> Hi,

what do you mean with "not used"?? is agent->ifqueue empty?? But it's
used in recvReply as well as in AODV::rt_ll_failed to drop the packets
in the interface queue, that also could not be forwarded!!!! Does it
have any effect now, since ifqueue is empty??
while((p = ifqueue->filter(broken_nbr))) {
     drop(p, DROP_RTR_MAC_CALLBACK);
    }
Can omebody clarify it. This is a little confusing.
Thanks
Riadh

---

From: Riadh Marrakchi <[email-masked]>
Date: Wed, 30 Oct 2002 11:25:02 +0100