Subject: Re: [manet] OLSR implementation

From: "Pete Sholander" <[email-masked]>
Date: Mon, 28 Oct 2002 12:09:56 -0500

Gayathri,

As another (possibly bogus!) thought ...

OSPF runs over Non-Broadcast Multicast Access (NBMA) networks.  (Check
the RFC for details.  Not sure if the code at opsf.org implements that
feature though!)

Maybe there's someway to extend OLSR to map its MPRs onto OSPF's
"Designated Router" concept.  Sounds like an interesing thesis topic. 
However, mobile ad hoc ATM networks are kind of passe by now.  Do you
have a end-user application in mind?

--Pete Sholander

>>> "Philippe Jacquet" <[email-masked]> 10/28/02 11:32AM
>>>
Dear Gayathri,

Sorry to have been late to answer. As far as I can see, the main
problem
with ATM interfaces is the broadcast, which is used in OLSR for
control
traffic and I don't know how it will work with ATM. Maybe a kind of
MARS
could be useful...

Philippe
----- Original Message -----
From: Gayathri Chandrasekaran <[email-masked]>
To: <[email-masked]>
Sent: Sunday, October 20, 2002 9:54 PM
Subject: [manet] OLSR implementation

> Hello,
> I would like to know if OLSR runs over ATM interfaces.I'm trying to
> implement some version 7 features to the INRIA version 3 OLSR linux
> implementation. So for initial testing purposes can ATM interfaces
be
> used?
>
> thanks
> gayathri
>
> Gayathri Chandrasekaran
> Department of Electrical
> Engineering and Computer Science
> University of Kansas
> Lawrence,KS-66045.
>
> _______________________________________________
> manet mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/manet 

_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Philippe Jacquet" <[email-masked]>
Date: Thu, 31 Oct 2002 15:34:04 +0100

Hello, Pete,

Do you think that the MPR could be used on OSPF only for the wireless
interfaces but also for the wired interface (as for the designated routers)?
For the latter case, are the links enough sufficiently redundant to take
advantage of MPRs? In the first case, one could imagine an extension of OSPF
for wireless links (I think it is an original idea of Fred Backer).

Philippe

---

From: "Philippe Jacquet" <[email-masked]>
Date: Thu, 31 Oct 2002 15:34:04 +0100

Hello, Pete,

Philippe