Subject: [manet] ip address allocation

From: "John Paul O'Grady" <[email-masked]>
Date: Wed, 2 Oct 2002 15:05:59 +0100

Hello

I have a question in regards to ip address allocation in an ad hoc
environment. In an ad hoc environment presumely ip addresses will be
allocated dynamically to new nodes as they attach themselves to the
network.

Is there much research out there into how exactly this will be done. 
I know in a normal network it can be done through a dhcp server, but
in an ad hoc environment you cant really assume a dhcp server will be
available.

john paul o grady
cit 
ireland

-------------------Legal  Disclaimer---------------------------------------

The above electronic mail transmission is confidential and intended only for the person to whom it is addressed. Its contents may be protected by legal and/or professional privilege. Should it be received by you in error please contact the sender at the above quoted email address. Any unauthorised form of reproduction of this message is strictly prohibited. The Institute does not guarantee the security of any information electronically transmitted and is not liable if the information contained in this communication is not a proper and complete record of the message as transmitted by the sender nor for any delay in its receipt.

----------------------------------------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Yasser A. Lotfy" <[email-masked]>
Date: Wed, 02 Oct 2002 16:02:01 -0400

Good day,

I believe your best bet in this are are

Charles E. Perkins, Jari T. Malinen, Ryuji Wakikawa, Elizabeth M. Belding-Royer, Yuan Sun, “IP Address Autoconfiguration for Ad Hoc Networks”, IETF draft, MANET working group, URL:<http://moment.cs.ucsb.edu/publications.html>, November 2001.

Ryuji Wakikawa, Jari T. Malinen, Charles E. Perkins, Anders Nilsson, Antti J. Tuominen, “Global Connectivity for IPv6 Mobile Ad Hoc Networks”, IETF draft, MANET working group, URL:<http://www.sfc.wide.ad.jp/~koshi/memo/> , November 2001.

This covers specially reactive algorithms. Proavtive algorithms followed many different avenues. Currently I'm working on enhancing the gateway information and forming sort of a gateway update protocol. If this is the way you're heading I can forward more elaborate resources.

Hope this helps,

Yasser
Carleton U

____________________________________________________________
Tired of all the SPAM in your inbox? Switch to LYCOS MAIL PLUS
http://www.mail.lycos.com/brandPage.shtml?pageId=plus
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet