Subject: [manet] DSR in TCP/IP stack

From: Kartik Rao <[email-masked]>
Date: Thu, 10 Oct 2002 15:14:30 -0400

Does anyone know where DSR sits in the TCP/IP stack? (between IP and MAC, 
at IP, between TCP and IP, above TCP)

Thanks,
Kartik
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked] (Noah H. Miller)
Date: 10 Oct 2002 15:55:54 EDT

--- You wrote: ---
Does anyone know where DSR sits in the TCP/IP stack? (between IP 
and MAC,at IP, between TCP and IP, above TCP)
Thanks,Kartik
--- end of quote ---

IETF Draft 7 for DSR (<http://www.ietf.org/internet-drafts/draft-ietf-manet-dsr-07.txt) specifies this location in Appendix B:

"Ultimately, we decided to specify and to implement [20] DSR as a layer 3 protocol, since this is the only layer at which we could realistically support multiple network interfaces of different types forming an ad hoc network."  This section also remarks 
on their hesitation and previous preference for layer 2.

In implementing DSR to run on Dartmouth's SWAN (simulation of wireless ad-hoc network), I had some difficulty inserting it into the stack.  It needs to get packets that are pushed and popped to IP, it needs to be able to push and pop packets to IP, and it
 needs to control the IP forwarding table.  It also needs control over the Network Queue (specified in section 4.5), which is analogous to the MAC buffer.

Noah Miller
ISTS, Dartmouth College

---

From: [email-masked] (Noah H. Miller)
Date: 10 Oct 2002 15:55:54 EDT

--- end of quote ---

Noah Miller
ISTS, Dartmouth College