Subject: [manet] Ad-hoc --> Ip of Nodes.

From: Sourabh Sharma <[email-masked]>
Date: Wed, 30 Oct 2002 19:36:18 +0800 (GMT-8)

Hello,
       Recently, I have set up an ad-hoc network. 
 But I noticed that somehow, the node's needed to be
 configured to be in the same subnet.
   By right, in ad-hoc , nodes having any random IP addr
 should be able to find routes to any Ipaddr and the
 underlying Ad-hoc routing protocol should update the
 source's routing table accordingly.

 In the case when the nodes are in the same subnet, you
 actually dun need an ad-hoc routing protocol! as long
 you have the routing entries correctly configured, you
 can make the nodes forward each others data packets, and
 thus have an ad-hoc network without the use of any special
 "ad-hoc" routing protocol.!!

 Secondly, I wanted to ask, out of the many ( ok, not so many)
 real ad-hoc test beds set up at CMU, MIT, INRIA etc.
 did any of you guys use any autoconf scheme ( like Zeroconf)
 or all the nodes were manually configured?
     Thirdly, since we now have an implementation of zerconf,
 known as zcip( available at http://zeroconf.sourceforge.net)
 has anyone tried using an Autoconfiguration scheme on 
 ad-hoc?

  Probably we can have seperate discussions on the 3 topics.

 Regards,
 Sourabh Sharma
 Centre for Internet Research
 National University of Singapore

--------------------------------------------------
There is an answer to everything in this world.
   The only question which remains to be answered
     IS whether we know the answers or not.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sourabh Sharma <[email-masked]>
Date: Thu, 31 Oct 2002 02:59:04 +0800 (GMT-8)

On Wed, 30 Oct 2002 [email-masked] wrote:
> In response to your first statement:
> All nodes being on the same subnet means they share the same subnet mask, but 
> not necessarily that each has a direct connection to every other.  Unless they 
> all are directly connected, you will need some routing protocol.  If they are 
> also in motion, you will need a protocol that exchanges topological information 
> and updates routing tables as nodes change position.

   Yeah, you'll need a routing protocol definitely! What I said,which
probably din get across properly, was that there is no need for a
_special_ "adhoc" routing protocol, if we (manually) configure the routing
 table of the participating nodes to forward each other's packet
correctly.

  Anyway, my main concern is --> why do the nodes need to be in the same
subnet!!...
    AODV,DSR  or any other RP for that matter should be able to find
 and consequently update routes, for sources (with random IP) trying
 to reach destinations with random IP which may or MAY NOT be in the
 same subnet.
      The RP should work for random IP addresses -- thats the bottomline
 for any ad-hoc routing protocol!!

  Regards,
  Sourabh.
  CiR, NUS.
  Singapore

> > <snip>

---

From: Joe Macker <[email-masked]>
Date: Wed, 30 Oct 2002 14:47:43 -0500

>  Anyway, my main concern is --> why do the nodes need to be in the same

They don't need to be.  Perhaps an implementation limitation.

---

From: Joe Macker <[email-masked]>
Date: Wed, 30 Oct 2002 14:47:43 -0500