Subject: [manet] AODV hello and neighbor

From: "yang weihua" <[email-masked]>
Date: Tue, 22 Oct 2002 16:13:10 +0800

hi,
	When i run a simple simulation on aodv, i found that NeighborTimer and HelloTimer 
handles have never been invoked. I just cann't understand this phenomenon.why?
	What's more, i want to do some modifications by adding infomation to hello messages.
If the NeighborTimer or HelloTimer don't work, what i can do?
	Sincely for your help. 

Best regards! 				

　　　　　　　　yang weihua
　　　　　　　　[email-masked]
　　　　　　　　　　2002-10-22

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Riadh Marrakchi <[email-masked]>
Date: Tue, 22 Oct 2002 10:42:28 +0200

Hi,
the reason is simple!! we have this piece of code in aodv.cc

int
AODV::command(int argc, const char*const* argv) {
  if(argc == 2) {
  Tcl& tcl = Tcl::instance();

    if(strncasecmp(argv[1], "id", 2) == 0) {
      tcl.resultf("%d", index);
      return TCL_OK;
    }

    if(strncasecmp(argv[1], "start", 2) == 0) {
      btimer.handle((Event*) 0);

#ifndef AODV_LINK_LAYER_DETECTION
      htimer.handle((Event*) 0);
      ntimer.handle((Event*) 0);
#endif // LINK LAYER DETECTION

      rtimer.handle((Event*) 0);
      return TCL_OK;
     }
  }
As you can see, htimer (hello timer)and ntimer(neighbor timer) are only invoked when
AODV_LINK_LAYER_DETECTION (allows using the link layer feedback to determine if a link is down)
is not defined.  To ativate these too timers you must NOT define AODV_LINK_LAYER_DETECTION in
your aodv.h file.

yang weihua wrote:

> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡yang weihua
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡[email-masked]
> ¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡¡2002-10-22
>

---

From: Riadh Marrakchi <[email-masked]>
Date: Tue, 22 Oct 2002 10:42:28 +0200

Hi,

int

---

From: "G.Lu" <[email-masked]>
Date: Tue, 22 Oct 2002 10:54:25 +0100

Hi,

If you use NS2b8, just comment out the AODV_LINK_LAYER_DETECTION in
aodv.h.

--------------------------------------------------
Mr Gang Lu
**************************************************
Centre for Mobile Communications Research
Department of Electronics & Electrical Engineering
The University of Sheffield
Mobile: +44-(0)7786-554632 (Voda)
Office: +44-(0)1142225182
HomePage: http://www.dcs.shef.ac.uk/~ganglu
**************************************************

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
yang weihua
Sent: 22 October 2002 09:13
To: [email-masked]
Subject: [manet] AODV hello and neighbor

hi,
	When i run a simple simulation on aodv, i found that
NeighborTimer and HelloTimer 
handles have never been invoked. I just cann't understand this
phenomenon.why?
	What's more, i want to do some modifications by adding
infomation to hello messages.
If the NeighborTimer or HelloTimer don't work, what i can do?
	Sincely for your help. 

Best regards! 				

　　　　　　　　yang weihua

---

From: "G.Lu" <[email-masked]>
Date: Tue, 22 Oct 2002 10:54:25 +0100

Hi,

-----Original Message-----

hi,

Best regards! 				

　　　　　　　　yang weihua