Subject: [manet] Question about traces (r,s,f,d)??

From: Riadh Marrakchi <[email-masked]>
Date: Tue, 01 Oct 2002 11:43:49 +0200

Hi,
the first column of the trace files (new traces) of the AODV simulation
just confused me a little bit.
s: is written once when the source sends a packet
d: when a packet is dropped by some node (this line is also found only
one time in the trace file when a packet is dropped)
r: when a packet arrives at the destination
f: when a packet is forwarded by some node.
so let's assume node 1 tries to send a packet to node 3 through node 2.
Node 1 sends (first column: "s") the packet, node 2 forwards ("f") it
and node 3 receives ("r") it. Is it right??? I mean doesn't node 2 first
receives ("r") the packet then forward it ("f")????
Normally we would get: Total of sent cbr packets = total of dropped cbr
packets + total of received cbr packets. But while analysing my trace
files i get:  Total of sent cbr packets < total of dropped cbr packets +
total of received cbr packets. Although the difference is not that big,
i would know how it exists???
Total of sent cbr packets: Lines with s at the beginning and cbr as
packet type
total of dropped cbr packets: Lines with d at the beginning and cbr as
packet type
total of received cbr packets:Lines with r at the beginning and cbr as
packet type

Thanks a lot for any help or comment.
Riadh

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Tue, 1 Oct 2002 08:58:21 -0700 (PDT)

You can not use the method you described. See the example below:
(The transport and IP layer trace are ON)
s 2.199994566 _1_ AGT  --- 6 cbr ....
r 2.199994566 _1_ RTR  --- 6 cbr ....
s 2.199994566 _1_ RTR  --- 6 cbr ....
r 2.200547959 _2_ RTR  --- 6 cbr ....
f 2.200547959 _2_ RTR  --- 6 cbr ....
r 2.201817971 _3_ AGT  --- 6 cbr ....

  The packet 6 is marked "cbr" all the time. It is sent by node 1 two
times (at different layers), and is received 3 times (by different nodes
and different layers). That is why your method does not work. In order
to compute correctly, you need to add "AGT" in your filter when you cout
the number of packets "sent" and "received".

  Hope it helps,

Zhenqiang(Frank)

-- 

****************************************
Zhenqiang(Frank) Ye
Ph.D Student
Department of Electrical Engineering
University of California, Riverside
Phone: (909)-787-2434
email: [email-masked]
****************************************

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Tue, 1 Oct 2002 08:58:21 -0700 (PDT)

Hope it helps,

Zhenqiang(Frank)

--

---

From: Riadh Marrakchi <[email-masked]>
Date: Wed, 02 Oct 2002 09:44:51 +0200

Hi,
the RTR Traces are set off in my simulation scripts, so that i get only the
AGT traces.

---

From: Riadh Marrakchi <[email-masked]>
Date: Wed, 02 Oct 2002 09:44:51 +0200

Hi,

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Wed, 2 Oct 2002 10:11:00 -0700 (PDT)

I don't think you can see the packet "DELETE" event in your trace file if
you turn off the RTR trace.

Frank

--

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Wed, 2 Oct 2002 10:11:00 -0700 (PDT)

Frank

--

---

From: Riadh Marrakchi <[email-masked]>
Date: Fri, 04 Oct 2002 11:27:30 +0200

Hi,
of course I can see this event although the RTR traces are disabled. When a
packet is deleted, I get notification in the trace line at the router level. It's
the only RTR traces I get when these are disabled.

---

From: Riadh Marrakchi <[email-masked]>
Date: Fri, 04 Oct 2002 11:27:30 +0200

Hi,

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Fri, 4 Oct 2002 10:21:04 -0700 (PDT)

Sorry about that. It depends on different routing protocols. How much is
the difference between the packets sent and packets received+dropped?

Frank

--

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Fri, 4 Oct 2002 10:21:04 -0700 (PDT)

Frank

--