Subject: [manet] DSR in TCP/IP stack

From: Kartik Rao <[email-masked]>
Date: Thu, 10 Oct 2002 15:14:30 -0400

Does anyone know where DSR sits in the TCP/IP stack? (between IP and MAC, 
at IP, between TCP and IP, above TCP)

Thanks,
Kartik
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sourabh Sharma <[email-masked]>
Date: Fri, 11 Oct 2002 04:00:52 +0800 (GMT-8)

> at IP, between TCP and IP, above TCP)

hi,
 These are implementation details, which can vary from one impl... to
another.(  kernel space or user space)

 but the most general one is this.
 a virtual interface (say dsr0) is created.
 all the AdNETwrk packets are sent to this interface, which
 keeps them in a store buffer.( by the time it does a route discovery).
 Anyway, I am not going to explain you the whole implementation here.
 Cutting it short, here DSR sits at the IP layer.
 ( some might say .. tht its actually below it!)

 -Sourabh Sharma
  Centre for Internet Research,
  National University of Singapore.

--------------------------------------------------
There is an answer to everything in this world.
   The only question which remains to be answered
     IS whether we know the answers or not.

---

From: Sourabh Sharma <[email-masked]>
Date: Fri, 11 Oct 2002 04:00:52 +0800 (GMT-8)

hi,

 -Sourabh Sharma