Subject: [manet] global connectivity for manets

From: "John Paul O'Grady" <[email-masked]>
Date: Fri, 11 Oct 2002 11:36:53 +0100

Hello

I am looking for research on methods for providing global internet
connectivity in manets. I have the internet drafts on Global
Connectivity for IPv4 and IPv6 Mobile Ad hoc Networks, I was just
wondering if there is any other information out there.

I would also be interested if anybody has any info on methods of
dynamic allocation of global ipv4 and ipv6 addresses in ad hoc
environments without the use of a dhcp server. Most of the research
papers I have seen seem to only consider a stand alone manet, and so
use private addresses.

Regards

john paul o grady 

-------------------Legal  Disclaimer---------------------------------------

The above electronic mail transmission is confidential and intended only for the person to whom it is addressed. Its contents may be protected by legal and/or professional privilege. Should it be received by you in error please contact the sender at the above quoted email address. Any unauthorised form of reproduction of this message is strictly prohibited. The Institute does not guarantee the security of any information electronically transmitted and is not liable if the information contained in this communication is not a proper and complete record of the message as transmitted by the sender nor for any delay in its receipt.

----------------------------------------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 11 Oct 2002 15:10:34 -0400

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
>
> If a manet node discovers an Internet Gateway, then the
> gateway "should" provide the node with prefix information
> so that the node can formulate an address which is topologically
> correct for the Gateway's attachment to the Internet.  That
> prefix can be used for dynamic address autoconfiguration (e.g.,
> RFC 2462).  The dynamic address can even be used as a care-of
> address for Mobile IP.  All of this is documented in Internet
> Drafts and some other recent publications.

I agree that this scheme for autoconfiguration should work (it uses ICMP router discover protocol vs DHCP, which some might argue amounts to the same thing in the greater scheme of things). But the Mobile IP part I don't understand.

The problem with any autoconfiguration scheme is always that no one outside that walled garden knows how to reach you unless you, the autoconfigured host, initiate the session to begin with. Same happens with DHCP. Unless you have some other protocol, like maybe SIP (which is just adding another server requirement on top of router discovery), how would your host be identifiable to the outside world?

Thanks.

Bert

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 11 Oct 2002 15:10:34 -0400

Thanks.

Bert