Subject: RE: [manet] QoS on ad-hoc networks - when and why?

From: "Martin Layley" <[email-masked]>
Date: Fri, 24 Jan 2003 08:28:01 -0000

If you are looking to carry audio or video in real time, the QoS can provide feedback to the compression system:- the better the QoS, the greater the minimum bandwidth available for data and the shorter the data transit time, due to fewer re-tries.  As the QoS diminishes, an adaptive coding scheme at application level can increase its compression rate accordingly.  If there is no communication about QoS from link-layer or network layers to application, the QoS within a layer is still helpful, as if a system tries to maintain or improve QoS, then the application sees fewer dropouts.

		Martin Layley
		Samsung - SERI

-----Original Message-----
From: Pablo Serrano Yáñez-Mingot [mailto:[email-masked]]
Sent: 23 January 2003 19:21
To: [email-masked]
Subject: [manet] QoS on ad-hoc networks - when and why?

Hi all,

I fully agree with 'SWAN philosophy', in the sense that
only a practical approach is feasible in ad hoc networks
(via a simple service differentiation).

However, for me there is still an unanswered question,
of "certain importance": When is needed QoS in ad hoc
networks? I think ad hoc networks are created towards
one concrete purpose, therefore all traffic might be
considered of the same importance.

I don't think ad hoc networks are going to be used as
"multipurpose networks", where service differentiation
is a must, at least during X months/years.

Does anybody have an actual application where there is
a true need for QoS?

"Its still early days for this topic I suspect", 
Andrew stated. I also agree here.

Cheers,

Pbl

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

The mail message has been scanned by MAILsweeper
for content analysis.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 24 Jan 2003 14:17:15 -0500

Martin,

This might be somewhat overly legalistic, but what you describe is not QoS. You are referring to Real Time Protocol (RTP), and its associated RT Control Protocol (RTCP). It works to provide audio without any QoS guarantees. It attempts to adjust the compression algorithm as a function of delivered performance, readjusting continuously in real time if need be, and is expressly designed to provide streaming service WITHOUT any QoS mechanisms.

I agree that RTP would be a way to tackle audio over a MANET. Precisely because QoS guarantees are unnecessary.

Bert

> From: Martin Layley [mailto:[email-masked]]
> Sent: Friday, January 24, 2003 3:28 AM
> To: [email-masked]
> Subject: RE: [manet] QoS on ad-hoc networks - when and why?
> 
> 
> If you are looking to carry audio or video in real time, the 
> QoS can provide feedback to the compression system:- the 
> better the QoS, the greater the minimum bandwidth available 
> for data and the shorter the data transit time, due to fewer 
> re-tries.  As the QoS diminishes, an adaptive coding scheme 
> at application level can increase its compression rate 
> accordingly.  If there is no communication about QoS from 
> link-layer or network layers to application, the QoS within a 
> layer is still helpful, as if a system tries to maintain or 
> improve QoS, then the application sees fewer dropouts.
> 
> 		Martin Layley
> 		Samsung - SERI
>

---

From: "Martin Layley" <[email-masked]>
Date: Mon, 27 Jan 2003 15:41:59 -0000

How about data communication at temporary venues?  I'm thinking of showgrounds/county fairs, where there is minimal need for infrastructure for most of the year, and huge need for 1 day/weekend/week.  The sorts of applications requiring a reasonable guarantee of data are pay kiosks, information booths and information display screens:-
Display screens need data for timetabling & messages (lost child etc) within a few minutes, information booths need an acceptable response time - long delays in responding == increase in vandalism as people get bored waiting.  The overriding requirement is the commercial traffic, to cut down on ticket queues.  This can be quite bursty in nature & must be carried swiftly & securely.

		Martin
		Samsung - SERI

-----Original Message-----
From: Pablo Serrano Yáñez-Mingot [mailto:[email-masked]]
Sent: 25 January 2003 15:32
To: Rex Buddenberg
Cc: [email-masked]
Subject: Re: [manet] QoS on ad-hoc networks - when and why?

Hi Rex,

First, thanks for your reply, but I have some brand
new comments!

I don't care for the military scenario (I mean: not from
a technical point of view :)

But I don't think 'emergency services' fit into a 
'QoS provisioning scenario', because it should be
considered an 'overlay network', and not a true
mobile ad hoc network.

I mean: in emergency situation, a new ad hoc network
should be deployed (I think). You won't have a previously
installed services, because there won't be what I called
'multipurpose ad hoc networks'. All traffic on the
network will be the same (from my point of view) in 
terms of priorities.

Also, in emergency situation you will need a reliable
authentication system, so as to only authorized nodes
are given a 'premium services' (this is why I envision
an overlay network, and not a network with QoS support)

And that's all, by the way. Cheers,

Pbl

On 23 Jan 2003, Rex Buddenberg wrote:

> Pablo,
> 
> The military scenarios for MANET are ones where some QoS control is
> needed.  There is lots of traffic -- expect it to exceed the capacity
> available forever.  And some traffic is more urgent than other.  So some
> means of priority queueing and probably some admittance control is going
> to be required. 
> 
> But ....
> 
> We have empirical evidence even in the wired Internet that most QoS
> control scheme cures are worse than the disease.  The stateful
> orientation of RSVP is an obvious one, but even diff-serv showed up a
> lot of warts.  But the IETF diff-serv exercise has to be leavened with
> at least two comments:
> 	- MANET is expressly designed to handle topology volatility.  That
> volatility is guaranteed to make any QoS control scheme harder than in a
> comparatively stable wired internet.  
> 	- the military MANET scenario is one where the standard ISP trick of
> overprovisioning isn't readily available.  
> 
> 
> If you don't care for the military scenario -- an army division on the
> move -- then an emergency services one might fit just as well.  Consider
> the emergency response and comms needs for a large fire (e.g. forest
> fire) or a chem/bio attack on a civilian population and the
> applicability of MANET capability as a need pops right out.  
> 
> On Thu, 2003-01-23 at 11:20, Pablo Serrano YÃ¡Ã±ez-Mingot wrote:
> > Hi all,
> >