Subject: RE: [manet] my doubts about QoS in ad hoc networks

From: "Pete Sholander" <[email-masked]>
Date: Tue, 28 Jan 2003 16:56:11 -0500

Ankur,

Another thought is that link-state based QoS (latency, jitter, ...) is
difficult in general MANETs.  However, node-state QoS metrics (e.g.,
remaining battery level) may be useful for unattended ground-based
sensor (UGS) networks that have a high-degree connectivity mesh.

--Pete Sholander

>>> "Kaustubh Phanse" <[email-masked]> 01/28/03 03:24PM >>>
Ankur,

	We have conducted similar experiments (in an indoor environment)
as a part of our research. I would like to point out two things here:
(1) Yes, there is considerable amount of "unpredictability" in the
performance of nodes especially at the periphery or fringe of the radio
range. However, its not necessary that this will always be the case in
all real-life scenarios. (2) Secondly, this unpredictability "typically"
increases considerably in an indoor environment (with lots of walls,
metal structures, microwave ovens, etc.) as compared to an outdoor
environment.
	So, what you are looking at is kind of a worst-case scenario.

	Talking about QoS in ad hoc networks, I agree that one may not
be able to "fully" provide any guarantees (bandwidth, delay, etc.).
However, as they say: "excellent is the enemy of good." I think the same
philosophy can be applied to QoS in ad hoc networks -- just because we
cannot have hard guarantess does not make the situation completely
hopeless!
	Our preliminary wireless experiements did include dynamic
bandwidth management, and demonstrated its effect using the VIC (video)
application. Our results, some other observations, and lessons learnt
can be found in the following paper:
K. Phanse, L. DaSilva and S. Midkiff, "Extending Policy-Based
Management to Ad Hoc Networks," submitted to IEEE Network Magazine,
October 2002. Available at:
http://www.ee.vt.edu/~kphanse/Adhoc_policy_mgmt.pdf 

Hope this helps.
Best regards,
Kaustubh
----------------------------------------------------
 Kaustubh S. Phanse     [email-masked] 
 PhD candidate          http://www.ee.vt.edu/~kphanse 
 Electrical & Computer Engineering Department
 Virginia Polytechnic Institute & State University
-----------------------------------------------------

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Ankur Jain
Sent: Tuesday, January 28, 2003 2:27 PM
To: [email-masked] 
Subject: [manet] my doubts about QoS in ad hoc networks

Hello everybody,

I have some doubt about QoS after doing experiments on the testbed for
ad
hoc networks.

In our experiments, we placed the nodes strategically so that they are
on
the periphery of the radio range of each other. Then we started the
packets
transfer and asked the nodes to move about their position. Our results
show
that the wireless link is so unstable that sometimes 50% of packets
get
lost.  Fifty percent is such a high figure for packet loss. I repeated
the
experiments many times but the loss percantage varied from 5% to upto
70%.
We conducted the expts. in the office environment so there was some
interference with the office's wireless LAN and other RF expts running
nearby.

I wanted to ask that if we can't even ensure connectivity in such a
small
region, how will we guarantee QoS over any infrastructure-less network.
If
there is some fixed infrastructure then we can give some assurance of
QoS
over some no. of hops. But I don't think that we can fully guarantee
to
provide specified bandwidth in real ad hoc networks - be it a militray
application or in emergency situations and the network containing
hundreds
of nodes. And in case of fairs/sports events, I think the network won't
even
work with 802.11b due to hidden node / exposed node problem where many
nodes
are in the radio range of each other.

I think right now the definition of QoS over ad hoc network is not
clear. Is
there any proposal of including QoS in IRTF. Doing QoS tests in
simulators
won't give the actual scenario. Has anybody done QoS experiments with
the
actual testbed (with wireless links) for ad hoc networks. I am really
anxious to know their results. Please give me some pointers if there
are any
papers on this.

Best Regards
Ankur

----- Original Message -----
From: Rex Buddenberg <[email-masked]>
To: Pablo Serrano Yáñez-Mingot <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, January 27, 2003 11:05 PM
Subject: Re: [manet] QoS on ad-hoc networks - when and why?

> On Sat, 2003-01-25 at 07:31, Pablo Serrano Yáñez-Mingot wrote:
>
> > But I don't think 'emergency services' fit into a
> > 'QoS provisioning scenario', because it should be
> > considered an 'overlay network', and not a true
> > mobile ad hoc network.
> >
>
> Any real world scenario of any scale will be a mixture of
infrastructure
> and MANET.  I can't imagine a practical standalone MANET of any
size.
> So yes, there will be a fixed infrastructure -- that the fire
> departments use on a daily basis and for both operational and
> non-operational traffic.
> In the event of a catastrophe (the large forest fire example) a
couple
> things happen:
> - some fixed infrastructure is damaged
> - the existing fire department resources may need to extend
> connectivity into unplanned places so you have ad hoc buildout.
> - the local fire department is augmented with assets that surge into
> the area.  A lot more ad hot (freudian sic... hoc) buildout.
> - as the fire progresses and assets move, the topology of the ad hoc
> part of the network will surely change.  Similarly, the places where
the
> ad hoc portions of the network connect to the fixed portions can be
> expected to change too.
>
>
> > I mean: in emergency situation, a new ad hoc network
> > should be deployed (I think).
>
> If you have any experience with either military or emergency
services,
> you should have develope antibodies that say: 'the last thing you
should
> do in the face of a crisis is reorganize'.  The order of battle
should
> be the same as the order of sailing (Nelson).
>
> You won't have a previously
> > installed services, because there won't be what I called
> > 'multipurpose ad hoc networks'.
>
> All emergency services outfits I've ever dealt with have previously
> installed services that they use daily -- this is a Good Thing since
the
> crew knows how the stuff works.
>
>  All traffic on the
> > network will be the same (from my point of view) in
> > terms of priorities.
>
> Don't agree, but easy to go overboard.  There will be urgent traffic
and
> there will be not so urgent traffic.
> But sorting this into more than about 4 bins represents such a
> departure from KISS that you get in real trouble.  One outfit I'm
> working with (government, of course) is looking at 64 levels of
priority
> since they have 6 bits to work with ... aaack.
> These comments are to substantive traffic (I need the next water
drop
> over here).  They are not directed at the network convergence
traffic,
> which may indeed be single priority.
>
> >
> > Also, in emergency situation you will need a reliable
> > authentication system, so as to only authorized nodes
> > are given a 'premium services' (this is why I envision
> > an overlay network, and not a network with QoS support)
>
> Take a look at the IETF diff-serv exercise that ended last year. 
The
> hard lessons learned there:
> - the QoS control cures may be worse than the disease
> - departure from KISS has severe consequences.
> Note that the need for authentication assumes the need for QoS
control.
> - attempts to diddle with the DS byte open DoS attack vectors.
>
> Second, take a look at the IEPREP working group in IETF.  Lotsa cruft
in
> the archive, but the basics are 1) overprovision the fixed network
and
> pre-empt the QoS control problem there.  2) Yes, if you're going to
> provide _any_ kind of premium service, you're going to need an
> authentication system to prevent abuse (by both insiders and
> outsiders).
> >
>
> >
>
>
> _______________________________________________
> manet mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/manet 

_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet 

_______________________________________________
manet mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Shaiful <[email-masked]>
Date: Tue, 28 Jan 2003 17:09:32 -0800 (PST)

Hi,

Before ARPANet nobody said that packet switching is
feasible ;-)

Seriously, AFAIK after doing some background research
on QoS, there is no work yet done in actual test bed
for QoS network. 

The first work on QoS ad hoc network is by CEDAR team.
The latest work done by Chenxi Zhu for his PhD study.
But really there is NO conclusive work done yet, and
according to Chenxi Zhu may be it is not worth doing
after all for highly mobile network. His paper was
published in IEEE INFOCOM 2002. 

My suggestion is just repeat any test bed experiment
from Rice, Texas or CMU, and then add CEDAR or any
current proposed QoS support as comparison.  It will
be a good journal paper candidate. Easily said than
done ;-)

Good luck,

Regards,
Shaiful Hashim
Universiti Putra Malaysia

"Ankur Jain" <[email-masked]> wrote:

Hello everybody,

I have some doubt about QoS after doing experiments on
the testbed for ad hoc networks.

In our experiments, we placed the nodes strategically
so that they are on the periphery of the radio range
of each other. Then we started the packets
transfer and asked the nodes to move about their
position. Our results show that the wireless link is
so unstable that sometimes 50% of packets get
lost.  Fifty percent is such a high figure for packet
loss. I repeated the experiments many times but the
loss percantage varied from 5% to upto 70%.
We conducted the expts. in the office environment so
there was some interference with the office's wireless
LAN and other RF expts running
nearby.

I wanted to ask that if we can't even ensure
connectivity in such a small region, how will we
guarantee QoS over any infrastructure-less network. 
If there is some fixed infrastructure then we can give
some assurance of QoS over some no. of hops. But I
don't think that we can fully guarantee to provide
specified bandwidth in real ad hoc networks - be it a
militray application or in emergency situations and
the network containing hundreds of nodes. And in case
of fairs/sports events, I think the network won't 
even work with 802.11b due to hidden node / exposed
node problem where many nodes are in the radio range
of each other.

I think right now the definition of QoS over ad hoc
network is not clear. Is there any proposal of
including QoS in IRTF. Doing QoS tests in simulators
won't give the actual scenario. Has anybody done QoS
experiments with the actual testbed (with wireless
links) for ad hoc networks. I am really anxious to
know their results. Please give me some pointers if
there are any papers on this.

Best Regards
Ankur

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Scott Corson <[email-masked]>
Date: Thu, 30 Jan 2003 14:50:38 -0500

<snip>

> If some one has good ideas on how to do this study or has done this 
> study, please enlighten the rest of us.  

I have some ideas...  See below.

> Perhaps one of the tasks for the irtf might be to publish a 
> common set 
> of metrics that should be presented for every new protocol.  
> It is not 
> sufficient to simply present a protocol and describe how it works. 
> There should be a checklist that evey proposer of a new 
> protocol should 
> have to fulfill before submitting their work.

One of the near-term goals of the IRTF group will be to specify just what it
is we are looking for in a protocol, and how its performance should be
quantified.

> 
> I know there is some work on common metrics, for example 
> control packet 
> overhead seems to have emerged as a "must have" metric in any study. 
> This is probably a good metric, but once again, total meaningless, 
> unless put in the perspective of mobility.  the actual metric 
> should be: 
> "control overhead given that our scenario is xxxxx on the 
> mobility scale"

To study a protocol, a set of protocol-independent "black box" criteria are
necessary.  For example, I don't care what the protocol is, but I do care
how my data traffic is delivered (xput, latency, possibly other metrics).
At this level of analysis, you don't care *how* a protocol does what it
does.  You only measure *what* is does; i.e. the effectiveness of data
routing based on some set of criteria.  These need to be defined, along with
test cases, etc.

Beyond that, one can delve into various levels of "white box" testing on a
protocol class or individual protocol basis.  For example, certain
performance criteria may be valid for "proactive" protocols (e.g. HELLO
protocol overhead), but not for reactive and vice versa.  Other criteria may
only apply to a given protocol.  

I think control packet overhead as a metric in isolation is relatively
useless.  It says little about the effectiveness of routing (the ultimate
black box measure).  It is meaningful only upon close inspection of what is
happening with a given protocol, to understand its inner workings, to
improve it, etc.

Once we nail down the set of this year's mtg dates, I'll post the IRTF
webpage, the mailing list and a lot of this kind of discussion is welcome
there.

-Scott