Subject: Re: [manet] General questions

From: Anders Lindgren <[email-masked]>
Date: Thu, 2 Jan 2003 15:25:56 +0100 (CET)

Ayman,

We have developed ISAIAH, a slight modification of AODV that works in a
scenario as the one you describe below (in our scenarios we do however
also assume that the fixed nodes have better power supplies than the
mobile nodes (they can e.g. be plugged into a power outlet)).

We have a paper describing this protocol (BibTeX entry below), and it can
be found at my publications page at
http://www.sm.luth.se/~dugdale/index/publications.shtml

@inproceedings{iwahn2002:lindgren_02,
  author = {Anders Lindgren and Olov Schel\'{e}n},
  title = {Infrastructured ad hoc networks},
  booktitle = {Proceedings of the 2002 International Conference on Parallel Processing Workshops (International Workshop on Ad Hoc Networking (IWAHN 2002))},
  year = {2002},
  pages = {64-70},
  month = aug,
  url = {http://www.sm.luth.se/csee/csn/publications/iwahn2002_lindgren.pdf}
}

/Anders

On Sun, 29 Dec 2002, ayman ghazi wrote:

> second question is, all Manet Protocol it used for assumption that
> all nodes are moving (highly dynamic, or medium dynamic), but we
> have some kind of network where most node are moving( hihgly
> dynamic), but some nodes are eaither semi fixed or fixed (  like
> WaveLAN with some fix Access points and many mobile nodes), so are
> there any protocols for this condition.
>
> thanks
> Ayman

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Mon, 06 Jan 2003 18:10:14 -0500

>http://www.sm.luth.se/~dugdale/index/publications.shtml

Anders:

That is interesting..we and others have proposed similar approaches for hybrid operation of existing protocols. Other slight additions to specifications such as OLSR and TBRPF (e.g., preferred router metrics) also make such infrastructured designs directly manageable. We have seen this as a practical approach that is likely very useful for potential community or campus type of deployments. 

-Joe

---

From: Anders Lindgren <[email-masked]>
Date: Tue, 14 Jan 2003 11:12:09 +0100 (CET)

Joe,

Glad to hear you found our work interesting.
Do you have any pointers to the other work you mention? It would be
interesting to look more into that.

Regards,

/Anders

On Mon, 6 Jan 2003, Joe Macker wrote:

> That is interesting..we and others have proposed similar approaches for
> hybrid operation of existing protocols. Other slight additions to
> specifications such as OLSR and TBRPF (e.g., preferred router metrics)
> also make such infrastructured designs directly manageable. We have seen
> this as a practical approach that is likely very useful for potential
> community or campus type of deployments.
>
> -Joe
>

---

From: "Nitin H. Vaidya" <[email-masked]>
Date: Tue, 14 Jan 2003 08:17:37 -0600 (CST)

Anders:

We have also implemented yet another hybrid network. The report
is being revised presently to improve readability (though not
by much -:) and we will make the revised report available this
week through my web site  www.crhc.uiuc.edu/~nhv

In our implementation, we limit the routes to contain at most K
consecutive wireless hops before reaching an access point (or the
destination). The motivation here is that for a "suitable" K one can
reach most destinations, particularly, in campus environments, so the
overhead can be kept low by bounding the connectivity provided by the
network. (To put it differently, in many environments, a small K will
result in low overhead but "almost" full connectivity -- the lost
connectivity may be worth the reduction in overhead. One can always
augment the protocol with special features to find rouets to certain
specific destination, even if at high cost.)

There is a paper by Towsley's UMass group in Infocom'03 that you may
find interesting.

- nitin

On Tue, 14 Jan 2003, Anders Lindgren wrote:

.  >>Joe,
.  >>
.  >>Glad to hear you found our work interesting.
.  >>Do you have any pointers to the other work you mention? It would be
.  >>interesting to look more into that.
.  >>
.  >>Regards,
.  >>
.  >>/Anders
.  >>
.  >>On Mon, 6 Jan 2003, Joe Macker wrote:
.  >>
.  >>> At 03:25 PM 1/2/2003 +0100, Anders Lindgren wrote:
.  >>> >Ayman,
.  >>> >
.  >>> >
.  >>> >We have developed ISAIAH, a slight modification of AODV that works in a
.  >>> >scenario as the one you describe below (in our scenarios we do however
.  >>> >also assume that the fixed nodes have better power supplies than the
.  >>> >mobile nodes (they can e.g. be plugged into a power outlet)).
.  >>> >
.  >>> >We have a paper describing this protocol (BibTeX entry below), and it can
.  >>> >be found at my publications page at
.  >>> >http://www.sm.luth.se/~dugdale/index/publications.shtml
.  >>>
.  >>> Anders:
.  >>>
.  >>> That is interesting..we and others have proposed similar approaches for
.  >>> hybrid operation of existing protocols. Other slight additions to
.  >>> specifications such as OLSR and TBRPF (e.g., preferred router metrics)
.  >>> also make such infrastructured designs directly manageable. We have seen
.  >>> this as a practical approach that is likely very useful for potential
.  >>> community or campus type of deployments.
.  >>>
.  >>> -Joe
.  >>>
.  >>> _______________________________________________
.  >>> manet mailing list
.  >>> [email-masked]
.  >>> https://www1.ietf.org/mailman/listinfo/manet
.  >>>
.  >>
.  >>
.  >>
.  >>
.  >>
.  >>
.  >>_______________________________________________
.  >>manet mailing list
.  >>[email-masked]
.  >>https://www1.ietf.org/mailman/listinfo/manet
.  >>

---

From: Joe Macker <[email-masked]>
Date: Tue, 14 Jan 2003 11:04:30 -0500

>interesting to look more into that.

As mentioned, the two new proactive routing Internet Drafts (OLSR, TBRPF) have new features to allow one to manage such preferred router approaches within infrastructured manets. These were discussed at the last manet meeting. 

I think this is a very useful, practical feature. Perhaps you could look at that and give the WG any feedback/comments.

-Joe