Subject: [manet] Error simulating with AODV, DSR and TORA

From: [email-masked]
Date: Fri, 31 Jan 2003 11:36:08 +0100 (CET)

Hi,

I have sent a possible bug report to the NS mailing list, but since no one was
able to give me a reply, perhaps someone in this mailing list is interested.

Results of dozens of simulations using AODV, DSR and TORA in ns2.1b9a (2.1b8
too) show that these protocols do not behave correctly when there are 802.11
broken links.

When looking at the overall results of simulations with many nodes, the effect I
describe is not evident. It is necessary to look at a single flow to see that  
nodes fail to quickly detect broken links, making the re-routing process last
too long. This effect does not exist when using other protocols like OLSR or
Hello-driven AODV since they do not use link-layer info.

The files I attach show this problem clearly in a very simple scenario

Please help!

Best regards, 

_________________________________________________
Carlos Miguel Tavares de Araújo Cesariny Calafate
Polytechnic University of Valencia
e-mail: [email-masked]
http://reptar.grc.upv.es/~calafate/
Tel: +34 963879703 ext. 77977
_________________________________________________

---

From: Alvin Valera <[email-masked]>
Date: Fri, 31 Jan 2003 04:39:40 -0800 (PST)

Hi Carlos Miguel,

I performed many simulations in ns-2.1b8 specifically
on the reaction of routing protocols to link failures.
I haven't encountered your problem, though.

Could it be that the delay in detecting a link failure
is due to link layer retransmissions? In 802.11, as
far as ns-2.1b8 is concerned, a sender retries several
times (I could not remember the exact value) before
informing the routing protocol that a data packet is
undeliverable?

Another possible reason is congestion. In my studies,
I encountered many instances where 802.11 reports a
link layer failure even though the receiver is within
range. This is due to the fact that in highly
congested environment, the MAC of the sender may fail
to acquire the channel or complete the
RTS-CTS-DATA-ACK.

Best regards,
Alvin

> ATTACHMENT part 2 application/x-tcl
name=testlimit.tcl; name=testlimit.tcl

> ATTACHMENT part 3 application/octet-stream
name=scen-limit2; name=scen-limit2

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Fri, 31 Jan 2003 16:08:54 +0100 (CET)

Hi Alvin,

Thank you for your comments on this subject.

My opinion is that, since I created a very simple scenario with just 6 ones and
1 traffic flow, we can't blame collisions for the behaviour observed. Also, it's
true that the sender retries several times (I think 4 times), but I guess that
10 or 20 seconds to detect a broken link is too much, don't you? If link-level
aware protocols were supposed to behave that bad, we would conform to just
sending "Hellos"!

It's curious to notice that the problems are not the same for all: the worst
performance can be seen with DSR but TORA suddenly stops sending packets and
everything is still!

Please comment the "ns-random 0" line and you'll see exactly what I see.

Best regards,

Carlos

_________________________________________________
Carlos Miguel Tavares de Araújo Cesariny Calafate
Becário de la Universidad Politécnica de Valencia
e-mail: [email-masked]
http://reptar.grc.upv.es/~calafate/
Tel: +34 963879703 ext. 77977
_________________________________________________
\\\\\\\"In an open world without walls and fences who needs Windows and
Gates?\\\\\\\"
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet