Subject: Re: [manet] RTS/CTS in wireless MAC

From: "Paul Tan" <[email-masked]>
Date: Sat, 4 Jan 2003 11:45:18 +0800

Hi,

in WLAN, collision detection is not possible due to what is know as the
"near/far" problem. To detect a collision, a station must be able to
transmit and listen at the same time. For this reason, 802.11 uses a
different protocol known as Carrier Sense Multiple Access with Collision
Avoidance (CSMA/CA) or the Distributed Coordination Function (DCF). CSMA/CA
attempts to avoid packet collisions by using explicit packet acknowledgement
(ACK), which means that an ACK packet is sent by the receiving station to
confirm that a packet arrived intact.
CSMA/CA works by having the station that wishes to transmit senses the
channel and if there is no activity detected, the station will wait an
additional random period of time (DIFS) and if there still is no activity,
it will transmit the data. If the packet is received intact (checksum), the
receiving station will send and ACK frame that once it is received by the
original sender the transmission is complete. If the ACK command is not
received in a specified random period of time, the data packet will be
resent, assuming that the original packet experienced a collision.

By telling the card to go into "promiscuous mode", all traffic seen is
passed to the operating system. On a shared media network, this lets a
station to spy on every packet traversing the 'air'. Yes, you can still
tx/rx data.

Cheers,

Paul Tan

----- Original Message -----
From: "Liaw, Yong Shyang - LIAYS001" <[email-masked]>
To: "'Sumeeth Nagaraj'" <[email-masked]>; "Sachin Ganu"
<[email-masked]>; "Grzegorz Banasiak" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 06, 2002 7:30 AM
Subject: RE: [manet] RTS/CTS in wireless MAC

>
> So then how can the receiver knows if there is a collosion? Does it just
check
> the "checksum" of the data packet?  Another question. If the wireless LAN
i/f
> (i.e. waveLan) is put into promiscuous mode, it can receive all data
> transmissions that reach it. But can it also send data (in promiscuous
mode)
> when it is not receiving data?
>
> Thank in advance.
>
>
>
> -----Original Message-----
> From: Sumeeth Nagaraj [mailto:[email-masked]]
> Sent: Wednesday, 6 November 2002 7:31
> To: Sachin Ganu; Grzegorz Banasiak
> Cc: [email-masked]
> Subject: Re: [manet] RTS/CTS in wireless MAC
>
>
> CSMA/ CD is used in the Ethernet, Collision Detection is not possible
> because of the Half-Duplex nature of the nodes. The wireless nodes can
> either transmit or receive and hence cannot detect collisions at the
> destination(receiver). CSMA/CA is used and not CSMA/CD.
>
> Best Regards,
> Sumeeth
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Paul Tan" <[email-masked]>
Date: Sat, 4 Jan 2003 00:16:31 +0800

Hi,

Cheers,

Paul Tan

----- Original Message -----
From: "Liaw, Yong Shyang - LIAYS001" <[email-masked]>
To: "'Sumeeth Nagaraj'" <[email-masked]>; "Sachin Ganu"

check
i/f
mode)