Subject: [manet] some queries regarding simulations done using glomosim( urgent)

From: "pradnya sheth" <[email-masked]>
Date: Tue, 14 Jan 2003 23:25:52 +0530

Hello,

I am a graduate student and doing a project for comparing ad-hoc  protoccols using glomosim as the simulator. i have to compare them on the basis of acv end-to-end delay , goodput and overhead... i am comparing DSR and Lar1 .. by changing the parameters in the config.in file... i have taken cbr application for four different senders and four different receivers... eg of cbr that i have taken is

CBR 1 59 0 1460 2S 0S 599S.

i wanted to vary the load and wanted to know what various loads should i take for 50 nodes as well as 100 nodes during the simulation... when i ran the simulation for 50 nodes and given the above cbr application it sent 300 packets of 1460b each from sender to receiver during the simulation time... is this the maximum bandwidth that i can get... also how do i calculate overhead.. is it the no of control packets sent ... will anyone kindly give me some more info as to how to go about the simulations ...

regards

Pradnya..

The new MSN 8: smart spam protection and 2 months FREE*.
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Kenneth Brayer <[email-masked]>
Date: Tue, 14 Jan 2003 14:03:02 -0500

The deadline is approaching rapidly so I thought I would post this CFP
again as a reminder that we are still open for papers.

Call for Papers
Quality of Service Delivery in Variable Topology Networks
IEEE Journal on Selected Areas in Communications

Topics of keen interest today in networking technology include methods
of delivering services over variable topology networks, such as variable
point-to-point and Ad Hoc networks, in which the user is mobile and
inter-router connections are time varying. We seek contributions that
will be of value to system architects in selecting collections of
technologies and methodologies that meet their needs and establish
standards for user responsive system performance, and quality of service
(QoS) that can be delivered over such networks.  Contributions that
report QoS delivery in clearly defined network settings under clearly
defined metrics for a specific service or collection of services are of
special interest. Submissions might focus specifically on comparing
alternative technological or methodological approaches to delivering
services with quality guarantee. Variable topology peer-to-peer and Ad
Hoc constructions in both flat and hierarchical environments are of
interest.    

Contribution might focus on the performance that can be achieved using a
single technological and methodological approach, but varying key
factors, such as the number of end systems, end-system density, or the
delivery physical environment.  Throughout, the central theme should be
service delivery, and the metrics used should enable potential users to
clearly see patterns of performance in one or more of the following
dimensions: cost, complexity, timely delivery, traffic handling
capacity, or the number of end systems the system can handle.  Methods
for achieving quality of service under conditions of varying topology,
and new concepts for providing quality of service are likewise of interest.

Original, unpublished contributions and invited articles will be
considered for the issue. The call for papers is for extended abstracts
that propose development of papers to meet the goals of the issue.  The
proposal shall comprehensively describe the area of the paper relative
to the areas of interest of the call.  These extended abstracts will be
reviewed and the editors will invite final papers, which will be
refereed.  Instructions for submission can be found on the web at http://www.argreenhouse.com/society/J-SAC/Calls/variable_topology_qos.html.

Topics For This Issue Include

ß Variable point-to-point and Ad Hoc Routing including new
methodologies, bi-directional vs. unidirectional connectivity, source
based vs. dynamic routing, unicast vs. multicast, and content-based routing.
ß Variable topology network architectures and reconfiguration techniques
including flat vs. hierarchical organizations, proactive vs. reactive
reconfiguration, MAC vs. upper layer implementations,
self-configurations, and distributed algorithms (group and resource management).
ß Quality of Service (QoS) delivery including methodologies for timely
message delivery, predictable performance, error coding for achieving
QoS, and methods of measuring QoS in operational networks.
ß Performance analysis including comparative study (analysis,
simulation, emulation and/or implementation), new analytical approaches,
definition of performance metrics and optimizing the system performance
(capacity, response time, throughput, etc.).
ß Testbeds and applications including testbed descriptions and
objectives, experimental results based on testbeds and unique
applications of testbeds.
ß Standards including definition of common and desirable features of
standards, matching current and emerging standards to applications, and
applications requirements versus features provided by standards.

Timetable

Extended Abstract Submission Deadline:	April 1, 2003
Acceptance Notification of Proposed Paper: 	June 1, 2003
Submission of Invited Papers	October 1, 2003
Acceptance Notification	February 1, 2004
Final Revised Manuscript Due: 	March 1, 2004
Publication of issue: 	3rd-4th Quarter 2004	Guest Editors

Nicola Blefari-Melazzi, Università degli Studi di Roma - Tor Vergata,
Italy, [email-masked]
Kenneth Brayer, The MITRE Corporation, USA, [email-masked]
John N. Daigle, The University of Mississippi, USA, [email-masked]
Jean-Yves Le Boudec, Ecole Polytechnique Federale de Lausanne,
Switzerland, [email-masked]
Bo Li, Hong Kong University of Science and Technology, China, [email-masked]

-- 
Kenneth Brayer
M/S B312
The MITRE Corporation
202 Burlington Road
Bedford, MA 01730

e-mail: [email-masked]
tele: 781-271-5254
fax: 781-271-2841

---

From: manoj pandey <[email-masked]>
Date: Tue, 14 Jan 2003 13:45:48 -0800 (PST)

hi Pradnya

there are many ways of varying the load
 -increase the number of source/receiver nodes in the simulation
 -increase the speed of mobile nodes
 -increase the frequency of the CBR/packet size of the CBR
        [e.g. 1460 adn 2S in your example]
the channel capacity is limited (i am not sure, but i guess it is 2Mbps)

I can think of two ways to estimate overhead in GLOMOSIM,
	1. go to the protocol file e.g. dsr.pc and add a member
called overhead to the DSR_Stats structure and which in the end
(call of RoutingDsrFinalize()) estimates (say) the ratio of control bytes and
total bytes (data bytes and control bytes), which you can estimate using
data members like numReplySent, numDataTxed etc.
	2. write a script (python/perl) which reads output from the .stat
file and estimates the above ratio.

hope this was ur request :-)
thnx,

******************************
Manoj Pandey, PhD student,
#226, Deschutes, Computer and Information Science,
University of Oregon, Phone# 541-346-1381 [Office],
www.cs.uoregon.edu/~manoj
******************************

On Tue, 14 Jan 2003, pradnya sheth wrote:

> Hello,
>
>         I am a graduate student and doing a project for comparing ad-hoc  protoccols using glomosim as the simulator. i have to compare them on the
> basis of acv end-to-end delay , goodput and overhead... i am comparing DSR and Lar1 .. by changing the parameters in the config.in file... i have
> taken cbr application for four different senders and four different receivers... eg of cbr that i have taken is
> i wanted to vary the load and wanted to know what various loads should i take for 50 nodes as well as 100 nodes during the simulation... when i ran
> the simulation for 50 nodes and given the above cbr application it sent 300 packets of 1460b each from sender to receiver during the simulation
> time... is this the maximum bandwidth that i can get... also how do i calculate overhead.. is it the no of control packets sent ... will anyone
> kindly give me some more info as to how to go about the simulations ...
>
> regards
> Pradnya..
>
> ____________________________________________________________________________________________________________________________________________________________
> The new MSN 8: smart spam protection and 2 months FREE*. _______________________________________________ manet mailing list [email-masked]