Subject: Re: [manet] where does OLSR loss most occur in lightly loaded networks?

From: l s <[email-masked]>
Date: Thu, 2 Dec 2004 19:48:49 +0000 (GMT)

Hi Tao,

> 
> The 10-second buffer does not mean that the packet
> dealy is very long.  In other words, this does not
> necessary mean that VoIP will fail with such a
> 10-second buffer.  The real bottleneck is the actual
> end-to-end delay that occurs in your network.  In
> fact, AODV does have small end-to-end delays
> according to my simulations.  This is because AODV
> fixes broken routes immediately after a transmission
> fails.  The new shortest route is up fairly quick in
> AODV if the network size is reasonable.
> 
Indeed.  With my results, I have noticed that the
end-to-end delay is much greater in AODV than OLSR
(four times greater), using the implementation of OLSR
without Link Layer Notification to detect linkbreaks.
(20 applications running (CBR 4 packets per sec)
in the network of 50 nodes moving Random Way Point in
1500x300 with max speed of 20m per sec)

I think this can also be explained by the effect of
keeping a 10s buffer in AODV whereas OLSR would drop a
datagram.  So OLSR has a much higher loss but but also
a smaller end-to-end delay as it doesn't count those
packets that were dropped.

With the OLSR its an issue that a lot of packets are
lost, but with AODV in my simulations then a lot of
old packets stay in circulation which if they are part
of a flow with a low delay or jitter requirement then
they will just end up adding to congestion
pointlessly, and overflowing the queues.

Cheers,
   Lee -S-
   CCSR, Uni of Surrey, UK.

___________________________________________________________ 
Moving house? Beach bar in Thailand? New Wardrobe? Win £10k with Yahoo! Mail to make your dream a reality. 
Get Yahoo! Mail www.yahoo.co.uk/10k

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Tao Lin" <[email-masked]>
Date: Thu, 2 Dec 2004 21:22:51 -0500

Hi Lee,

Glad to see that now you can explain your simulation results and this does
match what I have in my PhD dissertation.

Another thing I want to point out is that the ARP protocol in MAC layer ns2
implementation has a bug.  This bug may lead to VERY long delay for one-hop
transmission in a MANET.  Basically, an ARP class in ns2 sends out one ARP
request and never times out or re-tries if there is no ARP reply comes back.
The outgoing packet triggered that ARP request is buffered unless another
packet to the same next hop is ready for transmission.  Therefore if a
neighbor moves away right before an ARP is sent for this neighbor's MAC
address, the trigger packet can be hold up to a very long time, say
1,000,000 seconds. If we assume that that neighbor moves back and somehow
replies another node's ARP request, the buffered packet can be sent to the
neighbor with a 1,000,000 seconds one hop delay.  You can construct a simple
ns2 simulation script to see this bug.  Although this does not happen
frequently, but one such delay can change your simulation results
dramatically.  You can refer to my PhD dissertaion on experince on MANET
simulations for this kind of bugs and fair comparison assumptions.

Have a nice day!

 Tao Lin, Post-Doc
 ECE Department, McMaster University
 www.ece.mcmaster.ca/~tlin
Hi Tao,

Cheers,
   Lee -S-
   CCSR, Uni of Surrey, UK.