Subject: [manet] beaconning in manet

From: pakorn kulsirimongkol <[email-masked]>
Date: Thu, 23 Dec 2004 01:50:38 -0800 (PST)

Dear, sir
          i am researching in ah hoc network and have been confused something.
in link state routing protocol use beaconning for declaring its position . any node which receive beacon can know its neighbor.
my question 
first question
what layer is beacon used? (network/data link)
 
second question
when any node want to send a beacon, that node must sense for free channel before sending. thus many nodes want to send the beacon at the same time. do each node have to wait for free channel?
 
third question
if this routing send beacon more frequently, it will use more bandwidth  ??
 
sincerely
 
pakorn k.

---------------------------------
Do you Yahoo!?
 Send holiday email and support a worthy cause. Do good.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Giorgio Mulas" <[email-masked]>
Date: Thu, 23 Dec 2004 11:30:58 +0100

Dear pakorn k.
 
first answer:
network layer. Beaconing is part of the routing mechanism.
 
second answer:
sensing channel is a typical MAC operation, even if it depends on the particular MAC you are using. In CSMA-like MAC, transmission of frames is successful only if they don't collide on the channel: then you MUST send layer-2 frames only on free channels.
 
third answer:
of course. Determining the best trade-off between frequency of beaconing (this impacts on a better control over network topology -> critical especially in highly dynamic networks) and consumed bandwidth is an important issue that is related to the scenario you are considering.
 
br.
 
Giorgio

------------------------------------------
Giorgio Mulas | Researcher

CEFRIEL  Politecnico di Milano
Via Fucini, 2 · 20133 Milano (Italy)

p. +39 02 23954 265
f. +39 02 23954 465
e. [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of pakorn kulsirimongkol
Sent: giovedì 23 dicembre 2004 10.51
To: [email-masked]
Subject: [manet] beaconning in manet

Dear, sir
 
second question
 
third question
 
sincerely
 
pakorn k.

  _____  

Do you Yahoo!?
Send holiday email and support a worthy cause. Do  <http://us.rd.yahoo.com/evt=29911/*http://celebrity.mail.yahoo.com/> good.