Subject: [manet] 802.11/a/b/g drivers

From: DANIEL BYRNE <[email-masked]>
Date: Thu, 16 Dec 2004 11:58:34 -0600

Where can I find source code for any LAN card drivers?  Also where can I
find datasheets on the chipsets?

-----Original Message-----
From: Giorgio Mulas [mailto:[email-masked]]
Sent: Thursday, December 16, 2004 11:31 AM
To: Leon Martin; MANET Newsgroup
Subject: RE: [manet] 802.11/a/b/g transceiver

Hi,
The type of WLAN cards you are asking are composed of: 
- Media Access Controller (the same for a/b/g)
- Baseband processor (different for a/b/g, it is modulation dependent)
- Dual-band RF transceiver (5GHz vs. 2.4GHz)
- Dual-band power amplifier

For details, you should check whitepapers from WLAN card manufacturers:
E.g. Agere, Atheros, Broadcom, Engim, Texas Instruments (alphabetica and
non-exaustive order :-) ) 

About the cost: I found on e-bay performing a quick search in about 5
seconds a dual-band card (a/b/g orinoco-clone) for 25 dollars...

Br.

Giorgio

------------------------------------------
Giorgio Mulas | Researcher

CEFRIEL  Politecnico di Milano
Via Fucini, 2 · 20133 Milano (Italy)

p. +39 02 23954 265
f. +39 02 23954 465
e. [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Leon Martin
> Sent: giovedì 16 dicembre 2004 17.53
> To: MANET Newsgroup
> Subject: [manet] 802.11/a/b/g transceiver
> 
> 
> Hi,
> 
> I found that some wireless LAN cards support
> 802.11a/b/g. These three standards operate at 2.4GHz
> and 5GHz.If a single transceiver is used, there must
> be an RF amplifier that works across several GHz. I
> believe it is difficult and expensive. Does anyone
> know how many receivers are used in such cards?
> 
> Thanks.
> 
> -- Leon
> 
> 
> 		
> __________________________________ 
> Do you Yahoo!? 
> Take Yahoo! Mail with you! Get it on your mobile phone. 
> http://mobile.yahoo.com/maildemo 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: David Young <[email-masked]>
Date: Thu, 16 Dec 2004 14:57:05 -0600

> find datasheets on the chipsets?

Daniel,

You have to ask the manufacturers for datasheets.  Sometimes Google can
find a datasheet for you.  If you can find driver sources, they usually
provide more complete information than the datasheets.

As for driver sources: NetBSD has a growing set of drivers unified
under the net80211 framework.  You can browse the net80211 framework
at <http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/net80211/>.
Find out how to download the sources at
<http://www.netbsd.org/Documentation/current/#downloading>.

You can browse the sources on the web at
<http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/>.  Here are pointers to
the source files for particular drivers:

ADMtek
------
dev/ic/atwreg.h
dev/ic/atwvar.h
dev/ic/atw.c
dev/ic/rf3000reg.h
dev/ic/si4136reg.h

AMD
---
dev/ic/awi.c
dev/ic/awireg.h
dev/ic/awivar.h

Atheros
-------
dev/ic/ath.c
dev/ic/athcompat.c
dev/ic/athcompat.h
dev/ic/athioctl.h
dev/ic/athvar.h

Cisco/Aironet
-------------
dev/ic/an.c
dev/ic/anreg.h
dev/ic/anvar.h

Intel
-----
dev/pci/if_ipw.c
dev/pci/if_ipwreg.h
dev/pci/if_ipwvar.h

Lucent/Prism
------------
dev/ic/wi.c
dev/ic/wireg.c
dev/ic/wivar.c

Realtek (work in progress)
-------
dev/ic/rtw.c
dev/ic/rtwphy.c
dev/ic/rtwphy.h
dev/ic/rtwphyio.c
dev/ic/rtwphyio.h
dev/ic/rtwreg.h
dev/ic/rtwvar.h
dev/ic/sa2400reg.h
dev/ic/max2820reg.h

There are drivers for Prism54 and ACX-100 in-progress.

Dave

-- 
David Young             OJC Technologies
[email-masked]      Urbana, IL * (217) 278-3933