Subject: Re: [manet] AODV RERR and precursor list - RFC 3561

From: Bart Braem <[email-masked]>
Date: Tue, 21 Dec 2004 12:01:37 +0100

Hello,

I think you are right that there is a problem their. In my opinion there 
is a reference to a broader usage of precursors, so not just for nodes 
involved in RREPs:
"For each valid route maintained by a node as a routing table entry, the 
node also maintains a list of precursors that may be forwarding packets 
on this route."
So according to this sentence nodes forwarding data packets also 
qualifies them as precursors...

Greetings,
Bart Braem
University of Antwerp
Belgium

Bracha Hod wrote:

> Hi,
>  
> According to RFC 3561:
>  
> 1) In the route discovery phase, every node that get RREQ creates or 
> updated the reverse path to the RREQ originator.
> 2) The precursor list is updated only during the RREP generating and 
> forwarding.
> 3) The neighboring node(s) that should receive the RERR are all those 
> that belong to a precursor list of at least one of the unreachable
>    destination(s) in the newly created RERR. 
>  
> Based on those facts, consider the following case:
>  
> 0<--->1 <---> 2 <---> 3 <--->4
>  
> All the route tables are empty, then node 2 initiates RREQ to find a 
> route to 0.
> Nodes 3 and 4 get the RREQ and create a route to 2.
> The RREP that is forwarded from 0 via 1 to 2, does not have any effect 
> of nodes 3 and 4.
> Since node 4 has route to 2, it uses it to transmit data. 
> Then, if the link between 2 and 3 is broken, node 3 does not have any 
> node in the precursor list of its route entry, since no RREP was 
> generated or forwarded by it.
> Consequently, when it gets data from node 4 and no local repair is 
> done, or the local repair is failed, it does not send any RERR since 
> the precursor list is empty. 
>  
> This situation causes packet dropping, without any 
> notification.                        
> Do you have any solution to that case?
>  
> Thanks,
>  
> Bracha Hod
> The Hebrew University of Jerusalem
> Israel
>
>------------------------------------------------------------------------
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
>  
>

-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.296 / Virus Database: 265.6.2 - Release Date: 20/12/2004

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Bracha Hod <[email-masked]>
Date: Tue, 21 Dec 2004 13:28:53 +0200

I think the RFC did not mean that every data packet that is forwarded would
cause update of the precursor list.
This requires high overhead, mainly when due to the mobility there are
single packets that arrived mistakely (not as in my case).

Thanks for your reply.

Best Regards,
Bracha Hod.