Subject: [manet] ospf version 3

From: Gerry Holderbeke <[email-masked]>
Date: Thu, 06 Jan 2005 10:00:39 +0100

Hi there,

Does anyone of you know where to find an implementation (some freely 
available source code) of the newly developed OSPF version 3 protocol ? 
If so, and you have some comments on it (references or papers that prove 
its performance), please let me know.

Thanks in advance,

Gerry
Ghent University

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Yasuhiro Ohara <[email-masked]>
Date: Thu, 06 Jan 2005 19:19:31 +0900 (JST)

I believe the Zebra has the only freely available OSPFv3 implementation.
http://www.zebra.org/

I would be the person responsible for the performance paper, but
I haven't written any ;p)

I have done a brief performance test and showed the results at a
japanese workshop, and now I picked up the figures from the
presentation slide for you.
http://www.sfc.wide.ad.jp/~yasu/zebra-ospf6d.pdf

Briefly, WIDE 6bone operated by zebra is working fine
(50-60 routers, SPF time is within about 30ms).
Simulation was done on a slow PC, and:
  - LSDB lookup is about O(log (N))
  - SPF runtime is about O(N log (N))
When the number of LSAs grow, the SPF takes some seconds
but which is the reason for that is not decided yet,
whether the software is bad or the PC was slow.

regards,
yasu

From: Gerry Holderbeke <[email-masked]>
Subject: [manet] ospf version 3
Date: Thu, 06 Jan 2005 10:00:39 +0100