Subject: [manet] AODV rfc 3561

From: manet user <[email-masked]>
Date: Mon, 24 Jan 2005 11:50:32 -0800 (PST)

Hi,
 
AODV RFC 3561 does not say anything about precursor list deletion? Shouldn't be precursor lists for unreachable destinations be deleted while creating route error message. Old AODV drafts (draft 7,8,9) explicitly mentioned that "precursor lists for unreachable destinations should be deleted" while creating RERR. 
 
Precursor lists are populated with RREP processing and will be built again after a route is broken during next route discovery. While creating RERR, the aodv route entry is marked INVALID before being deleted, and if the precursor list for the unreachable destinations are not deleted, wouldn't these be carrying stale information?
 
Please correct me if my understanding is wrong. 
Thanks.

---------------------------------
Do you Yahoo!?
 Yahoo! Search presents - Jib Jab's 'Second Term'

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: lolo <[email-masked]>
Date: Wed, 26 Jan 2005 13:18:10 +0100

Hi M.U.

As the precursors list is a field of the routing table, i thought that 
precursors list get deleted only when that particular entry is deleted 
(after DELETE_PERIOD).
Precursors are among the recipients of the RERR messages, and maybe one 
of them, or the detector of the link breakage can attempt a "local 
repair". So one has to keep them presents in case the route table can be 
repaired.

HTH

Laurent

manet user wrote:
> Hi,
>  
> AODV RFC 3561 does not say anything about precursor list deletion? 
> Shouldn't be precursor lists for unreachable destinations be deleted 
> while creating route error message. Old AODV drafts (draft 7,8,9) 
> explicitly mentioned that "precursor lists for unreachable 
> destinations should be deleted" while creating RERR.
>  
> Precursor lists are populated with RREP processing and will be built 
> again after a route is broken during next route discovery. While 
> creating RERR, the aodv route entry is marked INVALID before being 
> deleted, and if the precursor list for the unreachable destinations 
> are not deleted, wouldn't these be carrying stale information?
>  
> ------------------------------------------------------------------------
> Do you Yahoo!?
> <http://us.rd.yahoo.com/evt=30648/*http://movies.yahoo.com/movies/feature/jibjabinaugural.html> 
>
>------------------------------------------------------------------------
>

---

From: manet user <[email-masked]>
Date: Fri, 28 Jan 2005 07:44:04 -0800 (PST)

Hi Laurent,
 
Thanks for the reply. One thing to clarify, in my previous email, i did not mean to delete full precursor list, but to delete those neighbors (nodes) from the precursor list for which this node has processed a RERR. I agree that precursor list should be deleted only when route is deleted, but shouldn't neighbors be removed from precursor list when RERR is processed for them?
 
If the node deletes the precursors while processing Route Error, even in case of local repair, the precursors will get added when a Route Reply is processed. For example, if node B processes a RERR for some destination D, and removes the node A from its precursor list. Node A then attempts a local repair (with higher seq num) and discoveres a different route to reach destination D. The new route is such that node B will have node X in its precursor list rather than A (as in previous route to dest D which is invalid now).
 
But if node B did not delete A from its precursor list while processing RERR, then it will have node A and the new neighbor X in its precursor after local repair, which will be incorrect.
Am i missing something ?
 
Also while checking AODV-UU and ns-2 implementations, i found the neighbors for whom a node has processed a RERR are deleted immediately, though RFC does not specify when to remove nodes from precursor.
 
Any comments will be greatly helpful.
 
Thanks.

lolo <[email-masked]> wrote:
Hi M.U.

As the precursors list is a field of the routing table, i thought that precursors list get deleted only when that particular entry is deleted (after DELETE_PERIOD).
Precursors are among the recipients of the RERR messages, and maybe one of them, or the detector of the link breakage can attempt a "local repair". So one has to keep them presents in case the route table can be repaired.

HTH

Laurent

manet user wrote: Hi,

 

---------------------------------
_______________________________________________manet mailing [email-masked]://www1.ietf.org/mailman/listinfo/manet  

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com