Subject: RE: [manet] Routing doubt

From: "Giorgio Mulas" <[email-masked]>
Date: Mon, 31 Jan 2005 09:26:29 +0100

Hi,
802.11 is a layer 1,2 technology, then it is not correct calling the managed bits packets, but instead we call them "frames". Saying that, ISO/OSI lower layers are not aware of the information provided by upper layers, then your question is based on incorrect suppositions (or likely I don't understand :-) ).

	Packet(s)
--------------------------------------Layer 3/2 interface
	Frame = Packet(s) + overhead

Finally 802.11 provides a reliable DLC implementing an acknowledgment mechanism for retrasmitting corrupted frames.

Hope this helps

Best regards

	Giorgio

------------------------------------------
Giorgio Mulas | Researcher

CEFRIEL  Politecnico di Milano
Via Fucini, 2 · 20133 Milano (Italy)

p. +39 02 23954 265
f. +39 02 23954 465
e. [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Vinod
> Sent: venerdì 28 gennaio 2005 18.29
> To: [email-masked]
> Subject: [manet] Routing doubt
> 
> 
> Hi,
> I have a basic doubt in routing of packets.
> Im working on odmrp in glomosim(on routing layer).
> To increase the reliability,we are re-sending the data
> packets not received by any receiver.
> 
> Now my doubt is,does MAC Layer (802.11) allow me to send
> the packets non sequentially ?.Suppose a receiver got
> 1,2,6,7,8 pkts.So NOW ,i re-send the pkts 3,4,5 again to the 
> receiver. All these is done in routing layer as said before. 
> Does MAC Layer of the receiver allow these new packets or 
> will it only allow packets from 9 onwards ?
> 
> Pls let me know.This one is for my project so kinda urgent.
> 
> Thnx in advance,
> Vinod Kone
> ----------------------
> Vinod Kone,
> Btech,Computer Science,
> VI sem,
> Room 179,Kapili,
> IIT Guwahati.
> mail  me @:
> [email-masked]
> [email-masked]
> Mobile: 9864036875
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ali Hamidian <[email-masked]>
Date: Mon, 31 Jan 2005 11:26:11 +0100

Hi Vinod,

Yes, MAC will accept frames that are re-sent and that don't arrive "in 
order". The reason is that, the "order" is defined/specified by the 
sender's network layer (by ODMRP) and understood only by the receiver's 
network layer (by ODMRP). So, the "order" doesn't mean anything to 802.11.

Kind regards
Ali