Subject: [manet] packet and its size of Multimedia

From: TAING Nguon <[email-masked]>
Date: Tue, 4 Jan 2005 21:16:26 -0800 (PST)

Hi, 

I am writing to simulate multimedia trafic in Manet.
Could you tell me which agent, UDP or TCP, is the
best? and Could you also pls tell me its packet size?

Thanks,

Nguon

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Giorgio Mulas" <[email-masked]>
Date: Mon, 10 Jan 2005 08:59:56 +0100

Hi,
As a simple rule, you can use: UDP for real-time applications, TCP for non-real-time ones.
UDP/TCP are transport layer protocols, so it is better to use the term segment instead of packet. (I know, I'm so pedantic...)
UDP segment size is maximum 2^16 bytes, minimum (i.e. only header present) is 8 bytes.
TCP segment size depends on network status because of the congestion control mechanism and the maximum size depends also on the send and receive buffers in the Tx and Rx, minimum (i.e. only header with no options - does it make sense? ) is 20 bytes.

Look for RFCs 

B.R.

		Giorgio

------------------------------------------
Giorgio Mulas | Researcher

CEFRIEL  Politecnico di Milano
Via Fucini, 2 · 20133 Milano (Italy)

p. +39 02 23954 265
f. +39 02 23954 465
e. [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of TAING Nguon
> Sent: mercoledì 5 gennaio 2005 6.16
> To: [email-masked]
> Subject: [manet] packet and its size of Multimedia
> 
> 
> Hi, 
>