Subject: [manet] Require address auto-configuration implementation or simulation code!

From: zhang zhi <[email-masked]>
Date: Wed, 26 Jan 2005 21:24:06 +0800

Hi,all
    I plan to implement an address auto-configuration protocol for
MANET. Does anyone know any exisiting implementation codes or
simulation package(s) written in ns2 or Qualnet?If you have please let
me know!
Thanks a lot!

-- 
Zhang Zhi       PhD Candidate
Northwesten Polytechnical University    College of Automation
Email: [email-masked]
          [email-masked]

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Christophe Jelger <[email-masked]>
Date: Thu, 27 Jan 2005 09:15:22 +0100

Hello,

Have a look there :

http://www-r2.u-strasbg.fr/~frey/safari/autoconf.html

You can find OLSR with IPv6 autoconfiguration based on prefix continuity.

Regards,
Christophe

---

From: Claudio Lavecchia <[email-masked]>
Date: Thu, 27 Jan 2005 12:19:12 +0100

>simulation package(s) written in ns2 or Qualnet?If you have please let
I heard of another existing implementation, please check the link below.
http://pacman-autoconf.sourceforge.net/
This implemtation has been done at the university of Karlsrhue.

Regards

Claudio Lavecchia

---

From: Manel Guerrero <[email-masked]>
Date: Fri, 28 Jan 2005 16:51:31 +0100

Hi Zhang Zhi :)

You might want to take a look at the section "14.4. SAODV Key Management"
of the SAODV draft (http://www.ietf.org/internet-drafts/draft-guerrero-manet-saodv-02.txt)
for an auto-configuration protocol that can be used for any MANET routing
protocol.

Although there is no ns2 or Qualnet code, it should be pretty straight forward
to modify the AODV ns2 code (or another protocol/simulator) to implement it.

Best regards,

	Manel

P.D.: The concept is explained in a more verbose manner in this paper ;) :
Manel Guerrero Zapata: "Key Management and Delayed Verification for Ad Hoc Networks".
In Proceedings of the 3rd International Trusted Internet Workshop (TIW 2004).

---

From: gabriel montenegro <[email-masked]>
Date: Fri, 28 Jan 2005 15:53:09 -0800

Yes, I agree. We've actually discussed this before on this list,
and at the AODV NG workshop (2002), although we did not implement it:

   Protecting AODV against impersonation attacks
   http://doi.acm.org/10.1145/581291.581313

There's some discussion as well in the updated "SUCV" paper at:

   Crypto-based identifiers (CBIDs): Concepts and applications
   http://doi.acm.org/10.1145/984334.984338

Manel, did I understand you correctly that this is not yet part of any
public AODV implementation? If it is implemented, could you please send
the pointer?

thanks,

-gabriel

Manel Guerrero wrote:
> of the SAODV draft 
> (http://www.ietf.org/internet-drafts/draft-guerrero-manet-saodv-02.txt)

---

From: Manel Guerrero <[email-masked]>
Date: Mon, 31 Jan 2005 11:03:41 +0100

Hi Gabriel :)

Yes, I'm not aware of any implementation of SAODV Key Management.

Regards,

	Manel