Subject: [manet]how can I modify DSR's ns2 implementation?

From: "BO Stephen" <[email-masked]>
Date: Wed, 23 Mar 2005 02:48:56 +0000

Dear all, 
      I am a newer to ns2. I've read through DSR ietf internet draft. I 
found that there is dsr directory under ns-2xxx, but  could not find any 
thing about modification. Could any one please tell me whether we 
can modify DSR algorithm? 

regards 
Stephen_Bo

_________________________________________________________________
与联机的朋友进行交流，请使用 MSN Messenger: http://messenger.msn.com/cn 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Farid Jaddi" <[email-masked]>
Date: Wed, 23 Mar 2005 09:42:03 +0100 (CET)

Hi Stephen,

this FAQ could be helpful:

http://www.geocities.com/b_j_hogan/

Farid

> ÓëÁª»úµÄÅóÓÑ½øÐÐ½»Á÷£¬ÇëÊ¹ÓÃ MSN Messenger: http://messenger.msn.com/cn
>
>

---

From: "Stephen Bo" <[email-masked]>
Date: Wed, 23 Mar 2005 17:47:15 +0000

dear Farid,
     I cannot access this website in China. Can you show me other place?

best regards
Stephen Bo

>From: "Farid Jaddi" <[email-masked]>
>Reply-To: [email-masked]
>To: "BO Stephen" <[email-masked]>
>CC: [email-masked]
>Subject: Re: [manet]how can I modify DSR's ns2 implementation?
>Date: Wed, 23 Mar 2005 09:42:03 +0100 (CET)
>
>Hi Stephen,
>

_________________________________________________________________
与世界各地的朋友进行交流，免费下载 MSN Messenger:  
http://messenger.msn.com/cn

---

From: "Farid Jaddi" <[email-masked]>
Date: Thu, 24 Mar 2005 10:22:15 +0100 (CET)

Hello,

 I am a Phd student who works on ad hoc networks. I have run
simulations on ns2 with SCTP over DSR and AODV and i obtain some
segmentation faults under certain mobility scenarios (using setdest).
I have simulated an ad hoc network with the same scripts (traffic and
simulation) but without mobility (nodes stay in their initial position)
and there is no segmentation fault over numerous scenarios. In
my simulation scripts, i do not use multi-homing. I think the
problem stems from the mobility management.

In fact, if a destination becomes unreachable, how does SCTP
react ?

Best regards and thanks in advance for your help,

Farid.

---

From: "Farid Jaddi" <[email-masked]>
Date: Thu, 31 Mar 2005 13:24:31 +0200 (CEST)

> I'm afraid that I'm not familar with the code of sctp...I once had a seg
> fault that was occuring in a class that I had not altered...it turned out
> to be caused by referencing an array (in another class) beyond it's end
> (array out of bounds).
>
> Obviously, for you, it's more difficult as you have not altered
> anything...here are some thoughts -
>
> does it occur if you have above a certain number of nodes/data rate?
>
> have you looked at the trace file to see if the simulation up to the point
> of failure is accurate?
>
> Can you monitor the size of the StreamBuffer and determine if the crash
> occurs when it reaches certain limit?
>
> for a particular simulation that you know will crash, can you put a
> breakpoint in the code before the crash and step through? observer the
> size of arrays, buffers, etc.
>
> Bryan
>
> On Fri, 25 Mar 2005, Farid Jaddi wrote:
>
>> Hi Brian,
>>
>> i dont'make any changes to ns code and i use the CMUPriQueue. I use gdb
>> to
>> find the source of my seg fault: it stems from Packet:Free(),
>> Packet::new() , SctpAgent::UpdateAllStreams,
>> SctpAgent::InsertInStreamBuffer.
>> I can use all the memory of my system
>> > limit
>> cputime      unlimited
>> filesize     unlimited
>> datasize     unlimited
>> stacksize    8192 kbytes
>> coredumpsize 0 kbytes
>> memoryuse    unlimited
>> vmemoryuse   unlimited
>> descriptors  1024
>> memorylocked unlimited
>> maxproc      unlimited
>>
>> I guess i maybe run out of memory but i have made simulations on TCP
>> with
>> the same scenarios without any problem.
>>
>> > Hi,
>> >
>> > Have you made changes to the standard ns code?
>> > Have you used a debugger to find the source of the seg fault?
>> > If using DSR, have you switched to the CMUPriQueue?
>> >
>> > Bryan
>> > On Thu, 24 Mar 2005, Farid Jaddi wrote:
>> >
>> >> Hello,
>> >>
>> >> >>       I am a newer to ns2. I've read through DSR ietf internet
>> draft.
>> >> I
>> >> >> found that there is dsr directory under ns-2xxx, but  could not
>> find
>> >> any