Subject: Re: [manet] ZRP simulation results

From: [email-masked]
Date: Sun, 13 Mar 2005 18:13:06 +1100

Dear Price Samar,

The code i used is based on the second internet draft for ZRP. 
I patched this code in glomosim and observed the throughput and 
control overheads for 50 and 100 nodes with 10 and 20 CBR
sources transmitting at 4 packet per second. The mobility
level was varied between 0 and 20 m/s, with 0 pause time.
Under both scenarios, AODV produced over 90% throughput.
However, ZRP produced less than 70%. I also tried with lower
levels of mobility, however, the results were not
significantly better for ZRP. I also varied the update
intervals for the Inrazone updates, and tried different values
for zone radius (e.g. Zone radius values of 1, 2 and 3.

One observation i made was that the IARP component produces 
a lot of overhead, due to frequent link failure detection and
changes in the Inrazone, and packets where being dropped due
to buffer overflows. So i suppose that the Proactive component
of IARP should be improved. I am not sure if improvements to
this where made in the version 3 and 4 of ZRP??

I understand that ZRP is viewed as a framework, and
improvements can be made in both the proactive and reactive 
components. However, for majority of Hybrid routing protocols
proposed to date, ZRP is also seen as a performance comparison
bench mark, and hence, it is often treated as a routing
protocol than a framework.   

Kind regards,
Mehran

---- Original message ----
>Date: Sat, 12 Mar 2005 18:32:11 -0500 (EST)
>From: Prince Samar <[email-masked]>  
>Subject: Re: [manet] ZRP simulation results  
>To: Mehran Abolhasan <[email-masked]>
>Cc: [email-masked], [email-masked]
>
>
>Dear Mehran,
>
>Here are some of my thoughts on your unusual simulation results.
>
>- First a disclaimer: I am not familiar with the particular
code for ZRP
>that you are using. So, I cannot comment on the accuracy of the
>implementation, or rule out bugs in the code.
>
>- We consider ZRP as more of a routing protocol *framework*
than "yet
>another routing protocol out there." For a fair comparison of
ZRP with
>AODV, the reactive component (IERP) should be derived from AODV.
>Similarly, when comparing ZRP with any other
reactive/proactive routing
>protocol, the IERP/IARP should be based on that particular
routing
>protocol. Please refer to [1] and [2] for guidelines to
convert a reactive
>or proactive routing protocol into IERP or IARP.
>
>- At what network settings (node mobility, call rate etc.)
did you compare
>the results? And at what values of the routing zone radius
for ZRP? If the
>ratio of calling rate to mobility in your settings is very
low, so that
>highly reactive routing is preferred [3], then probably zone
radius of 1
>(or, 0) would be the optimal setting for ZRP. This setting
corresponds to
>pure reactive routing. Thus, the performance of ZRP would be
at least be
>as good as that of AODV, given that AODV is used as the IERP.
Also,
>clearly at this setting, the contribution of proactive (IARP)
component to
>routing overhead will be zero.
>
>- Please make sure that the update interval for periodic
routing updates
>by IARP is set appropriately in relation to the degree of
mobility in your
>simulation. It sounds like the update interval is set for
high mobility
>(and thus the high proactive overhead) as compared to the
actual degree of
>mobility in your simulation settings. Please refer to [4] for
a simple
>'rule of thumb,' or [5] for a much more efficient scheme for
this.
>
>- According to version 4 of the ZRP internet draft, a node
does not need
>to maintain extended routing zones. Hence, the proactive
component of the
>routing overhead is considerably reduced in version 4.
>
>- Independent Zone Routing (IZR), an enhancement to ZRP, is
proposed in
>[3]. IZR enables each node to independently autoconfigure its
own optimal
>zone radius depending on the network characteristics.
Further, it provides
>each node the ability to adapt its zone radius over time and
space as
>local network characteristics change. This significantly
increases the
>efficiency and scalability of the framework.
>
>- You may find further simulation results on Zone Routing in
[4] and [3].
>
>[1] Zygmunt J. Haas, Marc R. Pearlman, Prince Samar, "The
Interzone
> Routing Protocol (IERP) for Ad Hoc Networks," IETF Internet
Draft, MANET 
> WG, July 2002.
>[2] Zygmunt J. Haas, Marc R. Pearlman, Prince Samar, "The
Intrazone 
> Routing Protocol (IARP) for Ad Hoc Networks," IETF Internet
Draft, MANET 
> WG, July 2002.
>[3] Prince Samar, Marc R. Pearlman, Zygmunt J. Haas,
"Independent Zone 
> Routing: An Adaptive Hybrid Routing Framework for Ad Hoc
Wireless 
> Networks," IEEE/ACM Transactions on Networking,  Vol. 12 , 
Issue 4, pp. 
> 595-608, Aug. 2004.
>[4] Zygmunt J. Haas, Marc R. Pearlman, "The Performance of
Query Control 
> Schemes for the Zone Routing Protocol,"  ACM/IEEE
Transactions on 
> Networking, vol. 9, no. 4, pp. 427-438, August 2001.
>[5] Prince Samar, Stephen B. Wicker, "On the Behavior of
Communication 
> Links of a Node in a Multi-Hop Mobile Environment," in The
Fifth ACM 
> International Symposium on Mobile Ad Hoc Networking and
Computing 
> (MobiHoc) 2004, Tokyo, May 2004.
>
>Hope this helps.
>
>Regards,
>Prince
>
>
>-------------------
>Prince Samar, Ph.D.
>Airvana Inc.
>+1-978-250-3115
>
>
>
>On Thu, 3 Mar 2005, Mehran Abolhasan wrote:
>
>: Hi All,
>: 
>: Just wondering, has anyone simulated the ZRP routing
protocol? i simulated the 
>: ZRP protocol using the code provided for version 2 of
protocol (see 
>: http://people.ece.cornell.edu/~haas/wnl/wnlprojects.html).
I got some strange 
>: results, in particular throughput results far less scalable
that AODV. I am 
>: not sure if there is a bug in this code or are these the
actual results. I 
>: have also noticed that the IARP routing part produces a lot
of overhead. Are 
>: there any major changes between version 2 and version 4,
which address 
>: overhead issues? 
>: 
>: If anyone has has performed a simulation study of ZRP
interms of looking at 
>: packet delivery radio, throught, control overhead, could
you please refer me 
>: to your paper, results or simulation code.
>: 
>: Kind regards,
>: 
>: 
>: 
>
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
Mehran Abolhasan 
B.E Computer, PhD
Research Fellow 
Telecommunications and IT Research Institute (TITR)
University of Wollongong, Northfields Ave, NSW 2522, Australia
Phone: +61 2 4221 3347
Fax: +61 2 4221 3277
www.titr.uow.edu.au/~mehran
Email 1: [email-masked]
Email 2: [email-masked]

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Prince Samar <[email-masked]>
Date: Mon, 14 Mar 2005 01:21:22 -0500 (EST)

Dear Mehran,

: One observation i made was that the IARP component produces
: a lot of overhead, due to frequent link failure detection and
: changes in the Inrazone, and packets where being dropped due
: to buffer overflows. So i suppose that the Proactive component
: of IARP should be improved. I am not sure if improvements to
: this where made in the version 3 and 4 of ZRP??

The simple link-state based IARP implementation and source-route based
IERP implementation are provided to demonstrate a "proof of concept." The
fine-tuning and optimization of IARP and IERP is left to the particular
proactive and reactive routing protocols being used in the Zone Routing
framework.

The method of bordercasting was changed in Version 4 of the Internet
Drafts, so that a node does not need to maintain routing information about
its extended routing zone, but just its routing zone. That is, a node
proactively maintains routing information about all nodes within R hops
from it (and not 2*R -1 hops, which defines the extended routing zone).  
This reduces the proactive component of the routing control traffic by a
significant fraction.

Regards,
Prince

-------------------
Prince Samar, Ph.D.
Airvana Inc.
+1-978-250-3115 

On Sun, 13 Mar 2005 [email-masked] wrote:

: Dear Price Samar,
: 
: The code i used is based on the second internet draft for ZRP. 
: I patched this code in glomosim and observed the throughput and 
: control overheads for 50 and 100 nodes with 10 and 20 CBR
: sources transmitting at 4 packet per second. The mobility
: level was varied between 0 and 20 m/s, with 0 pause time.
: Under both scenarios, AODV produced over 90% throughput.
: However, ZRP produced less than 70%. I also tried with lower
: levels of mobility, however, the results were not
: significantly better for ZRP. I also varied the update
: intervals for the Inrazone updates, and tried different values
: for zone radius (e.g. Zone radius values of 1, 2 and 3.
: 
: One observation i made was that the IARP component produces 
: a lot of overhead, due to frequent link failure detection and
: changes in the Inrazone, and packets where being dropped due
: to buffer overflows. So i suppose that the Proactive component
: of IARP should be improved. I am not sure if improvements to
: this where made in the version 3 and 4 of ZRP??
: 
: I understand that ZRP is viewed as a framework, and
: improvements can be made in both the proactive and reactive 
: components. However, for majority of Hybrid routing protocols
: proposed to date, ZRP is also seen as a performance comparison
: bench mark, and hence, it is often treated as a routing
: protocol than a framework.   
: 
: 
: Kind regards,
: Mehran
: 
: 
: ---- Original message ----
: >Date: Sat, 12 Mar 2005 18:32:11 -0500 (EST)
: >From: Prince Samar <[email-masked]>  
: >Subject: Re: [manet] ZRP simulation results  
: >To: Mehran Abolhasan <[email-masked]>
: >Cc: [email-masked], [email-masked]
: >
: >
: >Dear Mehran,
: >
: >Here are some of my thoughts on your unusual simulation results.
: >
: >- First a disclaimer: I am not familiar with the particular
: code for ZRP
: >that you are using. So, I cannot comment on the accuracy of the
: >implementation, or rule out bugs in the code.
: >
: >- We consider ZRP as more of a routing protocol *framework*
: than "yet
: >another routing protocol out there." For a fair comparison of
: ZRP with
: >AODV, the reactive component (IERP) should be derived from AODV.
: >Similarly, when comparing ZRP with any other
: reactive/proactive routing
: >protocol, the IERP/IARP should be based on that particular
: routing
: >protocol. Please refer to [1] and [2] for guidelines to
: convert a reactive
: >or proactive routing protocol into IERP or IARP.
: >
: >- At what network settings (node mobility, call rate etc.)
: did you compare
: >the results? And at what values of the routing zone radius
: for ZRP? If the
: >ratio of calling rate to mobility in your settings is very
: low, so that
: >highly reactive routing is preferred [3], then probably zone
: radius of 1
: >(or, 0) would be the optimal setting for ZRP. This setting
: corresponds to
: >pure reactive routing. Thus, the performance of ZRP would be
: at least be
: >as good as that of AODV, given that AODV is used as the IERP.
: Also,
: >clearly at this setting, the contribution of proactive (IARP)
: component to
: >routing overhead will be zero.
: >
: >- Please make sure that the update interval for periodic
: routing updates
: >by IARP is set appropriately in relation to the degree of
: mobility in your
: >simulation. It sounds like the update interval is set for
: high mobility
: >(and thus the high proactive overhead) as compared to the
: actual degree of
: >mobility in your simulation settings. Please refer to [4] for
: a simple
: >'rule of thumb,' or [5] for a much more efficient scheme for
: this.
: >
: >- According to version 4 of the ZRP internet draft, a node
: does not need
: >to maintain extended routing zones. Hence, the proactive
: component of the
: >routing overhead is considerably reduced in version 4.
: >
: >- Independent Zone Routing (IZR), an enhancement to ZRP, is
: proposed in
: >[3]. IZR enables each node to independently autoconfigure its
: own optimal
: >zone radius depending on the network characteristics.
: Further, it provides
: >each node the ability to adapt its zone radius over time and
: space as
: >local network characteristics change. This significantly
: increases the
: >efficiency and scalability of the framework.
: >
: >- You may find further simulation results on Zone Routing in
: [4] and [3].
: >
: >[1] Zygmunt J. Haas, Marc R. Pearlman, Prince Samar, "The
: Interzone
: > Routing Protocol (IERP) for Ad Hoc Networks," IETF Internet
: Draft, MANET 
: > WG, July 2002.
: >[2] Zygmunt J. Haas, Marc R. Pearlman, Prince Samar, "The
: Intrazone 
: > Routing Protocol (IARP) for Ad Hoc Networks," IETF Internet
: Draft, MANET 
: > WG, July 2002.
: >[3] Prince Samar, Marc R. Pearlman, Zygmunt J. Haas,
: "Independent Zone 
: > Routing: An Adaptive Hybrid Routing Framework for Ad Hoc
: Wireless 
: > Networks," IEEE/ACM Transactions on Networking,  Vol. 12 , 
: Issue 4, pp. 
: > 595-608, Aug. 2004.
: >[4] Zygmunt J. Haas, Marc R. Pearlman, "The Performance of
: Query Control 
: > Schemes for the Zone Routing Protocol,"  ACM/IEEE
: Transactions on 
: > Networking, vol. 9, no. 4, pp. 427-438, August 2001.
: >[5] Prince Samar, Stephen B. Wicker, "On the Behavior of
: Communication 
: > Links of a Node in a Multi-Hop Mobile Environment," in The
: Fifth ACM 
: > International Symposium on Mobile Ad Hoc Networking and
: Computing 
: > (MobiHoc) 2004, Tokyo, May 2004.
: >
: >Hope this helps.
: >
: >Regards,
: >Prince
: >
: >
: >-------------------
: >Prince Samar, Ph.D.
: >Airvana Inc.
: >+1-978-250-3115
: >
: >
: >
: >On Thu, 3 Mar 2005, Mehran Abolhasan wrote:
: >
: >: Hi All,
: >: 
: >: Just wondering, has anyone simulated the ZRP routing
: protocol? i simulated the 
: >: ZRP protocol using the code provided for version 2 of
: protocol (see 
: >: http://people.ece.cornell.edu/~haas/wnl/wnlprojects.html).
: I got some strange 
: >: results, in particular throughput results far less scalable
: that AODV. I am 
: >: not sure if there is a bug in this code or are these the
: actual results. I 
: >: have also noticed that the IARP routing part produces a lot
: of overhead. Are 
: >: there any major changes between version 2 and version 4,
: which address 
: >: overhead issues? 
: >: 
: >: If anyone has has performed a simulation study of ZRP
: interms of looking at 
: >: packet delivery radio, throught, control overhead, could
: you please refer me 
: >: to your paper, results or simulation code.
: >: 
: >: Kind regards,
: >: 
: >: 
: >: 
: >
: >
: >_______________________________________________
: >manet mailing list
: >[email-masked]
: >https://www1.ietf.org/mailman/listinfo/manet
: Mehran Abolhasan 
: B.E Computer, PhD
: Research Fellow 
: Telecommunications and IT Research Institute (TITR)
: University of Wollongong, Northfields Ave, NSW 2522, Australia
: Phone: +61 2 4221 3347
: Fax: +61 2 4221 3277
: www.titr.uow.edu.au/~mehran
: Email 1: [email-masked]
: Email 2: [email-masked]
: 
: _______________________________________________
: manet mailing list
: [email-masked]
: https://www1.ietf.org/mailman/listinfo/manet
: 
: