Subject: : Re: [manet] AODV + Promoscuous mode

From: Abdalla Mahmoud <[email-masked]>
Date: Mon, 21 Mar 2005 21:12:28 +0200

Dear Claudio, 
                       I meant that I want to have AODV's nodes  work
in promoscuous mode like nodes in DSR do. So how do I do that? Is it
that I change the config file in glomosim and have the promoscuous
mode on and that's it or how?

hope I made myself clear

Thanks,
Abdalla

On Mon, 21 Mar 2005 09:02:12 -0800 (PST), [email-masked]
<[email-masked]> wrote:
> Send manet mailing list submissions to
>        [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>        https://www1.ietf.org/mailman/listinfo/manet
> or, via email, send a message with subject or body 'help' to
>        [email-masked]
> 
> You can reach the person managing the list at
>        [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of manet digest..."
> 
> 
> Today's Topics:
> 
>   1. New version of UoBWinAODV (version 0.15) (Asanga Udugama)
>   2. implementation complexity of fuzzy system (cidambaram ramanathan)
>   3. software or script to calculate the link duration for the
>      mobility model generated by setdest (manet ns2)
>   4. Re: AODV + Promoscuous mode (Claudio Lavecchia)
> 
> 
> 
> ---------- Forwarded message ----------
> From: "Asanga Udugama" <[email-masked]>
> To: <[email-masked]>, <[email-masked]>
> Date: Mon, 21 Mar 2005 13:43:03 +0100
> Subject: [manet] New version of UoBWinAODV (version 0.15)
> 
> 
> Hello all,
> 
>  
> 
> We have released a newer version of UoB WinAODV, version 0.15. We fixed a lot of bugs and have also included a GUI to display the routes, status, etc., of a node.
> 
>  
> 
> Kind regards,
> 
> Asanga
> 
>  
> 
> ---------- Forwarded message ----------
> From: cidambaram ramanathan <[email-masked]>
> To: [email-masked]
> Date: Mon, 21 Mar 2005 12:51:12 +0000 (GMT)
> Subject: [manet] implementation complexity of fuzzy system
> Dear All,
> 
> Can anyone suggest me how to compute implementation complexity or communication
> complexity or time complexity of a fuzzy system on manet?
> 
> Thanks in advance for spending your valuable time
> Gomathy
> 
> Send instant messages to your online friends http://uk.messenger.yahoo.com
> 
> 
> 
> ---------- Forwarded message ----------
> From: manet ns2 <[email-masked]>
> To: [email-masked]
> Date: Mon, 21 Mar 2005 05:39:44 -0800 (PST)
> Subject: [manet] software or script to calculate the link duration for the mobility model generated by setdest
> 
> Hi
>  
> I wish to know whether there exists any software or script to calculate the link duration (is defined as the time that two nodes are within the transmission range of one another) for the mobility model generated by the setdest program
>  
> Regards
>  
> Sandeep
>  
>  
> 
> ________________________________
> Do you Yahoo!?
> Yahoo! Small Business - Try our new resources site! 
> 
> 
> 
> ---------- Forwarded message ----------
> From: Claudio Lavecchia <[email-masked]>
> To: Abdalla Mahmoud <[email-masked]>
> Date: Mon, 21 Mar 2005 16:46:03 +0100
> Subject: Re: [manet] AODV + Promoscuous mode
> Hello Abdalla,
> 
> I am not sure I understand your question: I do not see relationship
> between a MANET routing protocol (AODV, for example) and the promiscuous
> mode. The promiscuous mode is not related to the routing layer, it is
> just just an operating mode of your WLAN adapter. Please keep in mind
> that not all the WLAN adapter drivers support the promiscuos mode.
> 
> Regards
> 
> Claudio
> 
> Abdalla Mahmoud wrote:
> 
> >Hello,
> >        I am now to the field fo MANET and wanted to know if there is
> >a way or open-source code/function that I can integrate to the AODV
> >protocol to have it work in promoscuous mode.
> >
> >Thanks and your soonest help will be appreciated.
> >Abdalla
> >
> >
> >On Sun, 20 Mar 2005 23:49:41 -0800 (PST), [email-masked]
> ><[email-masked]> wrote:
> >
> >
> >>Send manet mailing list submissions to
> >>       [email-masked]
> >>
> >>To subscribe or unsubscribe via the World Wide Web, visit
> >>       https://www1.ietf.org/mailman/listinfo/manet
> >>or, via email, send a message with subject or body 'help' to
> >>       [email-masked]
> >>
> >>You can reach the person managing the list at
> >>       [email-masked]
> >>
> >>When replying, please edit your Subject line so it is more specific
> >>than "Re: Contents of manet digest..."
> >>
> >>
> >>Today's Topics:
> >>
> >>  1. Re: Tx Range on Contention (Hasan Raza)
> >>  2. NCA Call for Papers (Luke Demoracski)
> >>  3. Re: Tx Range on Contention (Huixian)
> >>  4. Announcing COMSWARE 2006 in New Delhi: Jan 8 to Jan 12
> >>     (Rajeev Shorey)
> >>
> >>
> >>
> >>---------- Forwarded message ----------
> >>From: Hasan Raza <[email-masked]>
> >>To: "S.Sivavakeesar" <[email-masked]>
> >>Date: Mon, 21 Mar 2005 00:57:23 +0530 (IST)
> >>Subject: Re: [manet] Tx Range on Contention
> >>
> >>
> >>
> >>>under heavy loaded condition, increasing the Tx range would increase the
> >>>overall throughput - Is it true ? As per my understanding, inccreasing
> >>>the Tx range would result in increased contention, and hence lead to
> >>>reduced throughput.
> >>>
> >>>
> >>If you are talking about adjusting the tx power for each individual tx-rx
> >>pair (link), then it might be true. More number of links can be packed in
> >>the network by adjusting the power of the links. An incoming link might
> >>not be able to join the network (due to lower SIR at receiver)  unless the
> >>transmitter increases its power. However, increasing the power must be in
> >>a controlled fashion such that other links' SIR is not deteriorated below
> >>the required threshold.
> >>
> >>Regards.
> >>Hasan
> >>
> >>On Sun, 20 Mar 2005, S.Sivavakeesar wrote:
> >>
> >>
> >>
> >>>Dear All :
> >>>
> >>>I am sure some of you guys who deal with Tx power/range control in MANETcan answer my question.
> >>>Considering IEEE 802.11 a/b/g  DCF based operation as the underlying MAC, can we assume that
> >>>increase of Tx range would result in reduced contention for a given  MANET having a constant
> >>>load and node-density. If I refine my question, does Tx range have any impact on MAC-level
> >>>contention - surely yes, but how ?. I am currently reading a paper, in which it is stated that
> >>>under heavy loaded condition, increasing the Tx range would increase the overall throughput -
> >>>Is it true ? As per my understanding, inccreasing the Tx range would result in increased
> >>>contention, and hence lead to reduced throughput. Can any one clarify this for me please.
> >>>
> >>>Thanks in advance for your invaluable time.
> >>>
> >>>Cheers
> >>>
> >>>Siva
> >>>
> >>>
> >>>
> >>
> >>---------- Forwarded message ----------
> >>From: Luke Demoracski <[email-masked]>
> >>To: [email-masked]
> >>Date: Sun, 20 Mar 2005 14:59:57 -0500 (EST)
> >>Subject: [manet] NCA Call for Papers
> >>CALL FOR PAPERS
> >>
> >>The 4th IEEE International Symposium on
> >>Network Computing and Applications (IEEE NCA05)
> >>July 27 - July 29, 2005
> >>Marriott Hotel, Kendal Square, Cambridge, MA, USA
> >>Sponsored by: IEEE Computer Society,
> >>Technical Committee on Distributed Processing.
> >>
> >>For paper submission and further information please see
> >>
> >>        http://www.ieee-nca.org
> >>
> >>Paper Submission Deadline: April 6, 2005
> >>
> >>On behalf of the PC of the IEEE NCA05
> >>
> >>
> >>
> >>---------- Forwarded message ----------
> >>From: Huixian <[email-masked]>
> >>To: [email-masked]
> >>Date: Mon, 21 Mar 2005 08:30:56 +0800
> >>Subject: Re: [manet] Tx Range on Contention
> >>Hi Siva,
> >>
> >>There are a few factors to take into consideration, when evaluating the
> >>effects of the Tx range on throughput. Some of these factors include
> >>node mobility, node density and traffic load.
> >>
> >>Having a higher Tx range will tend to increase the contention at the MAC
> >>layer, lead to higher probability of collisions and reduce the spatial
> >>reuse of the channel. However, higher Tx range will also lead to shorter
> >>path lengths and therefore, less frequent link breakages.
> >>
> >>I think you need to consider the above mentioned factors when evaluating
> >>the effects of adjusting the Tx power on throughput. In general,
> >>increasing the Tx power (and hence the range) will tend to increase the
> >>throughput during high node mobility. If you increase your node density
> >>gradually, you will find that your throughput starts to drop due to the
> >>increased contention and decreased spatial reuse.
> >>
> >>Hope this helps!
> >>
> >>regards
> >>Hwee-Xian Tan
> >>School of Computing
> >>National University of Singapore
> >>
> >>
> >>
> >>>Today's Topics:
> >>>
> >>>  1. Tx Range on Contention (S.Sivavakeesar)
> >>>
> >>>
> >>>----------------------------------------------------------------------
> >>>
> >>>Message: 1
> >>>Date: Sun, 20 Mar 2005 14:43:17 -0000
> >>>From: "S.Sivavakeesar" <[email-masked]>
> >>>Subject: [manet] Tx Range on Contention
> >>>To: manet <[email-masked]>
> >>>Message-ID:
> >>>      <[email-masked]>
> >>>Content-Type: text/plain; charset="iso-8859-1"
> >>>
> >>>Dear All :
> >>>
> >>>I am sure some of you guys who deal with Tx power/range control in MANETcan answer my question. Considering IEEE 802.11 a/b/g  DCF based operation as the underlying MAC, can we assume that increase of Tx range would result in reduced contention for a given MANET having a constant load and node-density. If I refine my question, does Tx range have any impact on MAC-level contention - surely yes, but how ?. I am currently reading a paper, in which it is stated that under heavy loaded condition, increasing the Tx range would increase the overall throughput - Is it true ? As per my understanding, inccreasing the Tx range would result in increased contention, and hence lead to reduced throughput. Can any one clarify this for me please.
> >>>
> >>>Thanks in advance for your invaluable time.
> >>>
> >>>Cheers
> >>>
> >>>Siva
> >>>
> >>>
> >>>
> >>>
> >>
> >>---------- Forwarded message ----------
> >>From: Rajeev Shorey <[email-masked]>
> >>To: [email-masked]
> >>Date: Mon, 21 Mar 2005 13:13:58 +0530
> >>Subject: [manet] Announcing COMSWARE 2006 in New Delhi: Jan 8 to Jan 12
> >>
> >>(Our apologies if you receive multiple copies of this document)
> >>
> >>                           CALL FOR PAPERS
> >>                                                   ************************
> >>
> >>                             COMSWARE 2006
> >>                The First International Conference on
> >>            Communication Systems Software and Middleware
> >>
> >>                                     http://www.comsware.org/
> >>
> >>                         January 8 - 12, 2006
> >>                Taj Palace Hotel, New Delhi, India
> >>
> >>
> >>        Technical Co-Sponsor: IEEE Communications Society
> >>        Technical Co-Sponsor: IEEE Computer Society (Pending)
> >>        In Co-operation with:       ACM SIGMOBILE
> >>        Sponsored by:                 CreateNet (Italy), ICST (USA),
> >>                                                               IBM, Microsoft, NOKIA
> >>
> >>The convergence of the communications, information technologies and the Internet
> >>has ushered in a revolution in the way people communicate with each other. The key
> >>enabler for this convergence has been the advancement of software technology in
> >>various communication sectors, as evident by the high levels of activity in the
> >>industry, academia, and standards bodies, coupled with the increasing dependence of
> >>this convergence to sustain and improve growth rates in many countries around the
> >>world.
> >>
> >>This new international conference will provide a forum to exchange ideas, techniques,
> >>and applications, discuss best practices and challenging issues, raise awareness and
> >>share experiences among researchers, practitioners, standard developers and policy
> >>makers in the field of software techniques in communications. The conference will
> >>bring leading researchers and practitioners in areas ranging from communications
> >>software and software engineering aspects of communications software, to middleware
> >>and networking protocols. The objective of the conference is to provide a high
> >>degree of collaboration, participation and discussions of the various topics among
> >>multi-national participants from the industrial, governmental and academic sectors.
> >>
> >>COMSWARE will include a regular paper track and an industry track. The paper track
> >>will include a highly selective technical program. The conference solicits original,
> >>previously unpublished research work, experimental efforts, and practical experiences
> >>for the technical program. COMSWARE will also feature panel discussions from experts
> >>in academia and industry, workshops and tutorials featuring the state-of-the-art in
> >>various communications software and related areas. There will be demos and exhibits
> >>that will expose the delegates to exciting products and software solutions from
> >>industry and academia. Accepted papers will be published by IEEE Computer Society.
> >>The top papers accepted to the conference will be published in a reputed journal.
> >>
> >>Areas of interest include, but are not limited to:
> >>
> >>· Communications Software
> >>· Reconfigurable Software Stacks
> >>· Software Engineering Aspects of Communications Software
> >>· Context-Based and Implicit Computing
> >>· Telecommunications Services and QoS
> >>· Software for Billing and Pricing
> >>· User Interfaces and Interaction Models
> >>· Multi-Agent Systems
> >>· Client-Server Applications
> >>· Mobile and Intermittently Connected Applications
> >>· Mobile Data Management
> >>· Middleware Services and Agent Technologies
> >>· Middleware for Wireless Sensor Networks
> >>· Middleware for P2P Systems
> >>· Middleware for Future Communication Networks
> >>· Information Infrastructure and Security
> >>· Security and Privacy Issues of Pervasive Computing Systems
> >>· Network Operations and Management
> >>· Policy and Workflow-based Network Operations
> >>· Reliability Support Software
> >>· Resource Management in Pervasive Computing Platforms
> >>· Network Monitoring Software
> >>· Internet and IP based Services
> >>· Dynamic Service Composition and Deployment
> >>· Service Discovery Mechanisms
> >>· Wireless/Mobile Service Management and Delivery
> >>· Mobile / Wireless Computing Systems and Services
> >>· Performance Evaluation Techniques
> >>· Location Determination
> >>· Positioning and Tracking Technologies Intelligent Environments
> >>· Smart Devices and Smart Spaces
> >>· Enterprise Networking
> >>· Personal Area Networks
> >>· Integration of Wired and Wireless Networks
> >>· Next Generation Networks and Services
> >>
> >>
> >>Paper Submission Deadline
> >>**********************************
> >>Paper Submission:                May 2, 2005
> >>Notification of Acceptance: September 5, 2005
> >>Camera-ready due:               September 26, 2005
> >>
> >>
> >>Conference Organizing Committee
> >>*****************************************
> >>
> >>General  Chairs:                        Alfred Spector, IBM Research, USA
> >>                                                Victor Bahl, Microsoft Research, USA
> >>                        Bijendra Nath Jain, IIT, Delhi, India
> >>                        Henning Schulzrinne, Columbia University, USA
> >>
> >>
> >>Steering Committee
> >>Chairs:                                        Imrich Chlamtac, University of Trento, Italy
> >>                        Rajeev Shorey, IBM Research, India
> >>                        Prasant Mohapatra, University of California, Davis, USA
> >>
> >>Program Chairs:        Sanjoy Paul, Lucent Technologies, USA
> >>                        G. Venkatesh, SASKEN Technologies, India
> >>                        Jim Woodcock, University of York, UK
> >>
> >>Tutorial Chair:                Archan Misra, IBM Research, USA
> >>
> >>Workshop Chairs:        Ashwin Gumaste, Fujitsu Research, USA
> >>                        Gaurav Sharma, University of Rochester, USA
> >>
> >>Demos/Exhibit Chair:          Huzur Saran, IIT, Delhi, India
> >>Demos/Exhibit Co-Chair: Jaijit Bhattacharya, Oracle, India
> >>
> >>Publicity Chair:                  Thyaga Nandagopal, Lucent Technologies, USA
> >>Publicity Co-Chairs:          Sunghyun Choi, Seoul National University, Korea
> >>                        Marco Conti, IIT, Pisa, Italy
> >>                        Ben Lancini, LinLan, Brisbane, Australia
> >>                        Prashant Pradhan, IBM Research, USA
> >>                        Hemant Chaskar, Airtight Networks, India
> >>
> >>Local Arrangement
> >>Co-Chairs:                           Sudipta Maitra, IBM, Delhi
> >>                        Laurent Mignet, IBM Research, Delhi
> >>
> >>Finance Chair:                Karen Decker, USA
> >>
> >>
> >>_______________________________________________
> >>manet mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/manet
> >>
> >>
> >>
> >>
> >>
> >
> >_______________________________________________
> >manet mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/manet
> >
> >
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> 
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Manoj K Pandey <[email-masked]>
Date: Mon, 21 Mar 2005 15:11:21 -0800 (PST)

hi Abdalla,

For glomosim, you can do this by defining a RoutingAodvPeekFunction() similar
to that of RoutingDsrPeekFUnction() and then setting the network peek
function to RoutingAodvPeekFunction() in AODV's Init().
  NetworkIpSetPromiscuousMessagePeekFunction(node, &RoutingAodvPeekFunction);

When MAC layer sees that the Promiscous mode is ON, it simply calls
the networkPromiscous function, which can be set to any routing protocol's
promiscious function.

-Manoj

---

From: Mehran Abolhasan <[email-masked]>
Date: Tue, 22 Mar 2005 10:20:24 +1100

Hi Abdalla,

You would also have to modify the AODV code. Take a look at the code for DSR, 
which uses promiscusous mode. From there you should get some ideas on how to 
use promiscuous mode.

Regards,
Mehran

On Tue, 22 Mar 2005 06:12 am, Abdalla Mahmoud wrote:
> > We have released a newer version of UoB WinAODV, version 0.15. We fixed a
> > lot of bugs and have also included a GUI to display the routes, status,
> > etc., of a node.
> >
> >
> >
> > Kind regards,
> >
> > Asanga
> >
> >
> >
> > Can anyone suggest me how to compute implementation complexity or
> > communication complexity or time complexity of a fuzzy system on manet?
> >
> > I wish to know whether there exists any software or script to calculate
> > the link duration (is defined as the time that two nodes are within the
> > transmission range of one another) for the mobility model generated by
> > the setdest program
> >
> > Regards
> >
> > Sandeep
> >
> >
> >
> > >>>under heavy loaded condition, increasing the Tx range would increase
> > >>> the overall throughput - Is it true ? As per my understanding,
> > >>> inccreasing the Tx range would result in increased contention, and
> > >>> hence lead to reduced throughput.
> > >>
> > >>If you are talking about adjusting the tx power for each individual
> > >> tx-rx pair (link), then it might be true. More number of links can be
> > >> packed in the network by adjusting the power of the links. An incoming
> > >> link might not be able to join the network (due to lower SIR at
> > >> receiver)  unless the transmitter increases its power. However,
> > >> increasing the power must be in a controlled fashion such that other
> > >> links' SIR is not deteriorated below the required threshold.
> > >>
> > >>Regards.
> > >>Hasan
> > >>
> > >>>I am sure some of you guys who deal with Tx power/range control in
> > >>> MANETcan answer my question. Considering IEEE 802.11 a/b/g  DCF based
> > >>> operation as the underlying MAC, can we assume that increase of Tx
> > >>> range would result in reduced contention for a given  MANET having a
> > >>> constant load and node-density. If I refine my question, does Tx
> > >>> range have any impact on MAC-level contention - surely yes, but how
> > >>> ?. I am currently reading a paper, in which it is stated that under
> > >>> heavy loaded condition, increasing the Tx range would increase the
> > >>> overall throughput - Is it true ? As per my understanding,
> > >>> inccreasing the Tx range would result in increased contention, and
> > >>> hence lead to reduced throughput. Can any one clarify this for me
> > >>> please.
> > >>>
> > >>Having a higher Tx range will tend to increase the contention at the
> > >> MAC layer, lead to higher probability of collisions and reduce the
> > >> spatial reuse of the channel. However, higher Tx range will also lead
> > >> to shorter path lengths and therefore, less frequent link breakages.
> > >>
> > >>I think you need to consider the above mentioned factors when
> > >> evaluating the effects of adjusting the Tx power on throughput. In
> > >> general, increasing the Tx power (and hence the range) will tend to
> > >> increase the throughput during high node mobility. If you increase
> > >> your node density gradually, you will find that your throughput starts
> > >> to drop due to the increased contention and decreased spatial reuse.
> > >>
> > >>Hope this helps!
> > >>
> > >>regards
> > >>Hwee-Xian Tan
> > >>School of Computing
> > >>>I am sure some of you guys who deal with Tx power/range control in
> > >>> MANETcan answer my question. Considering IEEE 802.11 a/b/g  DCF based
> > >>> operation as the underlying MAC, can we assume that increase of Tx
> > >>> range would result in reduced contention for a given MANET having a
> > >>> constant load and node-density. If I refine my question, does Tx
> > >>> range have any impact on MAC-level contention - surely yes, but how
> > >>> ?. I am currently reading a paper, in which it is stated that under
> > >>> heavy loaded condition, increasing the Tx range would increase the
> > >>> overall throughput - Is it true ? As per my understanding,
> > >>> inccreasing the Tx range would result in increased contention, and
> > >>> hence lead to reduced throughput. Can any one clarify this for me
> > >>> please.
> > >>>
> > >>                                                               IBM,
> > >> Microsoft, NOKIA
> > >>The convergence of the communications, information technologies and the
> > >> Internet has ushered in a revolution in the way people communicate
> > >> with each other. The key enabler for this convergence has been the
> > >> advancement of software technology in various communication sectors,
> > >> as evident by the high levels of activity in the industry, academia,
> > >> and standards bodies, coupled with the increasing dependence of this
> > >> convergence to sustain and improve growth rates in many countries
> > >> around the world.
> > >>
> > >>This new international conference will provide a forum to exchange
> > >> ideas, techniques, and applications, discuss best practices and
> > >> challenging issues, raise awareness and share experiences among
> > >> researchers, practitioners, standard developers and policy makers in
> > >> the field of software techniques in communications. The conference
> > >> will bring leading researchers and practitioners in areas ranging from
> > >> communications software and software engineering aspects of
> > >> communications software, to middleware and networking protocols. The
> > >> objective of the conference is to provide a high degree of
> > >> collaboration, participation and discussions of the various topics
> > >> among multi-national participants from the industrial, governmental
> > >> and academic sectors.
> > >>
> > >>COMSWARE will include a regular paper track and an industry track. The
> > >> paper track will include a highly selective technical program. The
> > >> conference solicits original, previously unpublished research work,
> > >> experimental efforts, and practical experiences for the technical
> > >> program. COMSWARE will also feature panel discussions from experts in
> > >> academia and industry, workshops and tutorials featuring the
> > >> state-of-the-art in various communications software and related areas.
> > >> There will be demos and exhibits that will expose the delegates to
> > >> exciting products and software solutions from industry and academia.
> > >> Accepted papers will be published by IEEE Computer Society. The top
> > >> papers accepted to the conference will be published in a reputed
> > >> journal.
> > >>
> > >>General  Chairs:                        Alfred Spector, IBM Research,
> > >> USA Victor Bahl, Microsoft Research, USA Bijendra Nath Jain, IIT,
> > >> Delhi, India
> > >>Chairs:                                        Imrich Chlamtac,
> > >> University of Trento, Italy Rajeev Shorey, IBM Research, India
> > >>Publicity Chair:                  Thyaga Nandagopal, Lucent
> > >> Technologies, USA Publicity Co-Chairs:          Sunghyun Choi, Seoul
> > >> National University, Korea Marco Conti, IIT, Pisa, Italy

-- 
Mehran Abolhasan
B.E Computer, PhD
Research Fellow
Telecommunications and IT Research Institute (TITR)
University of Wollongong
Northfields Avenue, NSW, 2522, Australia
Phone: +61 2 4221 3347
Fax: +61 2 4221 3277
http://www.titr.uow.edu.au/~mehran
Email 1: [email-masked]
Email 2: [email-masked]