Subject: [manet] Help needed in finding FTP implementation in ns

From: aravind rao <[email-masked]>
Date: Mon, 7 Mar 2005 11:52:18 +0000 (GMT)

Hi,
i have been trying to understand the flow of some tcl scripts. The senario involves ftp traffic and i wanted to trace the tcl statement "new [Application/FTP]" to its c++ code. But i am unable to find a ftp.cc or ftp.h in ns nor was i able to find a FTPClass.I have only found implementation of mftp in ~ns/apps folder. Where then is ftp being implemented? Please reply if u know where FTP is implemented.
 
Thankyou,
Aravind Rao
M.S. Ramaiah Institute of Technology

Send instant messages to your online friends http://uk.messenger.yahoo.com 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Mike Rodbell" <[email-masked]>
Date: Mon, 7 Mar 2005 08:08:21 -0500

I found some code in the subdirectory baytcp (using the allinone
distribution 2.28).  Perhaps that's what you're seeking?

Mike

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
aravind rao
Sent: Monday, March 07, 2005 6:52 AM
To: [email-masked]
Subject: [manet] Help needed in finding FTP implementation in ns

Hi,

i have been trying to understand the flow of some tcl scripts. The senario
involves ftp traffic and i wanted to trace the tcl statement "new
[Application/FTP]" to its c++ code. But i am unable to find a ftp.cc
<ftp://ftp.cc/>  or ftp.h <ftp://ftp.h/>  in ns nor was i able to find a
FTPClass.I have only found implementation of mftp in ~ns/apps folder. Where
then is ftp being implemented? Please reply if u know where FTP is
implemented.

Thankyou,

Aravind Rao

---

From: "Sherif M. ElRakabawy" <[email-masked]>
Date: Mon, 7 Mar 2005 14:52:30 +0100

hi,
 
the FTP application is written in tcl ..
take a look at ~/tcl/lib/ns-source.tcl ..
 
Regards

--------------------------------------------
Sherif M. ElRakabawy
University of Dortmund
Department of Computer Science                     Tel. +49 231 755 4797
Mobile Computing Systems Group                     Fax. +49 231 755 2417
August-Schmidt-Str. 12
44227 Dortmund / Germany
WWW: http://mobicom.cs.uni-dortmund.de/~moustafa/

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag
von aravind rao
Gesendet: Monday, March 07, 2005 12:52 PM
An: [email-masked]
Betreff: [manet] Help needed in finding FTP implementation in ns

Hi,
i have been trying to understand the flow of some tcl scripts. The
senario involves ftp traffic and i wanted to trace the tcl statement
"new [Application/FTP]" to its c++ code. But i am unable to find a
ftp.cc <ftp://ftp.cc/>  or ftp.h <ftp://ftp.h/>  in ns nor was i able to
find a FTPClass.I have only found implementation of mftp in ~ns/apps
folder. Where then is ftp being implemented? Please reply if u know
where FTP is implemented.
 
Thankyou,
Aravind Rao

Send instant messages to your online friends
http://uk.messenger.yahoo.com