Subject: [manet] DYMO & synchronization

From: Bart Braem <[email-masked]>
Date: Tue, 22 Mar 2005 18:43:24 +0100

Hello,

I'm doing simumlations of AODV and I noticed some synchronization issues with 
simultaneously started nodes. 
Now I wonder: does DYMO have any precautions against synchronization? I found 
1 reference to Hello (where I'm experiencing synchronization in AODV) in the 
RFC and no references to synchronization like in the OLSR RFC. 

Thanks
Bart Braem

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Bart Braem <[email-masked]>
Date: Tue, 22 Mar 2005 20:24:38 +0100

> Can you please elaborate? What is synchronized?  What occurs to
> demonstrate the fact that something is synchronized?
>

I mean by synchronized recurring synchronous transmissions of routing messages 
causing MAC layer collisions.

> In AODV if hello messages are used, a random jitter should be
> introduced to avoid synchronization.
>

Oh I'm sorry, I didn't find any references in the RFC. Is there an "official"  
recommendation somewhere?

> Which simulator and AODV implementation are you using?
>
I'm developping a Click implementation, so adding jitter won't be a problem.

> Is there something specific in DYMO that you think would lead to
> synchronization?

Yes, I noticed the recommendation to use linklayer monitoring. The RFC 
mentions hello messages, which is where I can see synchronizing in AODV if 
the nodes are started simultaneously.

Thanks
Bart