Subject: [manet] (OLSR) multiple global v6 address handling

From: manet user <[email-masked]>
Date: Thu, 3 Mar 2005 14:06:27 -0800 (PST)

Hi all,
 
I think in IPv6, an interface can support multiple global addresses. Then, in an OLSR network, if some interfaces have multiple global addresses, how this information should be relayed. Hellos are sent out per interface, so should we send hello for each global address of that interface?
 
Or there is a need of something like MID messages to distribute this information?
 
Please correct if i am missing something. Any thoughts will be greatly appreicated.
 
Thanks.

---------------------------------
Celebrate Yahoo!'s 10th Birthday! 
 Yahoo! Netrospective: 100 Moments of the Web 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 04 Mar 2005 10:11:22 +0000

>  I think in IPv6, an interface can support multiple global addresses. Then, in an OLSR network, 
>  if some interfaces have multiple global addresses, how this information should be relayed.
>  Hellos are sent out per interface, so should we send hello for each global address of that interface? 

You could use an HNA message (the H part of HNA) using a specific address for each interface
for routing.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************