Subject: [manet] aodv query

From: "jason alcock" <[email-masked]>
Date: Fri, 1 Apr 2005 16:44:31 +0100

Hi all
 
Is their any point in implementing AODV unidirectional black list feature if
I plan to use 802.11 at the link layer?
 
Thanks in advance.
 
Jason
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: manet user <[email-masked]>
Date: Fri, 1 Apr 2005 08:21:29 -0800 (PST)

802.11 uses broadcast mechanism to flood AODV RREQ. There is no backoff or acks related to broadcast transmissions.  In  AODV, a node acts on only the first RREQ with the same RREQ ID and  ignores any subsequent RREQs. So if the first RREQ comes through unidirectional link, RREP will never make it to the SRC. Subsequent route discovery after timeouts will also fail unless black list feature is used to ignore this first RREQ (receieved through unicast link).

jason alcock <[email-masked]> wrote:

Hi all

Is their any point in implementing AODV unidirectional black list feature if I plan to use 802.11 at the link layer?

Thanks in advance.

Jason

---------------------------------
Do you Yahoo!?
 Read only the mail you want - Yahoo! Mail SpamGuard.