Subject: [manet] An opnet simulation error

From: "jers\@inwind\.it" <[email-masked]>
Date: Tue, 19 Apr 2005 14:29:03 +0200

Hi all,

I'm a new user of Opnet Modeler and I'm utilizing it for my studies on manet
environment.
To learn how to use the modeler, I have developed a simple new process model
but,
 during the simulation process, while loading the model libraries, the
 simulation expires and shows the following
 error message:

 Beginning simulation of project_name-scenario1 at 11:31:26 mar apr 19 2005
 -----
 Kernel: development (not optimized), sequential
 -----
 <<< Warning >>>
 Repository missing process model (process_model_name)
 T (0), EV (-), MOD (NONE), PROC (sim_load_repos_prmatch)
 -----
 <<< Program Abort >>>
 The set of models necessary for running the simulation is incomplete.
 Check that all the 'repositories' attributes are complete.
 T (0), EV (-), MOD (NONE), PROC (sim_load_repos_load)
 -----

 I noticed that I can successfully carry out the simulations of  the "M/M/1
Queue" project
 included in the tutorial but, if at the beginning I change the name of the
 process model (e.g., from simple_source in my_source) and then I procede
 according to the "M/M/1 queue" tutorial example, the simulation leads
 to the aforementioned error. I suppose that this error may be due to wrong
 directory settings or to an installation problem. Could someone please
suggest me a way to solve my problem?
 Thanks a lot.
Jers

____________________________________________________________
Navighi a 4 MEGA e i primi 3 mesi sono GRATIS. 
Scegli Libero Adsl Flat senza limiti su http://www.libero.it

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "John P. Mullen" <[email-masked]>
Date: Tue, 19 Apr 2005 10:15:01 -0600

Hi Jers,

I think you are on the right track.

When you change the process model, how do you do this?  

John Mullen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Tuesday, April 19, 2005 6:29 AM
To: manet
Subject: [manet] An opnet simulation error

Hi all,

---

From: "Jers" <[email-masked]>
Date: Wed, 20 Apr 2005 08:55:36 +0200

Hi,
thanks for your replies.
I already have a C compiler installed.
To change the model, I follow these procedures:
-  load the "simple_source" process model
-  change its name by clicking on "save as"
-  compile the code, without any error or warning
-  save again (CTRL+S)
-  use this new model as source in the tutorial m/m/1 queue project.
I tried to save the new file both in "<opnet_dir>11.0A\models\std\traff_gen"
and in "Documents and Settings/Adiministrator/op_models" directories... same
error!

I suppose that the simulation executable file link is authomatically
generated when, after that I have construct the project, I configure  the
simulation (DES > Configure/Run Discrete Event Simulation (Advanced)). Is it
so?
In last mentioned configuration box I only change the probe_file included in
the "output statistic collection" section. Do I have to set something in the
input section, maybe? Do I do anything wrong?

Thanks again.
Jers

----- Original Message -----
From: "Flynn, Matthew" <[email-masked]>
To: <[email-masked]>; "manet" <[email-masked]>
Sent: Tuesday, April 19, 2005 9:45 PM
Subject: RE: [manet] An opnet simulation error

> You need to have a C compiler installed.  Modeler ships with prebuilt
> DLLs of all of the models.  If you change any of the process models they
> need to be recompiled and linked into a simulation executable or
> recompiled and linked into a DLL repository.  Either way you need a
> compiler.
>
>
> -Matt

---

From: [email-masked]
Date: Wed, 20 Apr 2005 10:28:16 +0200 (CEST)

Hi Jers ;==)

> I already have a C compiler installed.

It is logicl that  compiler is installed, because you said “I can
successfully carry out the simulations of  the "M/M/1 Queue" project
included in the tutorial. Otherwise, you cannot compile any project.

> and in "Documents and Settings/Adiministrator/op_models" directories...

If you have OPNET 10.0, you can create your own directory for you projects
and use it as default directory. To do this, select [File > Model Files >
Add Model Directory], in OPNET Modeler 10.0 window,  then create you
directory and make it as default.

> simulation (DES > Configure/Run Discrete Event Simulation (Advanced)). Is

Yes, M/M/1 is a simple example (you have not any promoted variables), so
you set only the simulation time, the seed, the Probe file and YOU SHOULD
not forget to select your Project-scenario in “Environment Files”

> input section, maybe? Do I do anything wrong?

check that the process model attribute of your "src module" is positioned
to your new saved simple_source process.

> Jers

Best regards

Hakim

---

From: "Jers" <[email-masked]>
Date: Wed, 20 Apr 2005 10:42:04 +0200

Hi Hakim,

> directory and make it as default.

I have already done that.

> > simulation (DES > Configure/Run Discrete Event Simulation (Advanced)).
Is
> > it
> not forget to select your Project-scenario in "Environment Files"

Of course!

>
> > In last mentioned configuration box I only change the probe_file
included
> > in

It is so.

Regards.
Jers

> >>>  included in the tutorial but, if at the beginning I change the name
of
> > the