Subject: Re: [manet] question about simultaneous use of different routing protocols in a single MANET

From: Saqib Ilyas <[email-masked]>
Date: Thu, 14 Apr 2005 17:35:47 +0100 (BST)

I think that the idea of administrative distance could be exploited here. If the network is not "wild enough" then the node somehow modifies the administrative distance of the more suitable protocol to favor it, and later set it back when the going gets tough. Just my two cents.
Regards

Faisal Adeem Siddiqui <[email-masked]> wrote:
Hi all,
I was wondering if it is possible and practical to use two different routing
protocols in a single MANET ? I think if we are using two routing protocols
then it will make two segments of MANET and there must be a node (gateway)
between these segments which understands both routing protocols to relay
traffic from one segment to another.
On the other hand, if we want to switch from one routing protocol to another
depending upon the network conditions, will it be practical ? For example,
initially we have a proactive routing protocol running but after some time
the mobility of nodes increase considerably and the performance of proactive
routing protocol is decreased. Now if we want to switch to a reactive
routing protocol, will it incur a lot of overhead ? Is it practical ? If
someone has done any experiments of this kind please refer it to me.
Thanks.

Faisal.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

Muhammad Saqib Ilyas
Assistant Professor
Department of Computer and Information Systems Engineering
NED University of Engineering and Technology, Karachi, Pakistan
http://www.neduet.edu.pk/CISE/faculty/MSaqib/index.htm
Chair, Student Activities Committee, IEEE Karachi Section
Member Executive Committee, IEEE Karachi Section
Country Leader, INETA Pakistan
IEEE Student Branch Counselor, NED University
Send instant messages to your online friends http://uk.messenger.yahoo.com 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: David Young <[email-masked]>
Date: Thu, 14 Apr 2005 15:00:40 -0500

On Thu, Apr 14, 2005 at 05:35:47PM +0100, Saqib Ilyas wrote:
> I think that the idea of administrative distance could be exploited
> here. If the network is not "wild enough" then the node somehow modifies
> the administrative distance of the more suitable protocol to favor it,
> and later set it back when the going gets tough. Just my two cents.

An aspect of Adaptive Hazy Sighted Link State (A-HSLS) may interest you:
it changes its operating mode from standard link-state to HSLS when, as
you say, "the going gets rough."  A technical memo from BBN Technologies,
<http://www.ir.bbn.com/documents/techmemos/TM1301.pdf>, describes A-HSLS.

BTW, an open-source A-HSLS implementation is part of the system that
the Champaign-Urbana Community Wireless Network is developing.  See
<http://lists.chambana.net/mailman/archive/cu-wireless/2004-October/001526.html>
for download instructions.

Dave

-- 
David Young             OJC Technologies
[email-masked]      Urbana, IL * (217) 278-3933

---

From: Manoj K Pandey <[email-masked]>
Date: Thu, 14 Apr 2005 17:22:30 -0700 (PDT)

Hi Everyone,

In glomosim SYNCHRONIZATION_TIME is added to every frame that is being
sent at the radio layer. And this is a large amount of time (192 micro-second).
Why do we need to add SYNCHRONIZATION_TIME to every frame
(RTS/CTS/DATA/ACK/Broadcast)? Isn't synchronization done only with PCF of 802.11 and
not with DCF? Also isn't sychronization used only with FHSS (stations needs to synchrnoize
the next frequency) at the radio layer and so do we need this when we use DSSS?

Is SYNCHRONIZATION_TIME added to frames in other versions of 802.11, which support
higher data rates than that provided in glomosim? If so, what is the value that
is used?

Thanks in advance,
Manoj Pandey

---

From: "Herbert Rubens" <[email-masked]>
Date: Thu, 14 Apr 2005 20:58:07 -0400

During the first 192 micro-seconds the radio transmits a training
sequence so that the receiver can establish a phase locked loop. It's
192 micro seconds in 802.11b/g and I believe it's less in 802.11a.

-Herb

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Manoj K Pandey
Sent: Thursday, April 14, 2005 8:23 PM
To: [email-masked]
Subject: [manet] SYNCHRONIZATION_TIME at Radio Layer

Hi Everyone,

In glomosim SYNCHRONIZATION_TIME is added to every frame that is being
sent at the radio layer. And this is a large amount of time (192
micro-second).
Why do we need to add SYNCHRONIZATION_TIME to every frame
(RTS/CTS/DATA/ACK/Broadcast)? Isn't synchronization done only with PCF
of 802.11 and
not with DCF? Also isn't sychronization used only with FHSS (stations
needs to synchrnoize
the next frequency) at the radio layer and so do we need this when we
use DSSS?

Is SYNCHRONIZATION_TIME added to frames in other versions of 802.11,
which support
higher data rates than that provided in glomosim? If so, what is the
value that
is used?

Thanks in advance,
Manoj Pandey