Subject: Re: [manet] Simulation Error

From: "Mohammad Haseeb Zafar" <[email-masked]>
Date: Mon, 4 Dec 2006 00:21:02 -0000

Hi
Further to my previous email. I have made following changes in ns-lib.tcl to check whether its working:
switch -exact $routingAgent_ {
	    
	    MPDSR {
		    $self at 0.0 "$node start-mpdsr"
	    }
	    --------
	    default {
		    puts "Wrong node routing agent:$routingAgent_"
		    exit
	    }
	} 
after remake, I again receive following message:

num_nodes is set 50
Wrong node routing agent!

It should have given following error:
Wrong node routing agent: MPDSR

This mean that after remake, changes have not been incorporated in ns-lib.tcl.

When I source ns-lib.tcl, I get the following:
-bash: ./ns-lib.tcl: line 50: syntax error near unexpected token `('
-bash: ./ns-lib.tcl: line 50: `set slinks_(0:0) 0'

How I can incorporate changes in ns-lib.tcl?
Your help will be hihhly appreciated.

Cheers

Haseeb

-----Original Message-----
From: Ash Mohammad Abbas [mailto:[email-masked]]
Sent: Fri 01/12/2006 2:12 AM
To: Mohammad Haseeb Zafar
Subject: Re: [manet] Simulation Error

You need to check the routing protocol you are using
in your tcl script. If you have written the code of
smr afresh, you need to make changes at several places
like    
config, routing agent, etc. Check whether you have
made all those updates.
Hope this helps,
Abbas

--- Mohammad Haseeb Zafar <[email-masked]>
wrote:

> Hi all,
>  
> I have run split multipath routing over ns-2.1b8a
> and the make process was successful. When I tried
> to run the simulation script, it bails out with an
> error
> 
> num_nodes is set 50
> Wrong node routing agent!
> 
> Can anyone please help to tell me how to solve this
> problem?
>  
> Thanks.
> 
> Haseeb
> > _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

Ash Mohammad Abbas 
  http://www.cse.iitd.ernet.in/~abbas

__________________________________________________________
Yahoo! India Answers: Share what you know. Learn something new
http://in.answers.yahoo.com/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Mon, 4 Dec 2006 11:34:59 +0000 (GMT)

Dear Haseeb
You will get the error you are expecting only when ns
recognizes your MPDSR. Actually, ns is not yet
recognizing your agent MPDSR. Changes at few more
places are needed to be done.

Do one thing, grep for either AODV or DSR in all your
directories/subdirectories to determine at what places
there are entries for these protocols and then make
similar entries for MPDSR.

Hope this helps.
Ash Mohammad Abbas

wrote:

> Hi
> Further to my previous email. I have made following
> changes in ns-lib.tcl to check whether its working:

Ash Mohammad Abbas

---

From: "Mohammad Haseeb Zafar" <[email-masked]>
Date: Mon, 11 Dec 2006 16:57:55 -0000

Hi
Has anybody adapted AOMDV to run in current versions? 
Cheers
Haseeb
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet