Subject: [manet] (no subject)

From: "Justin Dean" <[email-masked]>
Date: Thu, 16 Aug 2007 13:11:07 -0400

>> [Justin]
>> The inclusion of a node metric is because of the difference in 
>> wireless to wired medium. It may make more sense to transmit a value 
>> of say estimated contention on a per node basis rather than a link basis.

>[Teco]
>Can you come up with the advantage over incrementing the costs of all links
of the node?
>I can think of more efficient signaling, especially in case of high number
of neighbors. But if this is the only >one, I am not convinced it is needed.

If certain link cost values are symmetric but node costs are different
between nodes.  An example being max link throughput and node contention.
Its may be more efficient to send symmetric link costs from of the nodes and
have each node send a node cost, than to have every node send outbound link
metrics.  #L+#N compared to 2*#L.  The number of links will be greater than
the number of nodes in almost all cases.  The node representation is a
better fit for certain cost values in a manet, as a wireless network has
different properties than a wired network where orthogonal links metrics
generally fit well.

>>[Justin]
>> I was also playing around with the (16 + a) * 2^b - 15 method of 
>> representation as it seems to better match the scale of the flat 
>> representation (no fractions). The only issue I don't like with it is 
>> the fewer number of linear representations 1-15 to 1-31, but only 
>> representing integer values maps better with the linear representation 
>> and the trade off may be worth it.

>[Teco]
>What do you mean with fewer number of linear representations?
>Subtracting does not influence linear behavior.
>Compressed values 0-16 result in uncompressed values 1-17 (-15) or 16-32
(no -15).
>Am I missing something?

The current cost value equation of (1 + a/16) * 2^b allows for 1-32 integer
representation.  (16 + a) *2^b -15 allows for 1-17.(you are correct there)
The -15 is not what is causing this but the removal of the /16.  The
tradeoff is higher maximum cost value representation. 63488 to 1015793 for
the old to new respectively.

On a side note I would really like to hear from manet implementers, the
ranges of values you have tended to use for experimental metric based
routing.

Justin

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Teco Boot" <[email-masked]>
Date: Fri, 17 Aug 2007 09:32:41 +0200

> The current cost value equation of (1 + a/16) * 2^b allows for 1-32
> integer representation.
[Teco] 
Use integers? Chop or rounding? Or use 4 fractional bits as defined in
dearlove-olsrv2-metrics?

---

From: "Justin Dean" <[email-masked]>
Date: Fri, 17 Aug 2007 10:55:00 -0400

-----Original Message-----
From: Teco Boot [mailto:[email-masked]] 
Sent: Friday, August 17, 2007 3:33 AM
To: 'Justin Dean'
>Cc: [email-masked]
>Subject: Re: [manet] RE: Comments on Metric TLV

>> >>representation (no fractions). The only issue I don't like with it 
>> >>is  the fewer number of linear representations 1-15 to 1-31, but 
>> >>only  representing integer values maps better with the linear 
>> >>representation  and the trade off may be worth it.
>> 
>> >[Teco]
dearlove-olsrv2-metrics?

The first 80 values for both equations.  As you can see the current equation
can represent all integers 1-32.
The new one can only represent every integer in the 1-17 range.

(16 + a) * 2^b - 15	(1 + a/16) * 2^b
1				1
2				1.0625
3				1.125
4				1.1875
5				1.25
6				1.3125
7				1.375
8				1.4375
9				1.5
10				1.5625
11				1.625
12				1.6875
13				1.75
14				1.8125
15				1.875
16				1.9375
17				2
19				2.125
21				2.25
23				2.375
25				2.5
27				2.625
29				2.75
31				2.875
33				3
35				3.125
37				3.25
39				3.375
41				3.5
43				3.625
45				3.75
47				3.875
49				4
53				4.25
57				4.5
61				4.75
65				5
69				5.25
73				5.5
77				5.75
81				6
85				6.25
89				6.5
93				6.75
97				7
101				7.25
105				7.5
109				7.75
113				8
121				8.5
129				9
137				9.5
145				10
153				10.5
161				11
169				11.5
177				12
185				12.5
193				13
201				13.5
209				14
217				14.5
225				15
233				15.5
241				16
257				17
273				18
289				19
305				20
321				21
337				22
353				23
369				24
385				25
401				26
417				27
433				28
449				29
465				30
481				31
497				32
529				34