Subject: [manet] NHDP - including all addresses in hello message

From: "Teco Boot" <[email-masked]>
Date: Wed, 19 Mar 2008 15:55:49 +0100

Hi Chris,

I grabbed your mail from the archive, some filter stopped direct delivery.

At time of writing RFC2501, usage of Router_ID was suggested:
>   The concept of a "node identifier" (separate and apart from the
>   concept of an "interface identifier") is crucial to supporting the
>   multigraph topology of the routing fabric. It is what *unifies* a set
>   of wireless interfaces and identifies them as belonging to the same
>   mobile platform.  This approach permits maximum flexibility in
>   address assignment.  Node identifiers are used at the IP layer for
>   routing computations.
I am still interested why not taking this option. 
Maybe others have opinions on this?

Regards, Teco

-----Original Message-----

Unfortunately, pressure of work has meant that various
"rationale" material that Thomas and I (at least) have
always wanted to publish, have not made it into print.

Christopher Dearlove

-----Original Message-----
From: manet-bounces at ietf.org [mailto:manet-bounces at ietf.org] On Behalf
Of Teco Boot

Hi,
More on "MUST include all local interface addresses in the hello
message":
Is there a document that explains we really need this? I still have the
idea
that it may introduce huge overhead, which can be circumvented in many
cases.
Teco.

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 19 Mar 2008 08:57:18 -0700

Hello Teco,

Teco Boot wrote:
>>   multigraph topology of the routing fabric.

I reckon IP already does this to a great extent.

>>  It is what *unifies* a set
>>   mobile platform.

External to the node, what is the downside if this feature is
not available?  In other words, how bad is it if other nodes
remain unaware that two network interfaces belong to the
same node?

>>   This approach permits maximum flexibility in

What is the assignment authority for these node identifiers?
How is uniqueness guaranteed?

Up until now, I have not felt any lack resulting from AODV's
omission of this feature.  I wouldn't like to add the baggage
unless it paid its freight in signal reduction.  I reckon the
tradeoffs are quite different in manets compared to, say, a
static routing fabric.

I'd be happier if one of the existing addresses (say, the first
one) were pressed into service as a node identifier.  At least
then we wouldn't be making new problems.

Regards,
Charlie P.