Subject: [manet] Query about propogating hello messages to multihops

From: Romil Gupta <[email-masked]>
Date: Mon, 31 Mar 2008 23:45:23 +0530 (IST)

As a part of the acedemic project I am attempting to send some info throught the network by adding it to the hello messages. the plan I am using involves to propogate hello messages to more than one hop as the first step.

It would be very kind if someone can suggest a descent solution for it.

Thanks in advance.

Have a nice day !!!

!! Romil Gupta !!
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: "Gustavo Carneiro" <[email-masked]>
Date: Tue, 1 Apr 2008 00:04:00 +0100

On 31/03/2008, Romil Gupta <[email-masked]> wrote:
>
>
> As a part of the acedemic project I am attempting to send some info
> throught the network by adding it to the hello messages. the plan I am using
> involves to propogate hello messages to more than one hop as the first step.

What protocol are you using?

Keep in mind that if you make HELLOs propagate beyond a node's immediate
neighbors you will be violating a very basic principle of routing
protocols.  At least in OLSR, HELLO messages are used for neighbor sensing;
if HELLOs propagate more than to the next hop, nodes will start believing
they have neighbors that they don't really have.  That will cause routing to
fail and packets to be dropped.

You should look for other messages to carry your information, like TC or
LSA.

-- 
Gustavo J. A. M. Carneiro
INESC Porto, Telecommunications and Multimedia Unit
"The universe is always one step beyond logic." -- Frank Herbert
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Romil Gupta <[email-masked]>
Date: Tue, 1 Apr 2008 12:29:10 +0530 (IST)

>Subject: Re: [manet] Query about propogating hello messages to multihops

>You should look for other messages to carry your information, like TC or

Sorry it was my fault !!!

Actually what i meant was to propogate the information to multiple hops using HELLO messages by simply copying some fields from the recieved message onto the transmitted message. The sole intenetion is to propogate some info like trust value or alike calculated by one node to the other nodes in the network. 

As for the basic protocol , I am using the AODV protocol.

Regards !!

---
Romil Gupta