Subject: Re: [manet] ??: Multicast protocols on MANET

From: "Joe Macker" <[email-masked]>
Date: Thu, 1 May 2008 18:30:23 -0400

Vincent:

The way it worked was the following.

(1) MANET first was chartered back based upon discussions with Ads,etc

No multicast to get through the initial EXP RFC phase, that was quite a ways back.

(2) In rechartering, I discussed the idea with the AD and others of reintroducing a simple multicast forwarding design.

This is useful for a variety of reasons, but is limited in scope as the spec states.
There was some maturity in understanding various CDS approaches to optimized flooding that underpins this work.

(3) If progress is made we can examine more advanced concepts.

This could take multiple forms.

- As JKopena says SMF can be extended as is being done by some ongoing work (e.g., SMF FIB filtering)
- Multicast could be extended to unicast variants as you mention (unicast dependent)
- Previously worked on methods could be reexamined

You also missed some protocols that were worked on early in the WG such as ODMRP.
There is a large body of work in related multicast MANET/mesh research.

-Joe

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Vincent Nogues
> Sent: Wednesday, April 30, 2008 3:32 AM
> To: '???'; 'Teco Boot'
> Cc: [email-masked]
> Subject: Re: [manet] ??: Multicast protocols on MANET
> 
> Dears,
> 
> Thanks for your answer. So if I sum up :
> before MANET rechartering, some works have been done on multicast protocols (MOLSR, ...). Then after the
> rechartering, it has been decided to focus on unicast protocol (AODV and OLSR), and to define a simple
> multicast protocol (SMF) easier to implement than protocols like MOLSR, ...
> 
> The other multicast protocols are still studied, but outside the scope of the MANET WG. It is not planned to
> standardize these protocols for now.
> 
> One more question : Do you know, who are continuing to study the other multicast protocols (MOLSR, MAODV)
> and if the results of their work are available ?
> 
> Thanks,
> 
> Vincent
> 
> 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de ???
> Envoy� : mercredi 30 avril 2008 03:04
> � : Teco Boot
> Cc : [email-masked]
> Objet : [manet] ??: Multicast protocols on MANET
> 
> Yes, MANET WG should make the rules of MANET for traditional IP based
> wireless networks. But many real networks is not based on standard
> stack. Our project is one. I mean this.
> 
> 2008/4/29, Teco Boot <[email-masked]>:
> > I do not agree on this (personal) opinion.
> > The target for the MANET WG shall be defining standard protocols and not
> > designs for reference.
> > Thanks, Teco
> >
> > ----------------------------------------------------------------------
> >
> > Van: [email-masked] [mailto:[email-masked]] Namens ???
> > Verzonden: dinsdag 29 april 2008 8:25
> > Aan: [email-masked]
> > Onderwerp: Re: [manet] manet Digest, Vol 48, Issue 13
> >
> > I think SMF is more simple and easy to implement on real testbed. Many ad
> > hoc application is aiming at military use so IETF is just a reference for
> > design.
> > 2008/4/29, [email-masked] <[email-masked]>:
> > Send manet mailing list submissions to
> >        [email-masked]
> >
> > To subscribe or unsubscribe via the World Wide Web, visit
> >        https://www.ietf.org/mailman/listinfo/manet
> > or, via email, send a message with subject or body 'help' to
> >        [email-masked]
> >
> > You can reach the person managing the list at
> >        [email-masked]
> >
> > When replying, please edit your Subject line so it is more specific
> > than "Re: Contents of manet digest..."
> >
> >
> > Today's Topics:
> >
> >   1. Multicast protocols on MANET (Vincent Nogues)
> >   2. Re: Multicast protocols on MANET (Ian Chakeres)
> >
> >
> > ----------------------------------------------------------------------
> >
> > Message: 1
> > Date: Mon, 28 Apr 2008 14:05:36 +0200
> > From: "Vincent Nogues" <[email-masked]>
> > Subject: [manet] Multicast protocols on MANET
> > To: <[email-masked]>
> > Message-ID: <[email-masked]>
> > Content-Type: text/plain; charset="us-ascii"
> >
> > Dear all,
> >
> >
> >
> > I am working on MANET technologies and especially for now on multicast on
> > MANET: I have already tested a MOLSR implementation.
> >
> >
> >
> > I follow the MANET IETF working group discussions and the related work. I
> > notice that SMF protocol discussion is very active but the other work (like
> > MOLSR, MAODV .) seems to be suspended
> >
> >
> >
> > So my questions are:
> >
> >
> >
> > - Does it mean that previous work on multicast routing (MAODV, MOLSR, ODMRP)
> > protocole have been dropped?
> >
> > - Will these protocols be submitted as an RFC (experimental?) ?
> >
> > - Does some people know if some experiment have been done on MAODV or ODMRP
> > and if some results (or simulation code on NS-2 for example) exist and are
> > available?
> >
> >
> >
> > Thanks in advance for your help,
> >
> >
> >
> > ---------------------------------------------------
> >
> > Vincent NOGUES
> >
> > ---------------------------------------------------
> >
> > -------------- next part --------------
> > An HTML attachment was scrubbed...
> > URL:
> > http://www.ietf.org/pipermail/manet/attachments/20080428/b3f531ba/attachment.htm
> >
> > ------------------------------
> >
> > Message: 2
> > Date: Mon, 28 Apr 2008 21:51:53 +0530
> > From: "Ian Chakeres" <[email-masked]>
> > Subject: Re: [manet] Multicast protocols on MANET
> > To: "Vincent Nogues" <[email-masked]>
> > Cc: [email-masked]
> > Message-ID: <[email-masked]>
> > Content-Type: text/plain; charset=WINDOWS-1252
> >
> > During the rechartering (2+ years ago) the group got focused on
> > finishing a proactive and a reactive unicast routing protocol first.
> > Although SMF also got chartered for  experimental. Since then there
> > has been little discussion on previous more-complex manet multicast
> > protocols.
> >
> > I am aware of work outside the IETF on manet multicast, but I am not
> > aware of any current activity to standardize these protocols.
> >
> > Ian
> >
> > On Mon, Apr 28, 2008 at 5:35 PM, Vincent Nogues
> > <[email-masked]> wrote:
> > >
> > >
> > >
> > >
> > > Dear all,
> > >
> > >
> > >
> > > I am working on MANET technologies and especially for now on multicast on
> > > MANET: I have already tested a MOLSR implementation.
> > >
> > >
> > >
> > > I follow the MANET IETF working group discussions and the related work. I
> > > notice that SMF protocol discussion is very active but the other work
> > (like
> > > MOLSR, MAODV ?) seems to be suspended
> > >
> > >
> > >
> > > So my questions are:
> > >
> > >
> > >
> > > - Does it mean that previous work on multicast routing (MAODV, MOLSR,
> > ODMRP)
> > > protocole have been dropped?
> > >
> > > - Will these protocols be submitted as an RFC (experimental?) ?
> > >
> > > - Does some people know if some experiment have been done on MAODV or
> > ODMRP
> > > and if some results (or simulation code on NS-2 for example) exist and are
> > > available?
> > >
> > >
> > >
> > > Thanks in advance for your help,
> > >
> > >
> > >
> > > ---------------------------------------------------
> > >
> > >
> > > Vincent NOGUES
> > >
> > >
> > > ---------------------------------------------------
> > > _______________________________________________
> > >  manet mailing list
> > >  [email-masked]
> > >  https://www.ietf.org/mailman/listinfo/manet
> > >
> > >
> >
> >
> > ------------------------------
> >
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/manet
> >
> >
> > End of manet Digest, Vol 48, Issue 13
> > *************************************
> >
> >
> >
> > --
> > ---------------------------------------------------------
> >          ??
> >                                                ???
> >
> >
> 
> 
> --
> ---------------------------------------------------------
>          ??
>                                                ???
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: "赵玉亭" <[email-masked]>
Date: Fri, 2 May 2008 09:06:48 +0800

Thanks for Rex's explaination.
I did study MDP, NORM and SMF. Any MANET protocol is not a unifying solution
to all scenarios. One key, one lock.
BTW, I am workning at distributed synchronization in manet. Is anyone
pursuing it? It seems boring, ^_^.

2008/5/1, Rex Buddenberg <[email-masked]>:
>
> Vincent, et al,
>
> Sounds like a review of requirements is in order here.  (Apologies to
> those believers who are getting the rant for other than the first time).
>
> I agree that MANET does not expressly encompass multicast.  The WG has
> had enough on its hands that it's appropriate to take a Hippocratic
> approach -- do no evil toward multicast and get on with the business.
>
> But the motivations that drive MANET concepts intersect with multicast
> motivations a great deal ... we need to make both work eventually.
> Here, IMHO, is why:
>
> Demand side.  Many of the use case scenarios that motivate MANET are
> military (mobile formations) or emergency services (fire department
> incident command).  We know that the incidence of multicast traffic in
> military and emergency services is much higher than in commercial
> scenarios.
>        History of past communications systems illustrates well: to pick
> just
> one example, the US Navy's fleet broadcast system back in the HF radio
> days is classical multicast -- the communications station blasts out
> messages, each with a serial number (QLH on several frequencies so a
> (silent) receiver can copy at least one freq successfully).  The
> addressing included individual ships, tactical group calls and what were
> called Address Indicating Groups (roughly analogous to [email-masked]'
> in this message).  These messages were commonly repeated -- a crude FEC
> protocol -- on a rerun channel.  A receiving ship could be radio-silent
> except when it needed to NAK for a missing message.  You should
> recognize several layer 3 and layer 4 multicast characteristics here
> (NORM mirrors the layer 4 techniques quite faithfully).
>        One only needs to understand the concepts of 'blue force track' and
> 'common operational picture' to catch on that multicast is a requirement
> that is alive and well.  And it's in the same use case domain that MANET
> exists in.
>
> Supply side.  Increasingly our radio networks are not reaching to end
> systems, but to routers.  Military has driving need for radio-WANs; by
> contrast Wireless LANs are baubles.  The most mature form today is Navy
> ships where the ship-shore and intra-battle-group communications reach
> to a router on the ship, not directly to end systems.  End systems are
> attached to an intra-ship LAN (ubiquitously ethernet).  This is a
> topology shift -- the radio-WAN is in the interior of the internetwork,
> not at the fringe.  While the illustration is most mature in large
> ships, it applies to all platforms, all the way down to a dismounted
> infantryman who may have several end systems in his kit, not just one.
>        The numbers problem this shows up is the observed constant -- four
> orders of magnitude.  Terrestrial internet is commonly populated with
> OC192 (10.6Gbit) backbones these days.  Navy ships have Gig ethernet
> backbones (or can easily have them installed).  By contrast, the
> radio-WANs that interconnect the two are measured in M and Kbits.  (This
> relationship is remarkably constant -- when I was a comms officer for
> the first time, the shoreside network backbones ran at 64k and the
> ship-shore links at 75 baud -- 4 orders of magnitude diff).
>        Multicast in the radio-WAN (IEEE 802 folks call it
> point-to-multipoint)
> is the only offset we have to this orders-of-magnitude capacity
> difference.  ... in a naturally shared medium.
>
>