Subject: [manet] A quesion about AODV

From: "shaoxun" <[email-masked]>
Date: Fri, 16 Jan 2009 18:04:15 +0800

Hi all,
Here si a question about AODV. 
in AODV::command(), there is code as below:
    
    if(argc == 2){
        ......
        if(strncasecmp(argv[1], "start", 2) == 0){
                htimer.handle((Event*)0);   // for periodically sending hello packets
                ......
        }
        ......
    }

While in my OTcl scripts for simulation, there is no code like $aodv_  " xxx start", but only 
    $ns_  at 10.0 "$ftp_ start"

I wonder how could this  make the code for periodically sending hello packets work?

Thank you!

Regards
Shao
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: mustafa Bani- Khalaf <[email-masked]>
Date: Fri, 16 Jan 2009 17:55:43 -0800 (PST)

follow this link you will find the answer. 
http://www.ietf.org/mail-archive/web/manet/current/msg01124.html
Regards
Mustafa Bani Khalaf

--- On Fri, 1/16/09, [email-masked] <[email-masked]> wrote:
From: [email-masked] <[email-masked]>
Subject: manet Digest, Vol 57, Issue 4
To: [email-masked]
Date: Friday, January 16, 2009, 12:00 PM

Send manet mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www.ietf.org/mailman/listinfo/manet
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of manet digest..."

Today's Topics:

   1. A quesion about AODV (shaoxun)

----------------------------------------------------------------------

Message: 1
Date: Fri, 16 Jan 2009 18:04:15 +0800
From: "shaoxun" <[email-masked]>
Subject: [manet] A quesion about AODV
To: "manet" <[email-masked]>, "[email-masked]"
<[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="gb2312"

Hi all,
    
    if(argc == 2){
        ......
        if(strncasecmp(argv[1], "start", 2) == 0){
                htimer.handle((Event*)0);   // for periodically sending hello
packets
                ......
        }
        ......
    }

While in my OTcl scripts for simulation, there is no code like $aodv_  "
xxx start", but only 
    $ns_  at 10.0 "$ftp_ start"

I wonder how could this  make the code for periodically sending hello packets
work?

Thank you!

Regards
Shao
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://www.ietf.org/pipermail/manet/attachments/20090116/8affc8dc/attachment-0001.htm>

------------------------------

End of manet Digest, Vol 57, Issue 4
************************************