Subject: Re: [manet] OLSRv2 and "per node MPR selection"

From: Richard Ogier <[email-masked]>
Date: Wed, 08 Apr 2009 08:47:31 -0700

Teco Boot wrote:

>Not sure on this.
>Scenario:
>A transmits, B and C receives the message.
>B and C retransmit the message, one after each other,
>on both "fast" and "slow" interfaces
>D receives first on "fast" interface, from C.
>C is not MPR selector (2.2.3), so message is discarded.
>Same for E.
>Then D receives the message on the "slow interface", from B.
>Why is the packet not forwarded? Algorithm:
>  1: is B symmetric neighbor? Yes, continue
>  2: is msg received on "slow" interface before? No, continue
>  
>

Philippe was showing that there can be a problem if MPRs are selected
per node instead of per interface.  In that case, the algorithm
would naturally be modified by changing step 2 above to
"was msg received on any interface before".  However, if the above
step 2 is used, so that the first reception of the msg on *each*
interface is considered, then it appears to work fine.
A key point (which Christopher's example, which was not clear
to me, may have missed) is that if MPRs are not per interface,
then neither are MPR selectors, and so D would forward
the msg received from B regardless of which interface
it was received on.

Therefore, you may have shown that MPRs can be selected per node
(for all interfaces), in which case the spec should be changed
to do that.  Maybe someone can provide a clear example that
shows I am wrong (or can prove that I am right).

Richard

>  3: is msg forwarded before? No, continue
>  4: is prev_hop an MPR selector? Yes: FORWARD
>Same for E.
>
>What is the problem ???
>
>Again, maybe I overlook something.
>
>
>|When D or E eventually receive from the slow interface it could compare
>|time stamps to actually decide that slow interface indeed had precedence
>|on fast interface in race competition and finally to decide to actually
>|retransmit. But again you come out with the performance of the worse
>|interface (and a very complicated mechanism).
>|
>|If MPR are on per interface, then B will select E as MPR on fast
>|interface
>|and you gain on the fastest interface which will win the race
>|competition.
>|
>|I think this was the issue (but I am not sure), but I agree that the
>|result was a kind of compromise to keep things simple.
>
>Not sure what "simple" means.
>
>Side remark: both "per interface" and "per node" MPR based flooding can be
>performed with RouterIDs. And the "per interface MPR selection" is maybe
>somewhat less complex (I wonder), but the overhead on the "slow segment"
>looks unacceptable to me.
>
>Again, I might overlook something here...
>
>If agreed this scenario works fine on "per node MPR selection", can someone
>come up with a failing scenario?
>
>
>Teco.
>
>
>|Best regards,
>|Philippe
>|
>|Charles E. Perkins a écrit :
>|>
>|> Hello Chris,
>|>
>|> Comments below...
>|>
>|> Dearlove, Christopher (UK) wrote:
>|>>
>|>>> I don't understand this. The requirement is that the set
>|>>> of MPRs must provide connectivity to all 2-hop neighbors
>|>>>
>|>>
>|>> That's not sufficient.
>|>>
>|>
>|> I believe this is highly debatable.
>|>
>|>>
>|>>>  o   Why MPR selection per interface?
>|>>>
>|>>
>|>> Read the literature. And yes, that is me not putting in the effort
>|>> to point out the race condition case and why per interface avoids
>|>> it and per router doesn't (a subtlety in the MPR flooding proof).
>|>>
>|>
>|> I read the proofs, albeit a couple of years ago, and I don't remember
>|> anything particular about this point.  Too bad I can't go back and
>|review
>|> this material today.
>|>
>|
>|_______________________________________________
>|manet mailing list
>[email-masked]
>|https://www.ietf.org/mailman/listinfo/manet
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/manet
>
>  
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 8 Apr 2009 17:11:04 +0100

Richard Ogier 
> (for all interfaces)

Not and avoid the race condition. See an earlier email of mine.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************