Subject: [manet] IP protocol 138 and UDP port 269

From: Ian Chakeres <[email-masked]>
Date: Mon, 20 Apr 2009 08:46:59 -0400

Currently IANA has allocated the IP protocol number 138 and UDP port  
number 269 for use by protocols using PacketBB (RFC 5444).

I have initiated this email thread to discuss the default mode of  
operation for interoperable MANET implementations.

Please reply to this thread with your opinion.

Thanks.
Ian Chakeres

---

From: Ian Chakeres <[email-masked]>
Date: Mon, 20 Apr 2009 08:50:33 -0400

My own opinion is that we should use the IP protocol number 138. I  
feel using an IP protocol number is more common in routing protocols  
(e.g. OSPF, ISIS) and easily identifies the traffic.

Ian Chakeres

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 20 Apr 2009 15:58:21 +0200

Ian Chakeres a écrit :
> My own opinion is that we should use the IP protocol number 138. I feel 
> using an IP protocol number is more common in routing protocols (e.g. 
> OSPF, ISIS) and easily identifies the traffic.

A comment to this would be that it is more straightforward to write UDP 
applications with UDP port numbers and sockets. (for  IP protocol number 
one would have to use more special RAW sockets, among other alternatives 
of course).

Alex

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Teco Boot" <[email-masked]>
Date: Tue, 21 Apr 2009 09:19:20 +0200

Lets ensure implementations does not lock out each other.

I would say:
 o  A standard compliant implementation supports both types of encapsulation
 o  IP encapsulation is the recommended default
 o  UDP encapsulation is used where needed

Examples where UDP is used:
 o  link layer does not provide checksums
 o  link layer performance for UDP is better (e.g. header compression)
 o  UDP circumvents problems (e.g. some kind of TCP / UDP firewall)

Teco.

|-----Oorspronkelijk bericht-----
|Van: [email-masked] [mailto:[email-masked]] Namens Ian
|Chakeres
|Verzonden: maandag 20 april 2009 14:47
|Aan: manet
|Onderwerp: [manet] IP protocol 138 and UDP port 269
|
|Currently IANA has allocated the IP protocol number 138 and UDP port
|number 269 for use by protocols using PacketBB (RFC 5444).
|
|I have initiated this email thread to discuss the default mode of
|operation for interoperable MANET implementations.
|
|Please reply to this thread with your opinion.
|
|Thanks.
|Ian Chakeres
|
|_______________________________________________
|manet mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/manet